linux-raspi 5.8.0-1006.9 source package in Ubuntu

Changelog

linux-raspi (5.8.0-1006.9) groovy; urgency=medium

  * groovy/linux-raspi: 5.8.0-1006.9 -proposed tracker (LP: #1899928)

  * CVE-2020-12351 // CVE-2020-12352 // CVE-2020-24490
    - [Config] raspi: Disable BlueZ highspeed support

  * booting linux-generic-lpae armhf kernel under qemu results in relocation out
    of range, and thus no modules can be loaded (LP: #1899519)
    - [Config] raspi: armhf: ARM_MODULE_PLTS=y

  [ Ubuntu: 5.8.0-25.26 ]

  * groovy/linux: 5.8.0-25.26 -proposed tracker (LP: #1899940)
  * CVE-2020-12351
    - Bluetooth: L2CAP: Fix calling sk_filter on non-socket based channel
  * CVE-2020-12352
    - Bluetooth: A2MP: Fix not initializing all members
  * CVE-2020-12351 // CVE-2020-12352 // CVE-2020-24490
    - Bluetooth: Disable High Speed by default
    - Bluetooth: MGMT: Fix not checking if BT_HS is enabled
    - [Config] Disable BlueZ highspeed support
  * ec2-hibinit-agent needs to properly initialize swap file (LP: #1892728)
    - ext4: implement swap_activate aops using iomap

  [ Ubuntu: 5.8.0-24.25 ]

  * groovy/linux: 5.8.0-24.25 -proposed tracker (LP: #1899804)
  * Fix system reboot when disconnecting WiFi (LP: #1899726)
    - iwlwifi: msix: limit max RX queues for 9000 family
  * ceph: fix inode number handling on arches with 32-bit ino_t (LP: #1899582)
    - ceph: fix inode number handling on arches with 32-bit ino_t
  * booting linux-generic-lpae armhf kernel under qemu results in relocation out
    of range, and thus no modules can be loaded (LP: #1899519)
    - [Config] armhf: ARM_MODULE_PLTS=y

linux-raspi (5.8.0-1005.8) groovy; urgency=medium

  [ Ubuntu: 5.8.0-23.24 ]

  * CVE-2020-16119
    - SAUCE: dccp: avoid double free of ccid on child socket

 -- Juerg Haefliger <email address hidden>  Fri, 16 Oct 2020 07:57:18 +0200

Upload details

Uploaded by:
Juerg Haefliger
Uploaded to:
Groovy
Original maintainer:
Ubuntu Kernel Team
Architectures:
armhf arm64
Section:
devel
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Groovy release main devel

Builds

Groovy: [FULLYBUILT] arm64 [FULLYBUILT] armhf

Downloads

File Size SHA-256 Checksum
linux-raspi_5.8.0.orig.tar.gz 170.1 MiB 0657da4f4b0035f6ad60806f5fece4ff2575159f156d5f3fe8301d911e58081b
linux-raspi_5.8.0-1006.9.diff.gz 5.1 MiB 652974db93253137b520436276f49e4743a1aa712efadbfebf8f459f221a7693
linux-raspi_5.8.0-1006.9.dsc 4.7 KiB 3f2355bde457ddbab45bea2fb748af0f9fbda0e9156a94312198dd26c63b3a58

View changes file

Binary packages built by this source

linux-buildinfo-5.8.0-1006-raspi: No summary available for linux-buildinfo-5.8.0-1006-raspi in ubuntu hirsute.

No description available for linux-buildinfo-5.8.0-1006-raspi in ubuntu hirsute.

linux-buildinfo-5.8.0-1006-raspi-nolpae: Linux kernel buildinfo for version 5.8.0 on ARM (hard float) SMP

 This package contains the Linux kernel buildinfo for version 5.8.0 on
 ARM (hard float) SMP.
 .
 You likely do not want to install this package.

linux-headers-5.8.0-1006-raspi: Linux kernel headers for version 5.8.0 on ARM (hard float) SMP

 This package provides kernel header files for version 5.8.0 on
 ARM (hard float) SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-5.8.0-1006/debian.README.gz for details.

linux-headers-5.8.0-1006-raspi-nolpae: Linux kernel headers for version 5.8.0 on ARM (hard float) SMP

 This package provides kernel header files for version 5.8.0 on
 ARM (hard float) SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-5.8.0-1006/debian.README.gz for details.

linux-image-5.8.0-1006-raspi: No summary available for linux-image-5.8.0-1006-raspi in ubuntu hirsute.

No description available for linux-image-5.8.0-1006-raspi in ubuntu hirsute.

linux-image-5.8.0-1006-raspi-dbgsym: Linux kernel debug image for version 5.8.0 on ARM (hard float) SMP

 This package provides the kernel debug image for version 5.8.0 on
 ARM (hard float) SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-image-5.8.0-1006-raspi-nolpae: No summary available for linux-image-5.8.0-1006-raspi-nolpae in ubuntu hirsute.

No description available for linux-image-5.8.0-1006-raspi-nolpae in ubuntu hirsute.

linux-image-5.8.0-1006-raspi-nolpae-dbgsym: No summary available for linux-image-5.8.0-1006-raspi-nolpae-dbgsym in ubuntu hirsute.

No description available for linux-image-5.8.0-1006-raspi-nolpae-dbgsym in ubuntu hirsute.

linux-modules-5.8.0-1006-raspi: No summary available for linux-modules-5.8.0-1006-raspi in ubuntu hirsute.

No description available for linux-modules-5.8.0-1006-raspi in ubuntu hirsute.

linux-modules-5.8.0-1006-raspi-nolpae: Linux kernel extra modules for version 5.8.0 on ARM (hard float) SMP

 Contains the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Generic no-LPAE processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-raspi-nolpae meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-raspi-headers-5.8.0-1006: Header files related to Linux kernel version 5.8.0

 This package provides kernel header files for version 5.8.0, for sites
 that want the latest kernel headers. Please read
 /usr/share/doc/linux-raspi-headers-5.8.0-1006/debian.README.gz for details

linux-raspi-tools-5.8.0-1006: Linux kernel version specific tools for version 5.8.0-1006

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 5.8.0-1006 on
 ARM (hard float).
 You probably want to install linux-tools-5.8.0-1006-<flavour>.

linux-tools-5.8.0-1006-raspi: Linux kernel version specific tools for version 5.8.0-1006

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 5.8.0-1006 on
 ARM (hard float).

linux-tools-5.8.0-1006-raspi-nolpae: No summary available for linux-tools-5.8.0-1006-raspi-nolpae in ubuntu hirsute.

No description available for linux-tools-5.8.0-1006-raspi-nolpae in ubuntu hirsute.