linux-raspi2 4.18.0-1010.12 source package in Ubuntu

Changelog

linux-raspi2 (4.18.0-1010.12) cosmic; urgency=medium

  * linux-raspi2: 4.18.0-1010.12 -proposed tracker (LP: #1814755)

  * bluetooth controller not detected with 4.15 kernel (LP: #1810797)
    - [Config] Disable BT_QCOMSMD_HACK

  * rpi-cm3 dtb is not present in the arm64 variant (LP: #1813133)
    - devicetree: add RPi CM3 dts to arm64; mimic the RPi 3B arm64 dts
      implementation, by referring to the actual dts file in the arm directory

  [ Ubuntu: 4.18.0-16.17 ]

  * linux: 4.18.0-16.17 -proposed tracker (LP: #1814749)
  * Packaging resync (LP: #1786013)
    - [Packaging] update helper scripts
  * CVE-2018-16880
    - vhost: fix OOB in get_rx_bufs()
  * RTL8822BE WiFi Disabled in Kernel 4.18.0-12 (LP: #1806472)
    - SAUCE: staging: rtlwifi: allow RTLWIFI_DEBUG_ST to be disabled
    - [Config] CONFIG_RTLWIFI_DEBUG_ST=n
    - SAUCE: Add r8822be to signature inclusion list
  * kernel oops in bcache module (LP: #1793901)
    - SAUCE: bcache: never writeback a discard operation
  * CVE-2018-18397
    - userfaultfd: use ENOENT instead of EFAULT if the atomic copy user fails
    - userfaultfd: shmem: allocate anonymous memory for MAP_PRIVATE shmem
    - userfaultfd: shmem/hugetlbfs: only allow to register VM_MAYWRITE vmas
    - userfaultfd: shmem: add i_size checks
    - userfaultfd: shmem: UFFDIO_COPY: set the page dirty if VM_WRITE is not set
  * Ignore "incomplete report" from Elan touchpanels (LP: #1813733)
    - HID: i2c-hid: Ignore input report if there's no data present on Elan
      touchpanels
  * Vsock connect fails with ENODEV for large CID (LP: #1813934)
    - vhost/vsock: fix vhost vsock cid hashing inconsistent
  * Fix non-working pinctrl-intel (LP: #1811777)
    - pinctrl: intel: Do pin translation in other GPIO operations as well
  * ip6_gre: fix tunnel list corruption for x-netns (LP: #1812875)
    - ip6_gre: fix tunnel list corruption for x-netns
  * Backported commit breaks audio (fixed upstream) (LP: #1811566)
    - ASoC: intel: cht_bsw_max98090_ti: Add quirk for boards using pmc_plt_clk_0
    - ASoC: intel: cht_bsw_max98090_ti: Add pmc_plt_clk_0 quirk for Chromebook
      Clapper
    - ASoC: intel: cht_bsw_max98090_ti: Add pmc_plt_clk_0 quirk for Chromebook
      Gnawty
  * kvm_stat : missing python dependency (LP: #1798776)
    - tools/kvm_stat: switch to python3
  * [SRU] Fix Xorg crash with nomodeset when BIOS enable 64-bit fb addr
    (LP: #1812797)
    - vgaarb: Add support for 64-bit frame buffer address
    - vgaarb: Keep adding VGA device in queue
  * Fix non-working QCA Rome Bluetooth after S3 (LP: #1812812)
    - USB: Add new USB LPM helpers
    - USB: Consolidate LPM checks to avoid enabling LPM twice
  * [SRU] IO's are issued with incorrect Scatter Gather Buffer (LP: #1795453)
    - scsi: megaraid_sas: Use 63-bit DMA addressing
  * x86/mm: Found insecure W+X mapping at address (ptrval)/0xc00a0000
    (LP: #1813532)
    - x86/mm: Do not warn about PCI BIOS W+X mappings
  * CVE-2019-6133
    - fork: record start_time late
  * Fix not working Goodix touchpad (LP: #1811929)
    - HID: i2c-hid: Disable runtime PM on Goodix touchpad
  * bluetooth controller not detected with 4.15 kernel (LP: #1810797)
    - SAUCE: btqcomsmd: introduce BT_QCOMSMD_HACK
    - [Config] arm64: snapdragon: BT_QCOMSMD_HACK=y
  * X1 Extreme: only one of the two SSDs is loaded (LP: #1811755)
    - nvme-core: rework a NQN copying operation
    - nvme: pad fake subsys NQN vid and ssvid with zeros
    - nvme: introduce NVME_QUIRK_IGNORE_DEV_SUBNQN
  * Crash on "ip link add foo type ipip" (LP: #1811803)
    - SAUCE: fan: Fix NULL pointer dereference

  [ Ubuntu: 4.18.0-15.16 ]

  * Ubuntu boot failure. 4.18.0-14 boot stalls. (does not boot) (LP: #1814555)
    - Revert "drm/i915/ringbuffer: Delay after EMIT_INVALIDATE for gen4/gen5"
  * Userspace break as a result of missing patch backport (LP: #1813873)
    - tty: Don't hold ldisc lock in tty_reopen() if ldisc present

 -- Khalid Elmously <email address hidden>  Mon, 11 Feb 2019 06:00:26 +0000

Upload details

Uploaded by:
Khaled El Mously on 2019-02-12
Sponsored by:
Kleber Sacilotto de Souza
Uploaded to:
Cosmic
Original maintainer:
Ubuntu Kernel Team
Architectures:
armhf arm64
Section:
devel
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Builds

Cosmic: [FULLYBUILT] arm64 [FULLYBUILT] armhf

Downloads

File Size SHA-256 Checksum
linux-raspi2_4.18.0.orig.tar.gz 149.8 MiB fd5c4f5ab07d6dccf7ef79317e36c2754438fb3d79d750df1d9868bab0de9573
linux-raspi2_4.18.0-1010.12.diff.gz 9.8 MiB 480bfc2968f37ca84325881c1ac34f6afbceb892499c7781d480fe02873bad54
linux-raspi2_4.18.0-1010.12.dsc 3.8 KiB ac225648b840e4e3aff7ac339b91371ea2abcaa1ac7ddb3afb0d458f4306d03d

Available diffs

View changes file

Binary packages built by this source

linux-buildinfo-4.18.0-1010-raspi2: No summary available for linux-buildinfo-4.18.0-1010-raspi2 in ubuntu disco.

No description available for linux-buildinfo-4.18.0-1010-raspi2 in ubuntu disco.

linux-headers-4.18.0-1010-raspi2: No summary available for linux-headers-4.18.0-1010-raspi2 in ubuntu disco.

No description available for linux-headers-4.18.0-1010-raspi2 in ubuntu disco.

linux-image-4.18.0-1010-raspi2: No summary available for linux-image-4.18.0-1010-raspi2 in ubuntu disco.

No description available for linux-image-4.18.0-1010-raspi2 in ubuntu disco.

linux-image-4.18.0-1010-raspi2-dbgsym: Linux kernel debug image for version 4.18.0 on ARM (hard float) SMP

 This package provides the kernel debug image for version 4.18.0 on
 ARM (hard float) SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-modules-4.18.0-1010-raspi2: Linux kernel extra modules for version 4.18.0 on ARM (hard float) SMP

 Contains the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Generic processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-raspi2 meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-raspi2-headers-4.18.0-1010: No summary available for linux-raspi2-headers-4.18.0-1010 in ubuntu disco.

No description available for linux-raspi2-headers-4.18.0-1010 in ubuntu disco.

linux-raspi2-tools-4.18.0-1010: Linux kernel version specific tools for version 4.18.0-1010

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 4.18.0-1010 on
 ARM (hard float).
 You probabaly want to install the linux-tools-<flavour> meta package.

linux-tools-4.18.0-1010-raspi2: Linux kernel version specific tools for version 4.18.0-1010

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 4.18.0-1010 on
 ARM (hard float).