Freeze in Dapper RC when logging out or shutting down

Bug #46874 reported by Nicklas Svanteson on 2006-05-27
10
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.15 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: nvidia-glx

After a clean install I don't have this problem but after installing nvidia-glx the system hangs when trying to logout or shutting down. Not even "sudo reboot" works.
It seems to have something to do with the xserver changing resolution from 1280x1024 to the console resolution.
I have come to this conclusion by changing the console (usplash) resolution to 1280x1024 (vga=794) and that solves the problem.

An other workaround is to remove the splash as suggested in the following thread:
http://ubuntuforums.org/showpost.php?p=940244&postcount=34

So the problem might be related to usplash instead of nvidia-glx. More info. in the thread:
http://ubuntuforums.org/showthread.php?t=161580

FYI

I have done a fresh install with Dapper Final and the issue is still there.
Doesn't everyone with a nvidia-glx installed have this problem? Is it just me?
It's not a showstopper for me. I solve it by changing the usplash resolution to 1280x1024 but I guess new users would not know about this.

Lillian (lillian) wrote :

Disabling the splash worked for me (GeForce FX 5700 Ultra) but I haven't tried setting the usplash resolution.

I've had this problem since I installed Breezy when it came out (on exactly the same hardware). I hadn't used ubuntu before then so I don't know if it was around before then (meaning is it an Ubuntu/uspash bug or an nvidia bug) but I don't remember this ever happening when I used Fedora (again, same hardware). Of course, YMMV.

When this was still broken for me, after powercycling the box the xserver would frequently not be able to run in any resolution other than 800x600. Trying to switch resolutions from the keyboard did nothing, and the Screen Resolution tool only showed 800x600 in the combobox. The xorg.conf seemed to still have all the right entries, but was apparently being ignored. I would also seem to get the wrong or vanilla/default session (no session-saved apps running). Sometimes several reboots were needed before I could get the other resolutions back; the proper session also seemed to return then as well.

Recently I helped in chat an user with same problem. He have a fresh new updated dapper (Kubuntu Dapper 64 bit) installation with XFX geforce 5700 ultra (driver 8762), 1280 * 1024 resolution. His PC freeze when loggin out.
Removing splash solved the issue.

Hope that helps.

sushswoosh (sushswoosh) wrote :

I've had the same problems on ATI Xpress200 onboard graphics. :-D

Disabling splash on boot should work.

Timo Aaltonen (tjaalton) wrote :

Closing the bug since it's very old without any activity in a long time. Please open a new bug against nvidia-graphics-drivers-VERSION if you have problems in 8.04 or later.

Changed in linux-restricted-modules-2.6.15:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers