Ubuntu

[acx111] default firmware not working for acx d-link dwl-g650+

Reported by Rafał Próchniak on 2006-02-07
172
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.15 (Ubuntu)
Medium
Unassigned
linux-restricted-modules-2.6.17 (Ubuntu)
Medium
Unassigned
linux-source-2.6.15 (Ubuntu)
Undecided
Unassigned

Bug Description

As in the summary, acx111-based d-link dwl-g650+ does not work with the default firmware.

It works with 1.2.1.34 (tiacx111c16) - this is the firmware recommended (as the better of the only two working) on acx100 development website - see http://acx100.sourceforge.net/wiki/Firmware

as required in readme.txt

as required

Each kernel upgrade breaks manual links (well, obviously). As of 2.6.15-17 default firmware does not work for d-link dwl-g650+

Sitsofe Wheeler (sitsofe) wrote :

This looks related to Bug #26703

also, firmware doesnt work fro dlink g520+.
As noticed in ubuntu forums
 http://www.ubuntuforums.org/showthread.php?p=863071&posted=1#post863071

fix for the problem (with dlink g520+s and g650+s) is to manually overwrite /lib/firmware/2.6.15-19-386/acx/2.3.1.31/tiacx111c16
with tiacx111c16 obtained from location stated in ubuntu thread, http://195.66.192.167/linux/acx_patches/fw/acx111_1.2.1.34/tiacx111c16 . Not sure why this works.

also, every kernel upgrade requires you to overwrite tiacx111c16 in the new kernels firmware directories.

So for kernel 2.6.15-19-386 you overwrite it in /lib/firmware/2.6.15-19-386/acx/2.3.1.31/

and for kernel 2.6.15-20-386 you overwrite it in
/lib/firmware/2.6.15-20-386/acx/2.3.1.31/

Rafał Próchniak (burlap) wrote :

Instead of overwriting files you should delete tiacx111c16
from /lib/firmware/[kernel version]/acx/default (it links to 2.3.1.31) and create a link to /lib/firmware/[kernel version]/acx/1.2.1.34/tiacx111c16. And repeat after each kernel upgrade.

gmlion (gm-l) wrote :

An easier way should be to add acx firmware_ver=1.2.1.34 in /etc/modules

gmlion (gm-l) wrote :

I wrong. Of course the best way is to add

options acx firmware_ver=1.2.1.34

somewhere (anywhere) in /etc/modprobe.d

Adam Conrad (adconrad) wrote :

The firmware selection based on PCI ID is handled by linux-source, LRM just ships the firmware.

Changed in linux-restricted-modules-2.6.15:
assignee: nobody → ben-collins
Jerry Chong (zanglang) on 2006-04-27
Changed in linux-restricted-modules-2.6.15:
status: Unconfirmed → Confirmed
Adam Conrad (adconrad) on 2006-04-28
Changed in linux-restricted-modules-2.6.15:
status: Confirmed → Rejected

I can confirm this. I have a ZyXEL G-360 EE pci card and it doesn't work with the default firmware provided in ubuntu. It works great if I follow the instructions found on the acx100 wiki page.

Changed in linux-source-2.6.15:
status: Unconfirmed → Confirmed
rodgie (rodgie) wrote :

From what i undestand it is not firmware problem.
Daper Drake has driver version 3.21.
(version available via iwconfig wlan0 command -> nickname)

Changelog from website http://acx100.erley.org/ where the driver is developed (only important parts)::

[20060126] 0.3.31
* fix bug uncovered by code added in support for firmware 2.3.1.31
[20060124] 0.3.30
* fix breakage introduced by vda
* Bas Vermeulen <email address hidden>:
  support for firmware 2.3.1.31
[20060108] 0.3.25
* fix scanning breakage

Also the new driver looks for firmware in /lib/firmware directory, so it is visible to all kernel versions.

I am new in Linux but I spent a lot of time installing my DLink G650+, and I think the best solution is to use the newest driver in Ubuntu:

http://acx100.erley.org/acx-20060521.tar.bz2

Including the new driver in Daper's kernel's modules would help many acx 100/111 users.

If it's possible I would be really grateful for saving my time each time I set up new kernel.
--
PS.I currently use driver v. 3.35 (acx-20060215.tar.bz2) , I haven't checked the newest one yet.
PS2. Installing with compiling of the whole kernel is explained in drivers README file.

David Planella (dpm) wrote :

I can also confirm this on my D-Link DWL-G650+.

After adding

options acx firmware_ver=1.2.1.34

to /etc/modprobe.d/options as gmlion suggested

AND

using the gtkwifi applet I got my wireless card to work.

Does the new firmware (2.3.1.31) work for anyone? Otherwise this bug could easily be fixed by linking to the right firmware (1.2.1.34), couldn't it?

rodgie (rodgie) wrote :

firmware 2.3.1.31 works on driver version 3.35 .
( D-link G650+ h/w B2).

Rafał Próchniak (burlap) wrote :

No change as of the official dapper release.

It is quite confusing, especially for new users: the card switches on (as indicated by a LED), but it doesn't work. Networking config shows it as "configured" and "active".

David Planella (dpm) wrote :

I was also quite disappointed to see this one not fixed on the release. Especially as the fix is apparently so simple.

I agree that the situation this creates is way too confusing. It is difficult enough to get wifi to work, let alone if you've got the wrong firmware.

I spent some hours trying to get my card to work until I found this bug report. The 'Link' LED was on, which made me think that this time we got the correct firmware (remember Breezy? back then the distributed firmware was also the wrong one).

Ben Collins (ben-collins) wrote :

Added PCI id's to driver, so this will be fixed in next dapper kernel update.

Changed in linux-source-2.6.15:
status: Confirmed → Fix Committed
Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
Jerry Chong (zanglang) wrote :

Hmm, doesn't appear to be fixed yet on Dapper linux-2.6.15.26-386 yet. `iwlist scanning` still returns no results?
-----------------------------------------

tail -f /var/log/messages shows:

Jul 24 14:23:53 localhost kernel: [17179839.608000] pccard: CardBus card inserted into slot 0
Jul 24 14:23:53 localhost kernel: [17179839.608000] PCI: Enabling device 0000:03:00.0 (0000 -> 0002)
Jul 24 14:23:53 localhost kernel: [17179839.608000] ACPI: PCI Interrupt 0000:03:00.0[A] -> Link [LNKD] -> GSI 10 (level, low) -> IRQ 10
Jul 24 14:23:53 localhost kernel: [17179839.608000] acx: found ACX111-based wireless network card at 0000:03:00.0, irq:10, phymem1:0x34020000, phymem2:0x34000000, mem1:0xe0c3c000, mem1_size:8192, mem2:0xe0d00000, mem2_size:131072
Jul 24 14:23:54 localhost kernel: [17179840.380000] acx: firmware 'Rev 2.3.1.31' does not work well with this driver
Jul 24 14:23:54 localhost kernel: [17179840.380000] acx: form factor 0x01 ((mini-)PCI / CardBus), radio type 0x16 (Radia), EEPROM version 0x05, uploaded firmware 'Rev 2.3.1.31' (0x03010101)
Jul 24 14:23:54 localhost kernel: [17179840.380000] acx v0.3.21: net device wlan0, driver compiled against wireless extensions 19 and Linux 2.6.15-26-386
Jul 24 14:23:55 localhost kernel: [17179840.864000] ADDRCONF(NETDEV_UP): wlan0: link is not ready
---------------------------------------

lspci -vv outputs:

0000:03:00.0 Network controller: Texas Instruments ACX 111 54Mbps Wireless Interface
        Subsystem: D-Link System Inc DWL-G650+ AirPlusG+ CardBus Wireless LAN
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64
        Interrupt: pin A routed to IRQ 10
        Region 0: Memory at 34020000 (32-bit, non-prefetchable) [size=8K]
        Region 1: Memory at 34000000 (32-bit, non-prefetchable) [size=128K]
        Capabilities: [40] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0+,D1+,D2+,D3hot+,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

Nikolaus Rath (nikratio) wrote :

I just wanted to note that it is not sufficient to rmmod the module and reload it with firmware_ver=.... It is necessary to restart the pc. Took me quite a while to figure that out.

David Planella (dpm) wrote :

The bug reappeared in edgy knot3.

I submitted another bug about it. In case anyone else can confirm this:

https://launchpad.net/distros/ubuntu/+source/linux-source-2.6.17/+bug/60905

Owen Stickley (owenstickley) wrote :

Would just like to confirm this bug.

It's "easily enough" fixed by performing the instructions here: http://acx100.sourceforge.net/wiki/Distribution_list/Ubuntu

I wonder why it hasn't been fixed yet? :(

Jerry Chong (zanglang) wrote :

Updated so hopefully this will gain exposure?

Changed in linux-restricted-modules-2.6.15:
status: Rejected → Unconfirmed
Ben Collins (ben-collins) wrote :

Default for acx111 r16 and r17 will be 1.2.1.34 in next upload. May retroactively do this for dapper too.

Changed in linux-source-2.6.17:
assignee: nobody → ben-collins
status: Unconfirmed → Fix Committed
Changed in linux-source-2.6.15:
assignee: ben-collins → nobody
status: Fix Released → Confirmed
David Planella (dpm) wrote :

It would be nice to have this bug fixed on the next dapper point release too, since now wireless does not work at all using the live cd on systems with cards with the TI acx chipset, and the bugfix seems relatively trivial.

AaronPeterson (alpeterson) wrote :

not in 2.6.15-27-386 that I just installed yesterday :(

Luckilly I know how to fix it now.

Loïc Martin (loic-martin3) wrote :

Edgy beta links to the right firmware, however the d-link dwl-g650+ is still not fonctionnal. On Dapper, one could add "blacklist acx" to /etc/modprobe.d/blacklist then the card would work (after selecting the right firmware of course), however doing the same on Edgy removes the card from the detected network interfaces (iwconfig doesn't show it anymore, nor does network-manager.

Has anybody had success with the card on Edgy yet?

David Planella (dpm) wrote :

The card works for me on my system and also on the edgy beta livecd.

IIRC, to get it working on the livecd, I simply edited /etc/network/interfaces with the right settings for my WLAN, and then did an 'ifdown wlan0' and an 'ifup wlan0'.

AFAIK, the beta livecd now loads the right firmware, so if I'm not mistaken, there is no need for the /etc/modprobe.d/blacklist thing.

Matthew Garrett (mjg59) wrote :

My g650+ works fine. Could you elaborate on "still not functional"?

Loïc Martin (loic-martin3) wrote :

Sorry, my mistake.
I was trying to install the card the same way as in Dapper. I didn't think there was free drivers yet for the g650+, and was using ndiswrapper. If I don't do anything, it works (just need to configure the wlan).

Thanks and sorry again.

Otto Kekäläinen (otto) wrote :

This firmware issue is fixed upstream.

Changed in linux-restricted-modules-2.6.15:
status: Confirmed → Fix Released
David Planella (dpm) wrote :

> This firmware issue is fixed upstream.

Could you please indicate which upstream you are referring to and include a link to the upstream bug that has been fixed for linux-restricted-modules-2.6.15 (or a mention to a changelog where this is reported as being fixed)?

Otto Kekäläinen (otto) wrote :

In Ubuntu Dapper there is an error - it has the 2.3.1.31 firmware by default. This version does not work at all. You must copy the firmware from /lib/firmware/`uname -r`/acx/1.2.1.34 to /lib/firmware/`uname -r`/acx/default and restart, after this, everything works ok.

Changed in linux-restricted-modules-2.6.15:
status: Fix Released → Confirmed
Changed in linux-source-2.6.15:
status: New → Fix Released
Changed in linux-restricted-modules-2.6.15:
status: Confirmed → Fix Released
Timo Aaltonen (tjaalton) on 2008-02-07
Changed in linux-restricted-modules-2.6.17:
assignee: ben-collins → nobody
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers