Change log for linux-restricted-modules-2.6.17 package in Ubuntu

128 of 28 results
Obsolete in edgy-updates on 2008-06-19
Obsolete in edgy-security on 2008-06-19
linux-restricted-modules-2.6.17 (2.6.17.9-12.4) edgy-security; urgency=low

  * vmware-player update to 1.0.5:
    CVE-2007-2446 CVE-2007-2447 CVE-2007-0494
    CVE-2007-2442 CVE-2007-2443 CVE-2007-2798
    CVE-2007-0061 CVE-2007-0062 CVE-2007-0063
    CVE-2007-4059 CVE-2007-4155 CVE-2007-4496
    CVE-2007-4497 CVE-2007-1856 CVE-2006-1174
    CVE-2006-4600 CVE-2004-0813 CVE-2007-1716
    CVE-2006-3619 CVE-2006-4146

 -- <email address hidden> (Fabio M. Di Nitto)   Tue, 13 Nov 2007 14:55:25 +0100
Superseded in edgy-updates on 2007-11-17
Superseded in edgy-security on 2007-11-15
linux-restricted-modules-2.6.17 (2.6.17.8-12.3) edgy-security; urgency=low

  * Kernel ABI bump

 -- Tim Gardner <email address hidden>   Wed, 11 Jul 2007 05:58:25 -0600
Superseded in edgy-security on 2007-07-18
linux-restricted-modules-2.6.17 (2.6.17.8-11.2) edgy-security; urgency=low

  * Fix PPC Madwifi build failure.

 -- Tim Gardner <email address hidden>   Thu, 28 Jun 2007 10:35:05 -0600
Superseded in edgy-security on 2007-06-29
linux-restricted-modules-2.6.17 (2.6.17.7-11.2) edgy-security; urgency=low

  * Included dropped fixes from linux-restricted-modules-2.6.17 (2.6.17.5-11)
    which fix LP#66908.
  * Uploading to edgy-security on instruction from Martin Pitt.

 -- Kyle McMartin <email address hidden>   Thu, 27 Feb 2007 15:42:58 -0500
Superseded in edgy-security on 2007-03-01
linux-restricted-modules-2.6.17 (2.6.17.7-11.1) edgy-security; urgency=low

  * Update l-r-m in accordance with l-s-2.6.17 abi bump.

 -- Kyle McMartin <email address hidden>   Thu,  1 Feb 2007 17:34:52 -0500
Superseded in edgy-security on 2007-02-08
linux-restricted-modules-2.6.17 (2.6.17.7-10.1) edgy-security; urgency=low

  * Upgrade madwifi to 0.9.2.1 to fix security issue.
  * Change lrm versioning to reflect ABI.

 -- Ben Collins <email address hidden>   Mon,  8 Jan 2007 23:31:13 -0500
Superseded in edgy-security on 2007-01-09
linux-restricted-modules-2.6.17 (2.6.17.6-1) edgy-security; urgency=low

  * SECURITY UPDATE: nvidia Xorg driver had a heap overflow allowing
    for arbitrary code execution.
  * Updated nvidia driver to version 8776.
  * References
    http://nvidia.custhelp.com/cgi-bin/nvidia.cfg/php/enduser/std_adp.php?p_faqid=1971
    CVE-2006-5379

 -- Kees Cook <email address hidden>   Fri, 20 Oct 2006 15:30:18 -0700
Deleted in feisty-release on 2007-04-06 (Reason: superseded by linux-restricted-modules-2.6.20)
Obsolete in edgy-release on 2008-06-19
linux-restricted-modules-2.6.17 (2.6.17.5-11) edgy; urgency=low

  * nvidia/nvidia-glx-config: Use modprobe with -i when checking for the
    nvidia module, since it will not load before xorg.conf gets changed.
    Closes: LP#66908

 -- Martin Pitt <email address hidden>   Thu, 19 Oct 2006 15:36:24 +0000
Superseded in edgy-release on 2006-10-20
linux-restricted-modules-2.6.17 (2.6.17.5-10) edgy; urgency=low

  * Introduce /sbin/lrm-video to do detection of the current Xorg driver,
    and load the right (nvidia/nvidia_legacy/fglrx or none) module.
  * Remove the modprobe hack that was used for the above, and replace with
    a much simpler modprobe.d snippet that just calls the above script.
  * Make nvidia-glx, nvidia-glx-legacy, and xorg-driver-fglrx depend on
    linux-restricted-modules-common to get the above script when wanted.
  * Disable building and shipping madwifi for powerpc64-smp, since we don't
    have a powerpc64 binary blob provided by upstream (yet, here's hoping).
  * Fix the clean target to get rid of vmware-player-kernel-modules.postrm.

 -- Adam Conrad <email address hidden>   Mon,  9 Oct 2006 15:36:47 +1000
Superseded in edgy-release on 2006-10-09
linux-restricted-modules-2.6.17 (2.6.17.5-9) edgy; urgency=low

  * Use the /.../I GNU extension to sed to match and replace
    case-insensitively instead of using /usr/bin/tr, otherwise people with
    /usr on a separate partition won't get the fglrx module loaded.

 -- Scott James Remnant <email address hidden>   Wed,  4 Oct 2006 10:03:48 +0100
Superseded in edgy-release on 2006-10-04
linux-restricted-modules-2.6.17 (2.6.17.5-8) edgy; urgency=low

  * Don't allow the fglrx module to be loaded if it's not used in
    xorg.conf

 -- Scott James Remnant <email address hidden>   Tue,  3 Oct 2006 10:30:01 +0100
Superseded in edgy-release on 2006-10-03
linux-restricted-modules-2.6.17 (2.6.17.5-7) edgy; urgency=low

  * Fix FTBFS on powerpc, s/powerpc-smp,/powerpc-smp/ in debian/rules.

 -- Adam Conrad <email address hidden>   Tue,  3 Oct 2006 13:27:50 +1000
Superseded in edgy-release on 2006-10-03
linux-restricted-modules-2.6.17 (2.6.17.5-6) edgy; urgency=low

  * Add powerpc64-smp target on powerpc.
    - Malone #63197

 -- Ben Collins <email address hidden>   Sun,  1 Oct 2006 12:11:00 -0400
Superseded in edgy-release on 2006-10-01
linux-restricted-modules-2.6.17 (2.6.17.5-5) edgy; urgency=low

  * ABI bump to -10.

 -- Ben Collins <email address hidden>   Tue, 26 Sep 2006 10:20:26 -0400
Superseded in edgy-release on 2006-09-26
linux-restricted-modules-2.6.17 (2.6.17.5-4) edgy; urgency=low

  * ABI bump to -9

 -- Tollef Fog Heen <email address hidden>   Fri, 22 Sep 2006 13:49:43 +0200
Superseded in edgy-release on 2006-09-22
linux-restricted-modules-2.6.17 (2.6.17.5-3) edgy; urgency=low

  * Temporary fixup for default acx111 v16 and v17 firmware. Set default to
    1.2.1.34. Next time the .orig.tar.gz is recreated, remove the default
    symlinks, and we'll always generate them in the rules file.

 -- Ben Collins <email address hidden>   Tue, 19 Sep 2006 12:17:37 -0400
Superseded in edgy-release on 2006-09-19
linux-restricted-modules-2.6.17 (2.6.17.5-2) edgy; urgency=low

  * Kernel ABI bump for linux-source-2.6.17 version 2.6.17-8.21.

 -- Ben Collins <email address hidden>   Mon, 18 Sep 2006 11:02:00 -0400
Superseded in edgy-release on 2006-09-19
linux-restricted-modules-2.6.17 (2.6.17.5-1) edgy; urgency=low

  * ABI bump.
  * Include vmware-player modules. vmware-server modules coming soon.
  * Rework package names based on recent kernel changes.
  * Add vmware-player vmmon and vmnet kernel modules. These are from
    vmware-player 1.0.2.

 -- Ben Collins <email address hidden>   Wed, 30 Aug 2006 13:00:06 -0400
Superseded in edgy-release on 2006-09-06
linux-restricted-modules-2.6.17 (2.6.17.4-1) edgy; urgency=low

  * Repack the orig with the correct nvidia-legacy package for amd64, this
    time including 32-bit libraries.  Revert the previous change to cope.

 -- Adam Conrad <email address hidden>   Wed, 30 Aug 2006 19:01:32 +1000
Superseded in edgy-release on 2006-08-30
linux-restricted-modules-2.6.17 (2.6.17.3-2) edgy; urgency=low

  * Adjust some static strings in debian/rules to cope with nvidia changing
    the filename for the amd64 nvidia-legacy package, resolving amd64 FTBFS.

 -- Adam Conrad <email address hidden>   Wed, 30 Aug 2006 11:09:14 +1000
Superseded in edgy-release on 2006-08-30
linux-restricted-modules-2.6.17 (2.6.17.3-1) edgy; urgency=low

  * Update fglrx to new upstream 8.28.8, required to support edgy's Xorg 7.1:
    - Include links in xorg-driver-fglrx for the new libfglrx_tvout library.
    - Include binaries from /usr/sbin and manpages from /usr/share/man/man8.
  * Update non-legacy NVIDIA driver to new upstream 1.0.8774 and legacy NVIDIA
    driver to new upstream 1.0.7184, both required for Xorg 7.1 support.
  * Bump xserver-xorg-core dependencies to (>= 1:1.1.1) for the above changes.

 -- Adam Conrad <email address hidden>   Tue, 29 Aug 2006 22:16:27 +1000
Superseded in edgy-release on 2006-08-29
linux-restricted-modules-2.6.17 (2.6.17.2-1) edgy; urgency=low

  * ipw3945: Update ipw3945d to 1.7.22.
  * madwifi: Remove legacy and ng drivers. Replace with stock madwifi-ng 0.9.2
    driver.
  * dvb: Added dvb firmware.
  * Kernel ABI bump for linux-source-2.6.17 version 2.6.17-6.17.

 -- Ben Collins <email address hidden>   Wed,  9 Aug 2006 14:37:41 -0400
Superseded in edgy-release on 2006-08-11
linux-restricted-modules-2.6.17 (2.6.17.1-6) edgy; urgency=low

  * Kernel ABI bump for linux-source-2.6.17 version 2.6.17-5.9.

 -- Colin Watson <email address hidden>   Sat, 15 Jul 2006 18:42:13 +0100
Superseded in edgy-release on 2006-07-15
linux-restricted-modules-2.6.17 (2.6.17.1-5) edgy; urgency=low

  * Provides: xserver-xorg-video instead of xserver-xorg-driver.

 -- Fabio M. Di Nitto <email address hidden>   Thu, 13 Jul 2006 13:58:25 +0200
Superseded in edgy-release on 2006-07-13
linux-restricted-modules-2.6.17 (2.6.17.1-4) edgy; urgency=low

  * debian/nvidia-glx.dirs.in: Add missing /usr/lib32/nvidia to fix ia32-libs
    installation breakage when nvidia-glx is installed (otherwise the
    libGL.so.1.2 diversion points into a nonexisting directory).

 -- Martin Pitt <email address hidden>   Thu, 13 Jul 2006 10:36:35 +0000
Superseded in edgy-release on 2006-07-13
linux-restricted-modules-2.6.17 (2.6.17.1-3) edgy; urgency=low

  * Kernel ABI bump for linux-source-2.6.17 version 2.6.17-4.5.

 -- Ben Collins <email address hidden>   Fri, 30 Jun 2006 14:54:34 +0000
Superseded in edgy-release on 2006-07-03
linux-restricted-modules-2.6.17 (2.6.17.1-2) edgy; urgency=low

  * Work around buggy binutils by not stripping pre-build nvidia libs.

 -- Ben Collins <email address hidden>   Thu, 29 Jun 2006 18:14:21 +0000
Superseded in edgy-release on 2006-06-29
linux-restricted-modules-2.6.17 (2.6.17.1-1) edgy; urgency=low

  * 2.6.17 kernel, glad to meet ya.
  * s/ia32-libs/libc6-i386/ on amd64 build-deps.
  * Use gcc on non-hppa, instead of gcc-4.0.
  * ATI
    - Add patch to fix no_iommu missing error.
    - Add patch to rework the makefile, since it's targets were clashing
      somehow with kbuil built-in targets.
  * Nvidia
    - Update legacy driver to 7182
  * Fritz
    - Disable fcpcmcia and fcpcmcia_cs. No longer build, no longer supported.

 -- Ben Collins <email address hidden>   Tue, 27 Jun 2006 21:05:50 -0400
128 of 28 results