iMac G5 will freeze after booting up

Bug #23445 reported by Reg User on 2005-10-08
154
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
High
Ben Collins
linux-source-2.6.17 (Ubuntu)
Undecided
Unassigned

Bug Description

I have a 2.0 Ghz iMac G5 with Breezy installed. After the command prompt comes
up (I have removed the gdm startup thinking this may be an X problem) I am able
to log in, but then maybe 20 seconds later, the prompt will freeze and I cannot
enter anything in. I have been able to quickly log in and update my computer and
everything will work fine, but about 20 seconds after the update/upgrade
completes, it freezes. After waiting for a minute or so, I will get these errors
at the prompt:

ata1; command 0x35 timeout, stat 0x50 host_stat 0x4
mpic_enable_irq timeout

and it will repeat.

Reg User (zeeeee) wrote :

I have to force a reboot by powering off.

Glen Gray (glen-lincor) wrote :

I can confirm this also on a rev A iMac G5 1.8GHz with nVidia gfx.

Chas Stewart (faramirtook) wrote :

I can also confirm this. I also think this is a kernel issue in USB 2 support. iMac G5 17" 1.8 GHz rev. a.
I think it's a kernel issue because the same thing happened to me when I was trying Gentoo. I thought it was just my crappy kernel
configuring skills, but apparently its not. It's not a problem with GDM or X because I could boot up, log in, and begin to emerge gnome. I
had tried to stop it, hitting ^C, but nothing would appear, and nothing would happen, but the output would keep scrolling across the screen.

Reg User (zeeeee) wrote :

One thing I am wondering is the relationship with mpic_enable_irq has with the processor. Is this something that can be uninstalled somewhere?
Also, does this have to do with the SATA drives? It works fine if I boot up off the rescue CD. I am guessing (i just a poweruser) that its has to
do with the kernel. I also confirm that it is not X because I have booted with novideo and disabled X. This happens at the command prompt.

Karl Bartel (karlb) wrote :

I have the same problem on my 2 GHz iMac G5.

I also have the same symptoms. I have an iMac G5 20" 2Ghz.

After some search/tries I discovered that the freeze occurs when a sound is
played (or tried to). It is the case when gdm is started. It is also the case on
the console if you use Tab for the completion and the shell wants to beep.

I found a work-around for now:

 * boot using "Linux single" so gdm is not started
 * do not use tab on the console
 * disable sound in gdm by setting

SoundProgram=/bin/true
#SoundOnLogin=true

I can now log in :-)

Reg User (zeeeee) wrote :

I realized that I did not dist-upgrade, but did that and issues still exist. i
have been able to log into x by disabling gdm and using a non-gnome (blackbox)
window manager. It seems that I can type tab in blackbox, but cannot in console.
This is very strange. Is there anyone who needs some logs? Per Ludovic's
suggestions, they seem to work.

Reg User (zeeeee) wrote :

OK, I can play around until my hearts desire, until I type the TAB key.

Karl Bartel (karlb) wrote :

If you are using Gnome-Terminal, you can turn off the terminal bell in the preferences, which allows you to press TAB
without crashing your machine.

To prevent Gnome from crashing, do the following:
- Follow Ludovic's instructions to get a working gdm login screen
- Log into a "Failsafe Terminal" session
- start gconf-editor, look for "Sound Server Startup" and turn it off.
- You can now log into an default gnome session.

Florian Fankhauser (flo-ffxml) wrote :

Same problem on my iMac G5 1.8GHz. Disable the sound daemon seems to be a
workaround. But after login, the fan starts up full speed.

Francois (f-taiani) wrote :

(In reply to comment #10)
> Same problem on my iMac G5 1.8GHz. Disable the sound daemon seems to be a
> workaround. But after login, the fan starts up full speed.

This is due to newer monoprocessor G5 models using a new chipset for their cooling/power infrastructure. After a few seconds the firmware detects
there is no driver for the fans and kicks them into full speed for safety. The new infrastructure is called SMU and replaces the old PMU. Ben
Herrenschmidt (the main kernel developper for the ppc port) has been working on this. Experimental support for the SMU chipset should now be
available in the most recent kernels (>= 2.6.15, to be double-checked): see

http://lists.debian.org/debian-powerpc/2005/09/msg00542.html and
http://lists.debian.org/debian-powerpc/2005/11/msg00220.html

for more details.

Ben Collins (ben-collins) wrote :

If possible, please upgrade to Dapper's 2.6.15-7 kernel. If you do not want to
upgrade to Dapper, then you can also wait for the Dapper Flight 2 CD's, which
are due out within the next few days.

Let me know if this bug still exists with this kernel.

Karl Bartel (karlb) wrote :

Upgrading to 2.6.15-10 didn't help.

I upgraded to Dapper with a kernel 2.6.15-18-powerpc64-smp version 2.16.15-18-27 and the bug is still present.

I loaded the kernel module snd-powermac and the system freezed when I started the sound configurator.

sam tygier (samtygier) wrote :

looks like Bug #29368

Reg User (zeeeee) wrote :

Ben, This still exists with Dapper flight 5. The report mentions status: need more information. What specifically is needed? I am about to reformat my computer and want to help getting this working.

Ben Collins (ben-collins) wrote :

Reverting the tumbler portions of my ppc-snd rework. Hopefully this will fix a lot of problems.

Changed in linux-source-2.6.15:
status: Needs Info → Fix Committed
Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released

Reopen this bug as per comments in bug #45152 (marked as duplicate).

Changed in linux-source-2.6.15:
status: Fix Released → Confirmed
Dennis de Vaal (d-devaal) wrote :

1. This bug has been around for some months. Has never been fixed.
2. The newest kernel stable kernel as of this writing: 2.6.17.6 has correct thermal support but no working sound. Upon boot dmesg says snd: unknown layout 0x53.

I am not running Ubuntu at all but i'm having these issues for months and no fix had ever been applied to my knowledge. On the Ubuntu forums, YellowDog forums, Fedora and Gentoo forums all people have the same problems. I posted in different bugs on launcpad but some of them were deleted? After months it's still not fixed how long will this take? Or will this post sit here for months again with a single fix?

cruiseoveride (cruiseoveride) wrote :

Everything but sound works on Fedora Core

Ben Collins (ben-collins) wrote :

Please test against Edgy Eft (Knot 1 CD's have been released).

This is based on a 2.6.17.6 kernel, but also has many updates from the alsa tree, especially related to snd_aoa.

Mark (azovap002) wrote :

Please splurge for an internal test unit. There have been more than enough user bug reports over many months/years. For sale on eBay and other places.

The iMac G5 needs to be part of the official Ubuntu dev/release cycles, not an afterthought.

If we want a Linux that takes endless debugging, Googling, and hacking, well, why use Ubuntu for that? Any other distro will do. The whole point of Ubuntu was regular packaging and compatibility testing. If the Ubuntu team is not going to do that for iMac G5's then it should be removed from the list of supported hardware. That would be sad but at least more honest.

Ben Collins (ben-collins) wrote :

Unfortunately, we cannot buy every piece of hardware that doesn't work or that we want to support. It's not a matter of money, it's more a matter of space. I already have 5 different powerpc machines (iMac G4, G4 Tower, G5 Tower, PowerBook G4, and IBM OpenServer). This is in addition to my other hardware. Other developers also have large amounts of existing, and expanding hardware.

Anyway, I'm more than willing to try to get this working if any of the users are willing to test some things. If we can pinpoint the problem, it's a one time deal to getting this hardware supported. Otherwise, it's going to remain non-working

Ben Collins (ben-collins) wrote :

This bug may be fixed in the current edgy developement system. In an effort to track this bug to our latest distribution, it is being targeted for edgy.

Please confirm whether this bug exists in edgy. If not, then please re-attach all related output (e.g. dmesg, oops output) while under edgy.

Latest Edgy CD's can be downloaded from:

http://cdimage.ubuntu.com/releases/edgy/knot-1/

If this image does not boot from you, you can also download a current daily build from:

http://cdimage.ubuntu.com/daily-live/current/

Note that it may only be necessary to boot the LiveCD to see if your bug is fixed. In this case, you do not need to upgrade your installed system at all to confirm it. Certain bugs may require that you do an actual installation.

Changed in linux-source-2.6.17:
status: Unconfirmed → Needs Info
Torrance (torrance123) wrote :

I'm happy to be at least one guinea pig.

Will provide feedback on Edgy in a week or so (need to repartition, etc.).

There are reports that kernel 2.6.17 also resolves this problem (using "g5_defconf"). Unfortunately I don't know how to test this as I am not able to get a working system to compile. If indeed the latest kernel fixes the issue it'd be nice if someone could create a CD image, so that we can use the stable Dapper system just with an updated kernel.

Cheers for the bug-fixing. :-)

Hi,
i booted latest edgy live cd. all fine but a black screen when X is startet. the start sound is played in backround, so i think everything booted ok into gnome. in my opinion the ati x600 switches into the mode of the second monitor output! so the primary apple tft in the imac is turned off.

to put a external monitor on the mac i need a special adapter :) but i dont own it!

perhaps anyone can try this out? or look into the x-conf ?

greeting clemens

i found this
https://wiki.ubuntu.com/iMacG5revC

perhaps it helps.

Mike Hore (mike-hore) wrote :

This looks like the same problem I'm getting, in trying to boot the CD 6.06.1 live image on my 1.6 GHz iMac G5. After the initial series of messages under the ubunto logo, the fans spool up, the screen goes black and everything freezes needing a hard reboot.

I'm actually a bit astonished that this has been around since Oct last year and still not fixed -- after all it's hard and reproducible, and there are a lot of these machines out there. The main ubuntu page should have a warning saying it's currently incompatible with this hardware.

The instructions in the link in the previous message may well be helpful but as a Linux newbie with little spare time I don't really want to go down that road. I think I'll just come back in a month and hope someone's fixed it.

Cheers, Mike.

Mark (azovap002) wrote :

Ben said: "we cannot buy every piece of hardware that doesn't work or that we want to support. It's not a matter of money, it's more a matter of space."

Your viewpoint is in effect "we have enough Macs already." I might sympathize if these bugs were not so ancient, glaring, and cemented into a final release even after multiple user reports and months of time. There was a reason to say that you need actual hardware.

Ben, there have been, and still are, plenty of G5 testers. The test pool is not the problem.

We *already know* where the problems live - bluetooth & sound. The point you're missing is basic. The bugs themselves are what demand developer hardware, not picky users.

Testing in the face of such serious bugs is not something users should do. Some bugs need hardware to solve right. Example - I could not type into yaboot.conf. Glitches froze everything in the middle of editing. It was a race against time to change a single line. That kind of thing makes "user testing" impossible. Yes I used "single" mode and every other trick. I tried every user-forum workaround, removing bluetooth packages, all of it. Nothing helped. If I were an Ubuntu developer with debug output screens and source familiarity, I would know what to do. That is why these bugs call for hardware.

Bugs that sit unsolved for endless months, AND are crashing-kernel severity, AND prevent user boot, AND have multiple corroboration reports, AND have known code locations (sound/bluetooth), merit hardware. Code this broken needs serious developer attention on the actual box. With hardware you'll have them fixed in short order. Without it Ubuntu will continue pretending to support hardware that it doesn't.

That you have other PPC machines is nice but irrelevant. Either Ubuntu supports the iMac G5 or not. If not, take it off the list of supported hardware.

Your office should not be full of hardware that works, but hardware that won't. My advice? Put one of those working G3/G4s in the closet; replace it with a G5. Desk space is then unchanged. No closet? Rent a public storage unit.

At least the G3/4 crowd can boot up and do proper user testing. I can't.

Mark (azovap002) wrote :

P.S. Make that bluetooth/sound/power-manager (fans). So there are at least three (3) hardware-specific bugs of maximum severity peculiar to this hardware. This is the kind of place where Ubuntu could really, really help Debian with hardware support and development.

I just tested it with the latest Edgy Eft iso (disk installation).
Both the cd and the disk install work with sound etc, not 1 crash and
its pretty fast too. Just some other glitches but I think these are
eft specific.Oh, the fan sometimes its not working at all, some times
is working at full speed. Anyway good job.

On 8/25/06, Mark <email address hidden> wrote:
> P.S. Make that bluetooth/sound/power-manager (fans). So there are at
> least three (3) hardware-specific bugs of maximum severity peculiar to
> this hardware. This is the kind of place where Ubuntu could really,
> really help Debian with hardware support and development.
>
> --
> iMac G5 will freeze after booting up
> https://launchpad.net/bugs/23445
>

--
- morthul surinen
        fenya quelli
     (R.I.P 0x7D4)

Torrance (torrance123) wrote :

Hi,

Could those reporting back please specify if they are using a Revision A, B or C iMac G5?

Revision A is the very first iMac G5, which has a flat/squarish back. Revision B has a curved back but no iSight. And Rev C has iSight. The components within each of these revisions are slightly different, including the fact that a Nvidia card is used in Rev A, and it seems an ATI card is used in Rev C. While all 3 don't work with Breezy, it seems as though there are differing results with Edgy.

Oh, and Emmanuel, could you please elaborate on the fan issue? Sounds dangerous if at times it is not working at all - couldf result in hardware overheating!

Cheers,

Torrance

Mike Hore (mike-hore) wrote :

Mine's Rev A.

It looks like I should give Edgy a try -- I will if I get time. We're about to go away for a few weeks' break :-)

Cheers, Mike.

Emmanuel Ch. (eruyome) wrote :

Mine is a Rev B with an Ati card.

Terrace, sure. Just tell me what to do. I am new in the mac on linux
stuff myself, and Eft is the first distro that i've set up working on
the iMac (working with disk install, that is, ubuntu and kubuntu
breezy live worked at it too, but no sound, and crazy fan). So I might
need a bit of guidance.

On 8/27/06, Mike Hore <email address hidden> wrote:
> Mine's Rev A.
>
> It looks like I should give Edgy a try -- I will if I get time. We're
> about to go away for a few weeks' break :-)
>
> Cheers, Mike.
>
> --
> iMac G5 will freeze after booting up
> https://launchpad.net/bugs/23445
>

--
- morthul surinen
        fenya quelli
     (R.I.P 0x7D4)

Dylan (dylanross) wrote :

I planned on booting Edgy Live on my Rev. B today, but upon opening Disk Utility, I discovered that the ISO is something like 715 MB... So I can't burn a CD. So maybe you fixed the iMac bug... That's wonderful, albeit useless if I can't burn the CD.

Maybe I'm doing this wrong? I used the daily ISO from today. Are the older images burnable (and do they work on the iMac)?

Dylan (dylanross) wrote :

Oh, and just FYI, I started downloading the release I found at

http://cdimage.ubuntu.com/releases/edgy/knot-1/

I assume this is probably what the rest of you have been using, as it says it's 676 MB. I'll be sure to let you know how everything goes once I've downloaded/burned the ISO.

Torrance (torrance123) wrote :

I'm using an iMacG5 Rev A, 17inch.

Incredibibly the LiveCD for Edgy Knot 1 boots, Gnome comes up, and for the first time ever I also have sound under a linux system.

Unfortunately, the thermal/fan control still isn't enabled (it's a kernel option!) and my native screen resolution wasn't recognised (though the work-around for Breezy resulted in native screen resolution so I think this may just be a problem with the LiveCD).

Anyway, it seems to me the initial problem for all systems has been fixed with the latest kernel. What still needs to be worked around is X-Windows configurations for the Nvidia and ATI chips, as well as the thermal control.

Dylan (dylanross) wrote :

I've got Edgy Knot 1 installed and running on my Rev B.

However, the resolution is totally screwed. If anyone could offer some direction or an xconf, that'd be great.

PS. Bluetooth and AirPort aren't working (although I wouldn't expect them to work out of the box, anyway).

On 8/28/06, Dylan <email address hidden> wrote:
> I've got Edgy Knot 1 installed and running on my Rev B.
>
> However, the resolution is totally screwed. If anyone could offer some
> direction or an xconf, that'd be great.
>
>
> PS. Bluetooth and AirPort aren't working (although I wouldn't expect
> them to work out of the box, anyway).
>
> --
> iMac G5 will freeze after booting up
> https://launchpad.net/bugs/23445
>

--
- morthul surinen
        fenya quelli
     (R.I.P 0x7D4)

It can be easily changed at /etc/X11/xorg.conf
Just add "1440x900" at the resolutions for depth 24. You'll see when
you get there.
I had my Airport working. See http://www.ubuntuforums.org/showthread.php?=142727
It needs to grab your Airport firmware from
/System/Library/Extensions/AppleAirPort2.kext/Contents/MacOS/AppleAirport2

Again you will see when you read the howto.

I suppose needing to find the firmware yourself makes "AirPort not
working" not a bug, but could someone get into dapper a script that
does it automatically (since the modules for hfs+ are in the installer
cd anyway we could grab a copy of it and set up AirPort automatically.

Dylan (dylanross) wrote :

Thanks for the help. I fixed my resolution problem within minutes of making my post, then realized how stupid it was.

I can't view the ubuntu forums right now (they're temporarily down); however, I assume I'll need OS X installed to find my AirPort firmware key? I wiped my drive clean and have yet to install OS X... If there's another way, I'd rather do that, but it sounds like there isn't.

Lastly, any word on bluetooth?

Thanks for the help. Sorry if some of my questions seem stupid... I'm relatively new to Linux.

Mike Hore (mike-hore) wrote :

I can confirm Edgy knot-1 installer runs fine on my Rev-A. Once I've backed up my Mac partition and fixed the screen resolution I should be in business!
The fan is still running at full speed, but that's not a big problem for me since I'm in the tropics (Darwin -- lat 12deg S). Hopefully this will be fixed when Edgy goes final.

Cheers, Mike.

Mike Hore (mike-hore) wrote :

I can now confirm Edgy knot-1 installation runs on my Rev-A. I still have to work out how to convince the partitioner to let me dual-boot, but that's another question!

Cheers, Mike.

Dylan (dylanross) wrote :

Mike, adding the line

macosx=/ht@0,f2000000/pci@3/k2-sata-root@c/k2-sata@0/disk@0:8

(8 is my OS X partition number. It's probably different for you) to your /etc/yaboot.conf and then running ybin should let you boot into OS X.

Mike Hore (mike-hore) wrote :

Thanks Dylan,

Thanks -- my OSX partition is on # 5, but I'll keep that ready if I need it.

Actually my main problem is that I haven't been able to set up yaboot yet -- for dual-boot I have to choose manual partitioning, but there doesn't seem to be an option to create an Apple_bootstrap partition, then when the installer comes to install yaboot it complains that there's no Apple_bootstrap partition.

I've now done it by dropping into terminal and running mac-fdisk, and I'll try a bit later and see if I can just boot from the CD and run yabootconfig to set up yaboot. Alternatively I might be able to re-run the install and just accept the existing partitions (which are now correct) and continue from there.

Anyway the real problem (maybe needing fixing) is that in manually editing partitions there's no obvious way to create an Apple_bootstrap partition.

Cheers, Mike.

Torrance (torrance123) wrote :

"Anyway the real problem (maybe needing fixing) is that in manually
editing partitions there's no obvious way to create an Apple_bootstrap
partition."

Yes, I came across this too - it's listed as a bug the Ubuntu graphical
installer bug wiki. You can either use mac-fdisk to create a boot partition
(and the installer will write to this at the end despite saying it can't see
the partition at the start) or use the text installer.

Back to this bug, though: I managed to compile the 2.6.17.11 kernel in
Dapper using the g5_defconfig setting by halting X Windows from loading and
playing in the terminal. Incredibly, I have a working (and very fast)
Dapper, just minus the sound. This includes fan control. I'm having a play
right now to see if I can get the sound going.

Dylan (dylanross) wrote :

Let us know if you get the sound working in Dapper. While I will definitely continue to contribute as much as I can to Edgy, I would much rather be running a quick, stable OS (with sound).

Torrance (torrance123) wrote :

Yes, I got the sound working too. I have a fully functioning Dapper - sound and fans controlled (except for video that is a bit jerky) - simply by compiling the 2.6.16-rc5 kernel with the g5_defconfig configuration.

I've posted instructions about how to get a working Dapper here: http://ubuntuforums.org/showthread.php?p=1447777#post1447777 It'd be good to get feedback on how well this works.

Also, rather that using the kernel I've compiled, I'd really like people to try compiling their own kernel and see if we can also get smooth video. I tried compiling from the Ubuntu source (rather than from vanilla) but failed - but that source is probably the best to be experimenting with I think.

Torrance (torrance123) wrote :

Oops, that should have read 2.6.18-rc5 kernel - only this kernel has native sound support, although patches can be applied to earlier kernels, as has been done in the 2.6.17 Edgy kernel.

gothink3 (gothink3) wrote :

I'm sucking down the lastes edgy. I've been beating my head against the wall for hours with the red screen of death. Much thanks for all the work you guys did on this. Hopefully us g5imackers' will be up and running soon. Thanks again.

I just tried Dapper 6.061 (xubuntu) on my G5 single (PowerMac 9.1) and the same problems are there that go all of the way back to Breezy Badger (5.10):

1) Freezes at startup due to (among other things???) sound driver.
2) Lack of thermal fan control.

This has been going on forever.

Are there any developers out there listening, or has Ubuntu given up on the PPC platform?

How can you release new "versions" of Ubuntu and derivatives, without addressing the issues on "newer" Macs (ie Macs that are only 2-3 years old)?

Not everyone feels comfortable with compiling a new kernel or see the need, when Ubuntu "claims" that it supports the PPC architecture.

Let's try to get these issues sorted guys.

cruiseoveride (cruiseoveride) wrote :

These problems are very specific to ubuntu, as a similar setup (linux kernel, gdm, gnome etc) forund on Fedora Core work perfectly on the new iMac.
I suggest someone install Fedora Core and use it for deubugging to catch the symbols coming from gdm during the freeze point on ubuntu.

Emmanuel Ch. (eruyome) wrote :

Guys you could read the replies. It is said that in edgy eft it is
fixed. I've tried it on my "problematic" single g5 and it works, with
sound and everything (except bluetooth i guess)

Just wait for edgy to be released :)

On 9/4/06, cruiseoveride <email address hidden> wrote:
> These problems are very specific to ubuntu, as a similar setup (linux kernel, gdm, gnome etc) forund on Fedora Core work perfectly on the new iMac.
> I suggest someone install Fedora Core and use it for deubugging to catch the symbols coming from gdm during the freeze point on ubuntu.
>
> --
> iMac G5 will freeze after booting up
> https://launchpad.net/bugs/23445
>

--
- morthul surinen
        fenya quelli
     (R.I.P 0x7D4)

Mark (azovap002) wrote :

We use a "rev B" model with bluetooth mouse/keyboard from Apple. This means until bluetooth is fixed we can't even test anything.

Emmanuel Ch. (eruyome) wrote :

Well, revB comes with a bundled USB keyboard/mouse doesnt it? You can
still connect it when running linux and work :)

On 9/5/06, Mark <email address hidden> wrote:
> We use a "rev B" model with bluetooth mouse/keyboard from Apple. This
> means until bluetooth is fixed we can't even test anything.
>
> --
> iMac G5 will freeze after booting up
> https://launchpad.net/bugs/23445
>

--
- morthul surinen
        fenya quelli
     (R.I.P 0x7D4)

Mark (azovap002) wrote :

> Well, revB comes with a bundled USB
> keyboard/mouse doesnt it? You can
> still connect it when running linux and work :)

No it does not and no we cannot. Bluetooth-only input was a stock factory configuration from Apple, a popular one we hear.

Emmanuel Ch. (eruyome) wrote :

Tested bluetooth today, exchanging files with my mobile phone and it works.

On 9/5/06, Mark <email address hidden> wrote:
>
> > Well, revB comes with a bundled USB
> > keyboard/mouse doesnt it? You can
> > still connect it when running linux and work :)
>
> No it does not and no we cannot. Bluetooth-only input was a stock
> factory configuration from Apple, a popular one we hear.
>
> --
> iMac G5 will freeze after booting up
> https://launchpad.net/bugs/23445
>

--
- morthul surinen
        fenya quelli
     (R.I.P 0x7D4)

billg (billg-straypackets) wrote :

I'm writing this on a 20-inch iMac iSight I bought the week before Apple made the Intel announcement. The stock keyboard and mouse are USB.

i got still a black screen but the system boots into gnome corretly.
has anyone an idea?
wrong graphic output perhaps (the external one)?

jk (johan-illwinter) wrote :

iMac G5 rev C.

It boots up nicely but as soon as xwindows starts it is black only. It is possible to log into gnome, but still only black. Fan starts to sound like a vaccum cleaner after a minute or so.

jk (johan-illwinter) wrote :

I should add that I tested with knot-2.

Peter Royle (peteroyle) wrote :

Clemens, jk:

Using 20" iMac G5 RevC with Edgy Knot 2 alternate install

After installing in text mode I found the same problem as you on my iMac G5 RevC when I booted up. Updating the xorg.conf fixed the problem. I'm currently using a configuration based on the one available at http://bersace03.free.fr/pub/Linux/iMac%20G5/. I think that one's for a 17" (and also note the locale is french) but if you want you can download my modified version for 20" and US keyboard (attached).

To be able to modify the xorg I had to boot off of the alternate-install disk in rescue mode and start up a shell in my edgy root partition. You can then wget the xorg.conf from my server.

In time I'll probably try to determine the differences between the config that ships with edgy and the version I'm using now to see what needs to change in the shipped config to make it work.

Peter Royle (peteroyle) wrote :

 "You can then wget the xorg.conf from my server."

Sorry, I was going to host it but then I saw the attachment section. Download the attachment instead :)

thanks a lot!
i will try this in a few days an report here.

Hi, I tried booting from today's edgy live cd (daily build 13-Oct 06) on my 20" iMac G5 RevC and I still have the original problems, i.e. black screen and ventilator starting after about 1 minute. Can anyone confirm this? Has there been any progress on fixing the issue? What can I do to help? Thanks

Hi,

I confirm this. The xorg.conf use wrong freq. I provided a working
xorg.conf at http://wiki.ubuntu.com/iMacG5RevC . About the fan, Benjamin
Herrenschmidt will work on it later, any help is welcome, we need a
windfarm121 driver.

Étienne.
--
Verso l'Alto !

Matt Zimmerman (mdz) wrote :

Comments indicate that the kernel problem is fixed with recent Edgy builds. Please file a separate report under the xorg package if there is a problem with X configuration.

Changed in linux-source-2.6.17:
status: Needs Info → Fix Released

I got a response from Benjamin already on this issue, with regards to windfarm and Dapper Flight 3:

On Jan 22, 2006, at 23:02, Benjamin Herrenschmidt wrote:

"Oh, ok.. you mean the fans going full speed ? That's a matter of thermal
control not working on the machine. It's the single CPU G5 names
PowerMac9,1 in /proc/device-tree/model right ?

It should indeed work with recent kernels. I got some code in 2.6.15 but
there might still have been unresolved issues. Make sure you load the
windfarm_pm91 module and let us know... If it doesn't work, try an up to
date git snapshot. If still doesn't work, let me know and we'll track
the problem down."

I have been told by some people claiming to be in the know, that the G5 single (PowerMac 9.1) is similar to the iMac internally, just with a G5 exterior, of course. This with which windfarm modules are needed for which model - is it pinned down? Should I file a separate bug report on the windfarm_pm91 module and G5 single machines??? Thermal control is still not working for me with the new Edgy builds.

Étienne BERSAC (bersace) wrote :

Don't confuse iMac G5 rev {A,B} and rev C. They have a lot of
difference.

The priors have Powermac 9,1, the third has Powermac12,1. Currently, rev
C has no windfarm modules for their chipset, and radeonfb crashes at
startup.

Étienne.
--
Verso l'Alto !

jk (johan-illwinter) wrote :

Thanks for taking a look at it Etienne. The rev C vaccum cleaner is no fun.

Andrew Ash (ash211) wrote :

It looks like backporting this fix to Dapper will be difficult; kernel backports are treated very cautiously.

But now that Edgy has been released, are all of the three revisions fully functional?

Étienne BERSAC (bersace) wrote :

No,

Benjamin Herrenschmidt contact me and another iMac G5 rev C owner. He
become the work for supporting such box. It appears that there are in
fact two iMac G5 rev C with slightly different fan managment.

But this do not fix the radeonfb crash. Afaik, the radeonfb crash is not
fixed. I tryed 2.6.19-rc4 in feisty and got no more results.

Thanks,
Étienne.
--
Verso l'Alto !

Étienne BERSAC (bersace) wrote :

> He become the work for supporting such box.
I meant he "began".

--
Verso l'Alto !

jk (johan-illwinter) wrote :

On Tue, 2006-11-07 at 00:20 +0000, Andrew Ash wrote:
> It looks like backporting this fix to Dapper will be difficult; kernel
> backports are treated very cautiously.
>
> But now that Edgy has been released, are all of the three revisions
> fully functional?
>

Unfortunatelly, the rev C fan doesn't work.

/Johan

Timothy Smith (tas50) wrote :

Can someone test this under a Feisty build so we can see if this bug still exists?

http://cdimage.ubuntu.com/ports/releases/feisty/herd-5/

THIS IS AN IMPORTANT MESSAGE FROM GO THINK, LLC

Our offices will be closed from March 16th through March 26th.
Please keep creative thoughts on your minds at all times.
If you have a creative thought write it down so that you do not forget.
Please report all creative thoughts to the Go Think team upon our return.

Thank you for writing Go Think, LLC and have a creative day.

~ Go Think (3)

Peter Royle (peteroyle) wrote :

Timothy, I've downloaded the iso but I'm just waiting to get my hands on some more blank CDs to test it. Should get some by tomorrow. Will let you know how it goes.

Peter Royle (peteroyle) wrote :

Fiesty Herd 5 on iMac G5 Rev C:

Standard install CD suffers same symptoms as always: Requires video=ofonly, wierd colours in Ubuntu logo during boot, startup sound plays but screen remains black, fans alternate between loud and quiet.

Will download alternate CD to try text install...

Peter Royle (peteroyle) wrote :

Feisty Herd 5 on 20" iMac G5 Rev C - Alternate Install

After text install (using powerpc-64 with video=ofonly) the system booted and sound seemed to work but the screen was left black. After downloading the attached xorg config file Xorg now works, but there are 2 processes (Xorg and mouseemu) taking up all the CPU, making the system barely usable. A few minutes after logging in to the Gnome desktop the fans crank up to full speed and never return to normal. This may be related to the aforementioned runaway processes. Also wireless networking doesn't appear to be working out of the box.

Peter Royle (peteroyle) wrote :

After disabling GDM and booting into text mode the mouseemu process was still present and running at full CPU. The fans wound up to full again and did not go away even several minutes after killing the mouseemu process.

The following messages are printed to the terminal before the text login appears:

FATAL: Error inserting therm_pm72 (/lib/modules/2.6.20-9-powerpc64-smp/kernel/drivers/macintosh/therm_pm72.ko): No such device
FATAL: Error inserting windfarm_pm112 (/lib/modules/2.6.20-9-powerpc64-smp/kernel/drivers/macintosh/windfarm_pm112.ko): No such device
FATAL: Error inserting windfarm_pm81 (/lib/modules/2.6.20-9-powerpc64-smp/kernel/drivers/macintosh/windfarm_pm81.ko): No such device
FATAL: Error inserting windfarm_pm91 (/lib/modules/2.6.20-9-powerpc64-smp/kernel/drivers/macintosh/windfarm_pm91.ko): No such device

bcm43xx: Microcode bcm43xx_microcode5.fw not available or load failed.

I have also attached an archive (logs.tar.gz) of a few logs from /var/log.

ScottMiller (stmiller) wrote :

Ubuntu does not include the broadcom driver for differing reasons. To get that card work, just
sudo apt-get install bcm43xx-fwcutter

The 2.6.21 kernel seems to have additional options for powermac thermal, or perhaps an updated driver? I do not have one of these machines to test. Ubuntu should have included these critical thermal modules in the kernel to avoid this.

Are you able to load the windfarm modules manually? What happens when you type
sudo modprobe therm-pm72
sudo modprobe windfarm

Timothy Smith (tas50) wrote :

You can also get the firmware installed easily using Ubuntu Gutsy. Alpha 2 added support for getting the firmware for these cards without the fmcutter.

Étienne BERSAC (bersace) wrote :

Fixed upstream

Changed in linux-source-2.6.15:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.