2.6.15 kernel fails to boot on ppc machine

Bug #34508 reported by keifer miller on 2006-03-11
74
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
High
Ben Collins
ubiquity (Ubuntu)
Medium
Unassigned

Bug Description

The 2.6.15 kernel fails to boot on Dapper. The boot process appears to stop with the lines:

"loading ramdisk
Ramdisk loaded at 01900000, size: 4625 Kbytes"

When booted with "linux debug" at the yaboot prompt, the same thing happens, but the the added effect of the monitor turning off after the line "Ramdisk loaded at 01900000, size: 4625 Kbytes" is displayed.

Machine is a 2002 g4 imac (800 mhz)

[sidenote] This bug appears to be very similar to bug #183278 in the Fedora bug trackers. (https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=183278) Is this a problem in kernel main, or is it caused by a mutual patch between the two distros?[/sidenote]

Anders Ström (phibxr-gmail) wrote :

This happens for me to on a 2002 iMac G4 700mhz.

Affects both the Installation disc, the Live CD and my dist-upgraded system.

HIGHLY critical if this affects all PPCs, and still extremely critical if only G4/iMacs.

Thunder.m (thunder-m) wrote :

I have same problem with iMAC G4 800MHz (i have only one of this type), but with iMAC G4 1000MHz (i tested it on 5 same machines) the same CD working perfectly.

Thunder.m : interesting, prehapes it only effects the first generation of g4 imacs?

Anyways, it would appear that this is resolved with the 2.6.16 kernels; or atleast Suse's 2.6.16 kernel, which is what I tested with. While it's too late for 2.6.16 to be included in dapper, maybe it would be possible to backport a patch from either Suse, or from upstream.

Like I said, I only tested with the kernel provided by suse (via a net install iso), so I don't know if this was resolved upstream, or is fixed by a patch from the suse guys.

Anders Ström (phibxr-gmail) wrote :

Upstream or not, this MUST be fixed. It is a MAJOR showstopper bug and Dapper SHOULD NOT be released with a bug like this.

I've tried posting about this on Ubuntuforums, but I haven't been able to get any attention. Probably these iMacs are not very widely spread amongst the testers and developers.

But if this bug doesn't receive any attention, it will still be here when Dapper is released, and that would be horrible.

Ben Collins (ben-collins) wrote :

Do any of the older images work (e.g. any 2.6.15 kernels)?

Note, I have a 500Mhz G4, and a 1.6Ghz G4 PowerBook, and both are booting this kernel fine.

I need some point of where this failure started occuring to determine what the problem might be.

Anders Ström (phibxr-gmail) wrote :

Dapper Flight 4 worked fine for me.

Ben Collins (ben-collins) wrote :

Do you recall what kernel version was on that CD?

Anders Ström (phibxr-gmail) wrote :

No, but that should be possible to view on the Ubuntu site, or otherwise the ubuntuforums.org should be of help.

htinn (htinnocent) wrote :

Flight 4 had the 2.6.15-15 kernel (which had the bug that broke Wine server).

Laurent Bigonville (bigon) wrote :

Work for me with a G4 500Mhz AGP

Anders Ström (phibxr-gmail) wrote :

"Work for me with a G4 500Mhz AGP"

Which flight and what kernel? Daily? If so, from which day? Has there ever been a problem with that box to begin with? If not, I don't think the information is of much use, since we already know that this is something that Works For Most but Breaks For Some. ^^

Anders Ström (phibxr-gmail) wrote :

I'll have to say that it works for me too with 2.6.15-19 in the latest daily live cd. Haven't tried the installer though. :)

Anders Ström (phibxr-gmail) wrote :

The bug seems to be here with the latest installer-cd though.

keifer miller (keifer-miller) wrote :

Installed the kernel on a (kubuntu) install, and it worked for me -- sort of. The kernel sets at "loading ramdisk" for a loooonish (tm) time. It takes much longer to load than reasonable, but it does.

Once it loads, it appears to jump straight to gdm/kdm/etc; skiping any initrd/bootsplash messages. I'm guessing that it isn't actualy hanging at the 'ramdisk' line, but rather, it stops printing output until X11 kicks in.

Also, booting with "Linux debug" still doesn't seem to work for me. But hey, it's progress.

Anders Ström (phibxr-gmail) wrote :

I left Dapper Flight 6 install CD on for about half an hour today, and it still freezes at the Ramdisk line.

Although, my mouse flashes shortly afterwards, so I guess it is loading in modules and then freezes. Maybe a module that is loaded causes this?

I have unplugged every unpluggable piece of hardware, so it should be some hardware built into this generation of iMacs thet.

I updated from a perfectly working Breezy to Dapper by apt-get dist-upgrade on 5/4/06, and now I have a wonderful paperweight that won't boot. The machine is a 2000 PowerBook "Pismo" model. (/proc/cpuinfo says PowerBook3). The installed kernel version is 2.6.15-19-powerpc.

When the machine tries to boot using the default (2.6.15-19) kernel, it displays only the following message:
[ 24.007715] no framebuffer address found for /pci@f0000000/ATY,RageM3pParent@10/ATY,RageM3pB

It then hangs for a few minutes and then displays the following message:
ALERT! /dev/hda13 does not exist. Dropping to a shell!

then drops into BusyBox.

If I try to boot using the previously working Breezy kernel (2.6.12-10), I get the following behaviour:
[ ??.??????] aty128fb: Invalid ROM signature 0 should be 0xaa55
[ ??.??????] no framebuffer address found for /pci@f0000000/ATY,RageM3pParent@10/ATY,RageM3pB
Segmentation fault
<repeats for many screenfulls>
ALERT! /dev/hda13 does not exist. Dropping to a shell!
[Note that the messages about aty128fb and RageM3p were also displayed during normal operation of Breezy.]

If I try to boot using Linux debug at the yaboot prompt, it probes the ide devices (not the partition tables), starts up the TCP stack, and the last few messags are:
[ 28.852783] Freeing unused kernel memory: 180k init
[ 29.013427] Capability LSM initialized
[ 29.121935] Found KeyWest i2c on "uni-n", 2 channels, stepping: 4 bits
[ 29.128864] Found KeyWest i2c on "mac-io", 1 channel, stepping: 4 bits
Then it hangs for a little while and drops into BusyBox.

These tests were conducted with the laptop connected only to the power supply, an ethernet and a Logitech 3 button USB wheelmouse. Removing the mouse did not seem to have any effect.

The issue I am describing here seems to be a little different from that described by others.

Ben Stanley (ben-stanley) wrote :

My problem could be related to bug #38287, although that one is on i386!

scoomey (shawn-coomey) wrote :

Just did a dist-upgrade to Dapper Flight 6 from Breezy Badger. Same issue here on a Power Mac G4/933 "Quicksilver" machine. Hangs indefinitely "Loading Essential Drivers" or some such. My machine too is now toast. Any attempt at booting the original working kernel just dumps the machine to the BusyBox shell like Ben.

Anders Ström (phibxr-gmail) wrote :

I can't believe that this bug is still around. It has been fixed in Gentoo, seemingly, with the latest kernel version in 2006.0.

Matt Zimmerman (mdz) wrote :

Ben Stanley: your problem sounds like bug #32123 and is unrelated to this one.

phibxr: if you can find out how this was fixed in Gentoo, we would like to know. Is there a bug report in their bug tracking system?

Anyone experiencing this bug: please get a trace by following https://wiki.ubuntu.com/DebuggingSystemCrash

Ben Stanley (ben-stanley) wrote :

Matt Zimmerman: Re bug #32123, at first I thought I had that bug, but then I looked around in the filesystem available in the BusyBox, and I found a whole bunch of ide drivers, including, I think, the ones that are necessary for my machine. I will have another look in the next few days, and I will try out the DebuggingSystemCrash link and post my results.

I agree that my problem may not be this bug.

Ben.

Anders Ström (phibxr-gmail) wrote :

Has this bug been fixed yet? I've ran out of discs by burning 15-20 daily builds, still finding the same bug over and over again - and only with Ubuntu Dapper, not Gentoo. :(

Phillip Calvin (phillipc) wrote :

Working with the 2.6.15-20 kernel package, broken in 2.6.15-21 on a PowerMac G4 -- right now I'm typing "old" at yaboot to boot.

Anders Ström (phibxr-gmail) wrote :

I don't think any release should hit beta with a bug like this still in.

I'll be trying a daily again today.

Scott B. Mosier (mrmosier) wrote :

I have experienced a similar problem booting from both the Ubuntu Live cd and the Xubuntu text mode cd for Dapper on my 333mhz iMac G3.
The following thread is what steps I have followed to rectify the problem to get a working Dapper machine:
http://ubuntuforums.org/showthread.php?t=121214
(my posts are on page two if you use the default page length).

mungewell (simon-mungewell) wrote :

For information the kernels used on the Xubuntu Live and Install 6.06beta2 CDs are:
---
simon@twopak:~$ strings live_vmlinuz | grep "2.6.15"
2.6.15-21-386 (buildd@rothera) #1 PREEMPT Fri Apr 21 16:43:33 UTC 2006
simon@twopak:~$ strings install_vmlinuz | grep "2.6.15"
2.6.15-20-386 (buildd@vernadsky) #1 PREEMPT Tue Apr 4 17:48:51 UTC 2006
---

Suggests something changed between '-20'/'-21' (Apr 4/Apr21).

I'll have a go with the 'install' kernel later and confirm whether it boots....
Simon.

Anders Ström (phibxr-gmail) wrote :

I see that Flight 7 just got released. I'm thinking about throwing my last empty disc in and give it a try again, but so far I've probably wasted far too many discs on this one issue. If I do try, I'll return with a report. Otherwise, has anyone identified what changed between '-20'/'-21', in reply to the poster above?

Anders Ström (phibxr-gmail) wrote :

Ah, this is great. Now I'm greeted with a black screen on booting the live disc of Flight 7. No signs of life after ~30 minutes. The disc is checked and has been burned properly, and the Breezy-discs still boot fine.

mungewell (simon-mungewell) wrote :

OK my previous comment (regarding kernel versions) was wrong..... I had mounted the wrong/i386 cdimage by mistake.

I can confirm that the kernel from 'Xubuntu 6.02beta2 PPC install' does not work either.... fails with the same 'can not allocate device-tree chuck'.
Simon

Anders Ström (phibxr-gmail) wrote :

6.06 is soon to be here, and the bug is still with us. No resolutions yet?

Phillip Calvin (phillipc) wrote :

This is resolved for me in 2.6.15-23. Mine was a hard freeze, too, and seemed to correlate with this bug, aside from the last message being different. Anyone else?

Anders Ström (phibxr-gmail) wrote :

A, in the daily of today it actually booted (although it took about 30 minutes still), but it was so slow it took almost an hour for the Live CD installation window to even open, leaving me no time to try it out installed. I'm getting the text based installer daily right now and will check if that one boots too. If it does, I guess this problem has been resolved for iMac G4 at least.

Anders Ström (phibxr-gmail) wrote :

Back from checking - the same bug is still here in 21 daily. It hardfreezes after the "ramdisk"-message.

mungewell (simon-mungewell) wrote :

Yes, it still fails for me as well (on iMac 266MHz/160MBytes)

The daily iso I downloaded (May 18) was missing the whole directory '/install/powerpc'.

So I have used the netboot (May 23) from:
http://archive.ubuntu.com/ubuntu/dists/dapper/main/installer-powerpc/current/images/powerpc/netboot/

Displays 'Ramdisk' message, screen goes black and the white with the same failure = 'Can't allocate device-tree chunk'

I agree with previous poster, it would be ''bad' if this could not be resolved before Dapper was released.

Simon

mungewell (simon-mungewell) wrote :

* Possible Solution *

This mailing thread appears to provide a solution (1 line kernel patch):
http://ozlabs.org/pipermail/linuxppc-dev/2006-March/021342.html

Which would make sense as my iMac has a similar memory arrangement (32MByte Dimm and 128MByte Dimm).

Most recent 2.6.15.7 (from kernel.org) does not have this patch.

Unfortunately I don't have the facilities to compile a PPC kernel.... Can someone push this in the direction of someone who does!!!

Simon.

Colin Watson (cjwatson) wrote :

This bug is already filed on the kernel; hopefully Ben will notice it and incorporate it in the event that we get another kernel upload before dapper. Thanks for the reference!

Anders Ström (phibxr-gmail) wrote :

Is there a link to this bug so we can follow the progress? We are only days away from Dapper now really. :)

Just for reference, regarding the post above, I have a total of 256MB of memory, although I don't know how it's arranged.

Reiner Jung (prefec2) wrote :

I can reproduce this bug with the new iso ubuntu-6.06-rc-desktop-powerpc.iso on my IMac g3 233 MHz with 96 MB RAM.

Yaboot loads from CD and whatever label I use after loading the ELF32 Loader and filling the RAM-Disk the folling line shows up 'can not allocate device-tree chuck' above the Mac-firmware-prompt.

Also the Mac is running fine with a debian-2.6.8 kernel. But this one has problems with hal and some minor usb stuff.

keifer miller (keifer-miller) wrote :

There is a (semi) way around this. It is possible to install dapper by dist-upgrading an existing breezy system using the dapper repositories.

Once you have installed Dapper, the boot process is *very* slow feeling. You still (appear to)hang at the ramdisk line, but after 'foo' amount of time (say, the length of a normal boot in breezy), GDM will launch, and the system is useable again. Then you could install new kernels via synaptic, and save some cdrs from being used to test the daily builds.

--------

In response to mungewell's patch that he found; my iMac has 1GB of memory that is equaly spread (I think) over two Dimms.

Anders Ström (phibxr-gmail) wrote :

I can still reproduce this bug with the RC too. Will this mean that we'll get this "feature" in Dapper and render hundreds of machines unbootable when they update their systems in a few days?

mungewell (simon-mungewell) wrote :

It's obviously a risk to start 'dicking around' with the kernel a few days before a release, but I agree with previous poster - this bug could seriously affect quite a large number of machines.

The 'one liner' patch proposed has yet to be confirmed as a solution. Unfortunately I can't build a test kernel to prove whether it works or fails.

Can someone please (pretty please with sugar icing) build a kernel and post a link to it so that 'we' can get confirmation that this fixes it.....

To the maintainers: Is this bug worth flagging as release critical?

Simon.

fra.sa (fra-sa) wrote :

hi all
same problem here tryng to upgrade xubuntu breezy to dapper on an imac g3 233 96mb ram.
Solved this way:
Before I ran the dist-upgrade I installed the official linux 2.6 powermac build from the ppckernel.org web site as an alternative kernel to boot from.
After the dist-upgrade finished I rebooted with the above mentioned kernel and the machine started.
Some functionalities were missing (because of the standard kernel) and so I recompiled a 2.6.16.18 vanilla kernel with the config from the dapper shipped kernel(2.6.15-23) and things went a bit better.
Still some tweaking to do but the most functionalities are there .
Hope helped someone.
francesco

 p.s. sorry my english

fra.sa (fra-sa) wrote :

Solved!

Applied the above suggested hack to the kernel source (2.6.15 from dapper repositories) and all went fine! My imac g3 233 now starts without problems.

bye
francesco

Anders Ström (phibxr-gmail) wrote :

But Dapper is out now. Does that mean that the bug got released with it?

fra.sa (fra-sa) wrote :

I think so.
I cannot boot dapper after a dist-upgrade from breezy at most a week ago nor being able to boot Xubuntu beta install or live CD.
In the mean time I didn't see any solution to this bug on the web.
Maybe the developers lack an old machine like mine (imac g3 233) and cannot test the solution suggested... so I did it.
Francesco

Gary Elshaw (asituationist) wrote :

Francesco, is there any chance you could provide links to what is needed and a step by step guide? I have a feeling there are going to be a number of us that will have this problem. I filed a bug with the same symptoms as this after RC1 came out and it was filed as a yaboot issue.

https://launchpad.net/distros/ubuntu/+source/yaboot/+bug/42305

I'm wondering if a few of the other bugs originally filed as being yaboot bugs are related to this bug.

Ben Collins (ben-collins) wrote :

Sorry this missed the release. It's slated for the next kernel update to hit dapper. Hipefully, it will eventually make it's way into the CD images.

Changed in linux-source-2.6.15:
assignee: nobody → ben-collins
status: Confirmed → Fix Committed
Anders Ström (phibxr-gmail) wrote :

I'm relieved that there is a fix for this at least, and honestly - even if I'd personally would love to be able to use the discs I've purchased from Ubuntu for Dapper, most of those waiting for Dapper to be released at june 1:st won't even know that this bug even exists.

Please notify us when it is safe to upgrade to Dapper again, and when there are images available with the new kernel. And many thanks to those who've been following this thread. :)

fra.sa (fra-sa) wrote :

hi Gary.
Sorry but I'm not going to write a step by step guide because it is not so easy for everyone to apply the fix and you can broke your system. In my case a big help came to me from my ibook G4 1.33 (dapper installed on it months ago without any symptom of the present bug) on which I recompiled the kernels I tried. Besides as Ben Collins said the kernel will be upgraded soon and so the disc images making them availaible to all.
So be patient, just wait.
francesco

Adam Neather (aneather) wrote :

Upgrading 5.10 to 6.06 (kernel 2.6.15-23-powerpc) on iMac.
Specs: http://lowendmac.com/imacs/imac.shtml

Got this error:

Can't allocate intial device-tree chunk

Apple iMac Open Firmware 3.0 f2 built on 04/23/99 at 14:31:03
Copyright 1994-1999 Apple Computer, Inc.
All Rights Reserved.
 ok
0 > _

Work around by booting from old kernel. (2.6.12-10-powerpc)

Gary Elshaw (asituationist) wrote :

this wasn't supposed to be made part of ubiquity, my cat decided to walk over my desk and stood on the mouse

Changed in ubiquity:
status: Unconfirmed → Rejected

Sorry this missed the release. It's slated for the next kernel update to hit dapper. Hipefully, it will eventually make it's way into the CD images
It s just a non sense that this bug exist still in the ppc release of dapper!!! so many users left alone out of the tracks...
what about this big community supposed thing, please MR UBUNTU release a PPC compliant for all version of Dapper Now if the fix is OK...

Anders Ström (phibxr-gmail) wrote :

I'm glad to see that there has been a fix commited. I hope it will be in the ISOs soon, as we already are one week into june.

Sadly enough I've gone back to Gentoo/PPC for now, but I'll be back for Edgy.

J.P. (mackdieselx27) wrote :

I was bitten by this bug while trying to boot both the live and traditional CDs on a clamshell iBook (300 MHz G3). Had to fish out the Breezy CDs I was going to throw away after burning the Dapper ISOs.

Jimmy Angelakos (vyruss) wrote :

June 7th's Xubuntu and Ubuntu desktop CDs do not exhibit this bug on a G3 300 MHz tangerine clamshell iBook with 128 MB RAM.

> June 7th's Xubuntu and Ubuntu desktop CDs do not exhibit
this bug on a
> G3 300 MHz tangerine clamshell iBook with 128 MB RAM.
>
> --
> 2.6.15 kernel fails to boot on ppc machine
> https://launchpad.net/bugs/34508
>
hello,
where do you get this daily release from because when I go to
http://mirror.cs.umn.edu/ubuntu-cdimage/xubuntu/daily/current/
and so on for Ubuntu there is no newer releases.
thanks.

Greg

By the way do you, such as me, love your clamshell so much
that you can't figure out buying a new laptop?

It's just the most beautiful computer ever for me...
changed HD-->40 gig, added some ram---> 256 and it works
perfect. I had 128+32 soldered but it s really to few for
proper OS I think, with 256 GImp, Openoffice and even VLC for
Xvid and some (thought not all) work perfect.

Finally One more question as you might have been facing this?
have you tried to have a virtual resolution of 1024 on this
machine, if so then how to do it, modifications in Xorg.conf
It never works, I don't know what I am doing wrong.

Ciao and thanx for the info

Accédez au courrier électronique de La Poste : www.laposte.net ;
3615 LAPOSTENET (0,34 €/mn) ; tél : 08 92 68 13 50 (0,34€/mn)

Jimmy Angelakos (vyruss) wrote :

Greg,

I don't think the CD ISOs I downloaded were dailies, I got them from my local official mirror at:

http://ftp.ntua.gr/pub/linux/ubuntu-releases/6.06/

I just mentioned the date I downloaded them in case the ISOs had been changed. I wish the iBook was mine, I love the idea of a 1999 laptop running a 2006 OS. Its owner also loves the idea that with linux he can watch high-resolution DivX and run the latest software on such an "old" machine ;-)

Niels Kristian Bech Jensen wrote:

>** Bug 32491 has been marked a duplicate of this bug
>
>** Bug 35165 has been marked a duplicate of this bug
>
>** Bug 40092 has been marked a duplicate of this bug
>
>
>
But Niels, does this mean that the bug is solved?
if so then can t we rebuild a iso, I m ready to give a hand with that

>But Niels, does this mean that the bug is solved?
>if so then can t we rebuild a iso, I m ready to give a hand with >that
>
The fix is in the next kernel update. The best way to install (at least until a new iso image is released) is to install breezy and then dist-upgrade.

Niels Kristian Bech Jensen wrote:

>>But Niels, does this mean that the bug is solved?
>>if so then can t we rebuild a iso, I m ready to give a hand with >that
>>
>>
>>
>The fix is in the next kernel update. The best way to install (at least until a new iso image is released) is to install breezy and then dist-upgrade.
>
>
>
I tried to install it that way as well, but the Kernel from the
dist-upgrade won t boot, initrd problem I think but I m not really good
at linux and when I try to fix it everything got wrong :-(
do you know good howtos for kernel configuring and installing under ubuntu?

thanx greg

SpaceBunny (spacebunny) wrote :

Niels Kristian Bech Jensen wrote:
>> But Niels, does this mean that the bug is solved?
>> if so then can t we rebuild a iso, I m ready to give a hand with >that
>>
>>
> The fix is in the next kernel update. The best way to install (at least until a new iso image is released) is to install breezy and then dist-upgrade.
>

Thanks Niels for updating us on this bug but ...

After seeing this message I tried this using online repositories via
graphical update method as described at
https://wiki.ubuntu.com/DapperUpgrades
and it seems to have still replaced with broken kernel that won't boot
and drops to firmware prompt on my bondi blue G3 iMac which was running
breezy very well.

So I guess the new kernel is not there for that method and people should
still hold off (on certain macs at least). Would it have worked if
changed repositories and used command line?

Ok, now I need to find out how to recover the machine. I am willing to
wait till new (alt) isos but how would I used these as they only seem to
do new install from boot easily (no detecting of existing system, there
seems a very limit rescue mode) and can only upgrade working system live
by being added via synaptic (or apt-cdrom add).

Luckily I did do a back of files home so at a push I could do a new
install and restore, but I am hoping there is a quick way to be able to
replace kernel.
Is it possible to get it to boot using old kernel?

I will ask above on forums if I can see anything there or on wiki.

cheers,

Micah
http://j12.org/sb/

My fault - I should have written "... install breezy, wait for the next kernel upgrade to dapper and then dist-upgrade."

You might be able to boot using the breezy kernel (should be called something with "old" in yaboot), but there might be some missing functionallity (e.g. sound, USB hotplug). It should give you the opportunity to upgrade the kernel when it is released though.

SpaceBunny (spacebunny) wrote :

Thanks.

Typing 'old' at yaboot prompt did the trick.

Tab gives two kernels to select old and kernel (new).

The delay at yaboot prompt is quite short and did not realise that
chance for user input there as first tried to boot a few time. It is not
like a lilo or grub boot selection screen used to on PCs.

It seems to boot ok, and as you say sound does not work. But am relieved
to have it working with virtually every thing major seeming to work ok,
I guess not much change in interface functionality for incremental
kernel change

Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
mungewell (simon-mungewell) wrote :

I'm very glad to say that with the changes to kernel, my crusty iMac (266MHz-160MByte) now boots without this error.... it then halts/fails as it can't find the 2.6.15-25 module tree. But that's to be expected.

I ripped the vmlinux out of this kernel 'deb':
https://launchpad.net/distros/ubuntu/dapper/powerpc/linux-image-2.6.15-25-powerpc/2.6.15-25.43

Looking forward to when this makes it into the daylies. Thanks to Ben and everyone else on the team,
Simon.

Gary Elshaw (asituationist) wrote :

I received mail this morning informing me that a fix has been committed and released? Many thanks for all your work on this, Ben. I'm doing a dist-upgrade now, but wondered if there is an updated install or live iso available we can use for later/clean installs etc?

Gary

Gary Elshaw (asituationist) wrote :

Okay. New bug during the boot cycle and i'm really beginning to think i shouldn't run Dapper at all. Dist-upgraded to all the new packages using the original dapper release cd and then upgraded via synaptic for all latest packages. Upon reboot i get the Ubuntu loading screen that informs me the essential file system (i think) loaded okay and then the system hangs, nothing more seems to be happening. If i hold down the option key at boot it appears i have two installs to choose from: one gives the aforementioned hang, the other error messages. Can anyone help?

Ben Collins (ben-collins) wrote :

On Fri, 2006-06-16 at 16:57 +0000, Gary Elshaw wrote:
> Okay. New bug during the boot cycle and i'm really beginning to think i
> shouldn't run Dapper at all. Dist-upgraded to all the new packages using
> the original dapper release cd and then upgraded via synaptic for all
> latest packages. Upon reboot i get the Ubuntu loading screen that
> informs me the essential file system (i think) loaded okay and then the
> system hangs, nothing more seems to be happening. If i hold down the
> option key at boot it appears i have two installs to choose from: one
> gives the aforementioned hang, the other error messages. Can anyone
> help?

Please remove "splash quiet" from your boot options so we can see
exactly what the kernel is reporting. Also, let the system wait for as
much as 10 minutes to see if it gets anywhere (maybe a busbox prompt).

Gary Elshaw (asituationist) wrote :

Ben, I let the system do its thing for half an hour and it was still stuck at Loading Essential Drivers [ok] when i came back. It might be best to email me with regard to removing "splash quiet", i have no idea how this is done.

Ben Collins (ben-collins) wrote :

On Sat, 2006-06-17 at 03:53 +0000, Gary Elshaw wrote:
> Ben, I let the system do its thing for half an hour and it was still
> stuck at Loading Essential Drivers [ok] when i came back. It might be
> best to email me with regard to removing "splash quiet", i have no idea
> how this is done.

You'll need to boot with a breezy kernel (or breezy CD, in recovery
mode). Mount and chroot into the rootfs if you need to, then
edit /etc/yaboot.conf, and remove "quiet splash" for the options. After
editing the file, run "ybin -v". You should now be able to reboot
without the splash getting in the way.

ebeyer (beyere) wrote :

Please forgive the newbie question, but I'm trying to get Dapper to work on an old Bondi Blue iMac (G3/233).

I can get Breezy to work OK, but in the past network upgrades would give me the 'chunk-tree' problem
outlined above. I'm assuming now, with the kernel fixed that all should be OK.

My question is can I get Dapper running by installing Breezy and doing a network upgrade, or will that not work?

Many thanks.

An upgrade from breezy should work OK.

SpaceBunny (spacebunny) wrote :

ebeyer wrote:
> Please forgive the newbie question, but I'm trying to get Dapper to work
> on an old Bondi Blue iMac (G3/233).
>
Been there myself and got there.

> My question is can I get Dapper running by installing Breezy and doing a
> network upgrade, or will that not work?
>

You can do better you can probably still boot into non-booting system,
and then do online update of kernel. Here is trick. When the system is
first booting. It may say in a flash something like
l for linux
c for cdrom

let that go to next stage when it says something like

Welcome to yaboot version 1.3.13
Enter 'help' to get basic usage information
boot:

But it goes to next stage (which fails) very quickly often before I
noticed it at first in only few seconds being used to slower more
obvious lilo and grub boot menus on pcs)

quickly press any key, I suggest the tab

Now it has stopped at that prompt type

old

then [return] key

or try
help

This is a yaboot prompt and choose which kernel to boot and old one is
still there.

Hopefully that should work, to get something usable maybe a bit slow.

Extra note: after upgrade I choose replace sys links for old so it was
still pointing to breezy kernel rather than the broken one so still had
same option knew works, just in case new kernel did not work as well but
it did for me. I may add step by step details to my page or forum post
later.

Still no sound though but that may be unrelated.

ebeyer (beyere) wrote :

Sound seems to work OK on my G3 iMac under Breezy. Will let you know about the network update - it's going slowly.

Gary Elshaw (asituationist) wrote :

Here we go....

Clean install Breezy --> dist-upgrade to Dapper via distribution CD --> updated packages via synaptic --> removed quiet splash options + ybin -v --> removed old Dapper distribution kernel + using SpaceBunny's cue, i set the old Breezy kernel for old.

This time starting the machine did actually prevent the splash from coming up (obviously the problems i had encountered earlier were to do with the ybin errors). The last couple of lines showing up now are:

hdb: cache flushes supported
hdb: [mac] hdb1 hdb2 hdb3 hdb4 hdb5 hdb6

After the last line, there doesn't appear to be any more activity. Booting using the old Breezy kernel gets to me to the desktop, however i seem to be sans ppp0 connection. I've tried taking a look at wvdial, but don't seem to be having much luck with that, but will persist. Logging out and back in again seems to present a different subset of problems - i can open the trash and right-click on the desktop, but nothing else. I hope this helps.

My configuration:

  Machine Name: Power Mac G4
  Machine Model: PowerMac3,5
  CPU Type: PowerPC G4 (2.1)
  Number Of CPUs: 1
  CPU Speed: 867 MHz
  L2 Cache (per CPU): 256 KB
  L3 Cache (per CPU): 2 MB
  Memory: 640 MB
  Bus Speed: 133 MHz
  Boot ROM Version: 4.2.5f1

GeForce FX 5200:

  Chipset Model: GeForce FX 5200
  Type: Display
  Bus: AGP
  Slot: SLOT-1
  VRAM (Total): 256 MB
  Vendor: nVIDIA (0x10de)
  Device ID: 0x0321
  Revision ID: 0x00b1
  ROM Revision: 2060
  Displays:

Apple Studio Display:
  Display Type: CRT
  Resolution: 1400 x 1050 @ 75 Hz
  Depth: 32-bit Color
  Core Image: Supported
  Main Display: Yes
  Mirror: Off
  Online: Yes
  Quartz Extreme: Supported

So??
there is still no easily working and safe method to install dapper yet??

Probably not. But it's still only july. We won't get a 6.06 probably,
but maybe an inofficial 6.07 release party would be handy. ;)

2006/7/3, gregory bahde <email address hidden>:
> So??
> there is still no easily working and safe method to install dapper yet??
>
> --
> 2.6.15 kernel fails to boot on ppc machine
> https://launchpad.net/bugs/34508
>

Anders Ström (phibxr-gmail) wrote :

Just back from upgrading from a fresh Breezy installation, I'll
confirm that Dapper finally w o r k s on my iMac/iLamp G4 700mhz with
the latest 2.6.15-25 kernel update. No bootsplash though, but that I
can live with.

conner_bw (dac514) wrote :

I've reported a similar (possibly the same) bug here:

https://launchpad.net/distros/ubuntu/+bug/54098

This is happening to me using both Xubuntu and Ubuntu Server versions 6.06. Does anyone know how to fix this without already having Ubuntu installed on the target machine?

mungewell (simon-mungewell) wrote :

As a 'Heads Up' this should now be working with the new release 6.06.1, although I can't confirm until after the weekend (can't really wait to try...)

New ISO apears to use kernel version 2.6.15-26 :-)

However the netboot is still stuck on 2.6.15-23-powerpc, so presumably has the same fault. :-(

I'm getting netboot from:
ftp://archive.ubuntu.com/ubuntu/dists/dapper/main/installer-powerpc/current/images/powerpc/netboot/
Simon.

mungewell (simon-mungewell) wrote :

Horay it works! - sort of...

But not untill I had worked through some hassles.

In my situation the internal CD is bust on my iMac (266MHz) so I have to copy bits of the CD to harddisk and the use open firmware to boot them (with 'boot hd:,\xubuntu\install\yaboot') and also use an external USB cd for once the kernel gets going....

[best to leave to absolute confirmation from someone with a working CD]

Observations (which may require seperate bug reports).

1) Yaboot.conf points to kernel '\install\powerpc\vmlinuz', however it is really '\casper\powerpc\vmlinuz'

2) Xserver config is wrong and requires xorg.conf hacking to get working.

3) Network is not recognised, doesn't even show up on 'lspci'.

Next is to try an install.... :-)
Simon.

keifer miller (keifer-miller) wrote :

I'm still getting this bug; atleast with the 6.06.1 install media. System still hangs at 'loading ramdisk', hardware is 2002 imac g4.

The Fedora Core bug seems to have been resolved in the newer FC6 kernels. If the bugs are releated, then the problem may lie with the offb video driver. The below bug report has a patch, and some technical mumbo jumbo. :)

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=186732

Arangel Angov (arangel) wrote :

Is there a step by step guide for installing Ubuntu on a ppc machine with net boot? I have the same problems installing dapper on my powerbook.

I honestly have no idea. The iMac that I have is just a test machine, so I
do not use it reguarly. I have installed dapper/edgy on at least three other
x86 machines, and the process seems almost identical.

On 1/22/07, Арангел Ангов <email address hidden> wrote:
>
> Is there a step by step guide for installing Ubuntu on a ppc machine
> with net boot? I have the same problems installing dapper on my
> powerbook.
>
> --
> 2.6.15 kernel fails to boot on ppc machine
> https://launchpad.net/bugs/34508
>

--
Scott B. Mosier
<email address hidden>
http://www.mrmosier.com
Registered Linux User #393365
"Ideas are bulletproof." - V

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.