Ubuntu

Hardlock of entire system (Dapper Flight 5)

Reported by beefsprocket on 2006-03-14
48
Affects Status Importance Assigned to Milestone
Linux
Expired
Medium
Ubuntu
Undecided
Unassigned
alsa-driver (Debian)
Fix Released
Unknown
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.15 (Ubuntu)
High
Daniel T Chen
linux-source-2.6.17 (Ubuntu)
Undecided
Unassigned

Bug Description

rosegarden4_1.0-1.2ubuntu1_i386.deb in Dapper Flight 5 locks the entire system. SSH and ping show that the computer is unresponsive and a hard reboot is required.

Lukas Sabota (punkrockguy318) wrote :

This also occurs for me. This is a VERY serious bug.

Just an educated bug: there may be a kernel bug somewhere as well; applications shouldn't be able to crash the ENTIRE system.

Changed in rosegarden4:
status: Unconfirmed → Confirmed
Changed in rosegarden4:
assignee: nobody → motu
Lukas Sabota (punkrockguy318) wrote :

This occurs with kernel -20.

This bug occurs when starting with both 'rosegarden' and 'rosegarden4'.

Lukas Sabota (punkrockguy318) wrote :

Comment 2: typo educated bug = educated GUESS.

Applications souldn't be able to crash the entire system, should a bug be filed in the kernel?

Robert (ubuntu-10-rmn30) wrote :

One workaround for this bug is to start a sequencer before loading rosegarden e.g.:

 $ timitidy -iA

Then everything seems to work smoothly.

Note that in current versions of dapper the module snd_seq_midi isn't loaded by default so you won't observe this behaviour until loading it with modprobe.

My hunch is that the root cause of the problems is a bug in the alsa kernel module.

Lukas Sabota (punkrockguy318) wrote :

I've never loaded snd_seq_midi, but it appears when I lsmod with the latest kernel...

Daniel T Chen (crimsun) wrote :

Per _default_ install, not reproducible.

Which ALSA driver(s) are you using?

Changed in rosegarden4:
assignee: motu → ubuntu-audio
status: Confirmed → Needs Info
Robert (ubuntu-10-rmn30) wrote :

Hi,

I'm using nforce2 chipset from nvidia:

$ sudo lsmod | grep snd | cut -f1 -d' '
snd_intel8x0
snd_ac97_codec
snd_ac97_bus
snd_pcm_oss
snd_mixer_oss
snd_pcm
snd_timer
snd
soundcore
snd_page_alloc

I did the upgrade from breezy but will check if same occurs with live cd. Perhaps the problem is that alsa doesn't seem to detect the hardware synth (maybe it's not supported?) and I suppose doesn't load the midi module. Of course neither timidity or rosegarden will work until snd_seq_midi is loaded. So the question is: whose responsibility is it to load the module?

I'm also tempted to file a bug against alsa since clearly rosegarden should not be able to crash the whole system no matter what it does.

Robert

Lukas Sabota (punkrockguy318) wrote :

I'm using SB Live
snd_emu10k1_synth
snd_emux_synth
snd_seq_virmidi
snd_seq_midi_emul
snd_seq_dummy
snd_seq_oss
snd_seq_midi
snd_seq_midi_event
snd_seq
snd_emu10k1
snd_rawmidi
snd_ac97_codec
snd_ac97_bus
snd_pcm_oss
snd_mixer_oss
snd_pcm
snd_seq_device
snd_timer
snd_page_alloc
snd_util_mem
snd_hwdep
snd
soundcore

Daniel T Chen (crimsun) wrote :

Tracking http://marc.theaimsgroup.com/?l=linux-kernel&m=114515779700238&w=2

Looks like the mpu401 fixes need to be propagated.

Changed in rosegarden4:
status: Needs Info → Confirmed
Daniel T Chen (crimsun) on 2006-04-21
Changed in linux-source-2.6.15:
status: Confirmed → In Progress
Daniel T Chen (crimsun) wrote :
Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
Lukas Sabota (punkrockguy318) wrote :

I can still confirm this bug on 2.6.15-21-686, latest dapper, x86. Reopening.

Changed in linux-source-2.6.15:
status: Fix Released → Confirmed
Daniel T Chen (crimsun) wrote :

@Lukas: I don't believe you're using the correct kernel. The fix is in 22, as the url directly above yours indicates. Check the changelog once 22 is installed.

Changed in linux-source-2.6.15:
status: Confirmed → Fix Released
Lukas Sabota (punkrockguy318) wrote :

Forgive me for my previous mistake.
I am now using the -22 kernel, but my box still crashes when rosegarden loads :(

Changed in linux-source-2.6.15:
status: Fix Released → Confirmed
Lukas Sabota (punkrockguy318) wrote :

lukas:~$ uname -r
2.6.15-22-686

Matt Zimmerman (mdz) wrote :

Please get a backtrace from the crash by following https://wiki.ubuntu.com/DebuggingSystemCrash

John Vivirito (gnomefreak) wrote :

i just installed it and ran it on kernel 2.6.15-22-386 without it crashing or freezing anything here is the output of lspci -nv to see if that helps in anyway. im using a sblive 5.1 soundcard. output:
0000:00:00.0 0600: 8086:7190 (rev 03)
        Flags: bus master, medium devsel, latency 64
        Memory at f0000000 (32-bit, prefetchable) [size=64M]
        Capabilities: <available only to root>

0000:00:01.0 0604: 8086:7191 (rev 03)
        Flags: bus master, 66MHz, medium devsel, latency 64
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
        I/O behind bridge: 0000e000-0000efff
        Memory behind bridge: fc000000-feffffff
        Prefetchable memory behind bridge: f5000000-f5ffffff

0000:00:07.0 0601: 8086:7110 (rev 02)
        Flags: bus master, medium devsel, latency 0

0000:00:07.1 0101: 8086:7111 (rev 01) (prog-if 80 [Master])
        Flags: bus master, medium devsel, latency 32
        I/O ports at ffa0 [size=16]

0000:00:07.2 0c03: 8086:7112 (rev 01)
        Flags: bus master, medium devsel, latency 64, IRQ 11
        I/O ports at dce0 [size=32]
0000:00:07.3 0680: 8086:7113 (rev 02)
        Flags: medium devsel, IRQ 9

0000:00:0d.0 0401: 1102:0002 (rev 0a)
        Subsystem: 1102:100a
        Flags: bus master, medium devsel, latency 64, IRQ 9
        I/O ports at dcc0 [size=32]
        Capabilities: <available only to root>

0000:00:0d.1 0980: 1102:7002 (rev 0a)
        Subsystem: 1102:0020
        Flags: bus master, medium devsel, latency 64
        I/O ports at dcb8 [size=8]
        Capabilities: <available only to root>

0000:00:0e.0 0200: 1317:0985 (rev 11)
        Subsystem: 1317:0570
        Flags: bus master, medium devsel, latency 64, IRQ 11
        I/O ports at d800 [size=256]
        Memory at ff000000 (32-bit, non-prefetchable) [size=1K]
        Expansion ROM at f9000000 [disabled] [size=128K]
        Capabilities: <available only to root>
0000:00:0f.0 0604: 1011:0024 (rev 03)
        Flags: bus master, medium devsel, latency 64
        Bus: primary=00, secondary=02, subordinate=02, sec-latency=64
        Memory behind bridge: fa000000-fbffffff
        Prefetchable memory behind bridge: 00000000e0000000-00000000eff00000
        Capabilities: <available only to root>

0000:01:00.0 0300: 1002:4742 (rev 5c)
        Subsystem: 1028:4082
        Flags: stepping, medium devsel, IRQ 11
        Memory at fd000000 (32-bit, non-prefetchable) [disabled] [size=16M]
        I/O ports at ec00 [disabled] [size=256]
        Memory at fcfff000 (32-bit, non-prefetchable) [disabled] [size=4K]
        Expansion ROM at f5000000 [disabled] [size=128K]
        Capabilities: <available only to root>

0000:02:0b.0 0300: 10de:0322 (rev a1)
        Flags: bus master, 66MHz, medium devsel, latency 248, IRQ 11
        Memory at fa000000 (32-bit, non-prefetchable) [size=16M]
        Memory at e8000000 (32-bit, prefetchable) [size=128M]
        Expansion ROM at e0000000 [disabled] [size=128K]
        Capabilities: <available only to root>

John Vivirito (gnomefreak) wrote :

here is the output of "cat /proc/asound/cards && lsmod |grep ^snd_"
wasnt sure if it would help but figured it couldnt hurt

gnomefreak@DapperDrake:~$ cat /proc/asound/cards && lsmod |grep ^snd_
0 [Live ]: EMU10K1 - SB Live [Unknown]
                     SB Live [Unknown] (rev.10, serial:0x100a1102) at 0xdcc0, irq 9
snd_rtctimer 3340 0
snd_emu10k1_synth 7296 0
snd_emux_synth 37376 1 snd_emu10k1_synth
snd_seq_virmidi 7680 1 snd_emux_synth
snd_seq_midi_emul 7168 1 snd_emux_synth
snd_seq_dummy 3844 0
snd_seq_oss 33536 0
snd_seq_midi 9376 0
snd_seq_midi_event 7552 3 snd_seq_virmidi,snd_seq_oss,snd_seq_midi
snd_seq 51984 9 snd_emux_synth,snd_seq_virmidi,snd_seq_midi_emul,snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_emu10k1 117156 2 snd_emu10k1_synth
snd_rawmidi 25504 3 snd_seq_virmidi,snd_seq_midi,snd_emu10k1
snd_ac97_codec 92704 1 snd_emu10k1
snd_ac97_bus 2304 1 snd_ac97_codec
snd_pcm_oss 53664 0
snd_mixer_oss 18688 1 snd_pcm_oss
snd_pcm 89736 3 snd_emu10k1,snd_ac97_codec,snd_pcm_oss
snd_seq_device 8716 8 snd_emu10k1_synth,snd_emux_synth,snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq,snd_emu10k1,snd_rawmidi
snd_timer 25220 4 snd_rtctimer,snd_seq,snd_emu10k1,snd_pcm
snd_page_alloc 10632 2 snd_emu10k1,snd_pcm
snd_util_mem 4608 2 snd_emux_synth,snd_emu10k1
snd_hwdep 9376 2 snd_emux_synth,snd_emu10k1

Alberto Torres (kungfoobar) wrote :

Using -23, same problem. This is very serious!!!!

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Alberto Torres wrote:
> Using -23, same problem. This is very serious!!!!

Please provide the debugging information requested a few posts above.
Note that this issue is very likely a hardware-specific one, as several
people with the affected hardware have not been able to reproduce the
freeze.

- --
Daniel T. Chen <email address hidden>
GPG key: www.sh.nu/~crimsun/pubkey.gpg.asc
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFEcmvle9GwFciKvaMRAgKRAKCXySb0ePNvX9SmdG+Ed5RurdNMzQCaAvOJ
yNaUdahfiNPgYhV52JOcDl0=
=mxDa
-----END PGP SIGNATURE-----

Alberto Torres (kungfoobar) wrote :

I think it's not hardware-specific, because the same issue happens in a laptop with a very different hardware, different soundcard, video, proccessor, chipset, everything.

Sometimes rosegarden may start up and nothing happens. Then I fire up some midi synth (such qsynth, zynaddsubfx, timidity) and bye bye. Sometimes zynaddsubfx alone also crashes the system.

I'll provide the debugging info tomorrow, now I'm in a hurry.

My friend's laptop soundcard is snd-hda-intel, mine is an sb live

BTW, what happened with mixer controls? they're screwed up, while recording it doesn't work as expected, distorting one channel or muting the other one; even sometimes I can't record at all (tried alsamixer, alsamixergui and kmix).

$ sudo lsmod | grep snd | cut -f1 -d' '
snd_emu10k1_synth
snd_emux_synth
snd_seq_virmidi
snd_seq_midi_emul
snd_seq_dummy
snd_seq_oss
snd_seq_midi
snd_seq_midi_event
snd_seq
snd_emu10k1
snd_rawmidi
snd_ac97_codec
snd_ac97_bus
snd_pcm_oss
snd_mixer_oss
snd_pcm
snd_seq_device
snd_timer
snd_page_alloc
snd_util_mem
snd_hwdep
snd
soundcore

Alberto Torres (kungfoobar) wrote :

I've tried to get debugging information, going to console and executing rosegarden, but no luck: when it crashes, it doesn't respond to sysrq, and isn't logged anywhere. I've copied a message that appeared in the screen repeteadly:

rosegarden (sequencer): processMappedEvent(ev) - sending out single event at time 0.000000000R

Robert (ubuntu-10-rmn30) wrote :

Perhaps if someone has time they could compile the latest stock kernel from kernel.org and see if this bug is still present? Then at least we could narrow it down to either something which has been fixed since 2.6.15 or an ubuntu specific patch.

Just a thought.

Robert

Alberto Torres (kungfoobar) wrote :

I've found a way to avoid this bug: Ive unloaded snd_emu10k1_synth, snd_emux_synth, and every snd_seq* except snd_seq_device, then I've loaded only snd_seq. The rest of modules that I've unloaded prevously are loaded again, but rosegarden+zynaddsubfx works OK.

wtf?

tuxo (beat-fasel) wrote :

I can confirm this bug as well. The system freezes when the splash screen of rosegarden shows up. Only a reset can bring the computer back to life. I am using Dapper up-to-date as of 24.06.2006.

When the program is started on a console, I get following repeated output before crashing: rosegarden (sequencer): processMappedEvent(ev) - sending out single event at time 0.000000000R.

System Information (SMP, Dual PIII):

$ uname -r
2.6.15-23-686

$ lspci
0000:00:00.0 Host bridge: VIA Technologies, Inc. VT82C693A/694x [Apollo PRO133x] (rev c4)
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro133x AGP]
0000:00:04.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)
0000:00:04.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
0000:00:04.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 16)
0000:00:04.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 16)
0000:00:04.4 Host bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
0000:00:09.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
0000:00:0a.0 USB Controller: NEC Corporation USB (rev 43)
0000:00:0a.1 USB Controller: NEC Corporation USB (rev 43)
0000:00:0a.2 USB Controller: NEC Corporation USB 2.0 (rev 04)
0000:00:0b.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
0000:00:0b.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 07)
0000:00:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R200 QL [Radeon 8500 LE]

$ sudo lsmod | grep snd | cut -f1 -d' '
snd_emu10k1_synth
snd_emux_synth
snd_seq_virmidi
snd_seq_midi_emul
snd_seq_dummy
snd_seq_oss
snd_seq_midi
snd_seq_midi_event
snd_seq
snd_emu10k1
snd_rawmidi
snd_ac97_codec
snd_ac97_bus
snd_pcm_oss
snd_mixer_oss
snd_pcm
snd_seq_device
snd_timer
snd_page_alloc
snd_util_mem
snd_hwdep
snd
soundcore

I attempted to get some further output by pressing Alt+SysRq+1 followed by Alt+SysRq+t after the crash ocured but found nothing in /var/log/kern.log or dmesg related to the crash.

Thanks,
Beat

tuxo (beat-fasel) wrote :

Sorry, a small correction to my previous post: my system is up-to-date as of 24.05.2006 :-)

Cheers,
Beat

I've the same problem with final dapper here, kernel 2.6.15-23-686 #1 SMP PREEMPT
If I delete the content of ~/.kde/share/config/rosegarden4rc rosegarden sucessfully loads, but when I try to reload one of my previous work, the crash occurs.

Steph

I've also experienced the problem on my laptop (IBM X41, no emu10k1) using timidity -iA.

Steph

Daniel T Chen (crimsun) wrote :

@Stéph: What steps are you using to reproduce the problem? Thus far I've not been able to force this X41-2527 to freeze using the aforementioned steps.

I haven't tried again on X41 yet. When I tried, timidity -iA was running.
I have tried the new version of Rosegarden 4 (1.2.3, compiled, no deb available yet) on my computer with emu10k1 and the problem is still there.
I thus suppose there is some nasty bug in the midi code.

Steph

Following crimsun_'s advises on IRC, if snd-seq is loaded and timidity -iA is running when rosegarden is launched on X41, the crash does not happen on this machine.

Steph

Changed in alsa-driver:
status: Unknown → Unconfirmed
Daniel T Chen (crimsun) on 2006-07-04
Changed in linux-source-2.6.15:
status: Confirmed → In Progress
Daniel T Chen (crimsun) wrote :
Changed in linux-source-2.6.15:
status: In Progress → Fix Committed
Changed in alsa-driver:
status: Unconfirmed → Fix Released
Lukáš Zapletal (lzap) wrote :

I confirm this with 2.6.15-25-k7

Lukáš Zapletal (lzap) wrote :

So when this will be fixed in Dapper? Is it the new -26 kernel or must we wait? Thanks for info...

Ben Collins (ben-collins) wrote :

It is in the new -26

Daniel T Chen (crimsun) on 2006-07-14
Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released

I confirm that I still have the freeze with emu10k1 and 2.6.15-26-686

Lukáš Zapletal (lzap) wrote :

Any new progress here? Its a blocker for me, I cannot use Rosegarden.

Daniel T Chen (crimsun) wrote :

@Lukáš: Have you tried 2.6.15-26.45?

Changed in linux-source-2.6.15:
status: Fix Released → Needs Info
mosteo (public-mosteo) wrote :

Just downloaded rosegarden and I get the total freeze on splash screen. The system appears completely dead, not even the numlock light works anymore.

As how to reproduce, I'm not doing anything: just let the system boot, log into kde and launch it via menu or console.

$ uname -a
Linux entropia 2.6.15-26-k7 #1 SMP PREEMPT Thu Aug 3 03:40:32 UTC 2006 i686 GNU/Linux

$ cat /proc/asound/cards
0 [Live ]: EMU10K1 - SB Live [Unknown]
                     SB Live [Unknown] (rev.10, serial:0x80661102) at 0xc000, irq 209

$ lspci
0000:00:00.0 Host bridge: nVidia Corporation nForce2 AGP (different version?) (rev c1)
0000:00:00.1 RAM memory: nVidia Corporation nForce2 Memory Controller 1 (rev c1)
0000:00:00.2 RAM memory: nVidia Corporation nForce2 Memory Controller 4 (rev c1)
0000:00:00.3 RAM memory: nVidia Corporation nForce2 Memory Controller 3 (rev c1)
0000:00:00.4 RAM memory: nVidia Corporation nForce2 Memory Controller 2 (rev c1)
0000:00:00.5 RAM memory: nVidia Corporation nForce2 Memory Controller 5 (rev c1)
0000:00:01.0 ISA bridge: nVidia Corporation nForce2 ISA Bridge (rev a4)
0000:00:01.1 SMBus: nVidia Corporation nForce2 SMBus (MCP) (rev a2)
0000:00:02.0 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
0000:00:02.1 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
0000:00:02.2 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
0000:00:08.0 PCI bridge: nVidia Corporation nForce2 External PCI Bridge (rev a3)
0000:00:09.0 IDE interface: nVidia Corporation nForce2 IDE (rev a2)
0000:00:1e.0 PCI bridge: nVidia Corporation nForce2 AGP (rev c1)
0000:01:0a.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 0a)
0000:01:0a.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 0a)
0000:01:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:02:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200] (rev 01)
0000:02:00.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200] (Secondary) (rev 01)

$ lsmod | grep snd | cut -f1 -d' '
snd_emu10k1_synth
snd_emux_synth
snd_seq_virmidi
snd_seq_midi_emul
snd_seq_dummy
snd_seq_oss
snd_seq_midi
snd_seq_midi_event
snd_seq
snd_emu10k1
snd_rawmidi
snd_ac97_codec
snd_ac97_bus
snd_pcm_oss
snd_mixer_oss
snd_pcm
snd_seq_device
snd_timer
snd_page_alloc
snd_util_mem
snd_hwdep
snd
soundcore

Lukáš Zapletal (lzap) wrote :

2Daniel: no, I have still the stable ubuntu kernel...

iltony (iltony) wrote :

I confirm this bug, it is still present under Dapper with kernel 2.6.15-26.45
The real problem is, that this bug has not been fixed in alsa yet. I tried both alsa 1.0.12rc2 and 1.0.11 (patched) but the problem is still there.
Hardware: Creative Soundblaster live!
Software: Rosegarden
Syntoms: Hardlock of the whole system when loading rosegarden
It is a midi related problem.
The problem appears in alsa > 1.0.9 (i.e. doesn't appear on Breezy).
Don't know how to catch a kernel log (see no errors in /var/log/kernel.log).

I have the same problem with 2.6.15-26-k7.
Please note that there is absolutely no way to get more information on this bug, because the system COMPLETELY hangs up.
If you really need more information, please provide a detailed instruction. Your wiki link about DebuggingSystemCrash is not appliable on this complete freeze.

Ben Collins (ben-collins) wrote :

This bug may be fixed in the current edgy developement system. In an effort to track this bug to our latest distribution, it is being targeted for edgy.

Please confirm whether this bug exists in edgy. If not, then please re-attach all related output (e.g. dmesg, oops output) while under edgy.

Latest Edgy CD's can be downloaded from:

http://cdimage.ubuntu.com/releases/edgy/knot-1/

If this image does not boot from you, you can also download a current daily build from:

http://cdimage.ubuntu.com/daily-live/current/

Note that it may only be necessary to boot the LiveCD to see if your bug is fixed. In this case, you do not need to upgrade your installed system at all to confirm it. Certain bugs may require that you do an actual installation.

Changed in linux-source-2.6.17:
status: Unconfirmed → Needs Info
Lukáš Zapletal (lzap) wrote :

Well, nice. But does "LTS" mean something for audio team? I do not want to wait next year for the fix. I will try it for you, do the testing or whatever. But do provide some patch for the Dapper please. Thanks.

Donwloading, will do it later today.

Lukáš Zapletal (lzap) wrote :

Downloading AMD64 version. This will be a test by fire :-)

iltony (iltony) wrote :

I'm gonna try it as well, as soon as I finish downloading the image I'll tell you.
Thanks for interesting about the problem.

iltony (iltony) wrote :

I tried the live cd, but I could not manage to get my network work with it - and hence I could not download rosegarden. The gnome tool I used on dapper to configure the gateway which connects my computer to the internet (I think it's called network-admin) does not work in egdy, it loads but no option is available. I will now try no set the network up from the shell.

mosteo (public-mosteo) wrote :

I have also tried but the live CD doesn't finishes booting in my PC,
it dies someway before starting X.

iltony (iltony) wrote :

I confirm this bug with kernel 2.6.16.x as well. Since I compiled it, I think I can compile 2.6.17 for dapper as well. Will now try.

iltony (iltony) wrote :

Testing machine:

scrapthesurface@ubuntu:~$ uname -a
Linux ubuntu 2.6.17.190606 #1 SMP PREEMPT Mon Jun 19 22:51:32 CEST 2006 i686 GNU/Linux

scrapthesurface@ubuntu:~$ cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.11rc4 (Wed Mar 22 10:27:24 2006 UTC).

Testing result:

the bug is still there, but now rosegarden goes a little bit on before crashing the whole system.

Lukáš Zapletal (lzap) wrote :

I cannot test it, the CD image is larger than 700 MB and k3b wants to enable overburning or something like that...

Alberto Torres (kungfoobar) wrote :

The previous workaround I told doesn't work, but...

I've found a WORKING workaround: unloading the snd_emu10k1_synth

I don't need it since it's just for loading soundfonts into soundcard RAM, AFAIK. Instead I use qsynth with soundfonts of any size.

I've just deleted the file /lib/modules/2.6.15-26-k7/kernel/sound/pci/emu10k1/snd-emu10k1.ko
(where 2.6.15-26-k7 is your kernel version).

My system no longer freezes. The problem is probably located in that module.

I don't think this is the problem, since i don't have an emu10k1-soundcard at all.
But my problem doesn't occure to when i ensure that no other program is using my soundcard (/dev/dsp is available). My system only freezes if i forget a program.

Alberto Torres (kungfoobar) wrote :

Yeah, you're right. It happens also for me in a hda-intel soundcard in a laptop. The owner of that laptop has bought a sound blaster 24-bit usb, and I made a script which unloads all snd_ modules and loads snd-usb-audio and snd-seq, so he can use MIDI programs (although there is no MIDI support for that soundcard in linux, I think).

What I wanted to say is that the problem may be tracked down starting in emu10k1_synth.c which is 120 lines long.

By the way, it should be noted that I had a similar problem in breezy (or hoary, not sure): The entire sistem freezes because snd-seq wasn't loaded. So I would load that module, and it worked.

Alberto Torres (kungfoobar) wrote :

I think I've found the problematic module! Please confirm this works:

sudo modprobe -r snd_seq_virmidi
sudo modprobe snd-rtctimer

I think snd_seq_virmidi is the problematic module because it's used by snd_emux_synth and snd_emu10k1_synth which I don't use at all. In my last post I said that snd_emu10k1_synth was the problem, but after removing that module my system crashed as well 10 minutes after using MIDI. After removing snd_seq_virmidi, it always works for me so far.

Also, I think snd-rtctimer has something to do with it: Whithout loading/unloading it manually, it seems to be loaded each time it works, and not loaded each time it doesn't.

iltony (iltony) wrote :

I tried all the tricks you suggested, Alberto, but none of them did the magic for me. I tried to remove snd_emu10k1_synth, to unload snd_seq_virmidi and to load snd-rtctimer. But the situation is the same: rosegarden crashes the whole system while loading. B.T.W. I use a Creative Live! soundcard.

Alberto Torres (kungfoobar) wrote :

Try this:

sudo rmmod `lsmod|cut -d' ' -f1|grep snd_`
sudo modprobe snd-seq
sudo modprobe snd-emu10k1
sudo modprobe -r snd_seq_virmidi

By the way, which SB Live! do you have? I have a 5.1, I've read that 'Value' ones are buggy.

http://ubuntustudio.com/wiki/index.php/Audio_Hardware

iltony (iltony) wrote :

Tried out, but didn't work.
Something unexpected happened, but this shouldn't be a problem: the rmmod command gave me a memory leak error. Then the various modprobe commands worked as expected, rosegarden keeps on crashing everything.
I have a SB Live! 5.1. Player soundcard, I don't think it's the value one since it has a (useful) gamepad port and 6 channels output.
Could you please tell me which kernel are you using, and what's your alsa's version?
Mine is:
scrapthesurface@ubuntu:~$ uname -r
2.6.15-27-k7
scrapthesurface@ubuntu:~$ cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.10rc3 (Mon Nov 07 13:30:21 2005 UTC).
Thanks

Alberto Torres (kungfoobar) wrote :

Hey, I've just noted that my workarounds DOESN'T work when I open Rosegarden FIRST.

Use my workarounds, start jack (qjackctl), open qsynth or zynaddsubfx, and THEN open rosegarden. Tell me if it works.

My kernel is 2.6.15-26-k7 and alsa is same as yours.

iltony (iltony) wrote :

I tried it once again and now rosegarden does not crash my system, but it cannot open the hardware sequencer, since all the synth modules have been unloaded. It prints out:
rosegarden: RosegardenGUIDoc::syncDevices - waiting for Sequencer to come up
(many many times)
I believe that if I now load timidity or something like that, I could manage it to work.
Is this bug located in that module snd_seq_virmidi?

Alberto Torres (kungfoobar) wrote :

I suggest you Qsynth as sampler, you need soundfont (.sf2) files to use it. It is not limited to 8mb as your soundcard, the limit is your RAM.

Also I suggest ZynAddSubFX as softsynth, it comes with a lot of nice instrument presets. It doesn't need RAM for soundfonts, but CPU power for synth emulation.

Qsynth is a gui that uses fluidsynth underneath, which follows the soundfont2 specs very accurately.
I don't know of any timidity gui to configure it (it requires command line arguments), also timidity is rather old and not very useful for modern soundfonts (it was designed for GUS patches). I think that the only advantage of timidity over fluidsynth is that it loads the instuments on-demand instead the entire soundfont file, but it is annoying when it delays an instrument because it's loading.

Do the module unloading-loading trick and open zynaddsubfx, qsynth or timidity before opening rosegarden. Please tell us if it works or not for you.

I'm not a kernel dev, I hope someone tell us how to help tracking the bug.

Daniel T Chen (crimsun) wrote :

Please see this debdiff[0]. Essentially, add one line to /etc/modprobe.d/alsa-base:

install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }

Then, immediately a fresh boot /without/ any modifications (e.g., using an Edgy Beta live cd), is the system freeze still reproducible on non-Creative Labs hardware lacking hardware MIDI when you start Rosegarden?

For clarity:
1) Append the install.. line (above) to /etc/modprobe.d/alsa-base
2) Reboot into a pristine Dapper or Edgy environment
3) Check that snd-seq (and snd-seq-midi) is (are) loaded via ``lsmod|grep ^snd_seq''
4) Start Rosegarden and attempt to reproduce the hard freeze

Note for testing that you should /not/ start ``timidity -iA'' between steps (3) and (4)!

Also note that I've never been able to trigger said freeze on my hardware (uses snd-intel8x0), even when I don't use the sequence I just described, so I'm most interested in users of non-Creative Labs hardware lacking hardware MIDI.

[0] http://librarian.launchpad.net/4796837/alsa-driver_1.0.11-5ubuntu2.debdiff

Andrew Ash (ash211) wrote :

I'm closing this bug since there has been no feedback regarding Daniel's proposed fix. If it's still a problem just let us know.

Changed in linux-source-2.6.15:
assignee: ubuntu-audio → nobody
status: Needs Info → Rejected
Changed in linux-source-2.6.17:
status: Needs Info → Rejected
tuxo (beat-fasel) wrote :

I upgraded my computer to Edgy (where this bug has been fixed), so I cannot test this anymore in Dapper. Question, has this bug also been fixed in Dapper? It seems not as I find following alsa package via the ubuntu package search facility (packages.ubuntu.com):

Source package alsa-driver
dapper (sound): 1.0.10-4ubuntu4
Binary packages: alsa-base, alsa-source, linux-sound-base

However, the fix provided by Daniel T Chen is contained in the version alsa-driver_1.0.11-5ubuntu2.

I thought that the LTS in Dapper means Long Term Support?

Andrew Ash (ash211) wrote :

Yes, LTS is Long Term Support. In order for a Stable Release to receive updates, they must meet the criteria in https://wiki.ubuntu.com/StableReleaseUpdates

If they do, it's up to the package maintainer to release the update. I think Daniel takes care of the alsa-driver package, but I'm not sure. Generally if there isn't someone who is still actually affected by the bug, the update is less likely to be backported to older releases.

Changed in linux-source-2.6.15:
status: Invalid → Fix Released
assignee: nobody → crimsun
Jørgen Tellnes (jorgis) wrote :

I can confirm that Rosegarden locks up my system, running Ubuntu 8.04. It forces me to do a hard reboot, as even the numlock-light is unresponsive (my way of checking if the kernel is dead..). I don't have any logs to point to, all logs I found in the System Log application had no indication of the crash, other than that a reboot was performed.

Beginning with the Hardy Heron 8.04 development cycle the kernel source package naming convention changed from "linux-source-2.6.xx" to just "linux". Going forward, kernel bugs should now be reported against the "linux" package. I'm going to automatically retarget this bug against the "linux" package.

Jorgen, care to test the latest Alpha for the upcoming Intrepid Ibex 8.10 release to verify if this will still be an issue? http://www.ubuntu.com/testing. I assume after you experience this bug, your system is completely unresponsive so you would be unable to capture your dmesg output after the crash? If so, can you try attaching your /var/log/kern.log.0 file after you have the crash and need to reboot? Thanks.

Changed in linux-source-2.6.24:
status: New → Incomplete
Jørgen Tellnes (jorgis) wrote :

Leann: As this is my day-to-day computer, I don't have the opportunity to test Intrepid on it until Intrepid is stable enough for day-to-day usage... I've also looked through the output of kern.log, and there is nothing to mention between the two computer boot-ups before and after the crash:

Aug 12 00:20:32 mcpower kernel: [ 66.435282] Bluetooth: RFCOMM TTY layer initialized
Aug 12 00:20:32 mcpower kernel: [ 66.435284] Bluetooth: RFCOMM ver 1.8
Aug 12 00:20:33 mcpower kernel: [ 68.110631] ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 16
Aug 12 00:20:35 mcpower kernel: [ 69.388393] [fglrx] Reserved FB block: Shared offset:0, size:1000000
Aug 12 00:20:35 mcpower kernel: [ 69.388399] [fglrx] Reserved FB block: Unshared offset:ff7f000, size:80000
Aug 12 00:20:36 mcpower kernel: [ 70.850047] NET: Registered protocol family 17
Aug 12 00:20:48 mcpower kernel: [ 82.585158] eth0: no IPv6 routers present
Aug 12 00:23:27 mcpower kernel: Inspecting /boot/System.map-2.6.24-20-generic
Aug 12 00:23:27 mcpower kernel: Loaded 28495 symbols from /boot/System.map-2.6.24-20-generic.
Aug 12 00:23:27 mcpower kernel: Symbols match kernel version 2.6.24.
Aug 12 00:23:27 mcpower kernel: Loaded 25820 symbols from 101 modules.
Aug 12 00:23:27 mcpower kernel: [ 0.000000] Initializing cgroup subsys cpuset
Aug 12 00:23:27 mcpower kernel: [ 0.000000] Initializing cgroup subsys cpu

The crash occurred sometime between 00:20:48 (when the computer had finished booting) and 00:23:27 (when it started booting again after I pressed the restart button). There is some terminal output from Rosegarden in the moments right before the crash, I'll see if I can write it down..

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Has anyone been able to test Intrepid yet? Also, the pre-release of Jaunty is available for testing as well - http://cdimage.ubuntu.com/releases/jaunty/alpha-2/ . We'd definitely appreciate any feedback.

Additionally, I'm again removing the linux-source-2.6.24 task since beginning with Hardy the kernel package naming convention changed from "linux-source-2.6.xx" to just "linux". This bug already has the "linux" task opened. Please do not add the linux-source-2.6.24 task.

Changed in linux-source-2.6.24:
status: New → Invalid

Yes, I get the same problem with intrepid. I also have the same issue in opensuse 11.0, and in intrepid by using a freshly compiled 2.6.28 kernel. I can reproduce the bug without rosegarden, just by loading a soundfont in the soundcard (using asfxload) and trying to play a note with my midi keyboard. I reported the bug upstream here:

http://bugzilla.kernel.org/show_bug.cgi?id=12324

Changed in linux:
status: Unknown → Confirmed
Boniek (boniek12p) wrote :

Unfortunately it seems this bug is still an issue. Can you confirm this issue exists with the most recent Lucid Lynx 10.04 release - http://cdimage.ubuntu.com/releases/lucid/alpha-2/. If the issue remains in Lucid, please test the latest 2.6.32 upstream kernel build - https://wiki.ubuntu.com/KernelMainlineBuilds . Let us know your results. Thanks.

Robert (ubuntu-10-rmn30) wrote :

sorry, I won't have an opportunity to install lucid and test any time
soon. I'm going away travelling for quite a long time!

On 19 January 2010 18:35, Boniek <email address hidden> wrote:
> Unfortunately it seems this bug is still an issue.  Can you confirm this
> issue exists with the most recent Lucid Lynx 10.04 release -
> http://cdimage.ubuntu.com/releases/lucid/alpha-2/.  If the issue remains
> in Lucid, please test the latest 2.6.32 upstream kernel build -
> https://wiki.ubuntu.com/KernelMainlineBuilds .  Let us know your
> results.  Thanks.
>
> --
> Hardlock of entire system (Dapper Flight 5)
> https://bugs.launchpad.net/bugs/34831
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Changed in linux (Ubuntu):
status: Incomplete → Invalid
Changed in linux:
importance: Unknown → Medium
Changed in linux:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.