Ubuntu

After hibernate, cooling on nc6220 does not restart

Reported by Jim Gettys on 2006-03-18
24
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
Critical
Unassigned

Bug Description

I have an HP nc6220 laptop.

After a hibernate, on resume, the machine resumed successfully, but did not properly restart the fans.

After a while, the system shut itself down (reasonably gracefully as such things go).

I didn't notice the machine was getting hot until the shutdown sequence started, as I was lying in bed with a cover between the laptop and my legs.

But boy was the poor laptop hot by that point.

Linux version 2.6.15-18-686 (buildd@rothera) (gcc version 4.0.3 20060304 (prerelease) (Ubuntu 4.0.2-10ubuntu1)) #1 SMP PREEMPT Thu Mar 9 15:29:22 UTC 2006

Note: the original reporter indicated the bug was in package 'linux-image'; however, that package was not published in Ubuntu.

Jim Gettys (jg-laptop) wrote :

Things that might damage hardware aren't minor, nor major in my book...

Sebastien Estienne (sebest) wrote :

looks similar to bug #30073 but on a different hardware

Matthew Garrett (mjg59) wrote :

Should be fixed in dapper (at least, I haven't been able to get this failure with my nc6220 in dapper)

Matthew Garrett (mjg59) wrote :

Oh, hmm, you're on dapper. Sorry about that. Ok, I'll look into it. My suspicion is that this is the same problem as the nx6125, which turns out to be HP's BIOS people assuming that multiple ACPI methods can run concurrently under certain circumstances.

Jim Gettys (jg-laptop) wrote :

BTW, I have two other power management related problems on the 6220: audio doesn't work after resume, and if I try to run totem after a resume, my X server wedges hard.

Same problems on Dapper as on Breezy...

Matthew Garrett (mjg59) wrote :

Sound is #21574, X is due to Xv not coming back after resume - something I've never been able to duplicate. Can you try toggling the output (Fn+F4) after resuming and see if it works then?

> X is due to Xv not coming back after resume

If it's an Intel graphics chip (i810*), this could be #28326.

Jim Gettys (jg-laptop) wrote :

The Xorg log file shows:

Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller rev 3, Mem @ 0xd0900000/19

It is an Intel chip. But the symptoms are different: I don't crash after a long time of use, just on startup; I've watched entire DVD's. However, I'd also say the color of the video is off; something is plain broken in Xv.

Specifically, I crash on startup of totem after resume. There are times (like this instant) when even without having suspended, Totem won't startup (but the system doesn't hang.

In this case, I get:

The program 'totem' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 81 error_code 11 request_code 141 minor_code 19)

Interestingly, xine works fine.

I'll see what happens after a resume next.

Jim Gettys (jg-laptop) wrote :

Ok, toggling the output had no effect. Machine still hung trying to start totem after resume. Happens every time for me, whether or not totem would start right after boot.

Also, on reboot after one of these events, the machine likes to hang in the "loading drivers" phase.

So this sure looks like a bad X driver to me. Bug #28326 talks about a different driver not having some of these problems; can I lay hands on it without having to go build it myself?
          - Jim

Matthew Garrett (mjg59) wrote :

www.fairlite.demon.co.uk should have binaries.

Jim Gettys (jg-laptop) wrote :

Yes, this driver works much better; my machine no longer hangs trying to run totem after resume. Of course, totem still gives me a BadAlloc error. Dunno what is happening there; I didn't have any problems like that with Breezy's totem.

Seems to me like it might be good to ship Alan Horihane's later i810driver (after checking with him, of course).

And the audio problem does seem to be the same as the one noted in #21574; the headphone jack works after resume, even if the speakers don't.
               - Jim

Paul Sladen (sladen) wrote :

Thanks Jim. Could you file separate bugs for each of the issues you're still having so they can be followed up individually. I think there's now about 4 reports in this one and they're getting hard to follow and affect various packages. :-)

Jim Gettys (jg-laptop) wrote :

Bug #21574 seems to cover my audio problem on resume pretty well.

Bug #28326 describes what may be the same X driver problem, causing display lockups.

Both ought to get fixed before shipping Dapper, I believe.

What's left is the totem problem I'm seeing. I'll file a separate bug on it if I don't find a similar bug already filed; if so, I'll return here to document that.

And this bug covers the cooling after hibernate problem that triggered this discussion, which is the most serious issue.

Would be nice if Malone had a way of linking to related bug reports; might be as simple as having it recognize #????? as a bug number and making a link...

Jim Gettys (jg-laptop) wrote :

Bug #35229 seems to cover the totem startup failure.

Paul Sladen (sladen) wrote :

Thanks for tracking all of those bugs down as matches. Yes, this is the core bug (Fan not being reloaded).

Jim: the related bugs sounds an excellent suggestion. At the moment Malone already recognises "[bB]ug #?[0-9]+" so it wouldn't take much. Perhaps file it at:

  https://launchpad.net/products/malone/+filebug

The LP people are pretty good at turning useful suggestions into reality.

Paul Sladen (sladen) on 2006-03-28
Changed in acpi-support:
status: Unconfirmed → Needs Info
msofer (msofer) wrote :

I'm having an issue that might be related - or actually the same. There is a segfault in some part of the restoration code, and the last parts of the resume.sh script are not executed. Among them, modprobing 'fan'.
In my case (averatec 3270) this happens with the 686 and k7 kernels, but not with the stock 386: there hibernate/resume works well. Can you reproduce with the 386 kernel?

(This is hoping that a maintainer files this info where it belongs, or provides instructions for me to do so)
With the 686 and k7 kernels (also with a self-compiled from ubuntu sources, k7 but not smp) there is a message on resume
  udevplug
  unable to create /dev/.udevplug/queue
and later a flurry of 'scheduling while atomic', and finally some segfault. Not sure how to provide better info, more than willing to follow instructions.

msofer (msofer) wrote :

oops: that msg is
   udevplug
   unable to create /dev/.udev/queue

An interesting quote from Ben Collins's git tree...
wait for the next kernel package to be uploaded...

>[UBUNTU:acpi] Threaded ACPI support
>
>Some machines (such as the nx6125) assume that multiple acpi methods can
>be executed in parallel. This patch adds support for this, which
>prevents situations where the fan fails to turn on and the machine
>melts.

Changed in linux-source-2.6.15:
status: Needs Info → In Progress

Cooling problems after hibernate on nc8230 as well.
Kernel 2.6.15-21-386
Dapper Beta

(can someone sort away non-relevant comments here please?

ok, a new kernel package is out...please, try to upgrade to kernel 2.6.15-22 because it includes an important feature (threaded acpi support) which (hopely) can fix this bug!

post your report here as soon as possible!

Karianne Fog Heen (simira) wrote :

And it works! Thank you!

Jim, can you confirm it's working on your Hp nc6220?

Karianne: Thanks for letting us know...we're a step closer to mark this bug as fixed!

Is anyone who has a HP nc6220 able to confirm that it's now fixed in flight-7?

Changed in linux-source-2.6.15:
status: In Progress → Needs Info
Jim Gettys (jg-laptop) wrote :

I've run it through 2-3 hibernate cycles; so far, so good. My fan is certainly running at the moment....

This is on my nc6220.

jg@ubuntu:/proc/acpi/fan$ acpi -V
     Battery 1: charging, 80%, 00:24:28 until charged
     Thermal 1: active[3], 42.0 degrees C
     Thermal 2: ok, 44.0 degrees C
     Thermal 3: ok, 34.0 degrees C
  AC Adapter 1: on-line

Ben Collins (ben-collins) wrote :

Thank for testing.

Changed in linux-source-2.6.15:
status: Needs Info → Fix Released
Karianne Fog Heen (simira) wrote :

Confirmed STILL NOT FIXED in f7. This is serious. Is it possible to have it fixed before release?

Paul Sladen (sladen) wrote :

simira: does do:

  sudo modprobe -r fan thermal
  sudo modprobe fan
  sudo modprobe thermal

start it again?

Karianne Fog Heen (simira) wrote :

OK, seems to work. It's still not a good thing we hve to do it manually, though.

Yet another problem related to this problem
I has also HP NX6125 laptop, with this cooling problem.
But the another bug is.... I'm using 6.06 LTS. My kernel version is still "Linux darkstar 2.6.15-19-386 #1 PREEMPT Mon Mar 20 16:46:02 UTC 2006 i686 GNU/Linux" because if I upgrade kernel (to solve cooling problem) - my laptop become veeeery slowly.
Anyone use higher kernel than me with nx6125?

Paul Sladen (sladen) wrote :

mantas: can you install the latest kernel in Dapper (-23), eg: do a:

  sudo apt-get install ubuntu-desktop

can you run 'top' from a terminal and see what program is at the top. If it's "modprobe fan" then this could be: bug #46303 which is currently showing up on an Acer.

Can you also try Alt-SysRq-t from a terminal (press Ctrl-Alt-F1) to get a kernel traceback.

Thanks for reply... but..
i had latest ubuntu-desktop installed in my system
I'v upgraded to the latest kernel now.. cooling work fine, but.. the same problem. Laptop become slow :/
There is some screenshots http://mantas.lt/tmp/ubuntu/

As you can see, Xorg start to slow down all system with the new kernel
With old kernel (from flight-7) everything fine execpt cooling ;-)

The situation is like "to be or not to be"... or cooling with slow system (for example to run gimp it was tak'd 5mins) or fast system with cooling problems

Any ideas? :)

Could you please attach the output of

cat /proc/acpi/processor/*/*

--
Matthew Garrett | <email address hidden>

With the 2.6.15.19 kernel (old) or you need output from the latest kernel?

processor id: 0
acpi id: 1
bus mastering control: yes
power management: yes
throttling control: yes
limit interface: yes
active limit: P0:T0
user limit: P0:T0
thermal limit: P0:T0
active state: C1
max_cstate: C8
bus master activity: 04812046
states:
   *C1: type[C1] promotion[C3] demotion[--] latency[000] usage[04651044]
    C2: <not supported>
    C3: type[C3] promotion[--] demotion[C1] latency[010] usage[00002911]
state count: 8
active state: T0
states:
   *T0: 00%
    T1: 12%
    T2: 25%
    T3: 37%
    T4: 50%
    T5: 62%
    T6: 75%
    T7: 87%

Matthew Garrett (mjg59) wrote :

The latest kernel.

--
Matthew Garrett | <email address hidden>

It's yours ;-)

processor id: 0
acpi id: 1
bus mastering control: yes
power management: yes
throttling control: yes
limit interface: yes
active limit: P0:T7
user limit: P0:T0
thermal limit: P0:T7
active state: C1
max_cstate: C8
bus master activity: fffffffd
states:
   *C1: type[C1] promotion[C3] demotion[--] latency[000] usage[00070059]
    C2: <not supported>
    C3: type[C3] promotion[--] demotion[C1] latency[010] usage[00003349]
state count: 8
active state: T7
states:
    T0: 00%
    T1: 12%
    T2: 25%
    T3: 37%
    T4: 50%
    T5: 62%
    T6: 75%
   *T7: 87%

Matthew Garrett (mjg59) wrote :

Thanks. Is this a 64-bit 6125, or a 32-bit one?
--
Matthew Garrett | <email address hidden>

64bit but installed ubuntu 32bit (need macromedia flash and other crapy stuff)

but ubuntu 64bit versio had same problem ;) (my wife laptop)

Something interesting and related here > http://bugzilla.kernel.org/show_bug.cgi?id=5534

danielmewes (danielmewes) wrote :

The given fix did not work for me, but I found that the newest HP BIOS ROM finally fixed all fan problems for my nx8220. Just as a tipp for all the people who still burn their fingers and mainboards because of not correctly working fans...

danielmewes (danielmewes) wrote :

Ok, well it seems that I was actually wrong. The update changes the fan's behaviour a lot, so I thought the fans would come up again, but actually they still do not as they should. However, I found out that only those fans do not response after suspend to RAM or disk (I experienced the same problem with both methods), which had been switched on when the system suspends. Thus, the following fix now eventually really seems to work:

I added the following script to /etc/acpi/suspend.d:
File 85-fan-stop.sh
<-->
#!/bin/sh

modprobe -r thermal

for x in /proc/acpi/fan/*; do
    if [ "`grep on $x/state`" ]; then
        echo -n 3 > $x/state;
    fi
done
<-->

This simply stops all fans before the system is suspended. This may make the system run a little bit hot when using suspend to disk, since writing all the pages to disk may take some time and the fans are turned off then. However it works very well for suspend to RAM.

I also modified /etc/acpi/resume.d/72-acpi-pain.sh, but did not test yet, if this modification is really necessary. I just commented out the "modprobe -r thermal", "modprobe -r fan" and "modprobe fan" lines as well the "NNGH FAN HATE" part.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers