panic in bcm43xx_interrupt_tasklet

Bug #35814 reported by Norbert Kiesel on 2006-03-21
16
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
Medium
Unassigned

Bug Description

Hi,

trying to use the bcm43xx driver on my HP dv8000z. Driver loads, and enables radio (at least LED turns on) on "ifup", but then fails with

bcm43xx: MAC suspend failed
bcm43xx: FATAL ERROR: BCM43xx_IRQ_XMIT_ERROR

lspci -vv returns
0000:06:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
        Subsystem: Hewlett-Packard Company: Unknown device 1355
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64
        Interrupt: pin A routed to IRQ 10
        Region 0: Memory at c0204000 (32-bit, non-prefetchable) [size=8K]

fixed typo in subject

hmm, seems I can't fix typos in subject. Sorry about that

Was this ever working for you? Did you get the firmware files and place them in the right location?

Norbert Kiesel (nk-iname) wrote :

This is a brand-new machine, my first 64bit machine (Turion), my first bcm43xx card, and my first dapper install. So no, it never worked for me before.

I somehow got it working to some extend yesterday night with a different firmware. But it stopped working after a while with the "bcm43xx: FATAL ERROR: BCM43xx_IRQ_XMIT_ERROR" error. I also see "ACPI: PCI interrupt for device 0000:06:02.0 disabled" messages (6:2.0 is the bcm43xx). I can't get it working right now, will try to find out what I did differently. The trick was somehow to first bring the interface up, then assign a static ip address, then wait some time and set the WEP key.

Ben Collins (ben-collins) wrote :

Try setting the rate to 11M (iwconfig eth0 rate 11M).

Hi

Can you please try 2.6.15-20 kernel? This has solved many issues with bcm43xx driver.

On Wed, 2006-04-05 at 22:13 +0000, kmon wrote:
> Hi
>
> Can you please try 2.6.15-20 kernel? This has solved many issues with bcm43xx driver.

I now get kernel panics on "modprobe bcm43xx" (not every time but 4 out
of 5 attempts). I scribbled the hopefully relevant part off the screen:
Pid: 12722, comm: udevd Not tainted 2.6.15-20-amd64-k8 #1
RIP: 0010:[<ffffffff884b01f9>]
<ffffffff884b01f9>{:bcm43xx:bcm43xx_dma_handle_xmitstatus+201
...
Process udevd (pid: 12722, threadinfo ffff810012070000, task
ffff8100280d7200)
Stack: 0000000000000000 0000000100000000 0000000000000000
ffff8100042d4cc8
       ffffffff803d8ed8 0000000000000000 0000000000000000
ffffffff884a094b
       ffff8100042d4d74 0000000000000202
Call Trace: <IRQ> {:bcm43xx:bcm43xx_interrupt_tasklet+1659}
       {process_timeout+0} {tasklet_action+102}
       {__do_softirq+100} {call_softirq+31}
       {do_softirq+44} {irq_exit+72}
       {do_IRQ+52} {ret_from_intr+0}
       <EOI>
code: 8b 92 80 00 00 00 41 83 e4 01 48 83 c7 70 e8 b4 33 c7 f7 48
RIP: {:bcm43xx:bcm43xx_dma_handle_xmitstatus+201} RSP <ffffffff803d8e68>
CR2: 0000000000000080
 <0> Kernel panic - not syncing: Aiee, killing interrupt handler!

Jose Gonzalez (jtpgogaj) wrote :

The driver bcm43xx "almost" works into my Compaq Presario
V5000 (turion 64), kernel 2.6.15-23-amd64. I have got some strange IRQ errors but after running bcm43xx-fwcutter /path/to/BCMWL564.SYS (the 64 bit windows broadcom driver),
the boot messages are ok, I think.

Jose Gonzalez (jtpgogaj) wrote :

In a notebook Compaq Presario V5079EA I have instelled Kubuntu Dapper Drake, kernel 2.6.15-23-amd64-generic.
The driver bcm43xx gave me the same error boot messages as the posted by Norbert Kiesel: "bcm43xx: FATAL ERROR: BCM43xx_IRQ_XMIT_ERROR" error, but after running bcm43xx-fwcutter /path/to/BCMWL564.SYS (the 64 bit windows broadcom driver) those errors have disappeared. But now I get:
[ 48.169774] bcm43xx: InitVals (bcm43xx_initvalXX.fw) file-format error. Please fix your bcm43xx firmware files.
¿Where can I find the firmware files for Broadcom 4319?

Thanks, Jose

mizoun (mizoun) wrote :

Dell Latitude D600 + Ubuntu 6.06 final:

lspci:
0000:02:03.0 Network controller: Broadcom Corporation BCM4309 802.11a/b/g (rev 02)

install firmware:

install_bcm43xx_firmware.sh
or
sudo bcm43xx-fwcutter -w /lib/firmware bcmwl5.sys
or
install http://ubuntu.cafuego.net/pool/bcm43xx/bcm43xx-firmware_1.1-0ubuntu1_all.deb

load bcm43xx module:

modprobe bcm43xx => KERNEL PANIC

Norbert Kiesel (nk-iname) wrote :

Using another firmware and the current kernel, the wireless connection works now.

Ben Collins (ben-collins) wrote :

Must just be an issue of using the correct firmware then.

Changed in linux-source-2.6.15:
status: Unconfirmed → Rejected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers