Kernel Won't Boot on an IBM Thinkpad R30

Bug #36998 reported by hn093 on 2006-03-28
26
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.15 (Ubuntu)
High
Ben Collins
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
High
Unassigned

Bug Description

Trying to install Dapper Flight 5 on a Thinkpad R30 fails with "hdc: lost interrupt" error. There's also messages about irq 15, no-one caring and appending "irqpoll" to the bootloader. Appending "irqpoll" gets the installation past this stage, with the side-effect of the CD drive no longer being recognised, making installation from CD impossible. Passing "acpi=off" at boot has the same results. Note this bug also affects other distros with recent kernels, like Fedora Core 5 and SLAX 5.08, but does not affect older distros like Ubuntu Hoary, SuSE 9.1 and Linspire 4.5. I can't say whether or not it works on Breezy, as I haven't attempted to install it on this machine.

Note: the original reporter indicated the bug was in package 'kernel-image'; however, that package was not published in Ubuntu.

Download full text (3.9 KiB)

I also have a ThinkPad r30, though I encountered the problem with the Dapper Live Flight 5 CD. I did not encounter this on the released Breezy Live CD. Using the "irqpoll" feature does allow the live CD to boot to the desktop, though not without complaints (which I'll get to later).

Without the "irqpoll" boot option the following information is dumped to the screen:
[4294743.696000] irq 15: nobody cared (try booting with the "irqpoll" option)
[4294743.696000] handlers:
[4294743.696000] [<c0251160>] (ide_intr+0x0/0x200)
[4294743.696000] Disabled IRQ #15
On one occation this was preceeded by lots of "/dev/hdc: error 2"

Using the "irqpoll" for a successful boot gets the following information dumped in dmesg:
[4294676.984000] ALI15X3: IDE controller at PCI slot 0000:00:10.0
[4294676.984000] ACPI: PCI Interrupt 0000:00:10.0[A]: no GSI - using IRQ 15
[4294676.984000] PCI: setting IRQ 15 as level-triggered
[4294676.984000] ALI15X3: chipset revision 195
[4294676.984000] ALI15X3: not 100% native mode: will probe irqs later
[4294676.984000] ide0: BM-DMA at 0x7050-0x7057, BIOS settings: hda:DMA, hdb:pio
[4294676.984000] ide1: BM-DMA at 0x7058-0x705f, BIOS settings: hdc:DMA, hdd:pio
[4294676.984000] Probing IDE interface ide0...
[4294677.248000] hda: HITACHI_DK23CA-30, ATA DISK drive
[4294677.860000] ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
[4294677.860000] Probing IDE interface ide1...
[4294678.532000] hdc: HITACHI DVD-ROM GD-S250, ATAPI CD/DVD-ROM drive
[4294683.064000] irq 15: nobody cared (try booting with the "irqpoll" option)
[4294683.064000] [<c013e922>] __report_bad_irq+0x22/0x80
[4294683.064000] [<c013ea18>] note_interrupt+0x68/0xc0
[4294683.064000] [<c013e2dc>] __do_IRQ+0xbc/0xe0
[4294683.064000] [<c010597a>] do_IRQ+0x1a/0x30
[4294683.064000] [<c01040ea>] common_interrupt+0x1a/0x20
[4294683.064000] [<c0121520>] __do_softirq+0x30/0xb0
[4294683.064000] [<c01215d5>] do_softirq+0x35/0x40
[4294683.064000] [<c0121685>] irq_exit+0x35/0x40
[4294683.064000] [<c010597f>] do_IRQ+0x1f/0x30
[4294683.064000] [<c01040ea>] common_interrupt+0x1a/0x20
[4294683.064000] [<c013e55c>] setup_irq+0x9c/0x120
[4294683.064000] [<c0251160>] ide_intr+0x0/0x200
[4294683.064000] [<c013e73b>] request_irq+0x7b/0xa0
[4294683.064000] [<c0255318>] init_irq+0x308/0x4b0
[4294683.064000] [<c0251160>] ide_intr+0x0/0x200
[4294683.064000] [<c0255973>] hwif_init+0xe3/0x2b0
[4294683.064000] [<c0254e2f>] probe_hwif_init_with_fixup+0x1f/0x90
[4294683.064000] [<c02589a3>] ide_setup_pci_device+0x93/0xa0
[4294683.064000] [<c01e666c>] __pci_device_probe+0x3c/0x60
[4294683.064000] [<c01e66af>] pci_device_probe+0x1f/0x40
[4294683.064000] [<c0243062>] driver_probe_device+0x32/0xa0
[4294683.064000] [<c0243140>] __driver_attach+0x0/0x40
[4294683.064000] [<c024317b>] __driver_attach+0x3b/0x40
[4294683.064000] [<c0242748>] bus_for_each_dev+0x48/0x80
[4294683.064000] [<c0243195>] driver_attach+0x15/0x20
[4294683.064000] [<c0243140>] __driver_attach+0x0/0x40
[4294683.064000] [<c0242be9>] bus_add_driver+0x69/0xc0
[4294683.064000] [<c01e68fa>] __pci_register_driver+0x6a/0xa0
[4294683.064000] [<d807d5cf>] ali15x3_ide_i...

Read more...

This is the output of lspci -vv after a successful boot using the "irqpoll" option.

Still an issue with Dapper Flight 6 Live CD.

Matt Zimmerman (mdz) wrote :

Closing spurious Ubuntu task; bug remains open against the appropriate package

Changed in linux-source-2.6.15:
assignee: nobody → ben-collins

I attempted to install Breezy this morning on my R30 (with a swapped HD) so I could run the entire battery of Laptop tests against it. The installer hung trying to load the ide-cd module, no errors given after several minutes of waiting. "irqpoll" for breezy causes a system reset. Its seems only the Live CDs work.

Jerome S. Gotangco (jsgotangco) wrote :

Please confim on Dapper Beta -21 kernel

Changed in linux-source-2.6.15:
status: Unconfirmed → Needs Info

Same issue on the Dapper Beta -20 kernel (-21 isn't available on the live cd yet).

hn093 (hn093) wrote :

Still broken in Flight 7.

hn093 (hn093) wrote :

Any updates? Having to use BSD is weak. :(

Nope, seeing as how Dapper RC just got put out I don't think this is getting fixed on this release. I'd use BSD in the meantime but I don't think it supports my wireless card. At some point I'll try a Live CD that uses the 2.4 kernel and see if that has similar difficulties. Thinkwiki (http://www.thinkwiki.org/wiki/Installing_Fedora_Core_4_on_a_ThinkPad_R30) seems to indicate that this failure is a recent kernel thing.

I haven't found much about this in other distro forums.

In the meantime, its WinXP for me. :(

So I tried out the Dapper RC and.... it still doesn't work. But I get something new this time. Now the graphical bootup stalls at "mounting root filesystem" and switching over to the 1st terminal and waiting for about a minute or so reveals this "BUG: soft lockup detected on CPU#0!"

irqpoll does bring it up to the desktop as usual. I do see that ide-cd is loaded and /dev/hdc is present (can't recall if they were missing in previous boots using older live CDs)... perhaps with irqpoll it is possibly installable now.

I found the same problem with my new server motherboard. With irqpoll kernel option first everything seems good, but I miss the installation DVD, and booted the 32-bit edition.
The server installation was about three hours(!).
WIth 64-bit edition (and irqpoll option) the installation was about 5 minutes, and the system seems stable, but the kernel drops many irq related errors...

Did this remain a problem until the final dapper release?

Still an issue on the Final Dapper release, though it does seem to fail much quick now.

Current output (transcribed):

[4294677.028000] irq 15: nobody cared (try booting with the "irqpoll" option)
[4294677.028000] handlers:
[4294677.028000] [<c0252040>] (ide_intr+0x0/0x200)
[4294677.028000] Disabling IRQ #15
[4294716.115000] BUG: soft lockup detected on CPU#0!

Another (possibly useless) tidbit of info: DSL linux's livecd boots with no issues and that uses the 2.4.26 kernel. Though I'm not sure if it was always working in 2.4 or if it was fixed after 2.6 started.

hn093 (hn093) wrote :

So this bug has been marked "Needs info" for several months now. What info is needed, exactly?

Changed in linux-source-2.6.15:
status: Needs Info → Confirmed

Still an issue on Edgy Knot-1.

I was able to get Debian Sarge to install and boot on the laptop with their 2.6 kernel (2.6.7 I think). However after boot I got lots of HD errors while installing packages. I'm not sure if that's the same issue. To preserve my primary OS, I had swapped in a very old laptop HD and it might be dying on me. This old HD was not present for any of my previous tests though.

PS - Sorry about my previous dupe post, Firefox did something funky when I submitted.

description: updated
moolcool (moolcool) wrote :

Im havening the same same problem with ubuntu 6,06 on my R30 This post is mainly so i can sign up for email updates.

accel (jpvissers) wrote :

I also have the same problem with Ubuntu 6.06 but on a Acer TravelMate 529 TXV.

Booting stops as it tries to load the cd-module.
The same thing happens when I try booting Kanoptix 2006 RC4

openSuSE and Knoppix are booting fine, with no bootoptions.

Susan Cragin (susancragin) wrote :

I have an Acer Ferrari 4005 AMD 64. Boot hangs for a very long time but eventually (about 1-2 minutes later) boots after messages about the timer clock.
Edgy Knot 3.
See Bug 38263
Have the feeling these two bugs are not identical but inter-related.
I have attached my lspci-vv and will attach lspci-vvn

Susan Cragin (susancragin) wrote :

as promised lspci -vvn

Still an issue in Edgy release.

In other news I fiddled with running a custom version the 2.6.19 kernel on a Debian install. I enabled the experimental libata driver for the ali5229 IDE controller, which is supposedly a rewrite. Same issue, though the printouts from the new driver may be useful, I've added them to this comment.

So far 2.6.8 is the only kernel that boots.

As of Feisty Herd 4 this still doesn't work. However after some hdc interrupt lost errors (hdc is the dvd drive) it dumps into an initrd console session. Never seen that before.

Codehead (codehead3) wrote :

Hello,

Please bear with me, because I'm new to using Linux....

I'm having the same problem on my ThinkPad i1472. Here are the specs:

Mobile Pentium II processor at 366 MHz with 256 KB onboard L2 cache

256 MB SDRAM

6.4 GB hard disk drive

DVD-ROM drive

USB port

PCMCIA Type III slot

14.1-in XGA TFT

Is there a "light-weight" version of BSD that doesn't use very much resources that I could use (instead of Xubuntu 6.06 LTS)?

Thanks!

schnirfl (schnirfl) wrote :

Hi,

dapper and edgy installed flawlessly with "pci=noapic" on my Thinkpad R30. acpi=off is NOT needed, but PCI/IRQ-Routing should be set to "Automatic" in the BIOS. Even suspend to disk works. The only remaining problem is suspend to ram (which did not bother me much). There are ACPI-related errors in the dmesg output. My attempts at fixing the DSDT only removed some errors with the laptop working (or not re s2ram) as before, so I dumped my handrolled DSDT.

After having upgraded to feisty, booting & running still works with pci=noapic, but resume after suspend to disk fails. Last output is the completion of loading the memory dump from swap space, after that the screen blanks (backlight goes out) and the laptoip hangs until switched off. A little debugging shows that all suspend scripts (/etc/acpi-support/suspend.d/*) are being run, but none of the resume scripts (/etc/acpi/resume.d). Booting the 2.6.17-11 kernel of edgy restores suspend to disk functionality, so it's probably a kernel related problem and not a dying X server.

I'll gladly post more information if needed.

Cheers,
schnirfl

Did you mean "noapic" (without the "pci=") or "pci=noacpi"? There is no "pci=noapic" option. I'm assuming the latter since you refer to IRQ routing.

I did try "pci=noapic" and I got to the Desktop, so schnirfl you're my hero. I'm going to run some tests off the liveCD to make sure things seem alive and then I'll swap in my old laptop drive for a test install.

schnirfl (schnirfl) wrote :

Yes of course, "pci=noacpi" is correct. Sorry, I was posting from my desktop machine and didn't check...

My next avenue of investigation is a BIOS update to my R30. Mine still runs 1.38, current is 1.40. As it involves creating a boot floppy on another computer an creating a bootable CD with an image of that floppy, I'll need a little while. I'll post my experiences when I'm done.

Glad to have been of assistance!

Cheers,
schnirfl

My install went fine (if a little slow, but then I only have 384mb of RAM). Everything appears functional.

I cannot recall which BIOS I am running. It has been ages since I last did an update. I'll take a peak tonight if I remember.

schnirfl (schnirfl) wrote :

Updating the BIOS to 1.40 went flawless, if a little bit convoluted. As the R30 has no floppy drive and is not running Windows, no IBM-supported update path exists. ThinkWiki has a valuable page: "http://thinkwiki.org/wiki/BIOS_Upgrade#Updating_via_CD.2FDVD_Drive". In a nutshell, you have to download the program to create a boot floppy and run it on a windows machine with a floppy drive. Then boot linux on that machine (KNOPPIX comes to mind...) and create an image of that floppy. At last you can create and burn a CD image that boots the floppy image. I can mail the CD image to you if you're interested.

As I said, latest version is 1.40 (Aug. 2006). If you want to check your BIOS' version, do a "sudo dmidecode | less". You'll find a "Version:" tag in the BIOS Information stanza, which is probably the first.

Success re resume after suspend to disk has been mixed. At first sight, nothing seemed to have changed - screen goes out, laptop freezes. But accidentally leaving the laptop in this state for a while showed some disk activity! After a reboot my debugging output lists the first two resume scripts as having been called... So, my next actions will be

* Try SysRq. I previously thought that my machine didn't react to Alt-SysRq combos, but checking while running normally revealed that I have to use the *right* Alt-key (which is in fact labeled as "AltGr" on my german keyboard).
* Check and maybe change the DSDT (again). The new BIOS revision might have changed something.
* Weed out all unneeded resume.d scripts. Maybe there's one which leads to this bug...?

I'll let you know if I discover anything interesting.

OT: Slow installation is probably not a result of not enough RAM but of a slow hard disk. Running on 512MB here did'nt make the installation (update actually) go any faster.

Cheers,
schnirfl

I survived my Gutsy upgrade with the "pci=noacpi" still on my boot line. It's still required to boot. If I try to boot the liveCD without it I just get lots of "Buffer I/O error on device fd0, logical block 0" errors with is single "ide_media: main: unable to read from /proc/ide/ide0/hda/media" amongst them.

Changed in linux-source-2.6.20:
status: New → Confirmed
Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-team
Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-team

Hi All,

There hasn't been any recent activity in this bug report and we were wondering if this is still an issue? The Hardy Heron Alpha series was recently released which contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha release from http://cdimage.ubuntu.com/releases/hardy/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/ .

Please also note that we will keep this bug report open against the actively developed kernel bug against 2.6.22, 2.6.20 and 2.6.15 this will be closed. Thanks.

Changed in linux:
status: New → Incomplete
Changed in linux-source-2.6.15:
status: Confirmed → Won't Fix
Changed in linux-source-2.6.20:
status: Confirmed → Won't Fix
Changed in linux-source-2.6.22:
status: Confirmed → Won't Fix

Hardy Alpha 5 was able to boot successfully without any boot parameter assistance (first time since Hoary). Ironically I bought a Thinkpad T61p a week ago to replace my R30 (fortunately I still had it).

richardmtl (richardmtl) wrote :

I also was able to boot it with Alpha 5; however, the install froze during partitioning. This may be due to faulty hardware on my end, though. Actually, it is almost fror sure due to my hardware (it's been giving me trouble forever, which is why I don't use the laptop anymore). I'll give it another try, but at least it booted completely finally! Yay!

richardmtl (richardmtl) wrote :

Just an update: I was able to install Alpha 5 without further problems, at least from an installation perspective. However, the screen resolution is totally off; I am unable to get it to use the whole screen. I am unfamilier with how to fix this type of problem, so hopefully someone here can point me in the right direction; otherwise, I guess I'll have to play with it myself somehow.

richardmtl: I had similar problems, but I was able to work around them using a lot of hackery that I'm now trying to recall.

Basically (from what I found) the new X auto-detects (poorly) your video and monitor configuration. Normally you could override the settings with the Screen & Graphics doogit, but the /etc/X11/xorg.conf file has changed formats slightly and "Screen & Graphics" can't figure it out.

If I recall using a recipe in bug #178061, I added the following to the end of my /etc/X11/xorg.conf:
Section "ServerLayout"
    Identifier "Default Layout"
    Screen "LCD"
EndSection

Then I believe I was able to get Screen & Graphics to identify the video driver, set the mode, and make the desktop cover the entire screen.

Changed in linux:
status: Incomplete → Fix Released

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers