Inaudible sound on Lenovo 3000 N100-07684JU

Bug #39517 reported by Justin Sunseri on 2006-04-14
28
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
Medium
Ubuntu Audio Team

Bug Description

0000:00:1b.0 0403: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

this is the same chip that is in many of the new thinkpad laptops

i have been told that "front" needs to be un muted. it is turned up to 70 and un muted.

Daniel T Chen (crimsun) wrote :

Please attach the output from ``lspci -v && lspci -nv && tail -2 /proc/asound/oss/sndstat''.

Changed in linux-source-2.6.15:
assignee: nobody → ubuntu-audio
Download full text (13.1 KiB)

supertux@defendguin:~$ lspci -v && lspci -nv && tail -2 /proc/asound/oss/sndstat
0000:00:00.0 Host bridge: Intel Corporation Mobile Memory Controller Hub (rev 03)
        Subsystem: Lenovo: Unknown device 2061
        Flags: bus master, fast devsel, latency 0
        Capabilities: <available only to root>

0000:00:02.0 VGA compatible controller: Intel Corporation Mobile Integrated Graphics Controller (rev 03) (prog-if 00 [VGA])
        Subsystem: Lenovo: Unknown device 2062
        Flags: bus master, fast devsel, latency 0, IRQ 177
        Memory at b0080000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at 1800 [size=8]
        Memory at c0000000 (32-bit, prefetchable) [size=256M]
        Memory at b0040000 (32-bit, non-prefetchable) [size=256K]
        Capabilities: <available only to root>

0000:00:02.1 Display controller: Intel Corporation Mobile Integrated Graphics Controller (rev 03)
        Subsystem: Lenovo: Unknown device 2062
        Flags: bus master, fast devsel, latency 0
        Memory at b0100000 (32-bit, non-prefetchable) [size=512K]
        Capabilities: <available only to root>

0000:00:1b.0 0403: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
        Subsystem: Lenovo: Unknown device 2066
        Flags: bus master, fast devsel, latency 0, IRQ 233
        Memory at b0000000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <available only to root>

0000:00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
        Capabilities: <available only to root>

0000:00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
        Memory behind bridge: b0200000-b02fffff
        Capabilities: <available only to root>

0000:00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 02) (prog-if 00 [UHCI])
        Subsystem: Lenovo: Unknown device 206b
        Flags: bus master, medium devsel, latency 0, IRQ 217
        I/O ports at 1820 [size=32]

0000:00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 02) (prog-if 00 [UHCI])
        Subsystem: Lenovo: Unknown device 206c
        Flags: bus master, medium devsel, latency 0, IRQ 209
        I/O ports at 1840 [size=32]

0000:00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 02) (prog-if 00 [UHCI])
        Subsystem: Lenovo: Unknown device 206d
        Flags: bus master, medium devsel, latency 0, IRQ 225
        I/O ports at 1860 [size=32]

0000:00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 02) (prog-if 00 [UHCI])
        Subsystem: Lenovo: Unknown device 206e
        Flags: bus master, medium devsel, latency 0, IRQ 177
        I/O ports at 1880 [size=32]

0000:00:1d.7 USB Controller: Intel Corporation 82801G (ICH7...

Daniel T Chen (crimsun) wrote :

0000:00:1b.0 0403: 8086:27d8 (rev 02)
        Subsystem: 17aa:2066

does not appear in our sound/pci/hda/patch_analog.c . Querying on irc.

amixer -c0 output

Changed in linux-source-2.6.15:
status: Needs Info → Fix Committed
Justin Sunseri (jmsunseri) wrote :

after the update of the kernel today to 2.6.15-21.32 sound works properly without having to modprobe any extra modules. I would say this bug has been fixed.

Daniel T Chen (crimsun) on 2006-04-24
Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
Alex (xp-newbie) wrote :

Sorry to bring the bad news, but as of today (June 14, 2006), with kernel 2.6.15-23-386 installed on my Lenovo 3000 N100 (type 0768, model 36U), sound works only if I added to /etc/modprobe.d/options the following line:

  options snd-hda-intel model=laptop-eapd

Daniel T Chen (crimsun) wrote :

Using "laptop-eapd" is the known workaround (and the original "fix" applied in earlier Ubuntu kernels) while upstream addresses the issue.

Changed in linux-source-2.6.15:
status: Fix Released → Confirmed
Tim Haughton (timhaughton) wrote :

The "options snd-hda-intel model=laptop-eapd" workaround does not work for me on this laptop, is there anything else I can try?

Module loads OK, just no sound. Is there any way it isn't picking up the options?

Daniel T Chen (crimsun) wrote :

@Tim: Please reload the module without any additional parameters.

Tim Haughton (timhaughton) wrote :

Done, but still no sound.

Tim Haughton (timhaughton) wrote :

Please ignore previous. Kernel update fixed it - my mistake. Had specific 686SMP kernel selected rather than meta package.

Daniel T Chen (crimsun) wrote :

These models should have audible sound by default; see the reinstatement commit id f939a127702d733ca9e87cbed300cf33b875c3b3, http://www.kernel.org/git/?p=linux/kernel/git/bcollins/ubuntu-dapper.git;a=commitdiff;h=f939a127702d733ca9e87cbed300cf33b875c3b3;hp=9eb3ccc545428daf1bc741e6f08e5cd597e47dfc

Changed in linux-source-2.6.15:
status: Confirmed → Fix Released

No sound on Lenovo 3000 C200 either.
It has almost the same lspci output, and I have already tried options and new alsa compilation, but no result.
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
        Subsystem: Lenovo Unknown device 3802
The interesting is, that the XP recognizes Realtek sound card, and uses Realtek driver.

Daniel T Chen (crimsun) wrote :

Denes, is the modem enabled or disabled in your bios?

Daniel T Chen írta:
> Denes, is the modem enabled or disabled in your bios?
>
>
Daniel,
The modem was enabled in the bios. I set it disabled, but no change.
I use Ubuntu 6.10, kernel 2.6.17. I compiled the new alsa 1.0.14rc2.
(The hardware should be good, because XP works.)
I can unload the driver by /etc/init.d/alsasound stop, and load it with
modprobe -v snd-hda-intel.
I do not find any fault. Alsamixer on the max. On board volume on.
With regards: Denes

Daniel T Chen (crimsun) wrote :

Denes, please open a support ticket[0] instead of following up here. Thanks.

[0] https://answers.launchpad.net/ubuntu/+addticket

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers