Ubuntu

no network access after ugrade breezy -> dapper

Reported by Dominique Pellé on 2006-06-03
28
Affects Status Importance Assigned to Milestone
linux-restricted-modules-2.6.15 (Ubuntu)
Undecided
Ben Collins
linux-source-2.6.15 (Ubuntu)
Medium
Ben Collins

Bug Description

Binary package hint: upgrade-system

I'm having a hard time trying to upgrade from
breezy to dapper. I had in the past done several
upgrades from Hoary to Breezy on 2 machines
which went all fine. No so with official Dapper-6.06 LTS.
I will try to summarise:

- I had a breezy system, all packages up to date.
- I tried to upgrade to dapper but system crashed
  during the upgrade (I don't have more details here)
- so I reinstalled my system from scratch from
  a hoary CD (that's all I had) with default packages
  only.
- then upgraded hoary -> breezy (which went fine)
- then upgraded breezy -> dapper (by the way, I had
  to manually remove old package linux-2.6.5 as
  mentionned in the release notes when upgrading from
  hoary->breezy or else upgrade was not allowed from
  graphical upgrade manager)
- upgrade went though although I saw a couple of
  possibly severe errors such as seg fault for example
  when setting up PCMCIA (I don't have PCMCIA though)
  (I will attach dist-upgrade-term.log which contains
  this error)

When starting dapper afterwards, I had several issues:
- graphical boot up screen was truncated (I can
  see half of it horizontally, this is not blocking).
- starting up froze the first 2 times I tried to boot
  up with a black screen. I waited several long minutes. I could not see any activity (no disc access).
- I tried to start up again, and then GDM came up (although I made no change)
- however, network access does not work. I see
  several errors in 'kern.log '
<pre>
Jun 4 09:35:04 localhost kernel: [4294939.917000] 0000:00:0a.0: tulip_stop_rxtx() failed (CSR5 0xfc740000 CSR6 0x2042202)
</pre>

This PC worked fine with Hoary and Breezy.
I will try to install Dapper from install CDs when
I receive them rather than doing an upgrade.

I will also attach several of my logs.

Notice in my 'dist-upgrade-term.log' the following errors:

---- [ errors in Perl scripts ]
Preparing to replace lvm2 2.01.04-5ubuntu1 (using .../lvm2_2.02.02-1ubuntu1_i386.deb) ...
debconf: unable to initialize frontend: Gnome
debconf: (Can't locate object method "signal_connect" via package "Gtk2::Window" at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 73.)
debconf: falling back to frontend: Dialog

---- [ segmentation fault when setting up pcmcia ]
Setting up bluez-pcmcia-support (2.24-0ubuntu6) ...
invoke-rc.d: initscript pcmcia, action "start" failed.
                                                                         [fail]
/etc/init.d/pcmcia: line 139: 4150 Segmentation fault modprobe $PCIC $PCIC_OPTS >/dev/null 2>&1
cardmgr[4164]: no sockets found!
Installing new version of config file /etc/init.d/pcmcia ...
Moving init script to /etc/rcS.d.
 * Starting PCMCIA services... /etc/init.d/pcmcia: line 139: 4150 Segmentation fault modprobe $PCIC $PCIC_OPTS >/dev/null 2>&1

---- [ warning with suspicious (null) in file name ]
Setting up gnome2-user-guide (2.14.2-0ubuntu1) ...
I/O warning : failed to load external entity "/var/lib/scrollkeeper/(null)/scrollkeeper_cl.xml"

Notice in the logs, the following errors which
most certainly explain why I don't have network
access after upgrade to dapper:

Jun 3 01:26:05 localhost kernel: 0000:00:0a.0: tulip_stop_rxtx() failed
Jun 3 01:27:32 localhost kernel: 0000:00:0a.0: tulip_stop_rxtx() failed
Jun 3 01:28:44 localhost kernel: 0000:00:0a.0: tulip_stop_rxtx() failed
Jun 3 01:32:15 localhost kernel: 0000:00:0a.0: tulip_stop_rxtx() failed
Jun 3 01:33:25 localhost last message repeated 3 times
Jun 3 01:38:01 localhost kernel: 0000:00:0a.0: tulip_stop_rxtx() failed
Jun 3 01:38:39 localhost kernel: 0000:00:0a.0: tulip_stop_rxtx() failed
Jun 3 01:45:56 localhost kernel: 0000:00:0a.0: tulip_stop_rxtx() failed
Jun 3 01:47:08 localhost kernel: 0000:00:0a.0: tulip_stop_rxtx() failed
Jun 3 01:47:36 localhost kernel: 0000:00:0a.0: tulip_stop_rxtx() failed
Jun 3 01:49:03 localhost kernel: 0000:00:0a.0: tulip_stop_rxtx() failed
Jun 3 01:51:41 localhost kernel: 0000:00:0a.0: tulip_stop_rxtx() failed
Jun 3 01:52:34 localhost kernel: 0000:00:0a.0: tulip_stop_rxtx() failed

Also notice this:

Jun 3 01:57:00 localhost kernel: PCI: Using ACPI for IRQ routing
Jun 3 01:57:00 localhost kernel: ** PCI interrupts are no longer routed automatically. If this
Jun 3 01:57:00 localhost kernel: ** causes a device to stop working, it is probably because the
Jun 3 01:57:00 localhost kernel: ** driver failed to call pci_enable_device(). As a temporary
Jun 3 01:57:00 localhost kernel: ** workaround, the "pci=routeirq" argument restores the old
Jun 3 01:57:00 localhost kernel: ** behavior. If this argument makes the device work again,
Jun 3 01:57:00 localhost kernel: ** please email the output of "lspci" to <email address hidden>
Jun 3 01:57:00 localhost kernel: ** so I can fix the driver.
J

Since error in kern.log says "please email the output of "lspci" to <email address hidden>", here is the output of lspci (which I will also email to Bjorn)

$ lspci
0000:00:00.0 Host bridge: VIA Technologies, Inc. VT82C693A/694x [Apollo PRO133x] (rev 02)
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro133x AGP]
0000:00:04.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 22)
0000:00:04.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 10)
0000:00:04.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 10)
0000:00:04.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 10)
0000:00:04.4 Host bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 30)
0000:00:04.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97 Audio Controller (rev 20)
0000:00:0a.0 Ethernet controller: Davicom Semiconductor, Inc. 21x4x DEC-Tulip compatible 10/100 Ethernet (rev 31)
0000:01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400 AGP (rev 04)

I tried booting afte changing my Linux command line in GRUB (by pressing ESC before booting up to enter GRUB's menu).

I tried with: "pci=routeirq" in command line but it does not help.
I also tried with: "pci=noacpi" but again it does not help.

Browsing though other bugs, I think package "linux-source-2.6.15" is more appropriate.

Googling for "+"linux" +"Ethernet controller: Davicom Semiconductor, Inc. 21x4x DEC-Tulip compatible 10/100 Ethernet", I found the following post
which describes the same error I have with
the exact same ethernet device:

http://www.redhat.com/archives/rhl-list/2006-March/msg05272.html
FC5

It describes the same error that I experience with the same kind of Ethernet device using "Linux version 2.6.15-1.2054_FC5 (bhcompile hs20-bc1-3 build redhat com)"

I found this interesting link:
http://lists.debian.org/debian-boot/2005/09/msg00744.html

It describes a problem using the exact same ethernet device. It sounds a lot like what I experience. It says: "[...] the kernel
module for this device was changed from dmfe to tulip." and that it was done to fix:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=284730

I started up my old Hoary live CD which works all fine unlike Dapper and I compared the kern.log.

Here are the relevant snippets of /var/log/kern.log on Hoary (which works) and Dapper (which is broken):

=== [ Hoary /var/kern.log]==============
Jun 4 05:49:34 localhost kernel: dmfe: Davicom DM9xxx net driver, version 1.36.4 (2002-01-17)
Jun 4 05:49:34 localhost kernel: ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 10
Jun 4 05:49:34 localhost kernel: PCI: setting IRQ 10 as level-triggered
Jun 4 05:49:34 localhost kernel: ACPI: PCI interrupt 0000:00:0a.0[A] -> GSI 10 (level, low) -> IRQ 10
Jun 4 05:49:34 localhost kernel: eth0: Davicom DM9102 at pci0000:00:0a.0, 00:80:ad:73:1f:e8, irq 10.
Jun 4 05:49:34 localhost kernel: Linux Tulip driver version 1.1.13 (May 11, 2002)

=== [ Dapper kern.log ] ===============
Jun 4 13:50:43 localhost kernel: [4294692.362000] PCI: Found IRQ 10 for device 0000:00:0a.0
Jun 4 13:50:43 localhost kernel: [4294692.362000] PCI: Sharing IRQ 10 with 0000:00:04.5
Jun 4 13:50:43 localhost kernel: [4294692.378000] tulip0: EEPROM default media type Autosense.
Jun 4 13:50:43 localhost kernel: [4294692.378000] tulip0: Index #0 - Media MII (#11) described by a 21140 MII PHY (1) block.
Jun 4 13:50:43 localhost kernel: [4294692.378000] tulip0: Index #1 - Media 10baseT (#0) described by a 21140 non-MII (0) block.
Jun 4 13:50:43 localhost kernel: [4294692.378000] tulip0: Index #2 - Media 100baseTx (#3) described by a 21140 non-MII (0) block.
Jun 4 13:50:43 localhost kernel: [4294692.378000] tulip0: Index #3 - Media 10baseT-FDX (#4) described by a 21140 non-MII (0) block.
Jun 4 13:50:43 localhost kernel: [4294692.378000] tulip0: Index #4 - Media 100baseTx-FDX (#5) described by a 21140 non-MII (0) block.
Jun 4 13:50:43 localhost kernel: [4294692.380000] tulip0: MII transceiver #1 config 3100 status 7809 advertising 01e1.
Jun 4 13:50:43 localhost kernel: [4294692.895000] eth0: Davicom DM9102/DM9102A rev 49 at 0001a400, 00:80:AD:73:1F:E8, IRQ 10.
Jun 4 13:50:43 localhost kernel: [4294693.003000] dmfe: Davicom DM9xxx net driver, version 1.36.4 (2002-01-17)
...cut...
Jun 4 13:51:44 localhost kernel: [4294767.005000] 0000:00:0a.0: tulip_stop_rxtx() failed (CSR5 0xfc740000 CSR6 0x2042202)
Jun 4 13:51:59 localhost kernel: [4294781.412000] 0000:00:0a.0: tulip_stop_rxtx() failed (CSR5 0xfc740000 CSR6 0x2042202)
Jun 4 13:52:01 localhost kernel: [4294783.814000] 0000:00:0a.0: tulip_stop_rxtx() failed (CSR5 0xfc740000 CSR6 0x2042202)

OK, I found bug #48026 which looked like mine:

https://launchpad.net/distros/ubuntu/+source/udev/+bug/48026

To remedy bug, it suggests to:
- rmmod tulip
- rmmod dmfe
- modprobe dmfe

I did just that, followed by:

- /etc/init.d/networking stop
- /etc/init.d/networking start

and voila, I now have networking with Ubuntu-6.06 LTS.

Now, this is only a workaround. More novice user
with the same network card are unlikely to find the
solution so bug needs to be fixed.

This simple patch removes the PCI ID's of the Davicom NIC's from the tulip driver. Currently, both dmfe and tulip handles them and this bug report suggests that the tulip driver is not up to it after all, so we should let dmfe handle them.

Soren Hansen (soren) wrote :

Bug #48026 confirms this issue.

Changed in linux-source-2.6.15:
status: Unconfirmed → Confirmed
Ben Collins (ben-collins) wrote :

Patch applied for next dapper update.

Changed in linux-source-2.6.15:
assignee: nobody → ben-collins
status: Confirmed → Fix Committed
Vassilis Pandis (pandisv) wrote :

This issue is still present upstream (by looking at Linus' git tree, the tulip driver still contains those IDs) - will this be forwarded upstream?

Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
Changed in linux-restricted-modules-2.6.15:
assignee: nobody → ben-collins
status: New → Fix Released
maximi89 (maximi89) wrote :

Hi, i have the same error on Debian "Squeeze",
maximi89@Maximiliano:~$ uname -a
Linux Maximiliano 2.6.26-1-686 #1 SMP Sat Jan 10 18:29:31 UTC 2009 i686 GNU/Linux

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=522592

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.