Ubuntu

Sound not working on Asus F3J

Reported by Vassilis Pandis on 2006-09-30
12
Affects Status Importance Assigned to Milestone
linux-source-2.6.15 (Ubuntu)
Low
Unassigned

Bug Description

I tried the 6.06.1 livecd on an Asus F3J. Sound doesn't work. When I try to play the sample content, it appears to be playing, but nothing can be heard (login sounds don't work either). The volume is turned on, the sound card is apparently detected (I can select "HDA Intel" in the default sound card preferences) but nothing can be heard. I made sure nothing is muted and that the volume is maximum.

ubuntu@ubuntu:~$ aplay --list-devices
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC861 Analog [ALC861 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC861 Digital [ALC861 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
ubuntu@ubuntu:~$

Attached you will find lspci and dmesg outputs.

Vassilis Pandis (pandisv) wrote :
Vassilis Pandis (pandisv) wrote :
Vassilis Pandis (pandisv) wrote :
Vassilis Pandis (pandisv) wrote :

Please tell me ASAP as possible what other information is needed, as afterwards I will not have access to the laptop for a fortnight. Thanks.

Daniel T Chen (crimsun) wrote :

Fix already pushed to kernel team.

Changed in alsa-driver:
importance: Undecided → Low
status: Unconfirmed → Fix Committed
André Santos (vigilnt) wrote :

I've got an Asus F3JC with the same sound card, and it's not working also...

Is there going to be a fix released soon ?

I'm going to compile alsa 1.0.13, don't know if it's going to work... :\

Martin Majlis (martin-majlis) wrote :

In Alsa Project bugzilla is hint, how "fix" this problem:
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=2480#12251

The sound work with options snd-hda-intel model=uniwill-m31 in the modprobe.conf (or similar for Unbutu)

Vassilis Pandis (pandisv) wrote :

I no longer have access to the laptop, but apparently this is still an issue.

Quoting from bug 89365, on Feisty:

Sound only comes after compiling and installing alsa 1.0.14rc2 (or rc1).

.14rc3 seems to be on its way... I do not what is the expected release date for .14, but that would a very good idea to have it in if the ubuntu release focuses on
hardware compatibilty.

Changed in linux-source-2.6.15 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers