SD cards >512mb don't work in Ricoh card reader

Bug #61758 reported by Yuriy Kozlov on 2006-09-21
14
Affects Status Importance Assigned to Milestone
linux-source-2.6.17 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: linux-source-2.6.17

Asus V6J laptop with this card reader:
Class 0805: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)

Inserting a 2GB SD card freezes my system.
For someone else with this card reader in a different laptop, a 1GB or 2GB card is just not recognized:
http://www.ubuntuforums.org/showthread.php?t=260760
http://www.ubuntuforums.org/showthread.php?t=261761

There is a patch to fix support for >512mb cards here:
http://marc.theaimsgroup.com/?l=linux-kernel&m=114980773206129&w=2

According to the above thread, this has been fixed in kernel 2.6.18

Please include the patch in the edgy kernel.

In Dapper, the card is not recognized, with a bunch of errors in dmesg but the system does not freeze.

Mikael Nilsson (mini) wrote :

Confirmed on Dell XPS M1710, and 2Gb SD card.

03:01.1 Class 0805: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)

Seems this fix is recommended by the shdci author, and has been discussed here

http://list.drzeus.cx/pipermail/sdhci-devel/2006-August/001215.html

and here

http://list.drzeus.cx/pipermail/sdhci-devel/2006-August/001269.html

Please include the patch.

knubbe (knubbe) wrote :

I can confirm this. I'm using kernel 2.6.17 (edgy beta), Dell inspiron 6000.

64mb card works fine, 2gb card hangs the computer.

Nafallo Bjälevik (nafallo) wrote :

Seems confirmed.

Changed in linux-source-2.6.17:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Jacob Emcken (jacob-emcken) wrote :

I can confirm this on a IBM x40:

02:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 8d)
02:00.1 Class 0805: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 13)

Entire system hangs when the card is inserted.

Hannes Ovrén (kigurai) wrote :

I can also confirm that a 2GB SD card freezes my system (Ubuntu Edgy 6.10) and does not mount on my girlfriends Kubuntu 6.06. Both computers are Asus A6k.
Mine (can't access hers right now) have this card reader:

00:0a.2 Class 0805: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 17)

Mounting cards up to 512 MB works without problem.

Efraim Karsh (efraimkarsh) wrote :

Confirmed on an Fujitsu/Siemens Amilo SI 1520, running Ubuntu dapper 2.6.15-27-686 with a Ricoh R5C822 SD/SDIO/MMC/MS/MSPro adapter (rev 19).

2GB SD card is not recognizes and/or freezes the system.

Alan Hartless (harty83) wrote :

I have a 1 gb sd card reading on a compaq presario v3000 with a built in sd card reader (R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter). The system has the most up to date edgy.

My system does not hang or lock up but it does take a very long time to read the card.

Yuriy Kozlov (yuriy-kozlov) wrote :

Fixed in Feisty.

Todays kernel upgrade on edgy (2.6.17-10-386) does now let me mount my
2GB SD-card without trouble.

2006/12/14, harty83 <email address hidden>:
> I have a 1 gb sd card reading on a compaq presario v3000 with a built in
> sd card reader (R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter). The system
> has the most up to date edgy.
>
> My system does not hang or lock up but it does take a very long time to
> read the card.
>
> --
> SD cards >512mb don't work in Ricoh card reader
> https://launchpad.net/bugs/61758
>

knubbe (knubbe) wrote :

I can confirm this. My 2GB SD-card works now in Edgy with kernel 2.6.17-10.

> Todays kernel upgrade on edgy (2.6.17-10-386) does now let me mount my
> 2GB SD-card without trouble.

Yuriy Kozlov (yuriy-kozlov) wrote :

I don't have edgy to test with anymore, but based on the last 2 comments marking as fixed.

Changed in linux-source-2.6.17:
status: Confirmed → Fix Released
Bob Stockdale (stocks29) wrote :

I am having the problem still and I am using the newest kernel.

stocksxps:~$ uname -a
Linux stocksxps 2.6.17-10-386 #2 Fri Oct 13 18:41:40 UTC 2006 i686 GNU/Linux

My 128 MB Lexar SD Card works fine, but when I put in my 2.0GB San Disk SD Card my dell xps m140 running edgy freezes and must be restarted. If I try to boot with the card in it freezes also.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers