linux 5.4.0-29.33 source package in Ubuntu

Changelog

linux (5.4.0-29.33) focal; urgency=medium

  * focal/linux: 5.4.0-29.33 -proposed tracker (LP: #1875858)

  * Packaging resync (LP: #1786013)
    - update dkms package versions

  * Add signed modules for the 435 NVIDIA driver (LP: #1875888)
    - [Packaging] NVIDIA -- add signed modules for the 435 NVIDIA driver

  * built-using constraints preventing uploads (LP: #1875601)
    - temporarily drop Built-Using data

 -- Stefan Bader <email address hidden>  Wed, 29 Apr 2020 15:34:16 +0200

Upload details

Uploaded by:
Stefan Bader
Uploaded to:
Focal
Original maintainer:
Ubuntu Kernel Team
Architectures:
all amd64 armhf arm64 ppc64el s390x i386
Section:
devel
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
linux_5.4.0.orig.tar.gz 162.4 MiB 805f3ed93854317814c59caf2dbfd2097745685f95c8c18b509c9347dcc7d51f
linux_5.4.0-29.33.diff.gz 4.0 MiB 82dc05af7f622be13683131aefe7a204029012d600a024ef20a31cce9643d911
linux_5.4.0-29.33.dsc 7.0 KiB d4780c56990f0060b346a9705753a0c14348c539498d1caf256cb9f017adf477

View changes file

Binary packages built by this source

block-modules-5.4.0-29-generic-di: No summary available for block-modules-5.4.0-29-generic-di in ubuntu groovy.

No description available for block-modules-5.4.0-29-generic-di in ubuntu groovy.

block-modules-5.4.0-29-generic-lpae-di: Block storage devices

 This package contains the block storage devices, including DAC960 and
 paraide.

crypto-modules-5.4.0-29-generic-di: crypto modules

 This package contains crypto modules.

crypto-modules-5.4.0-29-generic-lpae-di: No summary available for crypto-modules-5.4.0-29-generic-lpae-di in ubuntu groovy.

No description available for crypto-modules-5.4.0-29-generic-lpae-di in ubuntu groovy.

dasd-extra-modules-5.4.0-29-generic-di: No summary available for dasd-extra-modules-5.4.0-29-generic-di in ubuntu groovy.

No description available for dasd-extra-modules-5.4.0-29-generic-di in ubuntu groovy.

dasd-modules-5.4.0-29-generic-di: No summary available for dasd-modules-5.4.0-29-generic-di in ubuntu groovy.

No description available for dasd-modules-5.4.0-29-generic-di in ubuntu groovy.

fat-modules-5.4.0-29-generic-di: FAT filesystem support

 This includes Windows FAT and VFAT support.

fat-modules-5.4.0-29-generic-lpae-di: No summary available for fat-modules-5.4.0-29-generic-lpae-di in ubuntu groovy.

No description available for fat-modules-5.4.0-29-generic-lpae-di in ubuntu groovy.

fb-modules-5.4.0-29-generic-di: No summary available for fb-modules-5.4.0-29-generic-di in ubuntu groovy.

No description available for fb-modules-5.4.0-29-generic-di in ubuntu groovy.

firewire-core-modules-5.4.0-29-generic-di: Firewire (IEEE-1394) Support
floppy-modules-5.4.0-29-generic-di: Floppy driver support
fs-core-modules-5.4.0-29-generic-di: No summary available for fs-core-modules-5.4.0-29-generic-di in ubuntu groovy.

No description available for fs-core-modules-5.4.0-29-generic-di in ubuntu groovy.

fs-core-modules-5.4.0-29-generic-lpae-di: Base filesystem modules

 This includes jfs, reiserfs and xfs.

fs-secondary-modules-5.4.0-29-generic-di: Extra filesystem modules

 This includes support for Windows NTFS and MacOS HFS/HFSPlus

fs-secondary-modules-5.4.0-29-generic-lpae-di: No summary available for fs-secondary-modules-5.4.0-29-generic-lpae-di in ubuntu groovy.

No description available for fs-secondary-modules-5.4.0-29-generic-lpae-di in ubuntu groovy.

input-modules-5.4.0-29-generic-di: Support for various input methods
input-modules-5.4.0-29-generic-lpae-di: No summary available for input-modules-5.4.0-29-generic-lpae-di in ubuntu groovy.

No description available for input-modules-5.4.0-29-generic-lpae-di in ubuntu groovy.

ipmi-modules-5.4.0-29-generic-di: No summary available for ipmi-modules-5.4.0-29-generic-di in ubuntu groovy.

No description available for ipmi-modules-5.4.0-29-generic-di in ubuntu groovy.

ipmi-modules-5.4.0-29-generic-lpae-di: ipmi modules
kernel-image-5.4.0-29-generic-di: No summary available for kernel-image-5.4.0-29-generic-di in ubuntu groovy.

No description available for kernel-image-5.4.0-29-generic-di in ubuntu groovy.

kernel-image-5.4.0-29-generic-lpae-di: kernel image and system map
linux-buildinfo-5.4.0-29-generic: Linux kernel buildinfo for version 5.4.0 on ARM (hard float) SMP

 This package contains the Linux kernel buildinfo for version 5.4.0 on
 ARM (hard float) SMP.
 .
 You likely do not want to install this package.

linux-buildinfo-5.4.0-29-generic-lpae: No summary available for linux-buildinfo-5.4.0-29-generic-lpae in ubuntu groovy.

No description available for linux-buildinfo-5.4.0-29-generic-lpae in ubuntu groovy.

linux-buildinfo-5.4.0-29-lowlatency: Linux kernel buildinfo for version 5.4.0 on 64 bit x86 SMP

 This package contains the Linux kernel buildinfo for version 5.4.0 on
 64 bit x86 SMP.
 .
 You likely do not want to install this package.

linux-cloud-tools-5.4.0-29: No summary available for linux-cloud-tools-5.4.0-29 in ubuntu groovy.

No description available for linux-cloud-tools-5.4.0-29 in ubuntu groovy.

linux-cloud-tools-5.4.0-29-generic: Linux kernel version specific cloud tools for version 5.4.0-29

 This package provides the architecture dependant parts for kernel
 version locked tools for cloud for version 5.4.0-29 on
 64 bit x86.

linux-cloud-tools-5.4.0-29-lowlatency: No summary available for linux-cloud-tools-5.4.0-29-lowlatency in ubuntu groovy.

No description available for linux-cloud-tools-5.4.0-29-lowlatency in ubuntu groovy.

linux-cloud-tools-common: Linux kernel version specific cloud tools for version 5.4.0

 This package provides the architecture independent parts for kernel
 version locked tools for cloud tools for version 5.4.0.

linux-doc: Linux kernel specific documentation for version 5.4.0

 This package provides the various documents in the 5.4.0 kernel
 Documentation/ subdirectory. These document kernel subsystems, APIs, device
 drivers, and so on. See
 /usr/share/doc/linux-doc/00-INDEX for a list of what is
 contained in each file.

linux-headers-5.4.0-29: Header files related to Linux kernel version 5.4.0

 This package provides kernel header files for version 5.4.0, for sites
 that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-5.4.0-29/debian.README.gz for details

linux-headers-5.4.0-29-generic: Linux kernel headers for version 5.4.0 on ARM (hard float) SMP

 This package provides kernel header files for version 5.4.0 on
 ARM (hard float) SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-5.4.0-29/debian.README.gz for details.

linux-headers-5.4.0-29-generic-lpae: No summary available for linux-headers-5.4.0-29-generic-lpae in ubuntu groovy.

No description available for linux-headers-5.4.0-29-generic-lpae in ubuntu groovy.

linux-headers-5.4.0-29-lowlatency: Linux kernel headers for version 5.4.0 on 64 bit x86 SMP

 This package provides kernel header files for version 5.4.0 on
 64 bit x86 SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-5.4.0-29/debian.README.gz for details.

linux-image-5.4.0-29-generic: Signed kernel image generic

 A kernel image for generic. This version of it is signed with
 Canonical's UEFI/Opal signing key.

linux-image-5.4.0-29-generic-dbgsym: Signed kernel image generic

 A link to the debugging symbols for the generic signed kernel.

linux-image-5.4.0-29-generic-lpae: Linux kernel image for version 5.4.0 on ARM (hard float) SMP

 This package contains the Linux kernel image for version 5.4.0 on
 ARM (hard float) SMP.
 .
 Supports Generic LPAE processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-generic-lpae meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-image-5.4.0-29-generic-lpae-dbgsym: Linux kernel debug image for version 5.4.0 on ARM (hard float) SMP

 This package provides the kernel debug image for version 5.4.0 on
 ARM (hard float) SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-image-unsigned-5.4.0-29-generic: Linux kernel image for version 5.4.0 on ARMv8 SMP

 This package contains the unsigned Linux kernel image for version 5.4.0 on
 ARMv8 SMP.
 .
 Supports Generic processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-generic meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-image-unsigned-5.4.0-29-generic-dbgsym: Linux kernel debug image for version 5.4.0 on ARMv8 SMP

 This package provides the unsigned kernel debug image for version 5.4.0 on
 ARMv8 SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-image-unsigned-5.4.0-29-lowlatency: No summary available for linux-image-unsigned-5.4.0-29-lowlatency in ubuntu groovy.

No description available for linux-image-unsigned-5.4.0-29-lowlatency in ubuntu groovy.

linux-image-unsigned-5.4.0-29-lowlatency-dbgsym: Linux kernel debug image for version 5.4.0 on 64 bit x86 SMP

 This package provides the unsigned kernel debug image for version 5.4.0 on
 64 bit x86 SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-libc-dev: No summary available for linux-libc-dev in ubuntu groovy.

No description available for linux-libc-dev in ubuntu groovy.

linux-modules-5.4.0-29-generic: Linux kernel extra modules for version 5.4.0 on ARM (hard float) SMP

 Contains the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Generic processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-generic meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-modules-5.4.0-29-generic-lpae: No summary available for linux-modules-5.4.0-29-generic-lpae in ubuntu groovy.

No description available for linux-modules-5.4.0-29-generic-lpae in ubuntu groovy.

linux-modules-5.4.0-29-lowlatency: Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP

 Contains the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Lowlatency processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-lowlatency meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-modules-extra-5.4.0-29-generic: No summary available for linux-modules-extra-5.4.0-29-generic in ubuntu groovy.

No description available for linux-modules-extra-5.4.0-29-generic in ubuntu groovy.

linux-source-5.4.0: Linux kernel source for version 5.4.0 with Ubuntu patches

 This package provides the source code for the Linux kernel version
 5.4.0.
 .
 This package is mainly meant for other packages to use, in order to build
 custom flavours.
 .
 If you wish to use this package to create a custom Linux kernel, then it
 is suggested that you investigate the package kernel-package, which has
 been designed to ease the task of creating kernel image packages.
 .
 If you are simply trying to build third-party modules for your kernel,
 you do not want this package. Install the appropriate linux-headers
 package instead.

linux-tools-5.4.0-29: Linux kernel version specific tools for version 5.4.0-29

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 5.4.0-29 on
 ARM (hard float).
 You probably want to install linux-tools-5.4.0-29-<flavour>.

linux-tools-5.4.0-29-generic: Linux kernel version specific tools for version 5.4.0-29

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 5.4.0-29 on
 ARM (hard float).

linux-tools-5.4.0-29-generic-lpae: No summary available for linux-tools-5.4.0-29-generic-lpae in ubuntu groovy.

No description available for linux-tools-5.4.0-29-generic-lpae in ubuntu groovy.

linux-tools-5.4.0-29-lowlatency: Linux kernel version specific tools for version 5.4.0-29

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 5.4.0-29 on
 64 bit x86.

linux-tools-common: No summary available for linux-tools-common in ubuntu groovy.

No description available for linux-tools-common in ubuntu groovy.

linux-tools-host: Linux kernel VM host tools

 This package provides kernel tools useful for VM hosts.

linux-udebs-generic: Metapackage depending on kernel udebs

 This package depends on the all udebs that the kernel build generated,
 for easier version and migration tracking.

linux-udebs-generic-lpae: No summary available for linux-udebs-generic-lpae in ubuntu groovy.

No description available for linux-udebs-generic-lpae in ubuntu groovy.

md-modules-5.4.0-29-generic-di: No summary available for md-modules-5.4.0-29-generic-di in ubuntu groovy.

No description available for md-modules-5.4.0-29-generic-di in ubuntu groovy.

md-modules-5.4.0-29-generic-lpae-di: Multi-device support (raid, device-mapper, lvm)
message-modules-5.4.0-29-generic-di: Fusion and i2o storage modules

 This package containes the fusion and i2o storage modules.

mouse-modules-5.4.0-29-generic-di: Mouse support

 This package contains mouse drivers for the Linux kernel.

mouse-modules-5.4.0-29-generic-lpae-di: Mouse support

 This package contains mouse drivers for the Linux kernel.

multipath-modules-5.4.0-29-generic-di: DM-Multipath support

  This package contains modules for device-mapper multipath support.

multipath-modules-5.4.0-29-generic-lpae-di: DM-Multipath support

  This package contains modules for device-mapper multipath support.

nfs-modules-5.4.0-29-generic-di: NFS filesystem drivers

 Includes the NFS client driver, and supporting modules.

nfs-modules-5.4.0-29-generic-lpae-di: NFS filesystem drivers

 Includes the NFS client driver, and supporting modules.

nic-modules-5.4.0-29-generic-di: Network interface support
nic-modules-5.4.0-29-generic-lpae-di: Network interface support
nic-pcmcia-modules-5.4.0-29-generic-di: PCMCIA network interface support
nic-shared-modules-5.4.0-29-generic-di: No summary available for nic-shared-modules-5.4.0-29-generic-di in ubuntu groovy.

No description available for nic-shared-modules-5.4.0-29-generic-di in ubuntu groovy.

nic-shared-modules-5.4.0-29-generic-lpae-di: nic shared modules

  This package contains modules which support nic modules

nic-usb-modules-5.4.0-29-generic-di: USB network interface support
nic-usb-modules-5.4.0-29-generic-lpae-di: No summary available for nic-usb-modules-5.4.0-29-generic-lpae-di in ubuntu groovy.

No description available for nic-usb-modules-5.4.0-29-generic-lpae-di in ubuntu groovy.

parport-modules-5.4.0-29-generic-di: Parallel port support
parport-modules-5.4.0-29-generic-lpae-di: No summary available for parport-modules-5.4.0-29-generic-lpae-di in ubuntu groovy.

No description available for parport-modules-5.4.0-29-generic-lpae-di in ubuntu groovy.

pata-modules-5.4.0-29-generic-di: No summary available for pata-modules-5.4.0-29-generic-di in ubuntu groovy.

No description available for pata-modules-5.4.0-29-generic-di in ubuntu groovy.

pcmcia-modules-5.4.0-29-generic-di: PCMCIA Modules
pcmcia-storage-modules-5.4.0-29-generic-di: PCMCIA storage support
plip-modules-5.4.0-29-generic-di: PLIP (parallel port) networking support
plip-modules-5.4.0-29-generic-lpae-di: PLIP (parallel port) networking support
ppp-modules-5.4.0-29-generic-di: PPP (serial port) networking support
ppp-modules-5.4.0-29-generic-lpae-di: No summary available for ppp-modules-5.4.0-29-generic-lpae-di in ubuntu groovy.

No description available for ppp-modules-5.4.0-29-generic-lpae-di in ubuntu groovy.

sata-modules-5.4.0-29-generic-di: No summary available for sata-modules-5.4.0-29-generic-di in ubuntu groovy.

No description available for sata-modules-5.4.0-29-generic-di in ubuntu groovy.

sata-modules-5.4.0-29-generic-lpae-di: No summary available for sata-modules-5.4.0-29-generic-lpae-di in ubuntu groovy.

No description available for sata-modules-5.4.0-29-generic-lpae-di in ubuntu groovy.

scsi-modules-5.4.0-29-generic-di: SCSI storage support
scsi-modules-5.4.0-29-generic-lpae-di: No summary available for scsi-modules-5.4.0-29-generic-lpae-di in ubuntu groovy.

No description available for scsi-modules-5.4.0-29-generic-lpae-di in ubuntu groovy.

serial-modules-5.4.0-29-generic-di: Serial port support
storage-core-modules-5.4.0-29-generic-di: No summary available for storage-core-modules-5.4.0-29-generic-di in ubuntu groovy.

No description available for storage-core-modules-5.4.0-29-generic-di in ubuntu groovy.

storage-core-modules-5.4.0-29-generic-lpae-di: Core storage support

 Includes core SCSI, LibATA, USB-Storage. Also includes related block
 devices for CD, Disk and Tape medium (and IDE Floppy).

usb-modules-5.4.0-29-generic-di: No summary available for usb-modules-5.4.0-29-generic-di in ubuntu groovy.

No description available for usb-modules-5.4.0-29-generic-di in ubuntu groovy.

usb-modules-5.4.0-29-generic-lpae-di: Core USB support
virtio-modules-5.4.0-29-generic-di: No summary available for virtio-modules-5.4.0-29-generic-di in ubuntu groovy.

No description available for virtio-modules-5.4.0-29-generic-di in ubuntu groovy.

vlan-modules-5.4.0-29-generic-di: vlan modules

 This package contains vlan (8021.Q) modules.

vlan-modules-5.4.0-29-generic-lpae-di: No summary available for vlan-modules-5.4.0-29-generic-lpae-di in ubuntu groovy.

No description available for vlan-modules-5.4.0-29-generic-lpae-di in ubuntu groovy.