linux 5.4.0-37.41 source package in Ubuntu

Changelog

linux (5.4.0-37.41) focal; urgency=medium

  * CVE-2020-0543
    - SAUCE: x86/speculation/spectre_v2: Exclude Zhaoxin CPUs from SPECTRE_V2
    - SAUCE: x86/cpu: Add a steppings field to struct x86_cpu_id
    - SAUCE: x86/cpu: Add 'table' argument to cpu_matches()
    - SAUCE: x86/speculation: Add Special Register Buffer Data Sampling (SRBDS)
      mitigation
    - SAUCE: x86/speculation: Add SRBDS vulnerability and mitigation documentation
    - SAUCE: x86/speculation: Add Ivy Bridge to affected list

 -- Marcelo Henrique Cerri <email address hidden>  Wed, 03 Jun 2020 11:24:23 -0300

Upload details

Uploaded by:
Marcelo Cerri
Uploaded to:
Focal
Original maintainer:
Ubuntu Kernel Team
Architectures:
all amd64 armhf arm64 ppc64el s390x i386
Section:
devel
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
linux_5.4.0.orig.tar.gz 162.4 MiB 805f3ed93854317814c59caf2dbfd2097745685f95c8c18b509c9347dcc7d51f
linux_5.4.0-37.41.diff.gz 4.3 MiB b6dd98e0dfee87480e64db19b96fcf097f38effd07195c0dd3c5020aec1ec7eb
linux_5.4.0-37.41.dsc 6.9 KiB 43fc63d39e9383ab24f7c5806ab83b3eac738f4a770e1d456c994f13465053ea

View changes file

Binary packages built by this source

block-modules-5.4.0-37-generic-di: Block storage devices

 This package contains the block storage devices, including DAC960 and
 paraide.

block-modules-5.4.0-37-generic-lpae-di: Block storage devices

 This package contains the block storage devices, including DAC960 and
 paraide.

crypto-modules-5.4.0-37-generic-di: crypto modules

 This package contains crypto modules.

crypto-modules-5.4.0-37-generic-lpae-di: crypto modules

 This package contains crypto modules.

dasd-extra-modules-5.4.0-37-generic-di: No summary available for dasd-extra-modules-5.4.0-37-generic-di in ubuntu groovy.

No description available for dasd-extra-modules-5.4.0-37-generic-di in ubuntu groovy.

dasd-modules-5.4.0-37-generic-di: DASD storage support
fat-modules-5.4.0-37-generic-di: FAT filesystem support

 This includes Windows FAT and VFAT support.

fat-modules-5.4.0-37-generic-lpae-di: No summary available for fat-modules-5.4.0-37-generic-lpae-di in ubuntu groovy.

No description available for fat-modules-5.4.0-37-generic-lpae-di in ubuntu groovy.

fb-modules-5.4.0-37-generic-di: Framebuffer modules
firewire-core-modules-5.4.0-37-generic-di: Firewire (IEEE-1394) Support
floppy-modules-5.4.0-37-generic-di: Floppy driver support
fs-core-modules-5.4.0-37-generic-di: Base filesystem modules

 This includes jfs, reiserfs and xfs.

fs-core-modules-5.4.0-37-generic-lpae-di: No summary available for fs-core-modules-5.4.0-37-generic-lpae-di in ubuntu groovy.

No description available for fs-core-modules-5.4.0-37-generic-lpae-di in ubuntu groovy.

fs-secondary-modules-5.4.0-37-generic-di: Extra filesystem modules

 This includes support for Windows NTFS and MacOS HFS/HFSPlus

fs-secondary-modules-5.4.0-37-generic-lpae-di: Extra filesystem modules

 This includes support for Windows NTFS and MacOS HFS/HFSPlus

input-modules-5.4.0-37-generic-di: Support for various input methods
input-modules-5.4.0-37-generic-lpae-di: Support for various input methods
ipmi-modules-5.4.0-37-generic-di: No summary available for ipmi-modules-5.4.0-37-generic-di in ubuntu groovy.

No description available for ipmi-modules-5.4.0-37-generic-di in ubuntu groovy.

ipmi-modules-5.4.0-37-generic-lpae-di: ipmi modules
kernel-image-5.4.0-37-generic-di: kernel image and system map
kernel-image-5.4.0-37-generic-lpae-di: kernel image and system map
linux-buildinfo-5.4.0-37-generic: Linux kernel buildinfo for version 5.4.0 on ARMv8 SMP

 This package contains the Linux kernel buildinfo for version 5.4.0 on
 ARMv8 SMP.
 .
 You likely do not want to install this package.

linux-buildinfo-5.4.0-37-generic-lpae: No summary available for linux-buildinfo-5.4.0-37-generic-lpae in ubuntu groovy.

No description available for linux-buildinfo-5.4.0-37-generic-lpae in ubuntu groovy.

linux-buildinfo-5.4.0-37-lowlatency: No summary available for linux-buildinfo-5.4.0-37-lowlatency in ubuntu groovy.

No description available for linux-buildinfo-5.4.0-37-lowlatency in ubuntu groovy.

linux-cloud-tools-5.4.0-37: Linux kernel version specific cloud tools for version 5.4.0-37

 This package provides the architecture dependant parts for kernel
 version locked tools for cloud tools for version 5.4.0-37 on
 64 bit x86.
 You probably want to install linux-cloud-tools-5.4.0-37-<flavour>.

linux-cloud-tools-5.4.0-37-generic: Linux kernel version specific cloud tools for version 5.4.0-37

 This package provides the architecture dependant parts for kernel
 version locked tools for cloud for version 5.4.0-37 on
 64 bit x86.

linux-cloud-tools-5.4.0-37-lowlatency: Linux kernel version specific cloud tools for version 5.4.0-37

 This package provides the architecture dependant parts for kernel
 version locked tools for cloud for version 5.4.0-37 on
 64 bit x86.

linux-cloud-tools-common: Linux kernel version specific cloud tools for version 5.8.0

 This package provides the architecture independent parts for kernel
 version locked tools for cloud tools for version 5.8.0.

linux-doc: Linux kernel specific documentation for version 5.4.0

 This package provides the various documents in the 5.4.0 kernel
 Documentation/ subdirectory. These document kernel subsystems, APIs, device
 drivers, and so on. See
 /usr/share/doc/linux-doc/00-INDEX for a list of what is
 contained in each file.

linux-headers-5.4.0-37: Header files related to Linux kernel version 5.4.0

 This package provides kernel header files for version 5.4.0, for sites
 that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-5.4.0-37/debian.README.gz for details

linux-headers-5.4.0-37-generic: No summary available for linux-headers-5.4.0-37-generic in ubuntu groovy.

No description available for linux-headers-5.4.0-37-generic in ubuntu groovy.

linux-headers-5.4.0-37-generic-lpae: No summary available for linux-headers-5.4.0-37-generic-lpae in ubuntu groovy.

No description available for linux-headers-5.4.0-37-generic-lpae in ubuntu groovy.

linux-headers-5.4.0-37-lowlatency: Linux kernel headers for version 5.4.0 on 64 bit x86 SMP

 This package provides kernel header files for version 5.4.0 on
 64 bit x86 SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-5.4.0-37/debian.README.gz for details.

linux-image-5.4.0-37-generic: Signed kernel image generic

 A kernel image for generic. This version of it is signed with
 Canonical's UEFI/Opal signing key.

linux-image-5.4.0-37-generic-dbgsym: Signed kernel image generic

 A link to the debugging symbols for the generic signed kernel.

linux-image-5.4.0-37-generic-lpae: Linux kernel image for version 5.4.0 on ARM (hard float) SMP

 This package contains the Linux kernel image for version 5.4.0 on
 ARM (hard float) SMP.
 .
 Supports Generic LPAE processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-generic-lpae meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-image-5.4.0-37-generic-lpae-dbgsym: Linux kernel debug image for version 5.4.0 on ARM (hard float) SMP

 This package provides the kernel debug image for version 5.4.0 on
 ARM (hard float) SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-image-unsigned-5.4.0-37-generic: No summary available for linux-image-unsigned-5.4.0-37-generic in ubuntu groovy.

No description available for linux-image-unsigned-5.4.0-37-generic in ubuntu groovy.

linux-image-unsigned-5.4.0-37-generic-dbgsym: No summary available for linux-image-unsigned-5.4.0-37-generic-dbgsym in ubuntu groovy.

No description available for linux-image-unsigned-5.4.0-37-generic-dbgsym in ubuntu groovy.

linux-image-unsigned-5.4.0-37-lowlatency: No summary available for linux-image-unsigned-5.4.0-37-lowlatency in ubuntu groovy.

No description available for linux-image-unsigned-5.4.0-37-lowlatency in ubuntu groovy.

linux-image-unsigned-5.4.0-37-lowlatency-dbgsym: Linux kernel debug image for version 5.4.0 on 64 bit x86 SMP

 This package provides the unsigned kernel debug image for version 5.4.0 on
 64 bit x86 SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-libc-dev: Linux Kernel Headers for development

 This package provides headers from the Linux kernel. These headers
 are used by the installed headers for GNU glibc and other system
 libraries. They are NOT meant to be used to build third-party modules for
 your kernel. Use linux-headers-* packages for that.

linux-modules-5.4.0-37-generic: No summary available for linux-modules-5.4.0-37-generic in ubuntu groovy.

No description available for linux-modules-5.4.0-37-generic in ubuntu groovy.

linux-modules-5.4.0-37-generic-lpae: Linux kernel extra modules for version 5.4.0 on ARM (hard float) SMP

 Contains the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Generic LPAE processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-generic-lpae meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-modules-5.4.0-37-lowlatency: Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP

 Contains the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Lowlatency processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-lowlatency meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-modules-extra-5.4.0-37-generic: Linux kernel extra modules for version 5.4.0 on ARMv8 SMP

 This package contains the Linux kernel extra modules for version 5.4.0 on
 ARMv8 SMP.
 .
 Also includes the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Generic processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-generic meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-source-5.4.0: Linux kernel source for version 5.4.0 with Ubuntu patches

 This package provides the source code for the Linux kernel version
 5.4.0.
 .
 This package is mainly meant for other packages to use, in order to build
 custom flavours.
 .
 If you wish to use this package to create a custom Linux kernel, then it
 is suggested that you investigate the package kernel-package, which has
 been designed to ease the task of creating kernel image packages.
 .
 If you are simply trying to build third-party modules for your kernel,
 you do not want this package. Install the appropriate linux-headers
 package instead.

linux-tools-5.4.0-37: Linux kernel version specific tools for version 5.4.0-37

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 5.4.0-37 on
 ARMv8.
 You probably want to install linux-tools-5.4.0-37-<flavour>.

linux-tools-5.4.0-37-generic: Linux kernel version specific tools for version 5.4.0-37

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 5.4.0-37 on
 ARMv8.

linux-tools-5.4.0-37-generic-lpae: No summary available for linux-tools-5.4.0-37-generic-lpae in ubuntu groovy.

No description available for linux-tools-5.4.0-37-generic-lpae in ubuntu groovy.

linux-tools-5.4.0-37-lowlatency: Linux kernel version specific tools for version 5.4.0-37

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 5.4.0-37 on
 64 bit x86.

linux-tools-common: Linux kernel version specific tools for version 5.4.0

 This package provides the architecture independent parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 5.4.0.

linux-tools-host: Linux kernel VM host tools

 This package provides kernel tools useful for VM hosts.

linux-udebs-generic: Metapackage depending on kernel udebs

 This package depends on the all udebs that the kernel build generated,
 for easier version and migration tracking.

linux-udebs-generic-lpae: Metapackage depending on kernel udebs

 This package depends on the all udebs that the kernel build generated,
 for easier version and migration tracking.

md-modules-5.4.0-37-generic-di: Multi-device support (raid, device-mapper, lvm)
md-modules-5.4.0-37-generic-lpae-di: No summary available for md-modules-5.4.0-37-generic-lpae-di in ubuntu groovy.

No description available for md-modules-5.4.0-37-generic-lpae-di in ubuntu groovy.

message-modules-5.4.0-37-generic-di: Fusion and i2o storage modules

 This package containes the fusion and i2o storage modules.

mouse-modules-5.4.0-37-generic-di: No summary available for mouse-modules-5.4.0-37-generic-di in ubuntu groovy.

No description available for mouse-modules-5.4.0-37-generic-di in ubuntu groovy.

mouse-modules-5.4.0-37-generic-lpae-di: No summary available for mouse-modules-5.4.0-37-generic-lpae-di in ubuntu groovy.

No description available for mouse-modules-5.4.0-37-generic-lpae-di in ubuntu groovy.

multipath-modules-5.4.0-37-generic-di: DM-Multipath support

  This package contains modules for device-mapper multipath support.

multipath-modules-5.4.0-37-generic-lpae-di: DM-Multipath support

  This package contains modules for device-mapper multipath support.

nfs-modules-5.4.0-37-generic-di: NFS filesystem drivers

 Includes the NFS client driver, and supporting modules.

nfs-modules-5.4.0-37-generic-lpae-di: NFS filesystem drivers

 Includes the NFS client driver, and supporting modules.

nic-modules-5.4.0-37-generic-di: Network interface support
nic-modules-5.4.0-37-generic-lpae-di: Network interface support
nic-pcmcia-modules-5.4.0-37-generic-di: No summary available for nic-pcmcia-modules-5.4.0-37-generic-di in ubuntu groovy.

No description available for nic-pcmcia-modules-5.4.0-37-generic-di in ubuntu groovy.

nic-shared-modules-5.4.0-37-generic-di: nic shared modules

  This package contains modules which support nic modules

nic-shared-modules-5.4.0-37-generic-lpae-di: nic shared modules

  This package contains modules which support nic modules

nic-usb-modules-5.4.0-37-generic-di: USB network interface support
nic-usb-modules-5.4.0-37-generic-lpae-di: USB network interface support
parport-modules-5.4.0-37-generic-di: No summary available for parport-modules-5.4.0-37-generic-di in ubuntu groovy.

No description available for parport-modules-5.4.0-37-generic-di in ubuntu groovy.

parport-modules-5.4.0-37-generic-lpae-di: Parallel port support
pata-modules-5.4.0-37-generic-di: PATA support modules
pcmcia-modules-5.4.0-37-generic-di: PCMCIA Modules
pcmcia-storage-modules-5.4.0-37-generic-di: PCMCIA storage support
plip-modules-5.4.0-37-generic-di: PLIP (parallel port) networking support
plip-modules-5.4.0-37-generic-lpae-di: PLIP (parallel port) networking support
ppp-modules-5.4.0-37-generic-di: PPP (serial port) networking support
ppp-modules-5.4.0-37-generic-lpae-di: No summary available for ppp-modules-5.4.0-37-generic-lpae-di in ubuntu groovy.

No description available for ppp-modules-5.4.0-37-generic-lpae-di in ubuntu groovy.

sata-modules-5.4.0-37-generic-di: SATA storage support
sata-modules-5.4.0-37-generic-lpae-di: SATA storage support
scsi-modules-5.4.0-37-generic-di: SCSI storage support
scsi-modules-5.4.0-37-generic-lpae-di: No summary available for scsi-modules-5.4.0-37-generic-lpae-di in ubuntu groovy.

No description available for scsi-modules-5.4.0-37-generic-lpae-di in ubuntu groovy.

serial-modules-5.4.0-37-generic-di: No summary available for serial-modules-5.4.0-37-generic-di in ubuntu groovy.

No description available for serial-modules-5.4.0-37-generic-di in ubuntu groovy.

storage-core-modules-5.4.0-37-generic-di: Core storage support

 Includes core SCSI, LibATA, USB-Storage. Also includes related block
 devices for CD, Disk and Tape medium (and IDE Floppy).

storage-core-modules-5.4.0-37-generic-lpae-di: Core storage support

 Includes core SCSI, LibATA, USB-Storage. Also includes related block
 devices for CD, Disk and Tape medium (and IDE Floppy).

usb-modules-5.4.0-37-generic-di: Core USB support
usb-modules-5.4.0-37-generic-lpae-di: Core USB support
virtio-modules-5.4.0-37-generic-di: VirtIO Modules

 Includes modules for VirtIO (virtual machine, generally kvm guests)

vlan-modules-5.4.0-37-generic-di: vlan modules

 This package contains vlan (8021.Q) modules.

vlan-modules-5.4.0-37-generic-lpae-di: No summary available for vlan-modules-5.4.0-37-generic-lpae-di in ubuntu groovy.

No description available for vlan-modules-5.4.0-37-generic-lpae-di in ubuntu groovy.