Change log for lirc package in Ubuntu

174 of 74 results
Superseded in disco-release on 2018-11-09
Deleted in disco-proposed on 2018-11-10 (Reason: moved to release)
lirc (0.10.0-2build1) disco; urgency=medium

  * No-change rebuild to build for python3.7 as the default.

 -- Matthias Klose <email address hidden>  Wed, 31 Oct 2018 15:20:09 +0000
Published in disco-release on 2018-11-09
Deleted in disco-proposed (Reason: moved to release)
lirc (0.10.1-3) unstable; urgency=medium

  * Remove links created in postinst, closes: #911548.
  * Add missing Recommends: systemd.
  * Fix insecure URIs in d/control vcs-git: and d/copyright Format:.
  * Add rudimentary upstream/metadata.

 -- Alec Leamas <email address hidden>  Thu, 25 Oct 2018 13:05:49 -0400
Superseded in disco-release on 2018-10-31
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-08-17
Deleted in artful-proposed (Reason: moved to release)
lirc (0.10.0-2) unstable; urgency=medium

  * Fixed missing media/lirc.h, closes: #872074
  * Fixed VCS browser path
  * Fixed upstream bug #294 (VPATH build issues, in -1).
  * Fixed upstream bug #295  - lircmd non-existing socket writes, in -1.

 -- Alec Leamas <email address hidden>  Sun, 13 Aug 2017 09:45:34 +0200

Available diffs

Superseded in artful-release on 2017-08-17
Deleted in artful-proposed on 2017-08-18 (Reason: moved to release)
lirc (0.10.0-1) unstable; urgency=medium

  * New upstream release
  * Upload to unstable
  * Bump std-version to 4.0.1
  * Drop dh-autoreconf, useless with compat level 10

 -- Alec Leamas <email address hidden>  Sat, 12 Aug 2017 06:34:57 +0200

Available diffs

Superseded in artful-release on 2017-08-12
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
lirc (0.9.4c-9) unstable; urgency=medium

  * Fix missing systemd socket activation (Closes: #859491).
  * Fix package purge (Closes: #852118).

 -- Alec Leamas <email address hidden>  Thu, 06 Apr 2017 05:23:20 +0200

Available diffs

Superseded in zesty-release on 2017-04-08
Deleted in zesty-proposed on 2017-04-09 (Reason: moved to release)
lirc (0.9.4c-8) unstable; urgency=medium

  * Fix missinng deps for lirc-setup (Closes: #858144).

 -- Alec Leamas <email address hidden>  Tue, 21 Mar 2017 17:50:54 +0100

Available diffs

Superseded in zesty-release on 2017-03-27
Deleted in zesty-proposed on 2017-04-07 (Reason: moved to release)
lirc (0.9.4c-7) unstable; urgency=medium

  * Fix lirc_options.conf upgrade regression in 0.9.4c-6
  * Actually add the hurd build patch missing in 0.9.4c-6
  * Fix segfault on SET_INPUTLOG socket command (upstream #252).
  * Fix bad handling of ircat --config options (upstream #251).

 -- Alec Leamas <email address hidden>  Thu, 05 Jan 2017 00:05:35 +0100

Available diffs

Superseded in zesty-release on 2017-01-05
Deleted in zesty-proposed on 2017-01-07 (Reason: moved to release)
lirc (0.9.4c-6) unstable; urgency=medium

  * Fix unsecure permissions for /run/lirc. Closes: #848135
  * Fix missing config.h header (Upstream #250).
  * Fix HURD build (Closes: #845499)
    - Fix from Samuel Thibault
  * Add missing Suggests: for lirc-compat-remotes.
  * Fix --listen option parsing bug (upstream #249).
  * Fix bad update handling of lirc_options.conf (Closes: #849266).

 -- Alec Leamas <email address hidden>  Tue, 20 Dec 2016 12:36:19 +0100

Available diffs

Superseded in zesty-release on 2017-01-05
Deleted in zesty-proposed on 2017-01-06 (Reason: moved to release)
lirc (0.9.4c-5) unstable; urgency=medium

  * Team upload.
  * Updated README.debian, new package lirc-compat-remotes info.
  * Added patch for missing lircd-setup.service file.
  * Removed work-around for nowadays fixed  #801719.
  * Added fix for remove --purge not purging all files.
  * lirc-old2new fixes for default device.
  * Fixed to build on freebsd platforms.

 -- Alec Leamas <email address hidden>  Wed, 02 Nov 2016 19:36:19 +0100

Available diffs

Superseded in zesty-release on 2016-12-13
Deleted in zesty-proposed on 2016-12-14 (Reason: moved to release)
lirc (0.9.4c-4) unstable; urgency=low

  * Team upload.
  * Upload to unstable.
  * Resolves (new bugs) LP: #1636355, LP: #1636353
  * Resolves (old bugs) LP: #1497266, LP: #1565070, LP: #1395570, 
    LP: #1393056, LP: #1310508, LP: #1203483, LP: #1438381,

 -- Alec Leamas <email address hidden>  Fri, 28 Oct 2016 15:46:34 +0200

Available diffs

Superseded in zesty-release on 2016-11-01
Deleted in zesty-proposed on 2016-11-02 (Reason: moved to release)
lirc (0.9.4c-3) experimental; urgency=medium

  * debian/control: Fix bad upgrade paths.
  * Fix bad library specification in lirc.pc (#236)

 -- Alec Leamas <email address hidden>  Tue, 25 Oct 2016 21:46:06 +0200
Superseded in zesty-release on 2016-10-26
Deleted in zesty-proposed on 2016-11-01 (Reason: moved to release)
lirc (0.9.4c-2ubuntu1) zesty; urgency=medium

  * Fix typo preventing smooth upgrades

Superseded in zesty-release on 2016-10-26
Deleted in zesty-proposed on 2016-11-01 (Reason: moved to release)
lirc (0.9.4c-1) experimental; urgency=medium

  * New upstream release.
  * New tool irtext2udp.
  * Resolves build errors on kernels > 4.8.0A.
  * Most of patches upstreamed.

 -- Alec Leamas <email address hidden>  Sat, 22 Oct 2016 14:52:05 +0200
Superseded in zesty-proposed on 2016-10-24
lirc (0.9.4b-0.3) experimental; urgency=medium

  * Non-maintainer upload.

  [ Gianfranco Costamagna ]
  * fix arch:all build.

  [ Alec Leamas ]
  * Fix build errors on non-linux kernels.
    (conditionalize udev dependency)

 -- Gianfranco Costamagna <email address hidden>  Wed, 05 Oct 2016 19:30:47 +0200
Superseded in zesty-release on 2016-10-25
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2016-01-28
Deleted in xenial-proposed (Reason: moved to release)
lirc (0.9.0-0ubuntu6) xenial; urgency=medium

  * Multiarchify the library packages.

 -- Matthias Klose <email address hidden>  Thu, 28 Jan 2016 02:21:14 +0100

Available diffs

Superseded in xenial-release on 2016-01-28
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2014-03-16
Deleted in trusty-proposed (Reason: moved to release)
lirc (0.9.0-0ubuntu5) trusty; urgency=medium

  * debian/lirc.postinst, debian/lirc.templates, debian/po: drop a number of
    debconf templates that are no longer being prompted for at all due to
    the dropping of the lirc-modules-source package and the lirc.config some
    time ago.
  * debian/lirc.postinst: clean up the remaining debconf handling to not
    override settings in /etc/lirc/hardware.conf.
  * debian/lirc.postinst: drop code for removing /var/log/lircd, which has
    been gone for more than a decade.
  * fix blacklist handling, which creates files not used by modprobe, and
    doesn't put all the contents in a single file.
  * drop obsolete Ubuntu migration code that dates from jaunty and lucid.
  * fix a bug that causes transmitter device/driver settings to always be
    cleared on config change.
  * Adjust lircd handling for multiple devices so that events for all of
    them will appear on /dev/lircd as intended.  Thanks to Joel Ebel for
    the patch.  LP: #697999.
  * Use /run/lirc, the canonical name for /var/run/lirc.  LP: #474701.
  * Fix the init script to not report failures when stopping an
    already-stopped daemon.
 -- Steve Langasek <email address hidden>   Sun, 16 Mar 2014 05:35:47 -0700

Available diffs

Superseded in trusty-release on 2014-03-16
Deleted in trusty-proposed on 2014-03-17 (Reason: moved to release)
lirc (0.9.0-0ubuntu4) trusty; urgency=medium

  * Use dh-autoreconf for current libtool.
 -- Steve Langasek <email address hidden>   Sun, 15 Dec 2013 16:15:06 -0800

Available diffs

Superseded in trusty-release on 2013-12-16
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
lirc (0.9.0-0ubuntu3) quantal; urgency=low

  * Add an option to prevent disabling in-kernel IR device support while lirc
    is running (LP: #1038371)
 -- Joel Ebel <email address hidden>   Mon, 17 Sep 2012 12:02:34 -0400

Available diffs

Superseded in quantal-release on 2012-09-17
lirc (0.9.0-0ubuntu2) quantal; urgency=low

  * Fix path to modules in lirc.postinst (LP: #1004239)
 -- Joel Ebel <email address hidden>   Wed, 08 Aug 2012 01:28:48 -0400

Available diffs

Obsolete in natty-proposed on 2013-06-04
lirc (0.8.7-0ubuntu4.2) natty-proposed; urgency=low

  * debian/control:
    - Make lirc-modules-source a transitional package
  * debian/lirc-modules-source.*
    - Remove. (LP: #778026)
 -- Mario Limonciello <email address hidden>   Thu, 05 May 2011 14:59:30 -0500
Superseded in quantal-release on 2012-08-20
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
lirc (0.9.0-0ubuntu1) oneiric; urgency=low

  * New upstream version (0.9.0)
  * Drop lirc-modules-source (LP: #778026)
  * Change to v3 package (quilt)
  * debian/control:
    - Build-deps on newer debhelper
    - bump standards version.
  * debian/compat:
    - Bump to 7
  * Drop Patches:
    - debian/patches/13-warning-cleanup
    - debian/patches/define_current_cpu_data.patch
    - debian/patches/lirc-in-kernel-ioctls.patch
    - debian/patches/updated-driver-names.patch
  * Move extra remotes to our remotes DB.
  * debian/rules:
    - Remove references to quilt (as it's source package that does it now)
    - remove deprecated dh_clean -k
 -- Mario Limonciello <email address hidden>   Thu, 05 May 2011 14:45:59 -0500

Available diffs

Obsolete in natty-updates on 2013-06-04
Superseded in oneiric-release on 2011-05-05
Deleted in natty-proposed on 2013-06-04 (Reason: moved to -updates)
lirc (0.8.7-0ubuntu4.1) natty-proposed; urgency=low

  [ Ernst Sjöstrand ]
  * For disabling other protocols, adjust to the new location in 2.6.37.
    (LP: #698208)
 -- Mario Limonciello <email address hidden>   Mon, 25 Apr 2011 12:52:38 -0500

Available diffs

Superseded in oneiric-release on 2011-05-02
Obsolete in natty-release on 2013-06-04
lirc (0.8.7-0ubuntu4) natty; urgency=low

  [Ernst Sjöstrand]
  * update init script for /sys change in natty kernels (LP: #698208)
 -- Scott Moser <email address hidden>   Fri, 18 Mar 2011 16:26:14 -0400

Available diffs

Superseded in natty-release on 2011-03-24
lirc (0.8.7-0ubuntu3) natty; urgency=low

  * debian/patches/define_current_cpu_data.patch: fix undeclared
    current_cpu_data in lirc-modules-source (LP: #726182)
 -- BeeHock Goh <email address hidden>   Mon, 13 Mar 2011 17:37:25 +0100

Available diffs

Superseded in natty-release on 2011-03-14
lirc (0.8.7-0ubuntu2) natty; urgency=low

  * configure for devinput should show contents of /dev/input/by-id
    (LP: #695767)
 -- BeeHock Goh <email address hidden>   Thu, 03 Mar 2011 17:37:25 +0100

Available diffs

Superseded in natty-release on 2011-03-03
lirc (0.8.7-0ubuntu1) natty; urgency=low

  * Use 0.8.7 final version
 -- Robert Ancell <email address hidden>   Tue, 18 Jan 2011 11:42:19 +1100
Superseded in natty-release on 2011-01-18
lirc (0.8.7~pre3-0ubuntu2) natty; urgency=low

  * No-change upload to reduce changelogs.
 -- Martin Pitt <email address hidden>   Mon, 13 Dec 2010 12:47:14 +0100
Obsolete in lucid-updates on 2016-10-26
Deleted in lucid-proposed on 2016-11-01 (Reason: moved to -updates)
lirc (0.8.6-0ubuntu4.2) lucid-proposed; urgency=low

  * Fix bug where remote button presses are passed to uinput to be handled as
    standard key presses in X, but are ignored until lircd is stopped or
    restarted (LP: #567512).
    - debian/patches/uinput-send-syn.patch: Apply upstream patch
      d987ce9c68239f637dddb9de9f9668f6e8f9fc1d to restore passing of events to
      uinput.
 -- Jonathan Clarke <email address hidden>   Wed, 08 Sep 2010 07:57:50 +0200
Superseded in natty-release on 2010-12-13
Obsolete in maverick-release on 2013-03-05
lirc (0.8.7~pre3-0ubuntu1) maverick; urgency=low

  * Update to 0.8.7~pre3 snapshot.
  * Update lirc postinst to reference the right directory when unloading modules.
  * Don't show init script errors if no remote is plugged in.
  * Refresh lirc-in-kernel-ioctls.patch. (LP: #600739)
  * Build-depends on portaudio19-dev (LP: #567556)
 -- Mario Limonciello <email address hidden>   Sat, 04 Sep 2010 18:38:49 -0500
Superseded in maverick-release on 2010-09-05
lirc (0.8.7~pre2-0ubuntu1) maverick; urgency=low

  * Update to 0.8.7~pre2
    - Fixes issues with lirc on maverick. (LP: #620498)
  * Add lirc-in-kernel-ioctls.patch to use ioctls from the kernel for drivers.
  * Drop patches upstream now:
    - debian/patches/appleir_repeat_issue.patch
    - debian/patches/hauppauge-tv-card.patch
    - debian/patches/lirc-i2c-2.6.patch
    - debian/patches/lirc_dev-2.6.33.patch
  * Add updated-driver-names.patch
  * Refresh patches:
    - debian/patches/02_Makefile.in
    - debian/patches/13-warning-cleanup
  * Update extra transmitter and remote databases to not reference atiusb.
  * debian/control:
    - Update branches to be owned by ~mythbuntu-dev
  * Disable in-kernel-support when starting lircd, and re-enable when
    stopping.
 -- Mario Limonciello <email address hidden>   Fri, 02 Apr 2010 15:06:19 -0500
Superseded in lucid-updates on 2011-01-25
Deleted in lucid-proposed on 2011-01-26 (Reason: moved to -updates)
lirc (0.8.6-0ubuntu4.1) lucid-proposed; urgency=low

  * Add hauppauge-tv-card.patch to fix detection of Hauppauge TV Card as
    Leadtek IR (LP: #550369)
 -- Benjamin Drung <email address hidden>   Sun, 09 May 2010 00:00:50 +0200
Superseded in maverick-release on 2010-08-19
lirc (0.8.6-0ubuntu5) maverick; urgency=low

  * Add hauppauge-tv-card.patch to fix detection of Hauppauge TV Card as
    Leadtek IR (LP: #550369)
 -- Benjamin Drung <email address hidden>   Sat, 08 May 2010 23:59:53 +0200

Available diffs

Superseded in maverick-release on 2010-05-08
Obsolete in lucid-release on 2016-10-26
lirc (0.8.6-0ubuntu4) lucid; urgency=low

  [ Mario Limonciello ]
  * debian/patches/lirc-i2c-2.6.patch:
    - Fixes building lirc-i2c on kernel 2.6.32 (LP: #513042)
  * Enable building wpc8769l module.  Thanks Greg Vickers. (LP: #508266)
  * debian/patches/lirc_dev-2.6.33.patch:
    - Fixes lirc_dev to work with 2.6.33 as well.  Useful for people who use
      the kernel mainline PPA. (LP: #529514)
    - Thanks RK & MarkRandolph.
  * debian/patches/appleir_repeat_issue.patch:
    - Fix apple IR key repeat issue by backporting patch from LIRC CVS.
      (LP: #440466)
    - Thanks Chase Douglas for sharing this patch.

  [ Jeremy Yoder ]
  * Fix /regression in /etc/init.d/lirc where if both REMOTE and TRANSMITTER
    are selected the symlinks /dev/lircd and /dev/lircd1 both point to
    /var/run/lirc/lircd.
  * Fix related bug where if the user sets TRANSMITTER_SOCKET in hardware.conf
    a "1" is appended even though it doesn't need to be.
 -- Mario Limonciello <email address hidden>   Sun, 28 Mar 2010 00:12:34 -0500

Available diffs

Superseded in lucid-release on 2010-03-28
lirc (0.8.6-0ubuntu3) lucid; urgency=low

  * rebuild rest of main for armel armv7/thumb2 optimization;
    UbuntuSpec:mobile-lucid-arm-gcc-v7-thumb2
 -- Alexander Sack <email address hidden>   Sun, 07 Mar 2010 00:56:06 +0100

Available diffs

Superseded in lucid-release on 2010-03-07
Obsolete in karmic-release on 2013-03-04
lirc (0.8.6-0ubuntu2) karmic; urgency=low

  [ Jean-Yves Avenard ]
  * Add Antec Veris RM100 and RM200 to list of available remotes [LP # 453693]

 -- Jean-Yves Avenard <email address hidden>   Sat, 17 Oct 2009 14:53:03 +1100

Available diffs

Superseded in karmic-release on 2009-10-17
lirc (0.8.6-0ubuntu1) karmic; urgency=low

  [ Jeremy Yoder ]
  * Update to LIRC 0.8.6 release. (LP: #432678)
    - added support for ENE KB3926 revision B/C/D (ENE0100) CIR port
      (found on some notebooks, e.g: Acer Aspire 5720G, HP Pavilion dv5)
      (Maxim Levitsky)
    - New parameter for lircd: --repeat-max
    - merged 1st-gen mceusb device support into lirc_mceusb2,
      renamed lirc_mceusb2 to lirc_mceusb
    - added support for putting iMON receviers into MCE/RC6 mode
    - added input subsystem mouse device support to iMON driver
    - improved iMON driver to handle dual-interface iMON devices
      via a single lirc device, reducing configuration complexity
    - added support for more iMON devices, including proper support
      for touchscreen iMON devices (Rene Harder)
    - improved iMON driver including touchscreen support
    - Linux input support added to lircmd
    - added support for IT8720 CIR port
    - added support for XMP protocol
  * Cleanup more_remotes.hwdb
  * TODO:  Make changes to the "lircd.conf.atiusb" and
    "lircd.conf.hauppauge" files PATCHES instead of duplicates
  * TODO:  Submit "lircd.conf.atiusb" and
    "lircd.conf.hauppauge" file patches upstream again
  * Changed lirc init script to create socket in /var/run/lirc/lircd
    as is the new default, but also create a symlink /dev/lircd
    to point to it.  This makes all clients happy, old and new.
  * Fix bug in dkms.conf.in, forgot to increment array number
    when adding ene0100 driver.
  * Added the extra "Debian-only" remotes and transmitters back
    in, but in a different way.  I created a subdirectory
    "debian/extras" and copy that to /usr/share/lirc/extras.
    This avoids patching the source.
    NOTE: CONFIG FILES IN BOTH LOCATIONS WILL USE THE "extras"
    VERSION.  DUPLICATE LINES IN lirc.hwdb AND extras/remotes.hwdb
    WILL USE THE extras/remotes.hwdb VERSION.  TRY TO AVOID THIS.
  * Added support to build new ene0100 driver
  * Update debian/lircd.init.d to reflect new default
    PID location in /var/run/lirc
  * Update debian/lircd.init.d to force socket to /dev/lircd
    rather than the new default of /var/run/lirc/lircd
  * Add support for new lirc-extras package to
    debian/lirc.postinst
  * Remove /etc/lircd.conf link to /etc/lirc since
    0.8.6 defaults to /etc/lirc/lircd.conf now
  * Drop 04_man_pages patch, included in upstream
  * Drop 16_lirc-gpio in favor of a sed line in debian/rules
  * Drop 28_irrecord_resume_support - Doesn't work
    according to upstream
  * Drop 36_remove_extra_tekram in favor of a minor
    tweak to debian/lirc.postinst to ignore duplicates
  * Drop extra remote control/transmitter patches, move to lirc-extras:
    - 21_atiusb
    - 22_hauppauge_novat_500
    - 23_remove_md8800
    - 24_freecom_dvbt
    - 26_transmitter_lircd.conf
    - 30_medion_md1_remote
    - 31_hauppauge_hvr_1100
    - 32_radioshack_15_2116_remote
    - 33_asus_mycinema_remote
    - 34_nebula_digitaltv_remote
    - 35_general_deviniput
    - 37_msi_tv_anywhere
    - 38_encore_enltv
  * Cleaned up a few lintian warnings

  [ Mario Limonciello ]
  * lirc.init.d:
    - Merge a bunch of whitespace cleanup from debian.
  * control:
    - Merge whitespace cleanup from debian.
    - Drop breaks on udev.  We don't have any older version of udev in karmic.
  * copyright:
    - Sync from debian.
  * watch:
    - Sync from debian.
  * links:
    - Don't link to a transmitterdb, this should be provided by lirc-extras.
  * rules:
    - Install extra changelog, as mentioned in debian's debian/rules.
  * dkms.conf.in:
    - Drop bashisms. (LP: #445175)
  * lirc.postinst:
    - On upgrades from earlier versions, require the user to reconfigure
      their remote and transmitter.
  * lirc-modules-source.postinst:
    - Update to use the DKMS common postinst template.

 -- Mario Limonciello <email address hidden>   Mon, 12 Oct 2009 21:16:10 -0500

Available diffs

Superseded in karmic-release on 2009-10-13
lirc (0.8.5-0ubuntu3) karmic; urgency=low

  * Fix bug in init script.  Thanks Olaf! (LP: #391726)

 -- Mario Limonciello <email address hidden>   Wed, 24 Jun 2009 19:42:45 -0500

Available diffs

Superseded in karmic-release on 2009-06-25
lirc (0.8.5-0ubuntu2) karmic; urgency=low

  * Drop patch that upstream won't be accepting:
    - 20_serial_igor
  * Drop patches included upstream:
    - 23_pad2keys (see http://brakemeier.de/electronics/vdr/lirc-imon.html
      2009-04-10 entry for more information)
  * debian/lirc.postinst:
    - Drop serial igor references.
  * Refresh following patches:
    - 32_radioshack_15_2116_remote

 -- Mario Limonciello <email address hidden>   Tue, 23 Jun 2009 00:40:09 -0500

Available diffs

Superseded in karmic-release on 2009-06-23
lirc (0.8.5-0ubuntu1) karmic; urgency=low

  * New upstream version. (LP: #383446)
    - Fixes imon support (LP: #283317)
  * Refresh the following patches for new version:
    - debian/patches/04_man_pages
    - debian/patches/13-warning-cleanup
    - debian/patches/21_atiusb
    - debian/patches/23_pad2keys
    - debian/patches/28_irrecord_resume_support
    - debian/patches/35_general_deviniput
  * debian/control:
    - Add build-depends on libftdi-dev to prevent FTBFS.
  * debian/copyright:
    - Update to what debian is shipping.
  * debian/modules-source/{lirc-modules-source.conf, Makefile}
    - Don't build cmdir anymore.  It's now a userspace module
  * debian/rules:
    - Generate dkms.conf using sed instead.
  * debian/patches/12_pvr150_transmit_support:
    - Drop.  Upstream didn't like this patch due to questionable
     copyright, and we aren't properly supporting it anyway.
    - Refresh 20_serial_igor
    - Refresh 26_transmitter_lircd
  * debian/lirc-modules-source.README.Debian:
    - Drop, inaccurate now.
  * debian/lirc.init.d:
    - Cleanup a useless for loop.

 -- Mario Limonciello <email address hidden>   Thu, 18 Jun 2009 01:48:20 -0500

Available diffs

Superseded in karmic-release on 2009-06-18
Obsolete in jaunty-release on 2013-02-28
lirc (0.8.4a-0ubuntu5) jaunty; urgency=low

  * When in noninteractive mode, don't set the old and new remotes
    or transmitters identically.  Causes out of sync issues when changing
    remotes. (LP: #281575)

 -- Mario Limonciello <email address hidden>   Fri, 17 Apr 2009 01:32:01 -0500

Available diffs

Superseded in jaunty-release on 2009-04-20
lirc (0.8.4a-0ubuntu4) jaunty; urgency=low

  [ Mario Limonciello ]
  * debian/lirc.fdi:
    - Add Budget-CI dvb ir receiver. (LP: #329793)
  * debian/control:
    - Add setserial to depends. (LP: #341213)
  * debian/lirc.init.d:
    - Remove erroneous -k from modprobe call. (LP: #344781)
  * debian/lirc-modules-source.postrm:
    - Remove extra purge call removing lirc-modules-source.conf (LP: #350152)
  * debian/lirc.postinst:
    - Rename etc/modprobe.d/lirc-serial to append a .conf (LP: #350949)

  [ Kenny Millington ]
  * debian/patches/12_pvr150_transmit_support:
    - Fix compilation for latest kernels (LP: #306346)

  [ Gregory Lardiere ]
  * Add support for ite8709 and ttusbir for lirc-modules-source. (LP: #323923)
    - debian/rules
    - debian/modules-source/Makefile
    - debian/modules-source/lirc-modules-source.conf

 -- Mario Limonciello <email address hidden>   Mon, 30 Mar 2009 23:49:41 -0500
Superseded in jaunty-release on 2009-03-31
lirc (0.8.4a-0ubuntu3) jaunty; urgency=low

  * debian/udev.rules: Rename to debian/lirc.udev
  * debian/rules: Use dh_installudev rules to install
  * debian/lirc.install: Remove install line for udev rules
  * debian/control: Bump dep on debhelper to install to new path, add Breaks
    on udev to ensure we get the correct version

 -- Scott James Remnant <email address hidden>   Mon, 12 Jan 2009 20:39:34 +0000
Obsolete in intrepid-backports on 2013-02-20
lirc (0.8.4a-0ubuntu2~intrepid1) intrepid-backports; urgency=low

  * Automated backport upload; no source changes.

Superseded in jaunty-release on 2009-01-12
lirc (0.8.4a-0ubuntu2) jaunty; urgency=low

  * debian/lirc.postinst:
    - Properly quote includes.  The syntax of the include patch unfortunately
      changed as it landed upstream.
    - Migrate people from earlier LIRC versions to new include syntax if
      it is detected in their LIRC configuration.

 -- Mario Limonciello <email address hidden>   Wed, 12 Nov 2008 09:51:29 -0600

Available diffs

Superseded in jaunty-release on 2008-11-12
lirc (0.8.4a-0ubuntu1) jaunty; urgency=low

  * New upstream version.
  * Drop no longer necessary patches:
    - 03_extra_files
    - 25_upstream_2.6.27
    - 27_multiple_include
  * Update patches for new version:
    - 12_pvr150_transmit_support
    - 16_lirc_gpio
    - 26_transmitter_lircd.conf
    - 28_irrecord_resume_support
  * New patches:
    - 38_encore_enltv.dpatch (LP: #274087)
  * debian/lirc.fdi:
    - Update FDI file to match a few more remotes reported
      on bugs that work when keyed. (LP: #164627, #204960, #279472)
  * debian/control:
    - Update Recommends for lirc-modules-source
  * debian/lirc.preinst:
    - Remove old calls that will no longer be encountered in package
      upgrades.
  * Merge some packaging changes from Debian.  They hadn't done a
    release in a long time, so this will at least get us closer to their
    packaging for an overarching goal of being in sync.
    - Sync'ed changes:
      + debian/compat
      + README.Debian
      + debian/copyright
      + debian/doc-base.lirc
      + debian/liblircclient-dev.install
      + debian/lirc-modules-source.postrm
      + debian/lirc.postrm
      + debian/po
      + debian/lirc-svga.install
      + debian/lirc-svga.links
      + drop debian/lirc.config.in
      + drop debian/lirc.config.md5sum
      + drop debian/lirc.modules
    - Merge debian/control, remaining changes:
      + We don't share same VCS
      + We recommend udev
      + Our lirc-modules-source uses DKMS
    - Merge debian/rules, remaining changes:
      + DKMS support
    - Merge debian/liblircclient0.pc, remaining changes:
      + Version number we have is higher
    - Merge debian/lirc.install, remaining changes:
      + We install udev rules
      + We install an FDI file
    - Merge debian/lirc.templates, remaining changes:
      + Some of our keys are named differently because we differentiate
        between a remote and a transmitter device.
      + We've got some extra keys for details of devices.
    - Merge debian/lirc.init.d, remaining changes:
      + We've pretty much entirely revamped the file.  Our deltas will
        need to be submitted incrementally to Debian.
    - Merge debian/lirc.postinst, remaining changes:
      + We've pretty much entirely revamped the file.  Our deltas will
        need to be submitted incrementally to Debian.
    - Merge debian/rules, remaining changes:
      + We install a udev rule
      + We install an FDI file
      + We install DKMS support
      + We install transmitter lircd.conf's
      + We Install the remote and transmitter hwdb explicitly
    - Merge patches that we took from debian for 0.8.4 support:
      + debian/patches/02_Makefile.in
      + debian/patches/04_man_pages

Available diffs

Superseded in jaunty-release on 2008-11-09
Obsolete in intrepid-release on 2013-02-20
lirc (0.8.3-0ubuntu2) intrepid; urgency=low

  * debian/patches/25_upstream_2.6.26.patch:
    - Fix lirc-modules-source compilation on 2.6.26 by pulling some
      patches from CVS (LP: #247233)
  * debian/rules:
    - Install original modules back into proper location for
      intrepid kernel (LP: #242216)
  * debian/patches/37_msi_tv_anywhere.dpatch:
    - Create patch for supporting MSI TV @anywhere remote. (LP: #241830)
  * debian/lirc.postinst:
    - Correct path to look for module in Intrepid.
    - Ask for a path when using dvico remotes. (LP: #238032)
    - Don't accidentally overwrite lircd.conf and hardware.conf
      when things haven't really changed at all. (LP: #206609)
  * debian/lirc.init.d:
    - Don't allow udev to put us into endless spinning loops.  Instead
      pray that module hotplugging worked for all things USB. (LP: #269743)
  * debian/lirc.fdi:
    - Include this FDI file to prevent in kernel support for the
      saa7134 when LIRC is installed. (LP: #204960, #164627)
  * debian/rules:
    - Install FDI file.
  * debian/lirc.install:
    - List FDI file.
  * debian/patches/22_hauppauge_novat_500.dpatch:
    - Adapt to include alternative numeric keys. (LP: #224080)
  * debian/patches/25_upstream_2.6.27.dpatch:
    - Update to content that is currently sitting in Ubuntu GIT
      tree.

 -- Mario Limonciello <email address hidden>   Wed, 24 Sep 2008 12:02:17 -0500

Available diffs

Superseded in intrepid-release on 2008-09-24
lirc (0.8.3-0ubuntu1) intrepid; urgency=low

  * New upstream version.
  * Drop 05_fix_cmdir as it's now included in CVS.
  * Update 12_pvr150_transmit_support for configure
    script changes.
  * Update 13-warning-cleanup to change from whitespace
    changes from CVS.
  * Update 16_lirc-gpio for changes from CVS.
  * Update 23_pad2keys for changes from CVS.
  * Update 24_freecom_dvbt for changes from CVS.
  * Drop 25_upstream_2_6_24 as it's now included from CVS.
  * Drop 29_macmini_repeat as it's now included from CVS.
  * Update 30_medion_md1_remote for changes from CVS.
  * Update 33_asus_mycinema_remote for changes from CVS.
  * Update 23_pad2keys patch to properly work (LP: #153184)
  * Update 21_atiusb.dpatch because it's half upstream now (LP: #213549)
  * Add 23_remove_md8800 as the MD8800 remote is causing problems. (LP: #213549)
  * debian/modules-source/lirc-modules-source.conf:
    - Default the mode to be w/ soft carrier. (LP: #182530)
  * Update 31_hauppauge_hvr_1100 to use the right devinput driver instead. (LP: #206495)
  * Add 34_nebula_digitv.dpatch for supporting the Nebula Digitv remote (LP: #164867)
  * Add 35_general_devinput.dpatch for generic devinput devices. (LP: #235811)
  * Add 36_remove_extra_tekram.dpatch for removing extra option in lirc.hwdb.
    This option was causing lots of failures (LP: #211566)
  * debian/{modules-source/Makefile,rules}:
    - Allow the kernel version to be passed as an argument.
      prevents broken upgrades when the kernel ABI revs (LP: #218955)
  * debian/lirc-modules-source.prerm:
    - Check for both remove and upgrade.

 -- Mario Limonciello <email address hidden>   Sat, 10 May 2008 16:07:40 -0500
Obsolete in hardy-updates on 2015-04-24
Deleted in hardy-proposed on 2015-04-30 (Reason: moved to -updates)
lirc (0.8.3~pre1-0ubuntu7.1) hardy-proposed; urgency=low

  * debian/{modules-source/Makefile,rules}:
    - Allow the kernel version to be passed as an argument.
      prevents broken upgrades when the kernel ABI revs (LP: #218955)
  * debian/lirc-modules-source.prerm:
    - Check for both remove and upgrade.

 -- Mario Limonciello <email address hidden>   Wed, 04 Jun 2008 01:48:18 -0500
Superseded in intrepid-release on 2008-06-05
Obsolete in hardy-release on 2015-04-24
lirc (0.8.3~pre1-0ubuntu7) hardy; urgency=low

  [ Mario Limonciello ]
  * Fix a logical error in the init script related
    to udev preventing it from working.  (LP: #176616)
  * Fix race conditions with udev (LP: #204672)
  * Backup hardware.conf before changing. (LP: #198903)
  * Add support for the Medion MD1-NBC remote.  (LP: #192392)
    - Thanks Florian Fahr
  * Add support for the Hauppauge HVR-1100 remote (LP: #203493)
    - Thanks Lucas
  * Flag repeat events on apple mac mini (LP: #179608)
    - Thanks Don Mahurin
  * Add support for Radioshack 15-2116 remote (LP: #193568)
    - Thanks Scott D
  * Add support for ASUS MyCinema P7131 remote (LP: #190018)
    - Thanks Gianfranco Liporace

  [ Mathias Hasselmann ]
  * Add 28_irrecord_resume_support for resume support to
    irrecord. (LP: #197493)

  [ Andrew Barbaccia ]
  * Fix typo in lirc init script preventing transmitter
    arguments from properly being built.  (LP: #204664)
  * Update Scientific Atlanta config in 26_transmitter_lircd.conf.dpatch
    to better naming convention. (LP: #204342)

 -- Mario Limonciello <email address hidden>   Sun, 23 Mar 2008 23:25:36 -0500
Superseded in hardy-release on 2008-03-24
lirc (0.8.3~pre1-0ubuntu6) hardy; urgency=low

  * "Include" proper URL for transmitters in lircd.conf.
  * debian/control:
    - lirc-modules-source depends on dkms.
    - Update standards version to 3.7.3
    - Drop ucf, debianutils, debhelper from lirc-modules-source depends.
    - Update lirc-modules-source description.
  * Update lirc-modules-source behavior to automatically build
    modules using dkms as necessary. (LP: #181871)
  * Drop old lirc-svga stuff.
  * Update 12_pvr150_transmit_support.dpatch with patch from author.

 -- Mario Limonciello <email address hidden>   Sun, 10 Feb 2008 15:04:13 -0600
Superseded in hardy-release on 2008-02-13
lirc (0.8.3~pre1-0ubuntu5) hardy; urgency=low

  * debian/hardware.conf:
    - Add a variable to only force noninteracive reconfiguration
      when requested by user.
  * debian/lirc.postinst:
    - Add support for "Custom" remote type which will not overwrite
      chosen options when reconfiguring (even noninteractively).
  * debian/templates:
    - Add "Custom" remote and transmitter.
  * Update 13_warning_cleanup, 16-lirc-gpio, and 24_freecom_dvbt
    to update lirc.hwdb from extraneous equals signs and information.

 -- Mario Limonciello <email address hidden>   Thu, 03 Jan 2008 11:47:14 -0600
Superseded in hardy-release on 2008-01-07
lirc (0.8.3~pre1-0ubuntu4) hardy; urgency=low

  * Add 25_upstream_2_6_24 to fix lirc_dev,lirc_serial,lirc_sir
    on 2.6.24.
  * Add 26_transmitter_lircd.conf for pre-shipped cable/satellite
    receiver lircd.conf's as well as a transmitter.hwdb
  * Add 27_multiple_include for allowing lircd.conf's via
    an 'include' directive.
  * Update 16_lirc-gpio, 22_hauppauge_novat_500, 24_freecom_dvbt
    for upstream driver name change from dev/input to devinput.
  * Drop 17_devinput since it is no longer necessary due to
    upstream driver name change.
  * Update 12_lirc_pvr150 for 2.6.24.
  * Update 20_lirc_serial_igor for 2.6.24.
  * Update 13-warning-cleanup for more cleanup on sir
  * Update 03_extra_files, 04_manpages, 12_pvr150_transmit_support,
    13-warning-cleanup, 16_lirc-gpio, 20_serial-igor, 21_atiusb,
    22_hauppauge_novat_500, 23_pad2keys, 24_freecom_dvbt
    to give a description of the patches.
  * debian/control:
    - Have lirc depend on setserial, so that lirc.postinst can
      customize things. (LP: #152871)
  * debian/lirc.links:
    - Add symlink from /etc/lirc/lircd.conf -> /etc/lircd.conf
      to prevent confusion for users coming from different distros.
    - Add symlink for transmitter.hwdb to different share directories.
  * debian/hardware.conf
    - Change top level remotes, drivers, etc to be remote specific.
    - Add support for transmitters.
    - Default to having lircd off until the maintainer scripts have
      updated things.
  * debian/lirc.init.d:
    - Reorder checking for hardware.conf, to make sure it occurs earlier.
    - Update init script to use LSB output.
    - Update init script to have the ability to spawn multiple lirc
      processes.
  * Drop devfs.conf and devfs.devices since devfs is no longer used
    in Ubuntu.
  * debian/rules:
    - No longer install devfs.conf and devfs.devices.
    - Install transmitter.hwdb
    - Install usr/share/lirc/transmitters
  * debian/lirc.templates:
    - Add extra templates for our chosen transmitter, device, driver,
      modules, and lircd_conf
    - Update all old device, driver, modules, and lircd_conf templates
      to be for remote only.
    - Remove extra space from remote template.
    - Add template for whether to enable/disable lircd.
    - Add a template for serial port selection (LP: 152871)
  * debian/lirc.postinst:
    - Unload all modules when issuing a reconfigure command.
    - In check_hardware_conf, don't write UNCONFIGURED, just write
      empty quotes to make sure we don't throw things off.
    - In check_hardware_conf, write out all our new modules as
      necessary.
    - In Save & DebconfLoad, read and store all new transmitter
      variables.
    - In ChooseRemote, read old values from hardware.conf rather than
      debconf, since debconf is not designed to be used as a database,
      but rather an intermediatary storage method.
    - In ChooseRemote, add transmitter support.
    - In ChooseRemote, define what lirc device we are using for
      dev/input as described in:
      https://blueprints.launchpad.net/mythbuntu/+spec/lirc-gpio-alternative
    - Remove clause to mv /etc/lircd.conf to /etc/lirc
    - Write out START_LIRCD, depending on whether we have remotes/transmitters
      enabled or disabled.
    - Check for REMOTE_DRIVER entitled 'none' and set it to ''.
    - Write out a lircd.conf with include directives and a description of how
      to update rather than copying the single file over.
    - Add support to customize serial port (LP: #152871)
    - No longer setup modutils (only applicable for kernel 2.4)
  * debian/lirc.preinst:
    - Migrate old hardware.conf over to new syntax in case user does not
      replace it upon package installation.

 -- Mario Limonciello <email address hidden>   Thu, 27 Dec 2007 23:16:40 -0600
Superseded in hardy-release on 2007-12-31
lirc (0.8.3~pre1-0ubuntu3) hardy; urgency=low

  * Fix -x call.

 -- Scott James Remnant <email address hidden>   Fri, 14 Dec 2007 16:53:50 +0000
Superseded in hardy-release on 2007-12-14
lirc (0.8.3~pre1-0ubuntu2) hardy; urgency=low

  * debian/lirc.init.d: call udevadm instead of udevsettle

 -- Scott James Remnant <email address hidden>   Fri, 14 Dec 2007 16:30:11 +0000
Superseded in hardy-release on 2007-12-14
lirc (0.8.3~pre1-0ubuntu1) hardy; urgency=low

  * New upstream version.
    - Includes Iguanaworks IR Support (LP: #153457)
  * Update 03_extrafiles patch for gpio changes.
  * Update 05_fix_cmdir patch for command IR lirc.hwdb update.
  * Update 12_lirc_pvr150 patch for transmitting support under
    kernel 2.6.22.
  * Update 13-warning-cleanup patch for items that were already
    cleaned up upstream.
  * Drop 14_mceusb2 patch since now included upstream.
  * Drop 14_lirc-i2c patch since now included upstream.
  * Drop 15_macmini patch since now included upstream.
  * Update 16_lirc-gpio patch for added changes upstream.
  * Update 17_devinput patch for added changes upstream.
  * Drop 18_irman-fix patch since now included upstream.
  * Drop 19_serial_support patch since now included upstream.
  * Update 20_serial_igor patch for new serial support upstream.
  * Update 22_hauppauge_novat_500 patch for new support upstream.
  * Add 23_pad2keys patch for pad2keys imon support (LP: #153184).
  * Add 24_freecom_dvbt patch for NovaT 500 Remote (LP: #152539).
  * Clean up lintian warning for -$(MAKE).
  * Clean up lintian warning for ${source:Version}.

 -- Mario Limonciello <email address hidden>   Tue, 30 Oct 2007 09:44:55 -0400
Superseded in hardy-release on 2007-10-31
Obsolete in gutsy-release on 2011-09-16
lirc (0.8.2-0ubuntu8) gutsy; urgency=low

  * Add 22_hauppauge_novat_500.dpatch for more complete
    novat-500 support. (LP: #145847)
  * Update 16_lirc-gpio.dpatch to make all lirc_gpio remotes
    use the dev/input interface instead. (LP: #148756)
  * Update 21_atiusb.dpatch to make Snapstream remotes
    have their own item. (LP: #140060)
  * Update 12_pvr150_transmit_support.dpatch to fix a
    m-a related FTBFS. (LP: #147440)

 -- Mario Limonciello <email address hidden>   Mon, 08 Oct 2007 02:35:50 -0500
Superseded in gutsy-release on 2007-10-13
lirc (0.8.2-0ubuntu7) gutsy; urgency=low

  * Be sure to rmmod ati_remote.ko if necessary (LP: #140940)

 -- Mario Limonciello <email address hidden>   Thu, 20 Sep 2007 10:06:20 -0500
Superseded in gutsy-release on 2007-09-20
lirc (0.8.2-0ubuntu6) gutsy; urgency=low

  * Add 20_serial_igor.dpatch for additional serial kernel module
    that is built with Igor Cesko support. (LP: #138247)
  * debian/patches/21_atiusb.dpatch:
    - for support of first generation ATI RF remote. (LP: #139238)
    - snapstream firefly support. (LP: #140060)
  * debian/lirc.postinst, debian/lirc.postrm, debian/lirc.templates:
    - Blacklist lirc_atiusb.ko when necessary (LP: #139961)
  * debian/rules, debian/lirc.preinst:
    - Update the service to start after alsa-utils (LP: #123557)

 -- Mario Limonciello <email address hidden>   Mon, 17 Sep 2007 01:56:54 -0500
Superseded in gutsy-release on 2007-09-18
lirc (0.8.2-0ubuntu5) gutsy; urgency=low

  [ Mario Limonciello ]
  * Add a udev script to automatically reload or stop lirc
    if /dev/lirc[0-9] devices are added/removed.
  * Modify lirc init script to work with udev script.
  * Update 14_lircmceusb2.dpatch to add support for
    HP MCEUSB2 remotes. (LP: #134949)
  * Add 19_serial_support.dpatch from lirc CVS
    to fix broken serial support.
  * debian/control:
    - Add udev to Recommends.
  * debian/lirc.postinst:
    - Add udev reloading.

  [ Tristan Hill ]
  * Fix irman support with dpatch from lirc CVS. (LP: #132011)

 -- Mario Limonciello <email address hidden>   Mon, 27 Aug 2007 21:11:49 -0500
Superseded in gutsy-release on 2007-09-05
lirc (0.8.2-0ubuntu4) gutsy; urgency=low

  * Clarify the intentions of choosing a remote (LP: #129038)
  * Add 17_devinput.dpatch to show correct DEVICE
    in doc/lirc.hwdb.  (LP: #129689)
  * Write out REMOTE="" to lircd.conf as well to allow
    external apps to parse this information.

 -- Mario Limonciello <email address hidden>   Sun, 29 Jul 2007 13:39:17 -0500
Superseded in gutsy-release on 2007-08-10
lirc (0.8.2-0ubuntu3) gutsy; urgency=low

  * Add 14_lirc_i2c.dpatch to fix lirc-i2c on 2.6.22 kernel
    for PVR-150 and HVR-1300. (LP: #128650)
  * Add 15_macmini.dpatch to fix macmini support. (LP: #126955)
  * Add 16_lirc-gpio.dpatch to fix GPIO by backporting deprecated
    functions, until sysfs support is added to GPIO module.
  * debian/lirc.postinst & debian/lirc.templates:
    Add functionality to choose your remote.  Automatically load this
    information into /etc/lirc/hardware.conf and choose a /etc/lirc/lircd.conf
    for your remote. (LP: #65174)

 -- Mario Limonciello <email address hidden>   Thu, 26 Jul 2007 19:47:03 -0700
Superseded in gutsy-release on 2007-07-27
lirc (0.8.2-0ubuntu2) gutsy; urgency=low

  * Make sure lirc_gpio is buildable by adding extra_2.6.22
    to 03_extra_files.dpatch. (LP: #125384)
  * Add 05_fix_cmdir.dpatch from lirc CVS to fix cmdir linking
    issues.
  * Add a symbolic link in case /usr/share/doc/lirc/lirc.hwdb
    is being used.
  * Add 13_warning_cleanup.dpatch to cleanup all compilation warnings
    encountered before submitting to the ubuntu kernel team.

 -- Mario Limonciello <email address hidden>   Wed, 11 Jul 2007 21:18:46 -0500
Superseded in gutsy-release on 2007-07-13
lirc (0.8.2-0ubuntu1) gutsy; urgency=low

  * New upstream version. (LP: #124842)
  * Drop 01_irxevent.dpatch.  Most of it is included upstream now.
  * Update 12_pvr150_transmit_support.dpatch for new configure script.
  * debian/rules:
    - Add lirc.hwdb to lirc binary package.
  * debian/lirc.postinst.
    - Remove all mknods.  This is handled when modprobing.
  * debian/lirc.init.d
    - Add LSB block.

 -- Mario Limonciello <email address hidden>   Sun,  8 Jul 2007 20:55:36 -0500
Superseded in gutsy-release on 2007-07-10
Obsolete in feisty-release on 2009-08-20
lirc (0.8.1+cvs20070310-0ubuntu2) feisty; urgency=low

  [ Mario Limonciello ]
  * Add 12_pvr150_transmit_support.dpatch for pvr-150 ir transmitter
    support (Closes: #95768)
  * debian/lirc-modules-source.templates: add pvr150 module option here.
  * debian/modules-source/Makefile: add pvr150 build options.

  [ Kees Cook ]
  * debian/modules-source/Makefile: don't limit cleaning action, this causes
    rebuilds to fail when a kernel version gets bumped.
  * debian/patches: clean up unused patches.

 -- Kees Cook <email address hidden>   Wed,  4 Apr 2007 11:27:06 -0700
Obsolete in edgy-backports on 2008-06-19
lirc (0.8.1+cvs20070310-0ubuntu1~edgy1) edgy-backports; urgency=low

  * Automated backport upload; no source changes.

Superseded in feisty-release on 2007-04-04
lirc (0.8.1+cvs20070310-0ubuntu1) feisty; urgency=low

  * New upstream release -- required for 2.6.20 kernels.
  * Dropping unneeded patches.

 -- Kees Cook <email address hidden>   Sat, 10 Mar 2007 12:25:58 -0800
Superseded in feisty-release on 2007-03-12
lirc (0.8.0-9ubuntu2) feisty; urgency=low

  * Rebuild for changes in the amd64 toolchain.
  * Set Ubuntu maintainer address.

 -- Matthias Klose <email address hidden>   Mon,  5 Mar 2007 01:22:16 +0000
Obsolete in dapper-backports on 2011-09-06
lirc (0.8.0-9ubuntu1~dapper1) dapper-backports; urgency=low

  * Automated backport upload; no source changes.

Superseded in feisty-release on 2007-03-07
lirc (0.8.0-9ubuntu1) feisty; urgency=low

  * Merge from debian unstable, remaining changes:
    - drop svgalib support

Superseded in feisty-release on 2006-11-28
Obsolete in edgy-release on 2008-06-19
lirc (0.8.0-5ubuntu1) edgy; urgency=low

  * Merge from debian unstable, remaining changes:
    - drop dependency on svgalib.

Superseded in edgy-release on 2006-07-10
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
lirc (0.7.1pre2-11ubuntu1) dapper; urgency=low


  * Resynchronise with Debian.

 -- Michael Vogt <email address hidden>  Fri, 11 Nov 2005 00:15:47 +0100
Obsolete in breezy-release on 2008-03-25
lirc (0.7.0.1-1ubuntu3) breezy; urgency=low


  * Build-Depends: libusb-dev (Bugzilla #14513)
  * GNU config automated update: config.sub (20041130 to 20050422),
    config.guess (20041112 to 20050422)

 -- root <email address hidden>  Tue, 20 Sep 2005 11:01:35 -0700
Obsolete in hoary-release on 2008-03-19
lirc (0.7.0.1-1ubuntu1) hoary; urgency=low


  * remove svgalib1 Dependency completely.

 -- LaMont Jones <email address hidden>  Mon, 17 Jan 2005 14:05:26 -0700
Obsolete in warty-release on 2008-01-09
lirc (0.6.6-7ubuntu2) warty; urgency=low


  * Fix svgalib build-deps the rest of the way.

 -- LaMont Jones <email address hidden>  Thu, 22 Jul 2004 21:49:09 +0000
174 of 74 results