Change log for littler package in Ubuntu

127 of 27 results
Published in focal-release on 2019-11-03
Deleted in focal-proposed (Reason: moved to Release)
littler (0.3.9-1) unstable; urgency=medium

  * New upstream release

 -- Dirk Eddelbuettel <email address hidden>  Mon, 28 Oct 2019 06:16:51 -0500

Available diffs

Superseded in focal-release on 2019-11-03
Published in eoan-release on 2019-08-17
Deleted in eoan-proposed (Reason: moved to release)
littler (0.3.8-2) unstable; urgency=medium

  * Source-only upload
  
  * debian/control: Set Build-Depends: to current R version
  * debian/control: Set Standards-Version: to current version 

 -- Dirk Eddelbuettel <email address hidden>  Fri, 16 Aug 2019 17:06:25 -0500

Available diffs

Superseded in eoan-release on 2019-08-17
Deleted in eoan-proposed on 2019-08-18 (Reason: moved to release)
littler (0.3.8-1) unstable; urgency=medium

  * New upstream release

  * debian/control: Set Build-Depends: to current R version

 -- Dirk Eddelbuettel <email address hidden>  Sun, 09 Jun 2019 13:49:44 -0500

Available diffs

Superseded in eoan-proposed on 2019-06-09
littler (0.3.7-2) unstable; urgency=medium

  * New upstream release

  * debian/control: Set Build-Depends: to current R version

 -- Dirk Eddelbuettel <email address hidden>  Fri, 15 Mar 2019 19:12:12 -0500
Superseded in eoan-release on 2019-08-12
Published in disco-release on 2019-01-28
Deleted in disco-proposed (Reason: moved to release)
littler (0.3.6-1) unstable; urgency=medium

  * New upstream release

  * debian/control: Set Build-Depends: to current R version
  * debian/control: Set Standards-Version: to current version 

 -- Dirk Eddelbuettel <email address hidden>  Sat, 26 Jan 2019 12:26:12 -0600

Available diffs

Superseded in disco-release on 2019-01-28
Deleted in disco-proposed on 2019-01-29 (Reason: moved to release)
littler (0.3.5-1) unstable; urgency=medium

  * New upstream release
  
  * debian/control: Set Standards-Version: to current version 

 -- Dirk Eddelbuettel <email address hidden>  Fri, 05 Oct 2018 21:44:20 -0500

Available diffs

Superseded in disco-release on 2018-11-11
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2017-12-18
Deleted in bionic-proposed (Reason: moved to release)
littler (0.3.3-1) unstable; urgency=medium

  * New upstream release
  
  * debian/control: Set Standards-Version: to current version 
  * debian/control: Set Build-Depends: to current R version 
  * debian/compat: Set level to 9

 -- Dirk Eddelbuettel <email address hidden>  Sun, 17 Dec 2017 15:46:23 -0600

Available diffs

Superseded in bionic-release on 2017-12-18
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed (Reason: moved to release)
littler (0.3.2-1) unstable; urgency=medium

  * New upstream release

  * debian/control: Set Build-Depends: to current R version

 -- Dirk Eddelbuettel <email address hidden>  Wed, 15 Feb 2017 15:33:11 -0600

Available diffs

Superseded in zesty-release on 2017-02-16
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
littler (0.3.1-1) unstable; urgency=medium

  * New upstream release based on second CRAN upload

  * debian/control: Removed libicu-dev from Builds-Depends but increased
    versioned Depends: to r-base-dev (>= 3.3.0-2) which now provides it

  * debian/control: Set Build-Depends: to current R version
  * debian/control: Set Standards-Version: to current version 

 -- Dirk Eddelbuettel <email address hidden>  Sun, 07 Aug 2016 08:22:38 -0500

Available diffs

Superseded in yakkety-release on 2016-08-08
Deleted in yakkety-proposed on 2016-08-09 (Reason: moved to release)
littler (0.3.0-3) unstable; urgency=low

  * debian/control: Add libicu-dev to Build-Depends	(Closes: #824465)
  
  * debian/rules: Strip /usr/bin/r when installing

 -- Dirk Eddelbuettel <email address hidden>  Mon, 16 May 2016 06:22:23 -0500

Available diffs

Superseded in yakkety-release on 2016-05-17
Published in xenial-release on 2015-11-04
Deleted in xenial-proposed (Reason: moved to release)
littler (0.3.0-2) unstable; urgency=low

  * debian/control: Add virtual package littler to ensure installation of
    r-cran-littler

 -- Dirk Eddelbuettel <email address hidden>  Tue, 03 Nov 2015 11:52:43 -0600

Available diffs

Superseded in xenial-release on 2015-11-04
Deleted in xenial-proposed on 2015-11-05 (Reason: moved to release)
littler (0.3.0-1) unstable; urgency=low

  * New upstream release based on intial CRAN upload

  * debian/control: Binary package renamed to 'r-cran-littler' to match
    other CRAN packages in Debian; added Conflicts:/Replaces:/Provides:
    
  * debian/rules: Rewritten for use as a CRAN package

 -- Dirk Eddelbuettel <email address hidden>  Wed, 28 Oct 2015 19:36:39 -0500

Available diffs

Superseded in xenial-release on 2015-11-03
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
littler (0.2.3-2) unstable; urgency=low

  * Interim release based on current GitHub repo; release will follow
  
  * litter.c: Invert logic to default to reproducible builds
  * bootstrp: Idem

 -- Dirk Eddelbuettel <email address hidden>  Thu, 07 May 2015 14:02:21 -0500

Available diffs

Superseded in wily-proposed on 2015-05-08
littler (0.2.3-1) unstable; urgency=low


  * New upstream release
  
  * debian/control: Updated (Build-)Depends: to current R version

  * This version support reproducible builds in the code, but I have not
    bumped this up to the build system (which I am contemplating
    changing). To activate, for now please add #define REPRODUCIBLE_BUILD=1 
    at the top of the littler.c file.
 
 -- Dirk Eddelbuettel <email address hidden>  Sat, 14 Mar 2015 08:18:47 -0500
Superseded in wily-release on 2015-07-30
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
littler (0.2.2-1) unstable; urgency=low


  * New upstream release

 -- Dirk Eddelbuettel <email address hidden>  Fri, 30 Jan 2015 06:33:58 -0600

Available diffs

Superseded in vivid-release on 2015-01-30
Deleted in vivid-proposed on 2015-01-31 (Reason: moved to release)
littler (0.2.1-1) unstable; urgency=low


  * New upstream release

 -- Dirk Eddelbuettel <email address hidden>  Sun, 19 Oct 2014 15:48:24 -0500

Available diffs

Superseded in vivid-release on 2014-11-11
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2011-10-31
littler (0.1.5-1) unstable; urgency=low


  * New upstream release with the following changes:

       - littler.c (littler_CleanUp): Remove call to Rf_KillAllDevices() 

 -- Dirk Eddelbuettel <email address hidden>  Sat, 17 Sep 2011 09:40:56 -0500
Superseded in precise-release on 2011-10-31
Obsolete in oneiric-release on 2015-04-24
littler (0.1.3-1ubuntu1) oneiric; urgency=low

  * Fix FTBFS with ld --as-needed. LP: #770980.
 -- Matthias Klose <email address hidden>   Wed, 14 Sep 2011 21:42:54 +0200

Available diffs

Superseded in oneiric-release on 2011-09-14
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
littler (0.1.3-1) unstable; urgency=low

  * New upstream release with the following changes:

       - initialize such that interactive() now returns FALSE, added 
         new switch -i|--interactive to get the prior behaviour of TRUE
  
       - augmented littler_CleanUp to be closer to the example in 
         section 8.1.2 on 'Setting R callbacks'
  
       - small fixes to examples install.r and update.r

  * debian/control: Updated (Build-)Depends: to current R version
  * debian/control: Updated Standards-Version: to current version
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  25 Jan 2010 03:42:31 +0000

Available diffs

Superseded in lucid-release on 2010-01-25
Obsolete in karmic-release on 2013-03-04
littler (0.1.2-2) unstable; urgency=low

  * r.1: Added missing \ to protect \n; also submitted in svn
  							(Closes: #520868)
  
  * debian/control: Changed Section: to new section 'gnu-r'
  * debian/control: Updated Standards-Version: to '3.8.1'

Available diffs

Superseded in karmic-release on 2009-04-29
Obsolete in jaunty-release on 2013-02-28
littler (0.1.1-1) unstable; urgency=low

  * New upstream release with the following changes:
  
     - littler.c: now exits with status provided by call to q()

     - tests/exitstatus.sh: Added test script for new exit status feature

     - r.1: Applied patch by Seb which adds more examples. Thanks!

     - README: added entry about getopt package on CRAN 

     - examples/update.r: simplified clearCache

  * debian/control: Updated (Build-)Depends: to 'r-base-dev (>= 2.7.2)'
  * debian/control: Updated Standards-Version: to '3.8.0'
  * debian/control: Added Suggests: for 'r-cran-getopt'
  

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  05 Nov 2008 10:38:43 +0000

Available diffs

Superseded in jaunty-release on 2008-11-05
Obsolete in intrepid-release on 2013-02-20
littler (0.1.0-3) unstable; urgency=low

  * Rebuilding under the current R version
  * debian/control: Updated (Build-)Depends accordingly

Superseded in intrepid-release on 2008-05-09
Obsolete in hardy-release on 2015-04-24
littler (0.1.0-1ubuntu1) hardy; urgency=low

  * Rebuilt under R 2.6.2 (LP: #217742)
  * debian/control: Updated (Build-)Depends accordingly
  * Modify Maintainer value to match the DebianMaintainerField
    specification.

 -- Cesare Tirabassi <email address hidden>   Tue, 15 Apr 2008 21:28:50 +0200
Superseded in hardy-release on 2008-04-16
littler (0.1.0-1) unstable; urgency=low

  * New upstream release with the following changes:

     - littler.c: Added new option -l|--packages to load R packages
                  Small change to optional argument handling
                  Also use --no-restore argument on startup
                  Small additions to --help output

     - r.1: Documented new option -l | --packages

     - README: Updated as well

     - autoloads.R: No longer suppress autoload of package datasets

     - bootstrap: Two small fixes for non-bash sh use

     - examples/update.r: rewritten cache clearing part

     - tests/timing*.sh: added Rscript for comparison
  
  * debian/control: Updated to new Standards-Version:

 -- Andrea Colangelo <email address hidden>   Wed,  23 Jan 2008 17:02:21 +0000
Superseded in hardy-release on 2008-01-23
littler (0.0.11-2) unstable; urgency=low

  * Rebuilt under R 2.6.1

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  30 Nov 2007 12:42:05 +0000
Superseded in hardy-release on 2007-11-30
Obsolete in gutsy-release on 2011-09-16
littler (0.0.11-1) unstable; urgency=low

  * New upstream release with the following upstream changes:
 
  * Makefile.am: Removed use of one GNU extension to Make to
    facilitate builds on non-GNU systems
  * examples/update.r: Fix by Jeff for file caching issues
  
  * Built against the new R 2.5.0 released yesterday
  * debian/control: Build-Depends: updated to r-base-core (>= 2.5.0)

Superseded in gutsy-release on 2007-04-27
Obsolete in feisty-release on 2009-08-20
littler (0.0.8-1) unstable; urgency=low

  * New upstream release

  * debian/control: Remove Build-Depends: on automake and autotools-dev 
							(Closes: #394295)

127 of 27 results