Change log for llvm-toolchain-snapshot package in Ubuntu

160 of 60 results
Deleted in disco-proposed on 2019-04-15 (Reason: LP: #1824784)
llvm-toolchain-snapshot (1:9~svn354105-1~exp1) experimental; urgency=medium

  * New snapshot release

  [ John Paul Adrian Glaubitz ]
  * Remove usr/lib/llvm-@LLVM_VERSION@/lib/LLVM*.so
    from debian/llvm-X.Y-dev.install.in and install
    the files conditionally in debian/rules

 -- Sylvestre Ledru <email address hidden>  Fri, 15 Feb 2019 09:32:35 +0100
Superseded in disco-proposed on 2019-02-28
llvm-toolchain-snapshot (1:9~svn351420-1~exp1) experimental; urgency=medium

  * New snapshot release
  * Fix a typo in the arch declaration
  * Remove patch D54677-hurd-path_max.diff (applied upstream)
  * Fix debian-changelog-line-too-long
  * Silent source-contains-prebuilt-windows-binary
  * Silent executable-not-elf-or-script
    usr/lib/llvm-8/share/clang/bash-autocomplete.sh
  * Remove unapplied patches:
    - D52340-rustc-debuginfo.diff
    - D54379-hurd-triple-clang.diff
    - hurd-cxx-paths.diff
    - openmp-jessie-missing-include.diff
    - rustc-aarch64-test-failure.diff
    - strip-ignore-deterministic-archives.diff
  * Update the list of openmp symbols (added):
    - omp_get_device_num
    - omp_get_initial_device
    - omp_get_num_devices
    - __kmpc_pause_resource (from v9)
    - omp_pause_resource (from v9)
    - omp_pause_resource_all (from v9)


 -- Sylvestre Ledru <email address hidden>  Thu, 17 Jan 2019 11:04:49 +0100
Superseded in disco-proposed on 2019-01-21
Deleted in cosmic-proposed on 2019-01-23 (Reason: Moved to disco-proposed)
llvm-toolchain-snapshot (1:8~svn343154-1) unstable; urgency=medium

  * Remove bat files https://bugs.llvm.org/show_bug.cgi?id=30755
  * Fix the autopkgtest script (no gcc in the test)
  * remove dep from lld to llvm-8-dev because lld
    doesn't use LLVM LTO
  * remove old Replaces/Breaks
  * Standards-Version: 4.2.1
  * New snapshot release

 -- Sylvestre Ledru <email address hidden>  Thu, 27 Sep 2018 02:15:18 +0200

Available diffs

Superseded in cosmic-proposed on 2018-10-02
llvm-toolchain-snapshot (1:8~svn342638-1) unstable; urgency=medium

  * New snapshot release
  * Fix the ftbfs under armel on libc++ and enable openmp on armel.
    Thanks to Adrian Bunk for the patch
  * Make libc++, libc++abi & openmp NOT co-installable
    Rational: the benefits are limited compared to the drawback.
    We should have issues like:
       - built with libc++-8-dev
       - run with libc++1-7
    (Closes: #903802)
  * Remove circular dependency by removing python-lldb-8: Depends: liblldb-8-dev
    (Closes: #888889)

 -- Sylvestre Ledru <email address hidden>  Thu, 20 Sep 2018 12:13:15 +0200
Superseded in cosmic-proposed on 2018-09-21
llvm-toolchain-snapshot (1:8~svn340819-1) unstable; urgency=medium

  * New snapshot release
  * Force sphinx to be >> 1.2.3
  * also ignore libc++experimental.a on dh_strip (fails on stretch)
  * Make libc++-8-dev & libc++abi-8-dev coinstallable
  * Remove libtool flex, bison, dejagnu, tcl, expect,
    and perl from the build deps (testing)
  * Disable force-gcc-header-obj.diff as it is introducing
    some regressions in the search headers
    (Closes: #903709)
  * branching to version 8
    - New symbols in libclang:
      clang_Cursor_getObjCPropertyGetterName
      clang_Cursor_getObjCPropertySetterName
      clang_Type_getModifiedType
      clang_Type_getNullability
      clang_Type_getNumObjCProtocolRefs
      clang_Type_getNumObjCTypeArgs
      clang_Type_getObjCObjectBaseType
      clang_Type_getObjCProtocolDecl
      clang_Type_getObjCTypeArg
  * python-recommonmark is a new build dep for the sphinx doc
  * dh_strip should be verbose
  * On Stretch (binutils 2.28), do not run strip on libFuzzer.a, libc++.a
    & libc++abi.a because it segfaults
  * Fixed "weak-library-dev-dependency libc++-7-dev on libc++-7-helpers"
  * Fixed "libomp5-7: shlibs-declares-dependency-on-other-package
           libomp5-7) (>= 1:7~svn298832-1~)"
  * Also use the local cmake binary if available (for trusty)
    and take in account the PRE_PROCESS_CONF option
  * Try to fix a FTBFS on jessie with openmp

  [ Gianfranco Costamagna ]
  * Add liblldb-8-dev to python-lldb runtime dependencies, needed to import it
  * Enable lld on arm64, mips64el
  * Enable lldb on mips64el
  * Enable lld on ppc64el

  [ John Paul Adrian Glaubitz ]
  * Don't build with ld.gold on powerpcspe
  * Disable polly on powerpcspe
  * Add upstream patch to make rustc build on powerpc

  [ Reshabh Sharma ]
  * Integrate opemp as part of the llvm-toolchain packages (Closes: #813672)
    As part of this work, the transition libiomp packages have been removed.

 -- Sylvestre Ledru <email address hidden>  Tue, 28 Aug 2018 16:28:24 +0200
Superseded in cosmic-proposed on 2018-09-03
llvm-toolchain-snapshot (1:7~svn331965-1) unstable; urgency=medium

  * New snapshot release
  * d/p/force-gcc-header-obj.diff Fix the detection of the objc path
  * Add python-yaml as dep for clang-tidy (Closes: #890514)
  * d/p/impl-path-hurd.diff: Try to fix an issue with hurd

  [ Peter Wu ]
  * Make CMake find_package(Clang) work. Fixes upstream bug
    https://bugs.llvm.org/show_bug.cgi?id=37128
    - Move Clang*.cmake back to /usr/lib/llvm-X.Y/lib/cmake/clang and install a
      symlink in /usr/lib/cmake/clang-X.Y.
    - Ensure that the LLVM installation prefix is correctly discovered despire
      symlinks (replaces fix-cmake-config-prefix.diff).
    - Create /usr/lib/llvm-X.Y/bin/clang-X.Y symlink as required by
      ClangTargets-relwithdebinfo.cmake.
    - Remove useless LLVM_CMAKE_DIR sed command that did not match anything.
    - Ignore missing binaries in ClangTargets-relwithdebinfo.cmake.

 -- Sylvestre Ledru <email address hidden>  Thu, 10 May 2018 10:58:31 +0200
Superseded in cosmic-proposed on 2018-05-10
llvm-toolchain-snapshot (1:7~svn327768-1build1) cosmic; urgency=medium

  * No-change rebuild for ncurses soname changes.

 -- Matthias Klose <email address hidden>  Thu, 03 May 2018 15:25:36 +0000
Superseded in cosmic-proposed on 2018-05-04
Deleted in bionic-proposed on 2018-05-05 (Reason: Moved to cosmic-proposed.)
llvm-toolchain-snapshot (1:7~svn327768-1) unstable; urgency=medium

  * New snapshot release
  * create the directory for the mips stuff
  * Fail the build when new symbols are added
  * 5 new symbols:
    - clang_PrintingPolicy_dispose
    - clang_PrintingPolicy_getProperty
    - clang_PrintingPolicy_setProperty
    - clang_getCursorPrettyPrinted
    - clang_getCursorPrintingPolicy
  * Use upstream ld.lld manpage instead of help2man
  * Move the VCS to git.
    Many thanks to James Clarke for doing the conversion
  * Create the directory before having the manpages generated
  * clang-tidy-7 also depends on clang-tools-7 for, at least
    clang-apply-replacements
  * Automatically update the debian/README
  * clang-tidy-7: depends on libclang-common-7-dev
    (Closes: #891999)

  [ James Clarke ]
  * Disable LLDB on powerpcspe

 -- Sylvestre Ledru <email address hidden>  Sat, 17 Mar 2018 14:56:19 +0100
Deleted in bionic-proposed on 2018-04-26 (Reason: NBS)
llvm-toolchain-snapshot (1:7~svn323616-1) unstable; urgency=medium

  * New snapshot release
  * Fix llvm-config with the change of versioning (Closes: #888592)
  * Update the creation of the README to unbreak the mips* FTBFS
  * Update of the clang-tools-X.Y description

 -- Sylvestre Ledru <email address hidden>  Sun, 28 Jan 2018 13:43:37 +0100
Superseded in bionic-proposed on 2018-01-29
llvm-toolchain-snapshot (1:7~svn322880-1) unstable; urgency=medium

  * Change the versioning from X.Y to X as upstream is using
    X.Y.Z and X
    I am keeping the epoch because it would be too complex to manage
    with the various updates scenario
  * Two new symbols in libclang
    - clang_getFileContents
    - clang_isInvalidDeclaration
  * Fix the VCS-* tags

 -- Sylvestre Ledru <email address hidden>  Thu, 18 Jan 2018 20:50:03 +0100
Superseded in bionic-proposed on 2018-01-22
llvm-toolchain-snapshot (1:6.0~svn321357-1) unstable; urgency=medium

  * Snapshot upload before rc1 (January)
  * Create clang-tools-6.0 and move the various clang tools into it
    clang-tools-6.0 depends on clang-6.0. This might affect some packages.
    (Closes: #836397)
  * Bring back the libedit support in lldb
    Fix upstream bug https://bugs.llvm.org/show_bug.cgi?id=35291
  * Also ship ld64.lld and wasm-ld in the lld-X.Y package
  * Update d/rules to reflect the move of libfuzzer into compiler-rt
  * Update of the copyright file (Closes: #878502)
    Thanks to Nicholas D Steeves for the work
  * Try to fix the mipsel FTBFS (Closes: #877567)
    I am trying the first option from the bug:
    - gsplit-dward on 32 bits archs
    - -g everywhere
    Many thanks to Adrian Bunk for that
  * Use ?= for some variables declarations
  * Remove the hardcoded declarations of llvm version in debian/rules
  * add /usr/lib/cuda to the CUDA toolkit search paths
    Thanks to Andreas Beckmann for the patch (Closes: #882505) (LP: #1706326)
  * Fix the fix-scan-view-path.diff path
  * Move libomp-dev from Suggests to Recommends (Closes: #882781)
  * Add a symlink to fix lldb-X.Y (Closes: #881993)
  * Remove update-cuda-search-path.patch (applied upstream)
  * Also install usr/bin/lldb-test-6.0
  * liblld-6.0-dev depends on liblld-6.0 (Closes: #856545)
  * Add new symbols for libclang1:
    - clang_CXIndex_setInvocationEmissionPathOption
    - clang_CXXRecord_isAbstract
    - clang_Cursor_getObjCManglings
    - clang_getCursorTLSKind
  * add test-keep-alive.diff to improve the keep alive for some
    archs like mips*
  * Standards-Version: 4.1.1
  * remove liblld-6.0-dbg for now

 -- Sylvestre Ledru <email address hidden>  Fri, 22 Dec 2017 15:23:17 +0100
Superseded in bionic-proposed on 2017-12-23
Deleted in artful-proposed on 2018-01-31 (Reason: Moved to bionic-proposed)
llvm-toolchain-snapshot (1:6.0~svn315736-1) unstable; urgency=medium

  * New snapshot
  * Ship liblldMinGW lld lib
  * Ship clang-refactor & clang-func-mapping in clang-X.Y
  * Remove the -Wl option to call gold instead of the normal linker
    (Closes: #876787)
  * Force the deactivation of ocaml until the transition is done
  * Standards Version 4.1.0

  [ Gianfranco Costamagna ]
  * Enable ocaml on release architectures.
  * Add NDEBUG flag, lost in the -g -> -g1 switch

  [ Matthias Klose ]
  * Link with --no-keep-files-mapped --no-map-whole-files when using gold.
  * build using gold on arm64 and s390x. For backports, arm64 might still
    need the BFD linker, and building with only one or two processes in
    parallel.
  * On amd64, s390x, arm64 and ppc64el, build with -g1 instead of -g.
  * Set CMAKE_CXX_FLAGS_RELWITHDEBINFO and pass opt_flags.

 -- Sylvestre Ledru <email address hidden>  Mon, 11 Sep 2017 22:27:20 +0200
Superseded in artful-proposed on 2017-10-16
llvm-toolchain-snapshot (1:6.0~svn311834-4~build4) artful; urgency=medium

  * Do not ship liblldMinGW (not built everywhere)

 -- Gianfranco Costamagna <email address hidden>  Tue, 19 Sep 2017 21:12:51 +0200
Superseded in artful-proposed on 2017-09-19
llvm-toolchain-snapshot (1:6.0~svn311834-4~build3) artful; urgency=medium

  * Fix typo in previous upload

 -- Gianfranco Costamagna <email address hidden>  Tue, 19 Sep 2017 16:14:16 +0200
Superseded in artful-proposed on 2017-09-19
llvm-toolchain-snapshot (1:6.0~svn311834-4~build2) artful; urgency=medium

  * Do not ship refactor (not built everywhere)

 -- Gianfranco Costamagna <email address hidden>  Tue, 19 Sep 2017 14:32:57 +0200
Superseded in artful-proposed on 2017-09-19
llvm-toolchain-snapshot (1:6.0~svn311834-4~build1) artful; urgency=medium

  * Ship liblldMinGW lld lib
  * Ship clang-refactor in clang-X.Y

  [ Gianfranco Costamagna ]
  * Enable ocaml on release architectures.

  [ Matthias Klose ]
  * Link with --no-keep-files-mapped --no-map-whole-files when using gold.
  * build using gold on arm64 and s390x. For backports, arm64 might still
    need the BFD linker, and building with only one or two processes in
    parallel.
  * On amd64, s390x, arm64 and ppc64el, build with -g1 instead of -g.
  * Set CMAKE_CXX_FLAGS_RELWITHDEBINFO and pass opt_flags.

 -- Sylvestre Ledru <email address hidden>  Mon, 11 Sep 2017 22:27:20 +0200
Superseded in artful-proposed on 2017-09-19
llvm-toolchain-snapshot (1:6.0~svn311834-2.1~build1) artful; urgency=medium

  * Fix typo in rules file, upload delta in Debian.

 -- Gianfranco Costamagna <email address hidden>  Tue, 05 Sep 2017 22:52:17 +0200
Superseded in artful-proposed on 2017-09-05
llvm-toolchain-snapshot (1:6.0~svn311834-2ubuntu3) artful; urgency=medium

  * Merge from Svn repo. Remaining changes:
    - Enable ocaml on all arches.

 -- Gianfranco Costamagna <email address hidden>  Thu, 31 Aug 2017 22:51:49 +0200
Superseded in artful-proposed on 2017-09-05
llvm-toolchain-snapshot (1:6.0~svn311834-2ubuntu2) artful; urgency=medium

  * Merge from Svn repo. Remaining changes:
    - Enable ocaml on all arches.

 -- Gianfranco Costamagna <email address hidden>  Thu, 31 Aug 2017 22:51:49 +0200
Superseded in artful-proposed on 2017-09-01
llvm-toolchain-snapshot (1:6.0~svn311834-2ubuntu1) artful; urgency=medium

  * Merge from Svn repo. Remaining changes:
    - Enable ocaml on all arches.

Superseded in artful-proposed on 2017-08-31
llvm-toolchain-snapshot (1:6.0~svn311834-1ubuntu1) artful; urgency=medium

  * Merge from Debian unstable. Remaining changes:
    - Enable ocaml on all arches.

Superseded in artful-proposed on 2017-08-31
llvm-toolchain-snapshot (1:5.0~svn305653-1ubuntu1) artful; urgency=medium

  * Enable ocaml on all arches.

 -- Dimitri John Ledkov <email address hidden>  Sat, 15 Jul 2017 23:14:49 +0100
Superseded in artful-proposed on 2017-07-16
llvm-toolchain-snapshot (1:5.0~svn305653-1build1) artful; urgency=high

  * No change rebuild against ocaml 4.04.

 -- Dimitri John Ledkov <email address hidden>  Mon, 03 Jul 2017 15:21:51 +0100
Superseded in artful-proposed on 2017-07-03
llvm-toolchain-snapshot (1:5.0~svn305653-1) unstable; urgency=medium

  [ Gianfranco Costamagna ]
  * Re-add clang-doc documentation

  [ Sylvestre Ledru ]
  * New snapshot release
  * Fix a hurd PATH_MAX issue
  * Transform the lldb swig check from a error to a warning
  * Add libomp-dev to the suggests of clang
  * Add Provides on python-lldb-x.y & python-clang-x.y & libllvm-x.y-ocaml-dev
    to avoid the recurring problem about conflicts
    (Closes: #835546, #863739, #863742)
  * Standards-Version => 4.0.0
  * Generate the llvm-tblgen, clang-change-namespace, clang-offload-bundler
    lld, clang++, clang-check, clang-cpp & clang-import-test manpages
  * Remove the --no-discard-stderr option from help2man calls
  * use -DPOLLY_BUNDLED_JSONCPP=OFF & add pkg-config as a dep (to help find
    the files)

 -- Sylvestre Ledru <email address hidden>  Fri, 09 Jun 2017 12:04:56 +0200
Superseded in artful-proposed on 2017-06-22
llvm-toolchain-snapshot (1:5.0~svn301421-2~build1) artful; urgency=medium

  * Fix doc generation

 -- Gianfranco Costamagna <email address hidden>  Sun, 04 Jun 2017 20:17:55 +0200
Superseded in artful-proposed on 2017-06-05
llvm-toolchain-snapshot (1:5.0~svn301421-1) unstable; urgency=medium

  * Limit the archs where the ocaml binding is built
    Should fix the FTBFS
    Currently amd64 arm64 armel armhf i386
  * d/p/add_symbols_versioning.patch removed (applied upstream)
  * Really fix "use versioned symbols" for llvm
    Thanks to Julien Cristau for the patch (Closes: #849098)
  * Explicit the dep of clang-tidy on same version of llvm to avoid
    undefined symbols
  * Add override_dh_makeshlibs for the libllvm or liblldb versions
    Thanks to Julien Cristau for the patch
  * change the min version of the libclang1 symbols to 1:4.0-3~
  * Fix the symlink on scan-build-py
  * add libncurses in the list of build deps (Closes: #861170)

  [ Rebecca N. Palmer ]
  * Use versioned symbols (Closes: #848368)

 -- Sylvestre Ledru <email address hidden>  Sun, 09 Apr 2017 10:11:56 +0200
Superseded in artful-proposed on 2017-04-30
Deleted in zesty-proposed on 2017-07-17 (Reason: Moved to artful-proposed)
llvm-toolchain-snapshot (1:5.0~svn294894-1) unstable; urgency=medium

  * New snapshot release
  * New library liblldb-intel-mpxtable.so

 -- Sylvestre Ledru <email address hidden>  Sun, 12 Feb 2017 13:20:36 +0100
Superseded in zesty-proposed on 2017-02-12
llvm-toolchain-snapshot (1:4.0~svn291432-1) unstable; urgency=medium

  * New snapshot release
  * Disable libedit usage in lldb because of garbage (Closes: #846616, #850111)
  * Build lld
    - d/p/lld-arg-cmake-issue.diff fixes upstream bug #27685
  * Run clang extra test suite
  * Fix the detection of lldb-server
  * Fix the run of the check-lldb target

 -- Sylvestre Ledru <email address hidden>  Sat, 07 Jan 2017 12:24:32 +0100
Superseded in zesty-proposed on 2017-01-17
llvm-toolchain-snapshot (1:4.0~svn290810-1) unstable; urgency=medium

  * New snapshot release
  * d/p/kfreebsd-support.diff removed (applied upstream)
  * debian/orig-tar.sh: less verbose
  * d/p/lldb-missing-install.diff: For the install
    of lldb-server and lldb-argdumper as they are not always installed
  * Ship new binary in clang-X.Y: clang-import-test
  * New symbols in libclang1:
    - clang_EvalResult_getAsLongLong
    - clang_EvalResult_getAsLongLong
    - clang_EvalResult_isUnsignedInt
  * Fix a regression in the test run for the code coverage
  * Silent ThinLTO/X86/autoupgrade.ll, fails with code coverage (and maybe others)

 -- Sylvestre Ledru <email address hidden>  Mon, 02 Jan 2017 13:51:06 +0100
Deleted in zesty-proposed on 2017-02-20 (Reason: NBS)
llvm-toolchain-snapshot (1:4.0~svn286225-1) unstable; urgency=medium

  * New snapshot release

  [ Kai Wasserbäch ]
  * debian/patches/{0003-Debian-version-info-and-bugreport.patch,
    0044-soname.diff,23-strlcpy_strlcat_warning_removed.diff,
    26-set-correct-float-abi.diff,atomic_library_[12].diff,
    fix-clang-path-and-build.diff,fix-lldb-server-build,lldb-libname.diff,
    lldb-soname.diff,mips-fpxx-enable.diff,removeduplicatedeclaration.diff}:
    Refreshed.
  * debian/patches/{silent-gold-utils,kfreebsd-support}.diff: Updated.

 -- Sylvestre Ledru <email address hidden>  Tue, 08 Nov 2016 12:19:55 +0100
Deleted in zesty-proposed on 2016-11-17 (Reason: NBS)
Deleted in yakkety-proposed on 2016-11-17 (Reason: Moved to zesty-proposed)
llvm-toolchain-snapshot (1:4.0~svn279916-1) unstable; urgency=medium

  * Snapshot is now 4.0
  * Introduce clang-include-fixer-4.0
  * Fix the usage of jsoncpp in polly. Thanks to James Clarke for the patch
    (Closes: #835607)
  * Fix the renaming of the manpages (Closes: #834077)
  * Use the manpage from clang.rst instead of help2man
  * Disable the build of lldb on mips64el, ppc64 and s390x for real
  * Add symlink from ./build to ../share and ../lib etc
    Thanks to Ximin Luo for the patch (Closes: #834144)
  * Sync the 3.9 changes into 4.0
  * Fix the cmake paths in llvm-4.0-dev deb package. Thanks to Brad King
    for the patch (Closes: #819072)
  * Bring back the lto (gone with the cmake migration)
    (Closes: #819333) (upstream: #27223)
  * LLVMConfig.cmake is now installed to <prefix>/lib/cmake/llvm instead of
    <prefix>/share/llvm/cmake
    Thanks to Brad King of the fix
  * Disable lldb on sparc64 (Closes: #832371)
  * Also install clang-rename.el & clang-rename.py in clang-4.0
  * scan-build llvm results are built using --show-description
  * Generate manpages for lli, lldb-mi & git-clang-format
  * Fix some lintian overrides
  * Generate more manpages
  * Remove some garbage from the manpages (Closes: #815991, #804347)
  * Disable -gsplit-dwarf on Ubuntu precise
  * Update the coverity configuration (Debian has moved to gcc 6)
  * remove compiler-rt-path.diff (file removed upstream, probably because
    we moved to cmake)
  * Ship clang-offload-bundler in clang 4.0
  * Set the correct Conflicts for python-clang-4.0, python-lldb-4.0
    (Closes: #832410)

 -- Sylvestre Ledru <email address hidden>  Sat, 27 Aug 2016 14:19:41 +0200
Superseded in yakkety-proposed on 2016-08-29
llvm-toolchain-snapshot (1:4.0~svn276280-1~exp1) experimental; urgency=medium

  * New snapshot release

 -- Sylvestre Ledru <email address hidden>  Thu, 21 Jul 2016 16:04:42 +0200
Superseded in yakkety-proposed on 2016-08-07
llvm-toolchain-snapshot (1:3.9~svn274438-1) unstable; urgency=medium

  * Remove the autoconf section
  * Bring back the removal of the build dir
  * Fix the coverage builds (didn't allow several cflags)
  * Set the correct conflicts on python-lldb-3.8 (Closes: #817873)
  * Set the correct conflicts on python-clang-3.8 (Closes: #817872)
  * remove llvm26003-sanitizer-check-env.diff (merged upstream)
  * Do not fail the build if the manpages cannot be built (failing on
    Ubuntu precise)
  * Install libfindAllSymbols.a as part of libclang-X.Y-dev
  * Ship scan-build-py
  * Use the libjsoncpp library embedded (fails to link otherwise)
  * Standards-Version 3.9.8
  * cmake files moved from usr/lib/llvm-3.9/share/llvm/cmake/
    to usr/lib/llvm-3.9/lib/cmake/llvm/
    (upstream change)
  * Add a symlink from usr/lib/llvm-3.9/share/llvm/cmake
    pointing to usr/share/llvm-3.9/cmake
  * Disable the run of lldb testsuite because of LLVM_LINK_LLVM_DYLIB=ON:
    https://llvm.org/bugs/show_bug.cgi?id=28127
  * Add -gsplit-dwarf to CXXFLAGS to workaround the memory allocation
    issue on i386
  * Ignore the lintian override about embedded-library for json.
    Doesn't link otherwise
  * Fix the soname of libclang and libLLVM. Might cause some breakage with
    existing app but no choice...

  [ Pablo Oliveira ]
  * Add python-six as a dependency of python-lldb (Closes: #825371)
    (thanks to Askar Safin)
  * Fix lldb symlinks
  * Fix missing _lldb.so import during lldb testsuite

  [ Ed Schouten ]
  * Preparation of the support of lld (not ready yet)

  [ Kai Wasserbäch ]
    * debian/rules:
      - Ensure ld-gold is used. CMake invokes the linker through g++ most of the
        time, therefore we need to set -Wl,-fuse-ld=gold.
      - Remove unused variable "confargs".

  [ Brad King ]
  * Install cmake files in usr/share/llvm-@LLVM_VERSION@/cmake/ instead of
    usr/share/llvm-@LLVM_VERSION@/cmake/
  * Also install libLLVM-3.8.so.1 as a symlink
  * debian/patches/fix-cmake-config-prefix.diff:
    cover the CMake build system too
  (Closes: #819072)

  [ Alexis La Goutte ]
  * Fix an issue with scan-view (Closes: #825101)

  [ YunQiang Su ]
  * Enable FPXX by default on mips/mipsel (Closes: #826749)

 -- Sylvestre Ledru <email address hidden>  Sat, 02 Jul 2016 20:46:05 +0200
Superseded in yakkety-proposed on 2016-07-03
Deleted in xenial-proposed on 2016-08-30 (Reason: Moved to yakkety-proposed)
llvm-toolchain-snapshot (1:3.9~svn262954-1) unstable; urgency=medium

  * New snapshot
  * Switch to 3.9 (remove lldb-3.9-dev as it was a transitionnal pkg)
  * Update the clang description for something more accurate (C++-11, 14, etc)
  * Cmake migration. Done by Andrew Wilkins. Many thanks to him
    - Update patches to set SONAME in CMake build
    - Create symlinks with ".links", don't install from build tree
    - Remove LLVM-internal tools (lit, FileCheck, not, tblgen, etc.)
    - Remove llvm-X.Y-tools package, because it contained only
      internal tools that are not intended for distribution.
    - Remove autotools-specific artifacts from packages.
    - Remove "dummy" documentation artifacts from llvm-X.Y-docs
      package. Not built/installed by CMake, not useful.
    - Update control/rules to support CMake
    - Patch LLDB SWIG interfaces to workaround a bug in SWIG
      See https://llvm.org/bugs/show_bug.cgi?id=25468
    - add missing files to clang-format
    - Add patch to fix sanitizer lit invocation
    - removed LLVM-internal tools (lit, FileCheck, not, *-tblgen, etc.);
      not installed by CMake, not intended for distribution
    - removed llvm-X.Y-tools (contained only internal tools)
    - removed autotools-specific artifacts (configure, Makefile, etc.)
    - removed dummy documentation files
  * Sync against 3.8
  * Disable "Sphinx warnings treated as errors"

 -- Sylvestre Ledru <email address hidden>  Tue, 08 Mar 2016 09:50:29 +0100
Superseded in xenial-proposed on 2016-03-14
llvm-toolchain-snapshot (1:3.8~svn254193-1ubuntu3) xenial; urgency=medium

  * Disable lldb on s390x.

 -- Matthias Klose <email address hidden>  Fri, 04 Dec 2015 16:10:46 +0100
Superseded in xenial-proposed on 2015-12-04
llvm-toolchain-snapshot (1:3.8~svn254193-1ubuntu2) xenial; urgency=medium

  * Disable polly on powerpc.

 -- Matthias Klose <email address hidden>  Mon, 30 Nov 2015 14:02:48 +0100
Superseded in xenial-proposed on 2015-11-30
llvm-toolchain-snapshot (1:3.8~svn254193-1ubuntu1) xenial; urgency=medium

  * Merge with Debian; remaining changes:
    - Disable lldb on powerpc.

 -- Matthias Klose <email address hidden>  Mon, 30 Nov 2015 08:18:33 +0100
Superseded in xenial-proposed on 2015-11-30
llvm-toolchain-snapshot (1:3.8~svn254193-1) unstable; urgency=medium

  * New snapshot release
  * Remove some warnings in the manpages generation (Closes: #795310)
  * Also ship sancov in clang-3.8
  * Fix the links to scan-build-3.8 & scan-view-3.8

 -- Sylvestre Ledru <email address hidden>  Tue, 20 Oct 2015 14:07:06 +0200
Superseded in xenial-proposed on 2015-11-30
llvm-toolchain-snapshot (1:3.8~svn250696-1ubuntu1) xenial; urgency=medium

  * Disabled lldb on powerpc.

 -- Matthias Klose <email address hidden>  Thu, 26 Nov 2015 22:16:15 +0100
Superseded in xenial-proposed on 2015-11-26
llvm-toolchain-snapshot (1:3.8~svn250696-1) unstable; urgency=medium

  * Remove macho-dump from LLVM (removed by upstream r248302)
  * Introduce clang-tidy-3.8 as a separate package. Replaces clang-modernize
  * Ship run-clang-tidy.py & clang-tidy-diff.py in clang-tidy-3.8
  * Remove cpp11-migrate-3.8 package. Has been replaced by clang-modernize
    for a while (which will be replaced by clang-tidy)
  * Add three new symbols in libclang1
    - clang_CompileCommand_getFilename@Base
    - clang_CompileCommand_getMappedSourceContent@Base 3.8
    - clang_CompileCommand_getMappedSourcePath@Base 3.8

 -- Sylvestre Ledru <email address hidden>  Mon, 21 Sep 2015 13:16:35 +0200
Deleted in wily-proposed on 2015-08-14 (Reason: remove llvm-toolchain-snapshot, llvm-toolchain-3.7 is mor...)
llvm-toolchain-snapshot (1:3.7~svn239806-1) unstable; urgency=medium

  * New snapshot release
  * Reflect upstream changes wrt vim package. Split the files into different
    directories
  * Preparation of the autotools => cmake transition
  * Disable the patch force-gcc-header-obj.diff. Seems to cause bug #23556
  * Fix the CMake build. thanks to Paweł Bylica for the fix.
    Fix upstream bug #23352

 -- Sylvestre Ledru <email address hidden>  Tue, 16 Jun 2015 11:00:21 +0200
Superseded in wily-proposed on 2015-06-17
llvm-toolchain-snapshot (1:3.7~svn230892-1) unstable; urgency=medium


  * New snapshot release
    - Fix the lldb arch detection issues (Closes: #777616)
  * Support of gcc 5.0 (Closes: #777988)
  * compiler-rt-i586.diff: fix a build issue of compiler-rt under i386
  * lldb-gdbserver & lldb-platform have been merged into lldb-server
  * Bring back polly and remove libcloog-isl-dev & libisl-dev as build deps
    (shipped in the polly source tree)
  * Set the correct conflicts (Closes: #777580, #777581, #777582)
  * lit-lang.diff: Force the call to ld to be in english
    (was failing with a french locale)
  * silent-MCJIIT-tests.diff: enable some tests and silents some other

 -- Sylvestre Ledru <email address hidden>  Sat, 28 Feb 2015 18:44:59 +0100
Published in trusty-updates on 2015-02-17
Published in trusty-security on 2015-02-17
llvm-toolchain-snapshot (1:3.5-4ubuntu2~trusty2) trusty-security; urgency=medium

  * No change rebuild in the security pocket
 -- Marc Deslauriers <email address hidden>   Thu, 12 Feb 2015 11:02:00 -0500
Superseded in wily-proposed on 2015-05-06
Deleted in vivid-proposed on 2015-10-23 (Reason: Moved to wily-proposed)
llvm-toolchain-snapshot (1:3.7~svn227076-1) unstable; urgency=medium


  * New snapshot release
  * Switch to version 3.7
  * Standards-Version updated to 3.9.6

 -- Sylvestre Ledru <email address hidden>  Mon, 26 Jan 2015 09:23:41 +0100
Superseded in trusty-updates on 2015-02-17
Deleted in trusty-proposed on 2015-02-18 (Reason: moved to -updates)
llvm-toolchain-snapshot (1:3.5-4ubuntu2~trusty1) trusty; urgency=medium

  [ Maarten Lankhorst ]
  * Copy package back to trusty. (LP: #1400626)

  [ Steve Langasek ]
  * Use the existing llvm-toolchain-snapshot source package name, which owns
    all of these binary packages in trusty.
 -- Steve Langasek <email address hidden>   Mon, 26 Jan 2015 10:57:53 -0800
Superseded in vivid-proposed on 2015-02-09
llvm-toolchain-snapshot (1:3.6~svn224810-1) unstable; urgency=medium


  * New snapshot release
  * Update library filename declaration 3.5 => 3.6 (Closes: #772006)

 -- Sylvestre Ledru <email address hidden>  Fri, 05 Dec 2014 17:46:56 -0800
Superseded in vivid-proposed on 2014-12-24
llvm-toolchain-snapshot (1:3.6~svn218612-1) unstable; urgency=medium


  * Fix my screw up. Add .1 to the libclang soname to make
    dpkg-shlibdeps happy
  * Remove useless dependency on doxygen
  * scan-build could not find clang binary (Closes: #758998)

 -- Sylvestre Ledru <email address hidden>  Fri, 26 Sep 2014 17:05:26 +0200
Superseded in vivid-proposed on 2014-10-25
Deleted in utopic-proposed on 2014-10-26 (Reason: moved to vivid-proposed)
Deleted in utopic-release on 2014-10-26 (Reason: lp: #1377235: llvm-toolchain-snapshot package should not ...)
Deleted in utopic-proposed on 2014-10-26 (Reason: moved to release)
llvm-toolchain-snapshot (1:3.6~svn215195-1) unstable; urgency=medium


  * Upload in unstable
  * Enable compressed debug sections (Closes: #757002)
  * Force scan-build to use the same version of clang
  * Old JIT has been removed. 0050-powerpcspe-fp.diff is useless
  * try to build lldb-gdbserver under kfreebsd (kfreebsd-lldb-gdbserver.diff)
  * Second try to fix build under HURD (hurd-EIEIO-undef.diff)

 -- Sylvestre Ledru <email address hidden>  Mon, 04 Aug 2014 13:36:15 +0200
Superseded in utopic-proposed on 2014-08-13
llvm-toolchain-snapshot (1:3.5~svn213451-1ubuntu1) utopic; urgency=medium

  * Merge from Debian unstable, remaining changes:
    - Build-depend on gcc-multilib on amd64 and i386.

Superseded in utopic-release on 2014-08-14
Published in trusty-release on 2014-03-24
Deleted in trusty-proposed (Reason: moved to release)
llvm-toolchain-snapshot (1:3.5~svn201651-1ubuntu1) trusty; urgency=medium

  * Merge with Debian; remaining changes:
    - Build-depend on gcc-multilib on amd64 and i386.

Superseded in trusty-release on 2014-03-24
Deleted in trusty-proposed on 2014-03-25 (Reason: moved to release)
llvm-toolchain-snapshot (1:3.5~svn197556-1ubuntu1) trusty; urgency=medium

  * Don't run the lldb tests on armhf (time out on the buildd).
  * Disable the lldb build for AArch64.
  * Build-depend on gcc-multilib on amd64 and i386.
 -- Matthias Klose <email address hidden>   Fri, 27 Dec 2013 20:03:40 +0100
Superseded in trusty-release on 2013-12-27
Deleted in trusty-proposed on 2013-12-29 (Reason: moved to release)
llvm-toolchain-snapshot (1:3.5~svn197556-1) unstable; urgency=low


  * New snapshot release
  * Merge changes from 1:3.4~+rc3-1
  * Disable much of the display of the lldb display

 -- Sylvestre Ledru <email address hidden>  Tue, 17 Dec 2013 12:02:52 +0100
Superseded in trusty-release on 2013-12-24
Deleted in trusty-proposed on 2013-12-25 (Reason: moved to release)
llvm-toolchain-snapshot (1:3.4~svn192795-1~ubuntu5) trusty; urgency=low

  * debian/patches/ubuntu-trusty.diff: Detect UbuntuTrusty as valid.
  * debian/rules: re-enable lldb on amd64 a little harder this time.
 -- Adam Conrad <email address hidden>   Thu, 24 Oct 2013 20:35:56 -0600
Superseded in trusty-proposed on 2013-10-25
llvm-toolchain-snapshot (1:3.4~svn192795-1~ubuntu4) trusty; urgency=low

  * Re-enable lldb on amd64, from which it was accidentally dropped.
 -- Adam Conrad <email address hidden>   Thu, 24 Oct 2013 18:39:32 -0600
Superseded in trusty-release on 2013-10-25
Deleted in trusty-proposed on 2013-11-09 (Reason: moved to release)
llvm-toolchain-snapshot (1:3.4~svn192795-1~ubuntu3) trusty; urgency=low

  * Re-enable running the tests on amd64, i386 and powerpc.
 -- Matthias Klose <email address hidden>   Sun, 20 Oct 2013 15:31:20 +0200
Superseded in trusty-proposed on 2013-10-20
Deleted in saucy-proposed on 2013-10-21 (Reason: Moved to trusty-proposed)
llvm-toolchain-snapshot (1:3.4~svn192795-1~ubuntu2) saucy; urgency=low

  * Really disable all tests to get a package into the archive (hanging
    on the buildds at least on armhf and powerpc).
  * Disable the lldb packages for AArch64 in the control file too.
  * Really apply the lldb-link-atomic.diff patch.
 -- Matthias Klose <email address hidden>   Wed, 16 Oct 2013 22:30:19 +0200
Superseded in saucy-proposed on 2013-10-16
llvm-toolchain-snapshot (1:3.4~svn192795-1~ubuntu1) saucy; urgency=low

  * Disable the lldb build for AArch64.

Superseded in saucy-proposed on 2013-10-16
llvm-toolchain-snapshot (1:3.4~svn190846-1) unstable; urgency=low


  * New snapshot release
  * Merge changes from the 3.3 branch (see 1:3.3-9)
  * Remove ia64-fix.diff (applied upstream)
  * cpp11-migrate renamed to clang-modernize
  * lldb-3.4 is back to Architectures: any
  * Patch lldb-hurd.diff removed (applied upstream)
  * Directory www/ from tarballs polly & lldb removed
  * Update of the description of LLVM packages

  [ Luca Falavigna ]
  * debian/control:
    - Add llvm-3.4-dev to lldb-3.4 Depends field.

 -- Sylvestre Ledru <email address hidden>  Thu, 05 Sep 2013 12:04:35 +0200
Superseded in trusty-release on 2013-10-21
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
llvm-toolchain-snapshot (1:3.4~svn183914-1ubuntu1) saucy; urgency=low

  * Remove build-dependency on binutils-gold on all architectures.
 -- Adam Conrad <email address hidden>   Wed, 31 Jul 2013 18:36:14 +0100
Superseded in saucy-release on 2013-08-01
Deleted in saucy-proposed on 2013-08-02 (Reason: moved to release)
llvm-toolchain-snapshot (1:3.4~svn183914-1) unstable; urgency=low


  * New snapshot release
  * Upload to unstable (will be blocked by a RC bug)
  * Sync changes from llvm-toolchain-3.3:
    - Introduce cpp11-migrate-3.4 and clang-format-3.4
    - Install the vim llvm script at the right place

 -- Sylvestre Ledru <email address hidden>  Thu, 13 Jun 2013 18:47:08 +0200
160 of 60 results