Change log for lsb package in Ubuntu

175 of 96 results
Published in eoan-release on 2019-06-14
Deleted in eoan-proposed (Reason: moved to release)
lsb (10.2019051400ubuntu1) eoan; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - Re-added LSB compatibility packages, so that auto-downloadable
      LSB-based printer driver packages work.
    - lsb_release.py: restore support for querying the list of installed
      modules, since for the moment some modules are still supported.
    - Make the 'lsb' package depend on libjpeg62 as well, known to be needed
      by printer driver packages.

Superseded in eoan-release on 2019-06-14
Published in disco-release on 2019-04-04
Deleted in disco-proposed (Reason: moved to release)
lsb (10.2019031300ubuntu1) disco; urgency=medium

  * Merge from Debian unstable.  Remaining changes:
    - Re-added LSB compatibility packages, so that auto-downloadable
      LSB-based printer driver packages work.
    - lsb_release.py: restore support for querying the list of installed
      modules, since for the moment some modules are still supported.
    - Make the 'lsb' package depend on libjpeg62 as well, known to be needed
      by printer driver packages.

 -- Adam Conrad <email address hidden>  Tue, 02 Apr 2019 13:17:44 -0600
Superseded in disco-release on 2019-04-04
Deleted in disco-proposed on 2019-04-05 (Reason: moved to release)
lsb (10.2018112800ubuntu1) disco; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - Re-added LSB compatibility packages, so that auto-downloadable
      LSB-based printer driver packages work.
    - lsb_release.py: restore support for querying the list of installed
      modules, since for the moment some modules are still supported.
    - Make the 'lsb' package depend on libjpeg62 as well, known to be needed
      by printer driver packages.
  * Dropped changes, no longer needed:
    - Added Conflicts/Replaces against cups-filters-invalid-mta and
      cups-filters-lsb for upgrade compatibility from the Xenial development
      cycle.

Superseded in disco-release on 2019-02-03
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2017-12-13
Deleted in bionic-proposed (Reason: moved to release)
lsb (9.20170808ubuntu1) bionic; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - Re-added LSB compatibility packages, so that auto-downloadable
      LSB-based printer driver packages work.
    - Added Conflicts/Replaces against cups-filters-invalid-mta and
      cups-filters-lsb for upgrade compatibility from the Xenial development
      cycle.
    - lsb_release.py: restore support for querying the list of installed
      modules, since for the moment some modules are still supported.
    - Make the 'lsb' package depend on libjpeg62 as well, known to be needed
      by printer driver packages.
  * Dropped changes:
    - 01-upstart-lsb: obsoleted upstream, no longer used in Ubuntu.

Superseded in bionic-release on 2017-12-13
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed (Reason: moved to release)
lsb (9.20160110ubuntu5) yakkety; urgency=medium

  * Revert changes to python2 vs. python3 installation of lsb_release.py,
    inadvertently breaking imports of lsb_release in python2.  LP: #1596638.

 -- Steve Langasek <email address hidden>  Wed, 06 Jul 2016 08:20:18 -0700
Published in xenial-updates on 2016-07-07
Deleted in xenial-proposed (Reason: moved to -updates)
lsb (9.20160110ubuntu0.2) xenial; urgency=medium

  * Revert changes to python2 vs. python3 installation of lsb_release.py,
    inadvertently breaking imports of lsb_release in python2.  LP: #1596638.

 -- Steve Langasek <email address hidden>  Wed, 06 Jul 2016 08:18:48 -0700
Superseded in xenial-updates on 2016-07-07
Deleted in xenial-proposed on 2016-07-08 (Reason: moved to -updates)
lsb (9.20160110ubuntu0.1) xenial; urgency=medium

  * lsb_release.py: restore support for querying the list of installed
    modules, since for the moment some modules are still supported.

  [ Till Kamppeter ]
  * Re-added LSB compatibility packages, so that auto-downloadable
    LSB-based printer driver packages work.  Thanks to Till Kammpeter
    for the patch.  LP: #1536353
  * Added Conflicts/Replaces against cups-filters-invalid-mta and
    cups-filters-lsb for upgrade compatibility from the Xenial development
    cycle.

 -- Steve Langasek <email address hidden>  Tue, 21 Jun 2016 15:14:49 -0700
Superseded in yakkety-release on 2016-07-10
Deleted in yakkety-proposed on 2016-07-11 (Reason: moved to release)
lsb (9.20160110ubuntu4) yakkety; urgency=medium

  * Make the 'lsb' package depend on libjpeg62 as well, known to be needed
    by printer driver packages.

 -- Steve Langasek <email address hidden>  Wed, 22 Jun 2016 01:26:31 +0000
Superseded in yakkety-proposed on 2016-06-22
lsb (9.20160110ubuntu3) yakkety; urgency=medium

  * lsb_release.py: restore support for querying the list of installed
    modules, since for the moment some modules are still supported.

 -- Steve Langasek <email address hidden>  Tue, 21 Jun 2016 21:25:00 +0000
Superseded in yakkety-proposed on 2016-06-21
lsb (9.20160110ubuntu2) yakkety; urgency=medium

  [ Till Kamppeter ]
  * Re-added LSB compatibility packages, so that auto-downloadable
    LSB-based printer driver packages work.  Thanks to Till Kammpeter
    for the patch.  LP: #1536353
  * Added Conflicts/Replaces against cups-filters-invalid-mta and
    cups-filters-lsb for upgrade compatibility from the Xenial development
    cycle.

 -- Steve Langasek <email address hidden>  Sat, 18 Jun 2016 17:16:59 +0000
Published in trusty-updates on 2016-09-13
Deleted in trusty-proposed (Reason: moved to -updates)
lsb (4.1+Debian11ubuntu6.2) trusty; urgency=medium

  * 01-upstart-lsb: when diverting an init script to an upstart job, we
    can't directly map the 'status' subcommand to /sbin/status because the
    return value of the latter is always 0 if we communicated successfully
    with upstart.  Instead, parse the output of the command to correctly map
    this to the LSB return codes.  LP: #1582813.

 -- Steve Langasek <email address hidden>  Tue, 17 May 2016 17:07:10 -0700
Superseded in yakkety-release on 2016-06-27
Deleted in yakkety-proposed on 2016-06-28 (Reason: moved to release)
lsb (9.20160110ubuntu1) yakkety; urgency=medium

  * 01-upstart-lsb: when diverting an init script to an upstart job, we
    can't directly map the 'status' subcommand to /sbin/status because the
    return value of the latter is always 0 if we communicated successfully
    with upstart.  Instead, parse the output of the command to correctly map
    this to the LSB return codes.  LP: #1582813.

 -- Steve Langasek <email address hidden>  Tue, 17 May 2016 17:04:06 -0700
Superseded in yakkety-release on 2016-05-19
Published in xenial-release on 2016-01-12
Deleted in xenial-proposed (Reason: moved to release)
lsb (9.20160110) unstable; urgency=medium

  * Merge the last Ubuntu diff

  [ St├ęphane Graber & Dimitri John Ledkov ]
  * Add 01-upstart-lsb from the upstart package, and make executing rc.d
    scripts no-op if there is an upstart job for that script

 -- Didier Raboud <email address hidden>  Sun, 10 Jan 2016 12:32:59 +0100
Superseded in xenial-release on 2016-01-12
Deleted in xenial-proposed on 2016-01-14 (Reason: moved to release)
lsb (9.20150917ubuntu1) xenial; urgency=medium

  * Merge from Debian unstable, remaining changes:
    - Add 01-upstart-lsb hook, to make executing rc.d scripts no-op if
    there is an upstart job for that script.

  * Dropped changes, merged upstream:
    - Drop pyshared usage, well, dist-packages symlinks are in place.
    - lsb-$foo packages are gone, hence dependencies/m-a changes are
    irrelevant now.
    - python3 port is accepted in Debian, and used by default.
    - tests pass under Ubuntu
    - status_of_proc operations are correct in Debian now too. However,
    mostly irrelevant to us, as on most systems systemd determines status
    for us anyway.

Superseded in trusty-updates on 2016-09-13
Deleted in trusty-proposed on 2016-09-14 (Reason: moved to -updates)
lsb (4.1+Debian11ubuntu6.1) trusty; urgency=medium

  * Add 01-upstart-lsb from the upstart package and make
    executing rc.d scripts no-op if there is an upstart
    job for that script. (LP: #1273462)

 -- Zhang Hua <email address hidden>  Thu, 06 Aug 2015 11:11:16 -0500
Superseded in xenial-release on 2015-11-22
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-22 (Reason: moved to release)
lsb (4.1+Debian11ubuntu8) utopic; urgency=medium

  * Modify 01-upstart-lsb hook, to make executing rc.d scripts no-op if
    there is an upstart job for that script.
 -- Dimitri John Ledkov <email address hidden>   Fri, 30 May 2014 11:38:47 +0200
Superseded in utopic-release on 2014-05-30
Deleted in utopic-proposed on 2014-05-31 (Reason: moved to release)
lsb (4.1+Debian11ubuntu7) utopic; urgency=medium

  * Add 01-upstart-lsb from the upstart package.
 -- Stephane Graber <email address hidden>   Tue, 27 May 2014 16:18:04 +0200
Superseded in utopic-release on 2014-05-28
Published in trusty-release on 2014-02-24
Deleted in trusty-proposed (Reason: moved to release)
lsb (4.1+Debian11ubuntu6) trusty; urgency=medium

  * Don't hardcode pyshared in the install files.
 -- Matthias Klose <email address hidden>   Sun, 23 Feb 2014 17:06:48 +0100
Superseded in trusty-proposed on 2014-02-23
lsb (4.1+Debian11ubuntu5) trusty; urgency=medium

  * Rebuild to drop files installed into /usr/share/pyshared.
 -- Matthias Klose <email address hidden>   Sun, 23 Feb 2014 13:48:36 +0000
Superseded in trusty-release on 2014-02-24
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
lsb (4.1+Debian11ubuntu4) saucy; urgency=low

  * Allow lsb-printing to depend on cups-filters | ghostscript-cups.
 -- Adam Conrad <email address hidden>   Mon, 09 Sep 2013 10:17:15 -0400
Obsolete in quantal-proposed on 2015-04-24
lsb (4.0-0ubuntu26.4) quantal-proposed; urgency=low

  * initdutils.py: Fully fix issues with Python 3. (LP: #1035136)
 -- Brian Murray <email address hidden>   Thu, 22 Aug 2013 15:16:33 -0700

Available diffs

Obsolete in raring-updates on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to -updates)
lsb (4.0-0ubuntu27.3) raring-proposed; urgency=low

  * initdutils.py: Fully fix issues with Python 3.  (LP: #1035136)
 -- Brian Murray <email address hidden>   Thu, 22 Aug 2013 15:10:16 -0700
Superseded in raring-proposed on 2013-08-29
lsb (4.0-0ubuntu27.2) raring-proposed; urgency=low

  * debian/rules: Add necessary 2to3.
  * initdutils.py: Fix issues with Python 3.  LP: #1035136
 -- Ma Xiaojun <email address hidden>   Mon, 01 Jul 2013 21:12:33 +0800

Available diffs

Superseded in quantal-proposed on 2013-08-29
lsb (4.0-0ubuntu26.3) quantal-proposed; urgency=low

  * debian/rules: Add necessary 2to3.
  * initdutils.py: Fix issues with Python 3.  LP: #1035136
 -- Ma Xiaojun <email address hidden>   Mon, 01 Jul 2013 21:30:05 +0800

Available diffs

Superseded in saucy-release on 2013-09-09
Deleted in saucy-proposed on 2013-09-10 (Reason: moved to release)
lsb (4.1+Debian11ubuntu3) saucy; urgency=low

  * Use open() rather than file() in initdutils.py, for Python 3
    compatibility (see LP #1035136).
  * Test fileob and strob against None in RFC822Parser.__init__ rather than
    testing their truth value, to avoid a misleading error in the case of a
    file with no LSB headers.
 -- Colin Watson <email address hidden>   Mon, 01 Jul 2013 12:36:13 +0100
Published in precise-updates on 2013-08-12
Deleted in precise-proposed (Reason: moved to -updates)
lsb (4.0-0ubuntu20.3) precise-proposed; urgency=low

  * lsb_release.py: Use the subprocess module instead of the commands
    module to work around Python SIGCHLD handler issue9127.  LP: #1094218
 -- Barry Warsaw <email address hidden>   Thu, 06 Jun 2013 17:21:04 -0400
Obsolete in quantal-updates on 2015-04-24
Deleted in quantal-proposed on 2015-05-01 (Reason: moved to -updates)
lsb (4.0-0ubuntu26.2) quantal-proposed; urgency=low

  * lsb_release.py: Use the subprocess module instead of the commands
    module to work around Python SIGCHLD handler issue9127.  LP: #1094218
 -- Barry Warsaw <email address hidden>   Thu, 13 Jun 2013 10:22:16 -0400
Superseded in raring-updates on 2013-09-12
Deleted in raring-proposed on 2013-09-14 (Reason: moved to -updates)
lsb (4.0-0ubuntu27.1) raring-proposed; urgency=low

  * lsb_release.py: Use the subprocess module instead of the commands
    module to work around Python SIGCHLD handler issue9127.  LP: #1094218
 -- Barry Warsaw <email address hidden>   Thu, 06 Jun 2013 16:35:30 -0400

Available diffs

Superseded in saucy-release on 2013-07-01
Deleted in saucy-proposed on 2013-07-03 (Reason: moved to release)
lsb (4.1+Debian11ubuntu2) saucy; urgency=low

  * Only run the tests under python3, correcting a build failure due to
    mismatched test expectations.
  * test/test_lsb_release.py: also, make lsb_release ignore dpkg origins
    for the test, otherwise the test fails on Ubuntu.
 -- Steve Langasek <email address hidden>   Sun, 19 May 2013 05:52:09 +0000
Superseded in saucy-proposed on 2013-05-19
lsb (4.1+Debian11ubuntu1) saucy; urgency=low

  * Merge from Debian unstable, remaining changes:
    - Mark lsb-core Multi-Arch: foreign.
    - Use python3 instead of python2.
    - Fix status_of_proc returning incorrect error code; and when a pidfile
      is specified, return "unknown" if it exists but isn't readable (as
      would be the case for non-root with a root-only pidfile), and return
      "not running" if the pidfile otherwise doesn't provide a useful PID.
      This issue may also be fixed now in the Debian version, but someone
      needs to compare the differing implementations to verify before this
      delta can be dropped.
    - Prefer mailx (main) over mailutils (universe)
    - Depend directly on libnss3 and libnspr4 rather than via the
      transitional packages libnss3-1d and libnspr4-0d.
  * Changes included in Debian:
    - lsb_release: Add -Es to #! line for Python.
    - Correct duplicate reference to log_action_end_msg_post in
      debian/lsb-base.README.Debian.
    - Fix debian/copyright to list the correct Canonical copyright for the
      Ubuntu logging functions.
    - Revert use of /bin/echo for echo-n.
    - Port initdutils.py to python3 so that the tests will pass at build
      time.
    - Fix build failure when only building architecture-dependent packages
      on Ubuntu.

Superseded in saucy-release on 2013-05-19
Deleted in saucy-proposed on 2013-05-20 (Reason: moved to release)
lsb (4.1+Debian9ubuntu4) saucy; urgency=low

  * Depend directly on libnss3 and libnspr4 rather than via the transitional
    packages libnss3-1d and libnspr4-0d.
 -- Colin Watson <email address hidden>   Thu, 16 May 2013 14:48:45 +0100
Superseded in saucy-release on 2013-05-16
Deleted in saucy-proposed on 2013-05-17 (Reason: moved to release)
lsb (4.1+Debian9ubuntu3) saucy; urgency=low

  * Prefer mailx over mailutils; this apparently was a deliberate (but
    undocumented) delta in Ubuntu.
 -- Steve Langasek <email address hidden>   Wed, 15 May 2013 17:49:45 +0000
Superseded in saucy-release on 2013-05-15
Deleted in saucy-proposed on 2013-05-17 (Reason: moved to release)
lsb (4.1+Debian9ubuntu2) saucy; urgency=low

  * Fix build failure when only building architecture-dependent packages.
 -- Steve Langasek <email address hidden>   Wed, 15 May 2013 04:22:58 -0500
Superseded in saucy-proposed on 2013-05-15
lsb (4.1+Debian9ubuntu1) saucy; urgency=low

  * Merge from Debian unstable:
    - lsb-desktop no longer depends on transitional libqt4-gui.  LP: #339501.
    - lsb-invalid-mta includes /usr/lib/sendmail as a symlink.  LP: #580914.
    - fixes a typo in the package description.  LP: #1177473.
  * Remaining changes:
    - Mark lsb-core Multi-Arch: foreign.
    - Use python3 instead of python2.
    - Fix status_of_proc returning incorrect error code; and when a pidfile
      is specified, return "unknown" if it exists but isn't readable (as
      would be the case for non-root with a root-only pidfile), and return
      "not running" if the pidfile otherwise doesn't provide a useful PID.
      This issue may also be fixed now in the Debian version, but someone
      needs to compare the differing implementations to verify before this
      delta can be dropped.
    - Correct duplicate reference to log_action_end_msg_post in
      debian/lsb-base.README.Debian.
    - lsb_release: Add -Es to #! line for Python.
  * Dropped changes, included in Debian:
    - Mark lsb-release and lsb-base Multi-Arch: foreign.
    - Drop Qt3 from lsb-desktop depends and add lsb-desktop.NEWS to explain
      its absence
    - Depend on libgl1-mesa-glx rather than libgl1-mesa as preferred libgl1
      alternative.
    - Use dpkg --print-architecture rather than
      --print-installation-architecture.
    - Use $DPKG_MAINTSCRIPT_ARCH in the maintainer scripts to decide the
      correct symlinks to set up, instead of going by the dpkg built-in
      architecture.
    - Don't conflict with python (>= 2.6).
    - Use dh_python2
    - lsb_release.py: Ensure that files are closed promptly; Python 3.2
      prints ResourceWarning noise otherwise.
    - Skip calling apt-cache if /etc/lsb-release contains everything we need.
    - sendmail, debian/control, debian/rules, debian/lsb-invalid-mta.dirs:
      include new "lsb-invalid-mta" package.
    - Remove /usr/lib/pymodules/python2.6/lsb_release.py on upgrades; this
      was a karmic-only upgrade issue that we could have removed the
      handling for back in maverick, better late than never.
    - Add Ubuntu logging functions.
    - Added ghostscript-cups dependency.
    - Made lsb-printing required by the lsb package, not just suggested.
  * lsb-languages must depend on python, not on python3, as /usr/bin/python is
    the interface guaranteed by this submodule.
  * Fix debian/copyright to list the correct Canonical copyright for the
    Ubuntu logging functions.
  * Revert wrongheaded calls to /bin/echo whenever -n is used; 'echo -n' is
    guaranteed by Debian policy, we don't want a bunch of extra forks here
    for no reason.
  * Port initdutils.py to python3 so that the tests will pass at build time.
  * Call 2to3 correctly so that the scripts in /usr/lib/lsb are usable under
    python3.  LP: #798192.

Superseded in precise-updates on 2013-08-12
Deleted in precise-proposed on 2013-08-14 (Reason: moved to -updates)
lsb (4.0-0ubuntu20.2) precise-proposed; urgency=low

  * lsb_release: Add -Es to #! line for Python so that it will ignore
    the $PYTHON* environment variables, and not add the user's site
    directory to sys.path.  Both of these are general recommendations that
    should apply to all system scripts, but in this case fixes LP: #938869
 -- Barry Warsaw <email address hidden>   Tue, 23 Oct 2012 20:20:42 -0400

Available diffs

Superseded in quantal-updates on 2013-08-12
Deleted in quantal-proposed on 2013-08-14 (Reason: moved to -updates)
lsb (4.0-0ubuntu26.1) quantal-proposed; urgency=low

  * lsb_release: Add -Es to #! line for Python so that it will ignore
    the $PYTHON* environment variables, and not add the user's site
    directory to sys.path.  Both of these are general recommendations that
    should apply to all system scripts, but in this case fixes LP: #938869
 -- Barry Warsaw <email address hidden>   Tue, 23 Oct 2012 18:52:45 -0400

Available diffs

Superseded in saucy-release on 2013-05-15
Obsolete in raring-release on 2015-04-24
lsb (4.0-0ubuntu27) raring; urgency=low

  * lsb_release: Add -Es to #! line for Python so that it will ignore
    the $PYTHON* environment variables, and not add the user's site
    directory to sys.path.  Both of these are general recommendations that
    should apply to all system scripts, but in this case fixes LP: #938869
 -- Barry Warsaw <email address hidden>   Tue, 23 Oct 2012 18:48:21 -0400

Available diffs

Obsolete in lucid-updates on 2016-10-26
Deleted in lucid-proposed on 2016-11-01 (Reason: moved to -updates)
lsb (4.0-0ubuntu8.1) lucid-proposed; urgency=low

  * If a pidfile is specified, but doesn't provide a PID
    to test, return 'not running', and return 'unknown'
    if the pidfile exists but is unreadable (LP: #683640)
 -- Adam Stokes <email address hidden>   Wed, 10 Oct 2012 14:26:06 -0400

Available diffs

Superseded in precise-proposed on 2012-10-24
lsb (4.0-0ubuntu20.1) precise-proposed; urgency=low

  * If a pidfile is specified, but doesn't provide a PID
    to test, return 'not running', and return 'unknown'
    if the pidfile exists but is unreadable (LP: #683640)
 -- Adam Stokes <email address hidden>   Wed, 10 Oct 2012 14:26:06 -0400

Available diffs

Superseded in raring-release on 2012-10-24
Obsolete in quantal-release on 2015-04-24
lsb (4.0-0ubuntu26) quantal; urgency=low

  * When a pidfile is specified, but fails to produce a PID to test,
    return "unknown" if it exists but isn't readable (as would be
    the case for non-root with a root-only pidfile), and return "not
    running" if the pidfile otherwise doesn't provide a useful PID.
 -- Adam Conrad <email address hidden>   Wed, 10 Oct 2012 11:21:48 -0600

Available diffs

Superseded in quantal-release on 2012-10-10
lsb (4.0-0ubuntu25) quantal; urgency=low

  * Fix regression from 4.0-0ubuntu23 that would cause status_of_proc
    to return success if asked to find a service by pidfile, while an
    entirely different copy (chroot, different user, etc) was running
 -- Adam Conrad <email address hidden>   Wed, 10 Oct 2012 10:20:42 -0600

Available diffs

Superseded in quantal-release on 2012-10-10
lsb (4.0-0ubuntu24) quantal; urgency=low

  * Drop Qt3 from lsb-desktop depends and add lsb-desktop.NEWS to explain its
    absence (following Debian) (LP: #1029476)
    - Needed for Qt3 removal
 -- Scott Kitterman <email address hidden>   Fri, 28 Sep 2012 20:32:15 -0400

Available diffs

Superseded in quantal-release on 2012-09-29
lsb (4.0-0ubuntu23) quantal; urgency=low

  * Fix status_of_proc returning incorrect error code (LP: #683640)
 -- Adam Stokes <email address hidden>   Tue, 24 Jul 2012 13:26:54 -0700

Available diffs

Superseded in quantal-release on 2012-08-15
lsb (4.0-0ubuntu22) quantal; urgency=low

  * Use python3 instead of python2 (again).
 -- Matthias Klose <email address hidden>   Wed, 25 Apr 2012 12:49:32 +0200

Available diffs

Superseded in quantal-release on 2012-04-26
Published in precise-release on 2012-02-24
lsb (4.0-0ubuntu20) precise; urgency=low

  * Revert back to using python 2, in a desperate act to get the CDs back in
    size by dropping Python 3. My special condolences to Barry!
 -- Martin Pitt <email address hidden>   Fri, 24 Feb 2012 17:52:31 +0100

Available diffs

Superseded in precise-release on 2012-02-24
lsb (4.0-0ubuntu19) precise; urgency=low

  * Mark lsb-base Multi-Arch: foreign (LP: #904013).
 -- Colin Watson <email address hidden>   Thu, 19 Jan 2012 16:59:48 +0000

Available diffs

Superseded in precise-release on 2012-01-19
lsb (4.0-0ubuntu18) precise; urgency=low

  * lsb_release.py: Ensure that files are closed promptly; Python 3.2 prints
    ResourceWarning noise otherwise.
 -- Colin Watson <email address hidden>   Thu, 19 Jan 2012 16:53:06 +0000

Available diffs

Superseded in precise-release on 2012-01-19
lsb (4.0-0ubuntu17) precise; urgency=low

  * Use python3 instead of python2.
 -- Matthias Klose <email address hidden>   Thu, 01 Dec 2011 14:58:09 +0100

Available diffs

Superseded in precise-release on 2011-12-01
Obsolete in oneiric-release on 2015-04-24
lsb (4.0-0ubuntu16) oneiric; urgency=low

  * Cherry-pick from Debian 3.2-28 (LP: #837745):
    - Fix symlinks for AMD64.  (Closes: #638450)
 -- Colin Watson <email address hidden>   Mon, 19 Sep 2011 10:20:31 +0100

Available diffs

Superseded in oneiric-release on 2011-09-19
lsb (4.0-0ubuntu15) oneiric; urgency=low

  * Use python (2.x) again for the scripts.
 -- Matthias Klose <email address hidden>   Thu, 25 Aug 2011 17:01:44 +0200

Available diffs

Superseded in oneiric-release on 2011-08-25
lsb (4.0-0ubuntu14) oneiric; urgency=low

  * Use $DPKG_MAINTSCRIPT_ARCH in the maintainer scripts to decide the correct
    symlinks to set up, instead of going by the dpkg built-in architecture.
  * Mark lsb-release Multi-Arch: foreign.
  * Mark lsb-core as Multi-Arch: foreign.  This is *incorrect*, because a
    given package needs the libraries of the corresponding architecture; but
    the common case is i386+amd64, where an amd64 lsb-core actually does
    guarantee that the i386 dependencies are satisfied via biarch, so we do
    this so we can have things like googleearth installable instead of having
    to worry about libncurses5 for oneiric.
 -- Steve Langasek <email address hidden>   Mon, 15 Aug 2011 18:43:56 -0700

Available diffs

Superseded in oneiric-release on 2011-08-16
lsb (4.0-0ubuntu13) oneiric; urgency=low

  * Use python3 instead of python2.
 -- Matthias Klose <email address hidden>   Fri, 10 Jun 2011 14:42:43 +0200

Available diffs

Superseded in oneiric-release on 2011-06-10
lsb (4.0-0ubuntu12) oneiric; urgency=low

  * switch from python-central to dh_python2
  * add "python" manually as a dependency for lsb-core, this used
    to get add by ${python:Depends} but its missing now
 -- Michael Vogt <email address hidden>   Fri, 10 Jun 2011 13:41:04 +0200

Available diffs

Superseded in oneiric-release on 2011-06-10
Obsolete in natty-release on 2013-06-04
lsb (4.0-0ubuntu11) natty; urgency=low

  * Make sure LOG_DAEMON_MSG is set to avoid init scripts crashing when
    running with -u (LP: #770381)
 -- Stephane Graber <email address hidden>   Mon, 25 Apr 2011 13:13:07 -0400

Available diffs

Superseded in natty-release on 2011-04-25
lsb (4.0-0ubuntu10) natty; urgency=low

  * Make lsb-base-logging-ubuntu.sh plymouth-aware (LP: #752393)
    When booting with plymouth running, log_daemon_msg now stores its output
    in a variable until log_end_msg is called. Avoid buffering issue.
 -- Stephane Graber <email address hidden>   Mon, 11 Apr 2011 14:05:55 -0400

Available diffs

Superseded in natty-release on 2011-04-11
lsb (4.0-0ubuntu9) natty; urgency=low

  * Rebuild to add support for python 2.7.
 -- Matthias Klose <email address hidden>   Fri, 03 Dec 2010 00:04:26 +0000

Available diffs

Superseded in natty-release on 2010-12-03
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
lsb (4.0-0ubuntu8) lucid; urgency=low

  * sendmail, debian/control, debian/rules, debian/lsb-invalid-mta.dirs:
    Added new binary package "lsb-invalid-mta" containing a fake
    /usr/sbin/sendmail so that the installation of LSB packages does not
    pull in an MTA any more, which once adds awkward configuration questions
    to the installation process and second adds an often unnneeded daemon to
    the system (LP: #141641).

  * debian/control: The LSB requires the printing environment already
    since version 3.2. Made lsb-printing required by the "lsb" package
    not only suggested (LP: #386128).
 -- Till Kamppeter <email address hidden>   Mon, 22 Feb 2010 23:50:49 +0100

Available diffs

Superseded in lucid-release on 2010-02-23
lsb (4.0-0ubuntu7) lucid; urgency=low

  * Remove /usr/lib/pymodules/python2.6/lsb_release.py on upgrades; this might
    have stayed behind due to using python-support in intermediate karmic
    development versions; LP: #418017.
 -- Loic Minier <email address hidden>   Fri, 18 Dec 2009 15:34:25 +0100

Available diffs

Superseded in lucid-release on 2009-12-18
lsb (4.0-0ubuntu6) lucid; urgency=low

  * lsb-base-logging-ubuntu.sh: Remove the log_to_console madness, it doesn't
    work with Plymouth anyway.
 -- Scott James Remnant <email address hidden>   Fri, 04 Dec 2009 11:46:53 +0000

Available diffs

Superseded in lucid-release on 2009-12-04
Obsolete in karmic-release on 2013-03-04
lsb (4.0-0ubuntu5) karmic; urgency=low

  * lsb-base-logging-ubuntu.sh: Honour CONSOLE environment variable and use
    it for output instead of /dev/console if it's set (LP: #440871).

 -- Colin Watson <email address hidden>   Thu, 08 Oct 2009 19:53:53 +0100

Available diffs

Superseded in karmic-release on 2009-10-08
lsb (4.0-0ubuntu4) karmic; urgency=low

  * Merge 3.2-23 from Debian, fixing TERM handling in log_use_fancy_output
    (LP: #418461).
  * Use dpkg --print-architecture rather than
    --print-installation-architecture (LP: #403316).

Available diffs

Superseded in karmic-release on 2009-09-10
lsb (4.0-0ubuntu3) karmic; urgency=low

  * rebuild using python-central and DH_PYCENTRAL=include-links
    (LP: #383697)
  * debian/control:
    - set XS-Python-Version to "all"
    - depend on python-central
  * debian/lsb-release.dirs, debian/rules:
    - install into usr/share/pyshared/

 -- Michael Vogt <email address hidden>   Fri, 21 Aug 2009 16:44:13 +0200

Available diffs

Superseded in karmic-release on 2009-08-21
lsb (4.0-0ubuntu2) karmic; urgency=low

  * debian/control: Added ghostscript-cups dependency (LP: #385606).

 -- Till Kamppeter <email address hidden>   Thu, 11 Jun 2009 23:43:49 +0200

Available diffs

Obsolete in jaunty-updates on 2013-02-28
Deleted in jaunty-proposed on 2013-02-28 (Reason: moved to -updates)
lsb (4.0-0ubuntu0.9.04.1) jaunty-proposed; urgency=low

  * Upgrade to support LSB 4.0.  LP: #370066.

 -- Jeff Licquia <email address hidden>   Thu, 30 Apr 2009 15:14:24 -0400
Obsolete in hardy-updates on 2015-04-24
Deleted in hardy-proposed on 2015-04-30 (Reason: moved to -updates)
lsb (4.0-0ubuntu0.8.04.1) hardy-proposed; urgency=low

  * Upgrade to support LSB 4.0.  LP: #370066

 -- Jeff Licquia <email address hidden>   Thu, 30 Apr 2009 15:14:24 -0400
Superseded in karmic-release on 2009-06-15
lsb (4.0-0ubuntu1) karmic; urgency=low

  * Merge from Debian unstable, remaining changes:
    - lsb-base-logging-ubuntu.sh: change log_{success,warning,failure}_msg()
      to use usplash_write "TEXT" instead of "STATUS" to avoid unreadable
      line-wrapping when using usplash in verbose mode.
    - Don't conflict with python (>= 2.6).
    - Depend on postfix rather than exim4 as preferred mail-transport-agent
      alternative.
    - Depend on libgl1-mesa-glx rather than libgl1-mesa as preferred libgl1
      alternative.
    - Since /etc/lsb-release overrides detected information, there's no
      need to try and detect that information if lsb-release contains
      everything we need.  This saves us calling the hugely expensive
      apt-cache.
    - Add Ubuntu logging functions.

  [ Jeff Licquia ]
  * Upgrade to support LSB 4.0.

Available diffs

Superseded in karmic-release on 2009-06-02
Obsolete in jaunty-release on 2013-02-28
lsb (3.2-20ubuntu4) jaunty; urgency=low

  * Replace the deprecated Python sets module with the builtin set type,
    if it is available (python >= 2.4), to avoid spewing warnings for
    python >= 2.6.  (LP: #336436)

 -- Anders Kaseorg <email address hidden>   Mon, 02 Mar 2009 03:35:14 -0500

Available diffs

Superseded in jaunty-release on 2009-03-02
lsb (3.2-20ubuntu3) jaunty; urgency=low

  * lsb-base-logging-ubuntu.sh: change log_{success,warning,failure}_msg()
    to use usplash_write "TEXT" instead of "STATUS" to avoid unreadable
    line-wrapping when using usplash in verbose mode (LP: #291543).

 -- Kees Cook <email address hidden>   Sat, 07 Feb 2009 14:22:19 -0800

Available diffs

Superseded in jaunty-release on 2009-02-09
lsb (3.2-20ubuntu2) jaunty; urgency=low

  * Since /etc/lsb-release overrides detected information, there's no
    need to try and detect that information if lsb-release contains
    everything we need.  This saves us calling the hugely expensive
    apt-cache.   LP: #262050.

 -- Scott James Remnant <email address hidden>   Thu, 15 Jan 2009 21:24:13 +0000

Available diffs

Superseded in jaunty-release on 2009-01-15
lsb (3.2-20ubuntu1) jaunty; urgency=low

  * Resynchronise with Debian (cups dependency change fixes LP: #279345).
    Remaining changes:
    - Don't conflict with python (>= 2.6).
    - Depend on postfix rather than exim4 as preferred mail-transport-agent
      alternative.
    - Depend on libgl1-mesa-glx rather than libgl1-mesa as preferred libgl1
      alternative.
    - Add Ubuntu logging functions.
  * Revert some apparently unintentional dependency changes on the Ubuntu
    side of the merge: move libncurses5 and libpam0g dependencies back from
    lsb-base to lsb-core; set lsb's dependencies on lsb-printing,
    lsb-multimedia, and lsb-languages back to suggestions; and remove lsb's
    suggestion of lsb-qt4.

Available diffs

Superseded in jaunty-release on 2008-11-04
Obsolete in intrepid-release on 2013-02-20
lsb (3.2-14ubuntu2) intrepid; urgency=low

  * Backport from Debian:
    - Fix log_action_end_msg_pre function definition (_post was defined
      twice). (LP: #262680)

 -- Colin Watson <email address hidden>   Tue, 16 Sep 2008 13:44:44 +0100

Available diffs

Superseded in intrepid-release on 2008-09-16
lsb (3.2-14ubuntu1) intrepid; urgency=low

  * Merge from debian unstable (LP: #249059), remaining changes:
    - debian/control:
      + Remove python from conflicts
      + Keep Ubuntu's Depends and Suggests
      + Update maintainer
    - debian/rules:
      + copy lsb-base-logging-ubuntu.sh
    - lsb-base-logging-ubuntu.sh:
      + logging functions suitable for Ubuntu
  * Dropped changes
    - Debian has accepted all of the status_of_proc() functionality

Available diffs

Superseded in intrepid-release on 2008-07-21
lsb (3.2-12ubuntu3) intrepid; urgency=low

  * init-functions:
    - In pidofproc(), if the kill -0 fails, use ps to detect if
      the proc is running.
    - Revert status_of_proc() functionality *back* to using pidofproc()
      now that it can run as non-root (LP: #246735).
    - Add support for passing a -p $pidfile parameter.

 -- Dustin Kirkland <email address hidden>   Wed, 09 Jul 2008 16:15:05 -0500

Available diffs

Superseded in intrepid-release on 2008-07-09
lsb (3.2-12ubuntu2) intrepid; urgency=low

  * init-functions: Replace pidofproc() call in status_of_proc() with a
    /bin/pidof call, to allow any user to query service status (LP: #246735).

 -- Dustin Kirkland <email address hidden>   Tue, 08 Jul 2008 15:38:55 -0500

Available diffs

Superseded in intrepid-release on 2008-07-08
lsb (3.2-12ubuntu1) intrepid; urgency=low

  * Merge from debian unstable, remaining changes:
    - init-functions:
      + Debian has a "return 0" that should be "return 3" per LSB spec
      + Make pidof call "set -e safe", LP: #204594
      + Add status_of_proc() function, LP: #203169
    - debian/control:
      + Remove python from conflicts
      + Keep Ubuntu's Depends and Suggests

 -- Dustin Kirkland <email address hidden>   Wed, 04 Jun 2008 13:18:56 -0500

Available diffs

175 of 96 results