lua5.3 5.3.3-1ubuntu0.18.10.1 source package in Ubuntu

Changelog

lua5.3 (5.3.3-1ubuntu0.18.10.1) cosmic-security; urgency=medium

  * SECURITY UPDATE: use-after-free
    - debian/patches/CVE-2019-6706.patch: fix in src/lapi.c.
    - CVE-2019-6706

 -- <email address hidden> (Leonidas S. Barbosa)  Thu, 04 Apr 2019 14:26:37 -0300

Upload details

Uploaded by:
Leonidas S. Barbosa on 2019-04-05
Uploaded to:
Cosmic
Original maintainer:
Ubuntu Developers
Architectures:
any
Section:
interpreters
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Cosmic updates on 2019-04-08 main misc
Cosmic security on 2019-04-08 main misc

Downloads

File Size SHA-256 Checksum
lua5.3_5.3.3.orig.tar.gz 287.4 KiB 5113c06884f7de453ce57702abaac1d618307f33f6789fa870e87a59d772aca2
lua5.3_5.3.3-1ubuntu0.18.10.1.debian.tar.xz 7.9 KiB f697c4119f89039565bc35d42088a87114f1e598fc9fd9991e68072e83d8fc0c
lua5.3_5.3.3-1ubuntu0.18.10.1.dsc 2.1 KiB afcdaec37e3d4003015a7e94a35123bf044c97707e494eb2532c7bc7b66c8106

View changes file

Binary packages built by this source

liblua5.3-0: Shared library for the Lua interpreter version 5.3

 Lua is a powerful, light-weight programming language designed for extending
 applications. The language engine is accessible as a library, having a C
 API which allows the application to exchange data with Lua programs and also
 to extend Lua with C functions. Lua is also used as a general-purpose,
 stand-alone language through the simple command line interpreter provided.
 .
 This package contains runtime libraries. You shouldn't need to install it
 explicitly.

liblua5.3-0-dbg: Debug symbols for the Lua shared library interpreter

 This package contains the debugging symbols for liblua5.3 and lua5.3

liblua5.3-dev: Development files for the Lua language version 5.3

 Lua is a powerful, light-weight programming language designed for extending
 applications. The language engine is accessible as a library, having a C
 API which allows the application to exchange data with Lua programs and also
 to extend Lua with C functions. Lua is also used as a general-purpose,
 stand-alone language through the simple command line interpreter provided.
 .
 This package contains developer resources for using the Lua library.
 Install it if you are developing programs which use the Lua C API.
 .
 This package also contains the official manual covering the Lua language
 and C API.

lua5.3: Simple, extensible, embeddable programming language

 Lua is a powerful, light-weight programming language designed for extending
 applications. The language engine is accessible as a library, having a C
 API which allows the application to exchange data with Lua programs and also
 to extend Lua with C functions. Lua is also used as a general-purpose,
 stand-alone language through the simple command line interpreter provided.
 .
 This package contains the Lua command line interpreter and bytecode compiler.
 Install it if you are developing or using Lua scripts.