Change log for m2300w package in Ubuntu

123 of 23 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2018-02-11
Deleted in bionic-proposed (Reason: moved to release)
m2300w (0.51-13) unstable; urgency=medium

  * Bump Standards-Version to 4.1.3 without changes needed
  * Update Vcs-* fields for the move to salsa.d.o
  * Initialize git-dpm

 -- Didier Raboud <email address hidden>  Sat, 10 Feb 2018 16:39:35 +0100
Superseded in bionic-release on 2018-02-11
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed (Reason: moved to release)
m2300w (0.51-12build1) zesty; urgency=medium

  * No-change rebuild to pick up -fPIE compiler default in static
    libraries

 -- Steve Langasek <email address hidden>  Wed, 12 Apr 2017 15:49:55 +0000
Superseded in zesty-release on 2017-04-12
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed (Reason: moved to release)
m2300w (0.51-12) unstable; urgency=medium


  * Move the repository from collab-maint to printing; update the VCS-* fields
    accordingly

 -- Didier Raboud <email address hidden>  Thu, 06 Mar 2014 16:04:07 +0100

Available diffs

Superseded in utopic-release on 2014-04-26
Published in trusty-release on 2013-12-07
Deleted in trusty-proposed (Reason: moved to release)
m2300w (0.51-11) unstable; urgency=low


  [ Didier Raboud ]
  * Add cups-filters >= 1.0.42 as first alternative dependency to
    foomatic-filters, also replace it in build-depends
  * Drop m2300w transitional package which reached stable
  * Bump Standards-Version to 3.9.5 without changes needed
  * Add patch to make sure CPPFLAGS and LDFLAGS are dpkg-buildflags'
  * Add patch to search foomatic-rip in cups filters, not in system
    binaries
  * Use dh-autoreconf to let the above patch apply to the build
  * Add patch to fix bashism in m2300-wrapper (Closes: #690634)

  [ Bart Martens ]
  * Update debian/watch

 -- Didier Raboud <email address hidden>  Fri, 06 Dec 2013 23:59:37 +0100

Available diffs

Superseded in trusty-release on 2013-12-07
Deleted in trusty-proposed on 2013-12-11 (Reason: moved to release)
m2300w (0.51-10) unstable; urgency=low


  * Rebuild against pyppd >= 1.0.1

 -- Didier Raboud <email address hidden>  Fri, 13 Sep 2013 12:48:28 +0200

Available diffs

Superseded in trusty-release on 2013-10-21
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
m2300w (0.51-9) unstable; urgency=low


  * Upload to unstable.

 -- Didier Raboud <email address hidden>  Sun, 19 May 2013 11:00:25 +0200

Available diffs

Superseded in saucy-release on 2013-05-20
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
m2300w (0.51-7ubuntu1) quantal; urgency=low

  * debian/control: Removed unneeded build dependencies on Foomatic packages.
 -- Till Kamppeter <email address hidden>   Tue, 11 Sep 2012 11:12:27 +0200

Available diffs

Superseded in quantal-release on 2012-09-11
Published in precise-release on 2012-02-15
m2300w (0.51-7) unstable; urgency=low


  * Bump Build-Dependency on pyppd to ensure that the compressed PPDs archive
    is correctly named.

 -- Didier Raboud <email address hidden>  Mon, 24 Oct 2011 21:12:45 +0200
Superseded in precise-release on 2012-02-15
Obsolete in oneiric-release on 2015-04-24
m2300w (0.51-0ubuntu15) oneiric; urgency=low

  * debian/rules: Added PPD files for the KONICA MINOLTA versions of the
    magicolor 2300W/2400W (LP: #250583).
  * debian/rules, debian/control: Compress PPD files with pyppd.
  * debian/rules, debian/control, debian/m2300w.postinst,
    debian/m2300w.ppd-updater: Let automatic update of the PPDs of already
    existing print queues be done by CUPS.
 -- Till Kamppeter <email address hidden>   Fri, 19 Aug 2011 20:37:23 +0200

Available diffs

Superseded in oneiric-release on 2011-08-19
m2300w (0.51-0ubuntu14) oneiric; urgency=low

  * debian/control: Versioned build dependency on foomatic-db to assure that
    the Ubuntu build server installs the physical package foomatic-db and
    not foomatic-db-compressed-ppds which only provides foomatic-db.
 -- Till Kamppeter <email address hidden>   Fri, 19 Aug 2011 18:10:23 +0200

Available diffs

Superseded in oneiric-release on 2011-08-19
m2300w (0.51-0ubuntu13) oneiric; urgency=low

  * debian/control: Changed build dependency on foomatic-db-xml back to
    foomatic-db and added "Build-Conflicts: foomatic-db-compressed-ppds"
    instead to assure that the Foomatic XML database is present during
    package build and not only the compressed archive of the Foomatic PPD
    files.
 -- Till Kamppeter <email address hidden>   Mon,  1 Aug 2011 19:07:23 +0200

Available diffs

Superseded in oneiric-release on 2011-08-01
m2300w (0.51-0ubuntu12) oneiric; urgency=low

  * debian/control: Changed build dependency on foomatic-db to foomatic-db-xml
    to assure that the Foomatic XML database is present and not only the
    compressed archive of the Foomatic PPD files.
 -- Till Kamppeter <email address hidden>   Thu, 28 Jul 2009 19:21:23 +0200

Available diffs

Superseded in oneiric-release on 2011-07-28
m2300w (0.51-0ubuntu11) oneiric; urgency=low

  * debian/patches/20_use_ghostscript_with_nointerpolate.dpatch: Added
    "-dNOINTERPOLATE" to the Ghostscript command line. This makes the
    page rendering by Ghostscript significantly faster.
 -- Till Kamppeter <email address hidden>   Sun, 24 Jul 2009 22:04:23 +0200

Available diffs

Superseded in oneiric-release on 2011-07-24
Obsolete in natty-release on 2013-06-04
m2300w (0.51-0ubuntu10) natty; urgency=low

  * debian/control: Fix build deps: gs → ghostscript.
 -- Martin Pitt <email address hidden>   Mon, 24 Jan 2011 11:13:34 +0100

Available diffs

Superseded in natty-release on 2011-01-24
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
m2300w (0.51-0ubuntu9) lucid; urgency=low

  * rebuild rest of main for armel armv7/thumb2 optimization;
    UbuntuSpec:mobile-lucid-arm-gcc-v7-thumb2
 -- Alexander Sack <email address hidden>   Sun, 07 Mar 2010 00:56:52 +0100

Available diffs

Superseded in lucid-release on 2010-03-07
Obsolete in karmic-release on 2013-03-04
m2300w (0.51-0ubuntu8) karmic; urgency=low

  * debian/m2300w.postinst: Fixed "lpstat -r" check for the
    auto update of PPDs of existing queues. "lpstat -r" exits always with
    status 0, we must check the actual output. Call lpstat, lpadmin, and
    cupsctl with "-h /var/run/cups/cups.sock" to avoid querying remote
    servers set up in /etc/cups/client.conf, and asking for passwords.
    Thanks to Martin-Éric Racine for tracking this down and the solution!
    See Debian bug #543468. Use signal names instead of numbers for trap.
    Quiesces a lintian bashism warning.

  * debian/control: Added dependency on cups and cups-client, to assure
    that automatic update of the PPDs of existing print queues.

 -- Till Kamppeter <email address hidden>   Fri, 18 Sep 2009 16:04:23 +0200

Available diffs

Superseded in karmic-release on 2009-09-18
Obsolete in jaunty-release on 2013-02-28
m2300w (0.51-0ubuntu7) jaunty; urgency=low

  * debian/m2300w.postinst: Silenced non-fatal error messages when
    post-install script updates PPDs and there are PPDs not belonging to
    a CUPS queue in /etc/cups/ppd/ (LP: #345866).

  * debian/local/apport-hook.py, debian/rules: Added apport hook (LP: #338442).

 -- Till Kamppeter <email address hidden>   Thu, 26 Mar 2009 16:57:50 +0100

Available diffs

Superseded in jaunty-release on 2009-03-27
m2300w (0.51-0ubuntu6) jaunty; urgency=low

  * debian/m2300w.postinst: Added automatic updating of the PPD files of the
    already existing CUPS queues which use this driver.

 -- Till Kamppeter <email address hidden>   Wed, 18 Feb 2008 10:57:50 +0100

Available diffs

Superseded in jaunty-release on 2009-02-18
Obsolete in intrepid-release on 2013-02-20
m2300w (0.51-0ubuntu5) intrepid; urgency=low

  * debian/rules: Add "*cupsFilter" line to accept PDF input data to the PPDs
  * debian/control: Require foomatic-filters 4.x, replaced "cupsys" by "cups".

 -- Till Kamppeter <email address hidden>   Wed, 13 Aug 2008 16:20:50 +0200

Available diffs

Superseded in intrepid-release on 2008-08-13
Obsolete in hardy-release on 2015-04-24
Obsolete in gutsy-release on 2011-09-16
Obsolete in feisty-release on 2009-08-20
m2300w (0.51-0ubuntu4) feisty; urgency=low

  * 10_ppd_for_2400w_fails_cupstestppd.dpatch: PPD for the Minolta magicolor
    2400W was not passing cupstestppd.

 -- Till Kamppeter <email address hidden>   Wed, 14 Mar 2007 19:30:00 +0000
Superseded in feisty-release on 2007-03-27
m2300w (0.51-0ubuntu3) feisty; urgency=low

  * debian/control, debian/rules: Let PPDs go into the main package, drop
    m2300w-ppds package; compressed the PPDs (see also LP#88224).

 -- Till Kamppeter <email address hidden>   Thu,  8 Mar 2007 14:30:00 +0000
Superseded in feisty-release on 2007-03-09
Superseded in feisty-release on 2007-02-06
m2300w (0.51-0ubuntu2) feisty; urgency=low

  * debian/control: Added "gs", "cupsys", "foomatic-db",
    "foomatic-db-engine", and "foomatic-filters" to Build-Depends. They are
    all needed by the ./configure script.

 -- Till Kamppeter <email address hidden>   Wed, 31 Jan 2007 12:00:00 +0000
Superseded in feisty-release on 2007-02-02
m2300w (0.51-0ubuntu1) feisty; urgency=low

  * Initial Release.

 -- Till Kamppeter <email address hidden>   Mon, 15 Jan 2007 12:00:00 +0000
123 of 23 results