Change log for mako package in Ubuntu

142 of 42 results
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-07-15
Deleted in artful-proposed (Reason: moved to release)
mako (1.0.7+ds1-1) unstable; urgency=medium

  * New upstream release
  * Standards-Version bumped to 4.0.0 (no changes needed)

 -- Piotr Ożarowski <email address hidden>  Fri, 14 Jul 2017 16:44:18 +0200

Available diffs

Superseded in artful-release on 2017-07-15
Published in zesty-release on 2017-02-08
Deleted in zesty-proposed (Reason: moved to release)
mako (1.0.6+ds1-2) unstable; urgency=medium

  * Update tests for Pygments 2.2 (closes: 852908, thanks to Gilles Filippini
    for the patch) 

 -- Piotr Ożarowski <email address hidden>  Tue, 07 Feb 2017 22:23:36 +0100

Available diffs

Superseded in zesty-release on 2017-02-08
Deleted in zesty-proposed on 2017-02-09 (Reason: moved to release)
mako (1.0.6+ds1-1) unstable; urgency=medium

  * New upstream release

 -- Piotr Ożarowski <email address hidden>  Wed, 21 Dec 2016 12:37:13 +0100

Available diffs

Superseded in zesty-release on 2016-12-21
Deleted in zesty-proposed on 2016-12-23 (Reason: moved to release)
mako (1.0.4+ds1-2) unstable; urgency=medium

  * Fix FTBFS due to Sphinx API change (closes: 830178, thanks to Nishanth
    Aravamudan for the patch)

 -- Piotr Ożarowski <email address hidden>  Wed, 02 Nov 2016 23:27:06 +0100
Superseded in zesty-release on 2016-12-10
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
mako (1.0.4+ds1-1ubuntu1) yakkety; urgency=medium

  * debian/patches/update_for_sphinx_structure.patch: Update for sphinx
    internal structure change layout.  Closes: #830178, LP: #1628712.

 -- Nishanth Aravamudan <email address hidden>  Wed, 28 Sep 2016 16:15:41 -0700
Superseded in yakkety-release on 2016-09-30
Deleted in yakkety-proposed on 2016-10-01 (Reason: moved to release)
mako (1.0.4+ds1-1) unstable; urgency=medium

  [ Ondřej Nový ]
  * Fixed VCS URL (https)

  [ Piotr Ożarowski ]
  * New upstream release
  * Replace python-nose with python-pytest (following upstream, this also
    closes: #813668)
  * Standards-Version bumped to 3.9.8 (no changes needed)

 -- Piotr Ożarowski <email address hidden>  Thu, 14 Apr 2016 21:16:59 +0200
Superseded in yakkety-release on 2016-04-23
Published in xenial-release on 2016-04-11
Deleted in xenial-proposed (Reason: moved to release)
mako (1.0.3+ds1-1ubuntu1) xenial; urgency=medium

  * Update template match data in test suite to fix FTBFS. Patch by Neil
    Williams. (Closes: #813668)

 -- Martin Pitt <email address hidden>  Mon, 11 Apr 2016 22:37:09 +0200
Superseded in xenial-release on 2016-04-11
Deleted in xenial-proposed on 2016-04-13 (Reason: moved to release)
mako (1.0.3+ds1-1) unstable; urgency=medium

  * New upstream release.

 -- Piotr Ożarowski <email address hidden>  Sat, 31 Oct 2015 23:27:16 +0100

Available diffs

Superseded in xenial-release on 2015-11-01
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
mako (1.0.2+ds1-1) unstable; urgency=medium

  * New upstream release.
    - remove python35-compat.patch - no longer needed
  * Add debian/upstream/signing-key.asc

 -- Piotr Ożarowski <email address hidden>  Wed, 26 Aug 2015 22:49:37 +0200
Superseded in wily-proposed on 2015-08-27
mako (1.0.1+ds1-1) unstable; urgency=medium

  [ Barry Warsaw ]
  * New upstream release.
  * debian/patches/python35-compat.patch: Upstream provided patch to
    fix compatibility issues with Python 3.5.

  [ Piotr Ożarowski ]
  * Convert debian/copyright to DEP-5 and use it to remove minified JS files
  * Add dh-python to Build-Depends
  * Standards-Version bumped to 3.9.6 (no changes needed)

 -- Piotr Ożarowski <email address hidden>  Wed, 26 Aug 2015 17:24:08 +0200
Superseded in wily-release on 2015-08-28
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
mako (1.0.0+dfsg-0.1) unstable; urgency=medium


  * Non-maintainer upload.
  * Remove minified javascript files from upstream source. They are not used
    in the build process. Closes: #722265

 -- Ivo De Decker <email address hidden>  Tue, 11 Nov 2014 12:39:18 +0100

Available diffs

Superseded in vivid-release on 2014-11-13
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
mako (1.0.0-1) unstable; urgency=medium


  * New upstream release
  * Add python-changelog and python-sphinx-paramlinks to Build-Depends
    (needed while rebuilding documentation)
  * Enable Python 3.X tests during build (add necessary packages to
    Build-Depends)
  * Update links to upstream changelog (now points to changelog.rst)
  * Add lintian override for source-is-missing doc/searchindex.js
    (this file is generated by sphinx-build, all sources are in the tarball)

 -- Piotr Ożarowski <email address hidden>  Tue, 10 Jun 2014 20:38:26 +0200

Available diffs

Superseded in utopic-release on 2014-06-10
Published in trusty-release on 2013-12-29
Deleted in trusty-proposed (Reason: moved to release)
mako (0.9.1-1) unstable; urgency=low


  * New upstream release
  * Standards-Version bumped to 3.9.5 (no changes needed)

 -- Piotr Ożarowski <email address hidden>  Sun, 29 Dec 2013 11:57:23 +0100

Available diffs

Superseded in trusty-release on 2013-12-29
Deleted in trusty-proposed on 2013-12-30 (Reason: moved to release)
mako (0.9.0-1) unstable; urgency=low


  * New upstream release

 -- Piotr Ożarowski <email address hidden>  Sat, 31 Aug 2013 11:58:59 +0200

Available diffs

Superseded in trusty-release on 2013-10-21
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
mako (0.8.1-1) unstable; urgency=low


  * New upstream release

 -- Piotr Ożarowski <email address hidden>  Sat, 25 May 2013 22:58:26 +0200

Available diffs

Superseded in saucy-release on 2013-05-26
Deleted in saucy-proposed on 2013-05-27 (Reason: moved to release)
mako (0.8.0-2) unstable; urgency=low


  [ Jakub Wilk ]
  * Use canonical URIs for Vcs-* fields.

  [ Piotr Ożarowski ]
  * Standards-Version bumped to 3.9.4 (no changes needed)

 -- Piotr Ożarowski <email address hidden>  Sun, 05 May 2013 21:28:00 +0200

Available diffs

Superseded in saucy-release on 2013-05-06
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
mako (0.7.3-1) experimental; urgency=low


  * New upstream release

 -- Piotr Ożarowski <email address hidden>  Mon, 12 Nov 2012 00:03:25 +0100

Available diffs

Superseded in raring-release on 2012-11-22
Obsolete in quantal-release on 2015-04-24
mako (0.7.1-1) experimental; urgency=low


  * New upstream release
    (upload to experimental due to Wheezy freeze)

 -- Piotr Ożarowski <email address hidden>  Fri, 13 Jul 2012 14:31:05 -0600

Available diffs

Superseded in quantal-release on 2012-07-29
mako (0.7.0-1) unstable; urgency=low


  * New upstream release
  * Standards-Version bumped to 3.9.3 (no changes needed)

 -- Piotr Ożarowski <email address hidden>  Sat, 31 Mar 2012 20:03:29 +0200

Available diffs

Superseded in quantal-release on 2012-05-01
Published in precise-release on 2011-10-17
mako (0.5.0-1) unstable; urgency=low

  * New upstream release
  * Add build-arch and build-indep targets to debian/rules
  * Add libjs-underscore to python-mako-doc's Depends

Available diffs

Superseded in precise-release on 2011-10-17
Obsolete in oneiric-release on 2015-04-24
mako (0.4.1-2) unstable; urgency=low

  * Rebuild to add Python 2.7 and drop Python 2.5 support

Available diffs

Superseded in oneiric-release on 2011-04-30
Obsolete in natty-release on 2013-06-04
mako (0.3.6-1) unstable; urgency=low

  * New upstream release
    - make_sure_2to3_is_used patch removed (applied upstream)
  * Switch from dh_pysupport to dh_python2
  * Add python-mako-doc package (and move documentation, examples and VIM
    files there), rebuild docs using Sphinx
  * Run tests for all 2.X Python versions
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  29 Nov 2010 11:25:30 +0000

Available diffs

Superseded in natty-release on 2010-11-29
mako (0.3.5-1) unstable; urgency=low

  * New upstream release
  * Standards-Version bumped to 3.9.1 (no changes needed)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  22 Oct 2010 15:50:26 +0000

Available diffs

Superseded in natty-release on 2010-10-22
mako (0.3.4-5) unstable; urgency=low

  * Upload to unstable 

Available diffs

Obsolete in lucid-updates on 2016-10-26
Obsolete in lucid-security on 2016-10-26
mako (0.2.5-2ubuntu1.3) lucid-security; urgency=low

  * SECURITY UPDATE: cross-site scripting via inadequate escaping
    - lib/mako/filters.py: use xml.sax.saxutils.escape instead of
      cgi.escape so we can escape single quotes.
    - CVE-2010-2480
 -- Marc Deslauriers <email address hidden>   Tue, 28 Sep 2010 09:35:53 -0400
Superseded in natty-release on 2010-10-15
Obsolete in maverick-release on 2013-03-05
mako (0.3.4-2) unstable; urgency=low

  * Move python-markupsafe to Depends (closes: #587760)
  * Standards-Version bumped to 3.9.0 (no changes needed)

Available diffs

Superseded in maverick-release on 2010-09-06
mako (0.3.3-1) unstable; urgency=low

  * New upstream release
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  05 Jun 2010 11:28:48 +0100

Available diffs

Superseded in maverick-release on 2010-06-05
mako (0.3.2-1) unstable; urgency=low

  * New upstream release

Available diffs

Superseded in maverick-release on 2010-05-15
Obsolete in lucid-release on 2016-10-26
Superseded in lucid-release on 2010-02-18
mako (0.2.5-2ubuntu1) lucid; urgency=low

  * debian/control: suggests python-beaker rather than recommends it since it
      doesn't seem to be really by required by the softwares using python-mako,
      the change will avoid promoting python-beakers in lucid
 -- Sebastien Bacher <email address hidden>   Wed, 17 Feb 2010 21:58:53 +0100

Available diffs

Superseded in lucid-release on 2010-02-17
mako (0.2.5-2) unstable; urgency=low

  * Add --prefix=/usr to setup.py's install command (fixes FTBFS bug with
    python2.6)
  * Remove requires.txt from Python's Egg metadata (dpkg handles dependencies
    way better, closes LP: #461281)

Available diffs

Superseded in lucid-release on 2009-11-24
Obsolete in karmic-release on 2013-03-04
mako (0.2.4-2ubuntu1) karmic; urgency=low

  * debian/rules: Add --install-layout=deb to setup.py install arguments to
    fix FTBFS with Python 2.6
  * debian/control: Bump-up python-all-dev build-dep.

 -- Alessio Treglia <email address hidden>   Tue, 26 May 2009 14:57:24 +0200

Available diffs

Superseded in karmic-release on 2009-05-26
mako (0.2.4-2) unstable; urgency=low

  * Set the minimum required Python version to 2.4 (closes: #515096)
  * Upload to unstable
  * Change Debian packaging license to MIT (to match upstream)

Available diffs

Obsolete in hardy-backports on 2015-04-24
mako (0.2.2-1~hardy1) hardy-backports; urgency=low

  * Automated backport upload; no source changes.

Available diffs

Superseded in karmic-release on 2009-04-29
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
mako (0.2.2-1) unstable; urgency=low

  * New upstream release

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  24 Jun 2008 13:48:53 +0100

Available diffs

Superseded in intrepid-release on 2008-06-24
mako (0.2.1-1) unstable; urgency=low

  * New upstream release
  * debian/copyright file updated
  * Standards-Version bumped to 3.8.0 (no changes needed)

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  19 Jun 2008 13:23:40 +0100

Available diffs

Superseded in intrepid-release on 2008-06-19
mako (0.2.0-1) unstable; urgency=low

  * New upstream release
  * Add "~" to setuptools' required build version (to ease backports)
  * Add manpage for new mako-render script
  * s/hyperfast/fast in short description to avoid inflated adjectives
    (closes: #466008)
  * doc-base: section changed to Programming/Python

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  04 Jun 2008 21:38:35 +0100

Available diffs

Superseded in intrepid-release on 2008-06-04
Obsolete in hardy-release on 2015-04-24
mako (0.1.10-1) unstable; urgency=low

  * New upstream release
  * Rename XS-Vcs-* fields to Vcs-* (dpkg supports them now)
  * Bump Standards-Version to 3.7.3 (no changes needed)

 -- Lucas Caba?as <email address hidden>   Mon,  11 Feb 2008 19:42:01 +0000
Superseded in hardy-release on 2008-02-11
mako (0.1.9-1) unstable; urgency=low

  * New upstream release
  * Homepage field added
  * debian/rules cleanups

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  23 Oct 2007 17:41:05 +0100
Superseded in hardy-release on 2007-10-23
Obsolete in gutsy-release on 2011-09-16
mako (0.1.8-1) unstable; urgency=low

  * New upstream release

 -- Piotr O?arowski <email address hidden>   Thu,  16 Aug 2007 14:52:29 +0100
Superseded in gutsy-release on 2007-08-16
mako (0.1.7-1) unstable; urgency=low

  * New upstream release

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  14 Jun 2007 08:54:35 +0100
Superseded in gutsy-release on 2007-06-14
mako (0.1.6-1) unstable; urgency=low

  * New upstream release
  * python-myghtyutils removed from Depends since it's no longer used,
  * python-beaker added to Recommends (it can be used for caching now)
  * Provides field removed (it's not used)

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  21 May 2007 09:33:52 +0100
Superseded in gutsy-release on 2007-05-21
mako (0.1.5-1) unstable; urgency=low

  * New upstream release
  * Changed my address to <email address hidden>

142 of 42 results