Ubuntu

Manpages do not format well

Reported by Joaquin Seoane on 2005-12-31
10
Affects Status Importance Assigned to Milestone
manpages-es (Ubuntu)
Medium
Colin Watson

Bug Description

Manpages-es and manpages-es-extra do not format well. The reason seems to be that they are encoded in utf-8, while man-db seems to expect an 8-bit encoding. Equivalent manpages-fr are encoded iso 8859-1 anf format well. Even 'man' spanish manpage is encoded in iso 8859-1 and formats well. Original Debian package formats well.

Might be an error of man-db or a configuration error (¿how does man knows the encoding of source manpages?)

Changed in manpages-es:
assignee: nobody → motu
Colin Watson (cjwatson) wrote :

At the moment, there's fundamentally no facility for a man page to declare its encoding other than by its location in the filesystem; putting UTF-8 Spanish man pages in /usr/share/man/es_ES.UTF-8/... *should* work, but it's really only peripherally supported at the moment and I'm not sure it'll do the right thing for all user locales.

Yes, man-db expects Spanish man pages to be encoded in ISO-8859-1. For now, I think the right thing to do would indeed be to recode them.

SVAKSHA (svaksha) wrote :

Thank you for reporting this bug. Kindly test it with the latest Dapper source and attach your error messages here. The beta release of Dapper is scheduled for next Thursday, 20060420 and we would like to fix bugs before the beta is publicized. -Thanks!

Changed in manpages-es:
status: Unconfirmed → Needs Info
Joaquin Seoane (jsp) wrote :

The problem still remains. The manpages should be recoded to ISO-8859-1. For example fremch manpages format well.

Furthermore, manpages-es and manpages-es-extra have a conflicting file:

/usr/share/man/es/man3/dlerror.3.gz

William Grant (wgrant) on 2007-04-05
Changed in manpages-es:
status: Needs Info → Unconfirmed
Siegfried Gevatter (rainct) wrote :

It's now over one year since the last comment on this bug. Could you please confirm that the problem is still present?

Changed in manpages-es:
status: New → Incomplete
Siegfried Gevatter (rainct) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in manpages-es:
status: Incomplete → Invalid
Colin Watson (cjwatson) wrote :

RainCT, I don't think there was really a justification for closing this bug. It would have been trivial for somebody to check the encoding of the manual pages in question; this isn't something that requires a particular setup to check.

In any case, this bug will no longer appear with man-db 2.5.0, as it will now transparently detect whether UTF-8 or ISO-8859-1 is in use for Spanish manual pages and do the right thing.

Changed in manpages-es:
assignee: motu → kamion
status: Invalid → Fix Released
Alejandro Díaz-Caro (janus) wrote :

This bug still present in Gutsy.

ubuntu version is 7.10, amd64
man-db package version is 2.4.4-3
manpages-es package version is 1.55-4
manpages-es-extra package version is 0.8a-16

Alejandro Díaz-Caro (janus) wrote :

I solved this problem as Colin Watson had suggested:

cd /usr/share/man
sudo mv es es_AR.UTF-8

Of course, each one have to put his own locale (es_ZZ, where ZZ is your country code).

Colin Watson (cjwatson) wrote :

Yes, I said it was fixed in a version of man-db that's in Hardy, not Gutsy.

Please do not recommend workarounds involving moving directories around in /usr/share/man; they may well cause upgrade problems in future.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers