Defaul awk version can't build zd1211 kernel moduke from Dapper source

Bug #48855 reported by Ben Bacarisse on 2006-06-07
4
Affects Status Importance Assigned to Milestone
mawk (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: mawk

In a fresh 6.06 install, "make modules" fails to compile the zd1211 module since it does not have POSIX regex support. Installing gawk instead does the trick.

Simon Law (sfllaw) wrote :

What errors does mawk spit out? And could you include the C source
files that mawk mentions?

Changed in mawk:
status: Unconfirmed → Needs Info
Simon Law (sfllaw) wrote :

Or rather, the failing awk script.

Ben Bacarisse (launchpad-bsb) wrote :

It does not give an error. It just does not generate the required output. In the zddevlist.awk script, a series of calls to "match" must succeed or the script generates a #error line for the compiler to find later.

Looking more closely, the problem is simply that mawk does not accept POSIX-style character classes like [:alnum:] in calls to match. I could not find any flag or environment variable that causes mawk to take POSIX character classes. gawk does so by default and thus works.

The script can be re-written to avoid POSIX-style character classes but at the expense of portability to systems with non-contiguous alphabetic character sets and/or locale-specific alphabetic characters (attached -- though this does not seem like the correct solution).

I have added POSIX character classes to Mawk. See the attached patch.

- Sam

Jim Qode (jimqode) on 2007-07-13
Changed in mawk:
status: Incomplete → Fix Committed
Przemek K. (azrael) on 2009-12-08
Changed in mawk (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers