Maxima hangs on ppc

Bug #37169 reported by Marco Ciampa
16
Affects Status Importance Assigned to Milestone
maxima (Ubuntu)
Invalid
Medium
Unassigned

Bug Description

Maxima hangs eating up all the cpu on my ibook (ppc) Dapper.
Maxima version is 5.9.2-2.

Tags: apple g4 ppc
Revision history for this message
sam tygier (samtygier) wrote :

confirmed on G4 powerbook. it spent 5 mins eating cpu before i killed it. it would not respond to crtl+c

"maxima -v" gives the following output before hanging
+ '[' gcl = clisp ']'
+ '[' gcl = cmucl ']'
+ '[' gcl = gcl ']'
+ exec /usr/lib/maxima/5.9.2/binary-gcl/maxima -eval '(cl-user::run)' -f -- -v '' '' '' '' '' '' '' ''

"maxima --version" hangs before outputing anything

Changed in maxima:
status: Unconfirmed → Confirmed
Revision history for this message
sam tygier (samtygier) wrote :

tested on 386, this issue only effects powerpc

Revision history for this message
X (u78qir8a9-deactivatedaccount) wrote :

I can confirm this on my install too, as of a dist-upgrade on the day of flight 6
Maxima 5.9.1-7 (grabbed from breezy) works though.

Revision history for this message
Daniel T Chen (crimsun) wrote :

Please follow https://wiki.ubuntu.com/DebuggingProgramCrash , particularly step #3 for a backtrace and attach the output.

Changed in maxima:
status: Confirmed → Needs Info
Revision history for this message
Daniel T Chen (crimsun) wrote :

...that is, if the symptoms are still reproducible in Dapper's current version.

Revision history for this message
sam tygier (samtygier) wrote :

its still happening. getting a backtrace is made a bit trickier by /usr/bin/maxima being a shell script. /usr/lib/maxima/5.9.2/binary-gcl/maxima seems to be the binary.

from gdb /usr/lib/maxima/5.9.2/binary-gcl/maxima
(gdb) run
Starting program: /usr/lib/maxima/5.9.2/binary-gcl/maxima
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)

Program received signal SIGSEGV, Segmentation fault.
0x0fd5ea28 in memset () from /lib/libc.so.6
(gdb) bt
#0 0x0fd5ea28 in memset () from /lib/libc.so.6
#1 0x1010d674 in realloc ()
#2 0x1010e4d8 in realloc ()
#3 0x1000602c in error ()
#4 0x0fd018ec in __libc_init_first () from /lib/libc.so.6
#5 0x0fd018ec in __libc_init_first () from /lib/libc.so.6
#6 0x0fd018ec in __libc_init_first () from /lib/libc.so.6
Previous frame inner to this frame (corrupt stack?)

i'll try to get a debug build built.

Revision history for this message
sam tygier (samtygier) wrote :

i build a debug version using the above instructions, installed it and now maxima runs ok.

i suspect the is a problem with the package in the dapper repos

Revision history for this message
Daniel T Chen (crimsun) wrote : Re: [Bug 37169] Re: Maxima hangs on ppc Dapper

On Tue, May 09, 2006 at 10:47:03AM -0000, sam tygier wrote:
> i build a debug version using the above instructions, installed it and now maxima runs ok.

These symptoms are consistent with those reported in the Debian BTS,
namely a debug version doesn't exist overlapping BDF sections.

--
Daniel T. Chen <email address hidden>
GPG key: www.sh.nu/~crimsun/pubkey.gpg.asc

Revision history for this message
sam tygier (samtygier) wrote : Re: Maxima hangs on ppc Dapper

as a workaround for dapper can a debug version be shipped?

Revision history for this message
Daniel T Chen (crimsun) wrote : Re: [Bug 37169] Re: Maxima hangs on ppc Dapper

On Tue, May 09, 2006 at 06:45:36PM -0000, sam tygier wrote:
> as a workaround for dapper can a debug version be shipped?

It would violate Debian policy, which I'm not fond of doing, for
starters. Furthermore, using the binary in gdb will exhibit the same
crash as before (with debugging symbols stripped). Lastly, I'm not
entirely convinced binutils isn't to blame, but it's far too late in
the release cycle to really do much about it even if it did turn out
to reside in that source package.

To recap: I'm not inclined to use the workaround mentioned in Debian
BTS, but it may have to be activated given the severity of the bug.
Other MOTU should feel free to chime in here and offer their opinions.

Sam, are you able to pinpoint any setbacks (slowness in operation,
etc.) when using an unstripped version?

Thanks,
--
Daniel T. Chen <email address hidden>
GPG key: www.sh.nu/~crimsun/pubkey.gpg.asc

Revision history for this message
sam tygier (samtygier) wrote : Re: Maxima hangs on ppc Dapper

i have not used maxima enough to know if its any slower.

Revision history for this message
Marco Ciampa (ciampix) wrote :

Is it out of question to compile the newest (and more bug free) of maxima before trying to fix (perhaps) some bugs already fixed?
I'll do manage to try to compile the newest version of stable maxima 5.9.3 and, if someone is interested, I'll post here my results.

Revision history for this message
ilbahr (ilba7r) wrote :

I confirm having the same problem using both xmaxima and wxmaxima for maxima 5.9.2-2.

I compiled a deb package from the new maxima 5.9.3-1 source.
The configure complained that gcl was compilied with a missing required option (can not remember it now).

I then compiled the source with clisp and now everything works fine. Xmaxima and wxmaxima can connect to maxima server with no problems.

All compilation were performed on i686 architecture

Revision history for this message
alonso gomez (alonso-raul-g) wrote :

I should add, on dapper ppc platform it Seems like Clisp is a bad package, it cannot be installed from Synaptic, (segfault). Cmucl is not available anymore so I couldn't compile. with Sbcl from repositories I get compile errors , there are no more options available to me in dapper. if Someone could compile it with any other clisp availabe on dapper and be successful please could you report it here, thanks.

Revision history for this message
alonso gomez (alonso-raul-g) wrote :

in relation to : https://launchpad.net/distros/ubuntu/+source/wxmaxima/+bug/43150

Just compiled newest available version of both maxima(5.9.3) and clisp(2.39) and maxima do work now in ppc dapper (no more 100% use).

Revision history for this message
William Grant (wgrant) wrote :

Can somebody please test this with Edgy?

Revision history for this message
alonso gomez (alonso-raul-g) wrote :

Just So you know... I downloaded the debian unstable package :

http://packages.debian.org/unstable/math/maxima

the powerpc version, updated to maxima 5.10.0. I think its compiled with GCL because "usr/lib/maxima/5.10.0/binary-gcl" with a maxima binary is created with this .deb . it seems to work correctly with this package.

Clisp on ubuntu ppc has severe problems ( i compiled last version , 2.40 from cvs) and SBCL from dapper repo doesn't even compile on ppc(I did not test the last version of SBCL).

So if this works on ubuntu dapper, GCL has to work. If I can I will compile GCL and check. I have to yet test wxmaxima.

Revision history for this message
alonso gomez (alonso-raul-g) wrote :

ok. Just compiled maxima 5.10.0 with the last version of gcl (2.6.7+ a diff patch I found on debian src package =2.6.7.22diff). and now everything is working perfectly.(Gcl had problems with ppc).

I think Clisp and SBCL have not fixed their problems with ppc architecture(did not have time to test their cvs versions), so maybe atm. you cannot compile maxima with them on ppc. for the sake of security I compiled wxmaxima and all fine too.

Hope it helps.

Revision history for this message
William Grant (wgrant) wrote :

Can you please test this with the latest Edgy version of maxima?

Revision history for this message
Marco Ciampa (ciampix) wrote : Re: [Bug 37169] Re: Maxima hangs on ppc Dapper

On Thu, Oct 05, 2006 at 12:07:48AM -0000, William Grant wrote:
> Can you please test this with the latest Edgy version of maxima? I can
understand that one would try to test maxima onto last version of the
distribution but... I think that it's more important to try to fix Dapper
first, to make the LTS acronym means something... I know, LTS it's only for
the "main" packages but maxima is an important package in itself, just
consider edubuntu without it...

All this is for saying that I have only one ppc around and with dapper onto it
and I'm _not_ intentioned to switch that _working_ machine of mine.

I'll ask around for someone more "brave" than me, I think I know someone how
can do that test for me.

TIA

--

Marco Ciampa

+--------------------+
| Linux User #78271 |
| FSFE fellow #364 |
+--------------------+

Revision history for this message
LaserJock (laserjock) wrote : Re: Maxima hangs on ppc Dapper

Marco,
   We have had some recent maxima fixes in Edgy, but we have to track things down and be very careful with dapper. As you say, we need to keep this LTS. We are looking to fix these issues for sure, but we need to carefully test fixes before we put then in the dapper-updates repo. If we can isolate a fix in edgy then we can backport the fix in dapper. We need ppc users to test the edgy packages to narrow down a fix.

-Jordan

Revision history for this message
William Grant (wgrant) wrote :

Confirmed in latest Edgy on IRC.

Changed in maxima:
status: Needs Info → Confirmed
Revision history for this message
William Grant (wgrant) wrote :

And the story gets more sinister: Upon further exploration, it turns out the Edgy PPC maxima is the same as the Dapper one. The newer ones fail to build, because gcl failed to build on PPC.

Revision history for this message
alonso gomez (alonso-raul-g) wrote :

after some tests I can conclude, maxima on ppc platform can be installed, but it won't start because there is a connection bug in that version of maxima(5.9.2) which does affect wxmaxima too.

the only viable solution for the users who might want to use maxima on ppc dapper isto compile maxima source with any clisp as its needed to compile maxima. these are the problems with some clisps in dapper repositories (PPC) at the moment:

-compiling last maxima (5.10.0) with the default clisp in dapper repositories can't be done because that clisp package is badly broken(clisp 2.38 from dapper repo seg faults on install but from source its ok, I self checked src 2.39(stable) and compiled on ppc).

-compiling with sbcl didnt work for me (although sbcl does install ok from repos).

-AFAIK cmucl is not available for ppc platform and cant be compiled (it needs a binary expecifically for ppc, sbcl is a replacement for it on ppc platform).

-gcl can be installed from repositories(2.6.7.14) but has some segfaults problems initializing maxima(even maxima compiles well with it).

For me the solution was to use clisp(>=2.39) or gcl(>2.6.7.14) From SOURCE as it seems there are problems with clisp packages on dapper ppc repositories.

Dont want to sound picky here, but as I needed maxima package on dapper, and the only platform available to me for dapper is ppc, I wanted to use It so had to make sure everything was working ok. I checked all I could at my knowledge level(i'm not a linux pro) and this is all info I could check on the matter.

Hope this helps and it can be fixed for dapper ppc users who might use this excellent math package(which does expand to xmaxima or wxmaxima for those wanting the gui).

cheers,

alonso.

Revision history for this message
Tormod Volden (tormodvolden) wrote :

Can anyone try the new dapper ppc build https://launchpad.net/+builds/+build/277671 and see if it works in Edgy, as a workaround?

Revision history for this message
sam tygier (samtygier) wrote :

no change for me.

Revision history for this message
X (u78qir8a9-deactivatedaccount) wrote :

Likewise no change with 5.9.2-2ubuntu2 (vs 5.9.2-2ubuntu1 etc) for me.

Revision history for this message
Leo Arias (elopio) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner.
There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test the current Ubuntu development version (10.10). If you can test it, and it is still an issue, we would appreciate if you could upload updated logs by running apport-collect 37169, and any other logs that are relevant for this particular issue.

Changed in maxima (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
rusivi2 (rusivi2-deactivatedaccount) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in maxima (Ubuntu):
status: Incomplete → Invalid
Revision history for this message
rusivi2 (rusivi2-deactivatedaccount) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. My apologies as I should not have marked this Invalid. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Maverick Meerkat. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in maxima (Ubuntu):
status: Invalid → Incomplete
Revision history for this message
Leo Arias (elopio) wrote :

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Revision history for this message
Leo Arias (elopio) wrote :

Please reopen the issue if you can give us the missing information. Thanks.

Changed in maxima (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.