Change log for module-init-tools package in Ubuntu

175 of 77 results
Deleted in raring-release on 2015-04-27 (Reason: (From Debian) ROM; replaced by kmod; Debian bug #681285)
Obsolete in quantal-release on 2015-04-24
module-init-tools (3.16-1ubuntu6) quantal; urgency=low

  * Update config.guess,sub for aarch64
 -- Wookey <email address hidden>   Mon, 01 Oct 2012 12:56:40 +0100

Available diffs

Superseded in quantal-release on 2012-10-01
module-init-tools (3.16-1ubuntu5) quantal; urgency=low

  * Add new iwlwifi.config file
    -LP: #1011420
 -- Leann Ogasawara <email address hidden>   Mon, 10 Sep 2012 09:13:20 -0700

Available diffs

Superseded in quantal-release on 2012-09-11
module-init-tools (3.16-1ubuntu4) quantal; urgency=low

  * Micro-optimize the upstart job to improve boot performance; thanks to
    Scott Moser for the patch.
  * Use dpkg-buildflags to enable hardening for the package build.
 -- Steve Langasek <email address hidden>   Thu, 06 Sep 2012 01:28:50 +0000

Available diffs

Superseded in quantal-release on 2012-09-06
module-init-tools (3.16-1ubuntu3) quantal; urgency=low

  * Blacklist udlfb which conflicts with the udl KMS driver.
    Added udlfb to debian/modprobe.d/blacklist-framebuffer.conf
 -- Tim Gardner <email address hidden>   Wed, 30 May 2012 11:42:15 -0600

Available diffs

Superseded in quantal-release on 2012-05-30
Published in precise-release on 2011-11-20
module-init-tools (3.16-1ubuntu2) precise; urgency=low

  * Mark module-init-tools Multi-Arch: foreign.
 -- Colin Watson <email address hidden>   Sun, 20 Nov 2011 22:15:21 +0000

Available diffs

Superseded in precise-release on 2011-11-20
Obsolete in oneiric-release on 2015-04-24
module-init-tools (3.16-1ubuntu1) oneiric; urgency=low

  * Resync with debian 3.16-1.
   - Remaining changes:
      + update to debhelper version 7 for upstart job support
      + Ubuntu specific control scripts carrying upgrade quirks
      + Ubuntu specific modprobe.d/depmod.d contents
      + debian/patches/ubuntu-maps_by_default -- Reenable map files
      + switch source to 'unapply-patches' to simplify merging with
        debian upstream
  * debian/patches/ubuntu-modinfo-wantparm-uninitialised dropped
    now upstream
 -- Andy Whitcroft <email address hidden>   Thu, 16 Jun 2011 13:10:43 +0100

Available diffs

Superseded in oneiric-release on 2011-06-16
module-init-tools (3.13-1ubuntu1) oneiric; urgency=low

  * Manual Resync with Debian version 3.13-1.
    - Remaining changes:
      + Ubuntu specific control scripts carrying upgrade quirks
      + Ubuntu specific modprobe.d/depmod.d contents
      + debian/patches/ubuntu-maps_by_default -- Reenable map files
      + debian/patches/ubuntu-modinfo-wantparm-uninitialised -- fix
        performance issue due to unitialised variable in modinfo
      + switch source to 'unapply-patches' to simplify merging with
        debian upstream

Available diffs

Superseded in oneiric-release on 2011-06-08
Obsolete in natty-release on 2013-06-04
module-init-tools (3.12-1ubuntu6) natty; urgency=low

  * Remove intel-3945-iwlagn-disable11n.conf completely as it has an
    erroneous module parameter. (LP: #747025)
 -- Tim Gardner <email address hidden>   Fri, 01 Apr 2011 07:19:50 -0600

Available diffs

Superseded in natty-release on 2011-04-01
module-init-tools (3.12-1ubuntu5) natty; urgency=low

  * Added intel-3945-iwlagn-disable11n.conf
    The iwlwifi driver is now split into legacy 3945 and
    everything else as of 2.6.38. Support for 4965 is still contained in the iwlagn
    driver even though considered a legacy device. Intel affirms
    802.11n should work. iwl3945 is no longer supported and will never
    have a functional 802.11n mode.
  * removed intel-5300-iwlagn-disable11n.conf
    -LP: #630748
 -- Tim Gardner <email address hidden>   Fri, 25 Mar 2011 09:29:16 -0600

Available diffs

Superseded in natty-release on 2011-03-31
module-init-tools (3.12-1ubuntu4) natty; urgency=low

  * debian/modprobe.d/blacklist-framebuffer.conf: re-enable vesafb so that
    we can load it as a fallback.  (LP: #702090)
 -- Andy Whitcroft <email address hidden>   Fri, 18 Mar 2011 18:00:19 +0000

Available diffs

Superseded in natty-release on 2011-03-18
module-init-tools (3.12-1ubuntu3) natty; urgency=low

  * debian/modprobe.d/blacklist-rare-network.conf: add alias blacklist for
    rare network modules to help defend against future vulnerabilities.
 -- Kees Cook <email address hidden>   Thu, 13 Jan 2011 12:43:38 -0800

Available diffs

Superseded in natty-release on 2011-01-13
Obsolete in maverick-release on 2013-03-05
module-init-tools (3.12-1ubuntu2) maverick; urgency=low

  * Temporarily disable 11n functionality for iwlagn driver.  Intel is
    actively working to get this properly fixed up in the firmware.  This
    workaround should be reverted once updated firmware is available.
    LP: #630748
 -- Leann Ogasawara <email address hidden>   Thu, 30 Sep 2010 14:47:34 -0700

Available diffs

Superseded in maverick-release on 2010-10-01
module-init-tools (3.12-1ubuntu1) maverick; urgency=low

  * Enable new firewire stack by blacklisting legacy firewire modules.
    http://blueprints.launchpad.net/ubuntu/+spec/kernel-maverick-firewire-stack
 -- Tim Gardner <email address hidden>   Wed, 30 Jun 2010 15:35:58 +0000

Available diffs

Superseded in maverick-release on 2010-06-30
module-init-tools (3.12-1) maverick; urgency=low

  * New upstream release:
    - modules.devname support
    - softdep support
    - bug fixes
 -- Scott James Remnant <email address hidden>   Mon, 07 Jun 2010 16:34:53 +0100

Available diffs

Superseded in maverick-release on 2010-06-08
Obsolete in lucid-release on 2016-10-26
module-init-tools (3.11.1-2ubuntu1) lucid; urgency=low

  * Blacklist viafb; the only framebuffer drivers we want loaded by default
    on x86 are the drm framebuffers and vga16fb.  LP: #558569.
 -- Steve Langasek <email address hidden>   Tue, 13 Apr 2010 21:20:05 -0700

Available diffs

Superseded in lucid-release on 2010-04-14
module-init-tools (3.11.1-2) lucid; urgency=low

  * debian/module-init-tools.{pre,post}inst:
    - remove the /etc/modprobe.d/arch-aliases symlink earlier to
      fix update-initramfs failing when module-init-tools in
      unpacked but not yet configured (LP: #530632)
 -- Michael Vogt <email address hidden>   Tue, 16 Mar 2010 17:23:03 +0100

Available diffs

Superseded in lucid-release on 2010-03-17
module-init-tools (3.11.1-1) lucid; urgency=low

  * New upstream release:
    - Fixed modinfo segfault with gone module.  LP: #430643.
    - Handles modules.builtin (which the kernel doesn't yet make).

  * Remove vga16fb from the framebuffer blacklist, we'll want this to be
    loaded if there are no better framebuffers available.
 -- Scott James Remnant <email address hidden>   Wed, 02 Dec 2009 02:36:16 +0000

Available diffs

Superseded in lucid-release on 2009-12-02
Obsolete in karmic-release on 2013-03-04
module-init-tools (3.10-3) karmic; urgency=low

  FFE LP: #427356.

  * Replace init script with Upstart job.
    - This drops support for the long deprecated (and never documented)
      /etc/modules-2.6 and /etc/modules-2.6.24 forms
  * debian/control:
    - Add missing ${misc:Depends}
    - Bump build-dependency on debhelper for Upstart-aware dh_installinit

 -- Scott James Remnant <email address hidden>   Tue, 15 Sep 2009 03:29:39 +0100

Available diffs

Superseded in karmic-release on 2009-09-15
module-init-tools (3.10-2) karmic; urgency=low

  * blacklist.conf: Blacklist pcspkr. It produces an ugly and loud noise,
    getting on everyone's nerves. If still needed at all, this should be done
    by a nice pulseaudio bing. (LP: #77010)

 -- Martin Pitt <email address hidden>   Fri, 07 Aug 2009 17:02:28 +0100

Available diffs

Superseded in karmic-release on 2009-08-07
module-init-tools (3.10-1) karmic; urgency=low

  * New upstream release:
    - Pretty comprehensive ELF handling rewrite.
      LP: #99547, #342255, #370968, #382676, #387081, #399955.
    - depmod can now check module symbol versions.
    - Comprehensive code cleanup.
    - Documentation cleanups.

  * debian/modprobe.d/blacklist-watchdog.conf: Add iTCO_wdt, it8712_wdt,
    it87_wdt, pc87413_wdt, sbc7240_wdt, sch311_wdt, smsc37b787_wdt,
    twl4030_wdt, w83697hf_wdt, w83697ug_wdt & wm8350_wdt.  LP: #378328.

 -- Scott James Remnant <email address hidden>   Thu, 16 Jul 2009 17:10:34 +0100

Available diffs

Superseded in karmic-release on 2009-07-16
module-init-tools (3.8-1) karmic; urgency=low

  * New upstream release:
    - code refactoring.
    - documentation work.
    - zlib may be linked dynamically.

 -- Scott James Remnant <email address hidden>   Tue, 05 May 2009 11:45:30 +0100

Available diffs

Superseded in karmic-release on 2009-05-05
module-init-tools (3.7-1) karmic; urgency=low

  * New upstream release:
    - Legacy support for pre-2.6 kernels dropped.
    - Makefile and test suite fixes.

 -- Scott James Remnant <email address hidden>   Wed, 29 Apr 2009 11:20:16 +0100

Available diffs

Superseded in karmic-release on 2009-04-29
Obsolete in jaunty-release on 2013-02-28
module-init-tools (3.7~pre9-2) jaunty; urgency=low

  * Moved ath_pci blacklist to /etc/modprobe.d/blacklist-ath_pci.conf
    for better jockey support.
    -LP: #323830

 -- Tim Gardner <email address hidden>   Wed, 18 Mar 2009 15:45:43 +0000

Available diffs

Superseded in jaunty-release on 2009-03-18
module-init-tools (3.7~pre9-1) jaunty; urgency=low

  * New upstream pre-release:
    - modprobe will die if a module dependency fails to load.
    - bug fixes.

 -- Scott James Remnant <email address hidden>   Fri, 13 Mar 2009 12:07:21 +0000

Available diffs

Superseded in jaunty-release on 2009-03-13
module-init-tools (3.7~pre7-5) jaunty; urgency=low

  * debian/module-init-tools.postinst: Correct call to depmod to include
    kernel version.  LP: #341955.

 -- Scott James Remnant <email address hidden>   Fri, 13 Mar 2009 12:04:33 +0000

Available diffs

Superseded in jaunty-release on 2009-03-13
module-init-tools (3.7~pre7-4) jaunty; urgency=low

  * debian/module-init-tools.links: Create an /sbin/lsmod symlink, that's
    always been the location in Debian/Ubuntu.  We want to keep /bin/lsmod
    since that's the upstream location.  LP: #340666.

 -- Scott James Remnant <email address hidden>   Wed, 11 Mar 2009 09:32:59 +0000

Available diffs

Superseded in jaunty-release on 2009-03-13
module-init-tools (3.7~pre7-3) jaunty; urgency=low

  * Cannot call update-initramfs without depending on initramfs-tools,
    and we don't want to do that; but we can do this a different way by
    using Breaks to force an update of initramfs-tools.

 -- Scott James Remnant <email address hidden>   Tue, 10 Mar 2009 10:51:09 +0000

Available diffs

Superseded in jaunty-release on 2009-03-10
module-init-tools (3.7~pre7-2) jaunty; urgency=low

  * debian/control: module-init-tools should depend on initramfs-tools

 -- Luke Yelavich <email address hidden>   Tue, 10 Mar 2009 11:34:10 +1100

Available diffs

Superseded in jaunty-release on 2009-03-10
module-init-tools (3.7~pre7-1) jaunty; urgency=low

  * Repackage afresh for Ubuntu based off an upstream GIT import into bzr,
    rather than the Debian package.
  * New upstream pre-release:
    - many bug fixes.  LP: #99547, #292887, #303613, #284001.
    - much profiling and optimisation work.
    - depmod generates and modprobe uses binary indexes for module lists,
      giving a significant performance benefit.
    - legacy support for pre-2.6 kernels dropped.
    - module ordering support.  LP: #118040, #317724.
    - updated documentation.  LP: #203828, #259791.

  * /etc/modprobe.d/aliases: Dropped this file, the kernel has been able to
    export the {char,block}-major-* aliases for a while and adding them to the
    appropriate modules is a one line patch.  All aliases present here have
    been added to the Ubuntu kernel if not already present.  LP: #332357.
  * /etc/modprobe.d/isapnp: Dropped this file, the modalias strings in it were
    not current with the strings produced by pnpacpi in the kernel (pnpbios
    does not produce any modalias strings), and this kind of thing is better
    off done with kernel patches.
  * /etc/modprobe.d/options: Dropped this file, changes to default kernel
    options should be changed in the kernel so that they also take effect if
    the module is built-in; and also to make sure they're kept in sync with
    any changes to option names or defaults (or even module names) in the
    kernel.
  * /etc/modprobe.d/arch/*, /etc/modprobe.d/arch-aliases: Dropped the arch
    directory and the symlink into it, these aliases and/or options are
    handled by kernel patches now.

  * /etc/modprobe.d/blacklist-amd76-edac: Merged with the ordinary blacklist
    file, since it only contains one line.
  * /etc/modprobe.d/blacklist{,-*}: Files renamed to end in ".conf" as
    required by new upstream version.a

  * /sbin/update-modules: This deprecated command has been removed.
  * Completely non-parallel-installable with modutils.  LP: #208874.

  * All patches either merged upstream or dropped:
    - always_apply_blacklist: merged
    - blacklist-warn.diff: dropped.  LP: #66423.
    - fix_8bit: merged
    - fix_sgml: merged
    - ignore_arch_directory: dropped
    - insmod-segv: merged
    - last_good_boot: dropped
    - modprobe_conf_and_directory: dropped
    - runparts_like_names: merged
    - silence_modprobe: dropped
    - use_blacklist_doc: merged

  * Note that from this version of module-init-tools, all configuration files
    in /etc/modprobe.d should end with ".conf", support for other names is
    retained with a warning but will be dropped.
  * Note that the Ubuntu -Q option to modprobe has been dropped, to silence
    modprobe use -q.

 -- Scott James Remnant <email address hidden>   Mon, 09 Mar 2009 17:13:55 +0000

Available diffs

Superseded in jaunty-release on 2009-03-09
module-init-tools (3.3-pre11-4ubuntu20) jaunty; urgency=low

  * Blacklist vt8623fb video framebuffer driver.  By default we want all
    framebuffer drivers blacklisted but this one is missing.  (LP: #208137)

 -- Andy Whitcroft <email address hidden>   Mon, 09 Feb 2009 15:18:19 +0000
Superseded in jaunty-release on 2009-02-09
module-init-tools (3.3-pre11-4ubuntu19) jaunty; urgency=low

  * Blacklist ath_pci in favor of ath5k. See extended discussion in
    extra/modprobe.d/blacklist.
    LP: #315056

 -- Tim Gardner <email address hidden>   Sat, 31 Jan 2009 20:14:23 +0000
Deleted in intrepid-proposed on 2009-04-16 (Reason: unverified SRU)
module-init-tools (3.3-pre11-4ubuntu17.1) intrepid-proposed; urgency=low

  [ Andy Whitcroft ]

  * Ensure we install blacklist-amd76-edac from LP: #297750, to ensure we
    never fall foul of this internal list install all of the modprobe.d
    files with the exception of the arch directory.
    LP: #297750

 -- Tim Gardner <email address hidden>   Tue, 16 Dec 2008 15:27:19 +0000
Superseded in jaunty-release on 2009-01-31
module-init-tools (3.3-pre11-4ubuntu18) jaunty; urgency=low

  [ Andy Whitcroft ]

  * We are enabling both the old and new firewire stacks, for this to work
    we need to blacklist one of them.  To maintain backwards compatibility
    blacklist the new one.
    LP: #276463

  * Copy all files in extra/modprobe.d except for arch specific files.
    LP: #297750

 -- Tim Gardner <email address hidden>   Fri, 26 Dec 2008 14:33:22 +0000
Superseded in jaunty-release on 2008-12-26
Superseded in intrepid-proposed on 2009-01-06
module-init-tools (3.3-pre11-4ubuntu17) intrepid-proposed; urgency=low

  [ Andy Whitcroft ]

  * Add a blacklist entry for the amd76x_edac which prevents the
    AGP aperture being initialised.
    LP: #297750

 -- Tim Gardner <email address hidden>   Thu, 04 Dec 2008 14:55:23 -0700
Superseded in jaunty-release on 2008-12-09
Obsolete in intrepid-release on 2013-02-20
module-init-tools (3.3-pre11-4ubuntu16) intrepid; urgency=low

  * Add ignore_hpa=1 option for libata to get prior functionality and
    consistency.

 -- Ben Collins <email address hidden>   Tue, 14 Oct 2008 11:45:32 -0400
Superseded in intrepid-release on 2008-10-14
module-init-tools (3.3-pre11-4ubuntu15) intrepid; urgency=low

  * Added ipw2200 modprobe option 'associate=0' to stop auto-association.
    -LP: #264104

 -- Tim Gardner <email address hidden>   Mon, 13 Oct 2008 10:45:16 -0600
Superseded in intrepid-release on 2008-10-13
module-init-tools (3.3-pre11-4ubuntu14) intrepid; urgency=low

  * debian/module-init-tools.preinst:
    - update the rm_conffile() function to the one currently in common use
    - call rm_conffile for /etc/modprobe.d/blacklist-e1000e to clean up
      after ourselves

 -- Steve Langasek <email address hidden>   Mon, 06 Oct 2008 10:25:44 +0000
Obsolete in hardy-updates on 2015-04-24
Deleted in hardy-proposed on 2015-04-30 (Reason: moved to -updates)
module-init-tools (3.3-pre11-4ubuntu5.8.04.1) hardy-proposed; urgency=low

  * Also build the main binary with -Os instead of -O2, this makes modprobe
    noticeably faster; backported from 3.3-pre11-4ubuntu12; thanks
    Scott James Remnant; LP: #276096.

 -- Loic Minier <email address hidden>   Mon, 29 Sep 2008 23:23:24 +0200
Superseded in intrepid-release on 2008-10-06
module-init-tools (3.3-pre11-4ubuntu13) intrepid; urgency=low

  * Remove e1000e blacklist as this was not sufficient to prevent
    installation of the module since its normally installed in the
    initrd. The kernel was uploaded instead with the e1000e
    module disabled.

 -- Tim Gardner <email address hidden>   Wed, 24 Sep 2008 20:45:46 +0000
Superseded in intrepid-release on 2008-09-24
module-init-tools (3.3-pre11-4ubuntu12) intrepid; urgency=low

  * Compile with -Os instead of -O2, making things smaller really helps
    speed things up.  Oh, would somebody pick that Gentoo developer up off
    the floor; anyone would think I just shattered their religion or
    something.

 -- Scott James Remnant <email address hidden>   Wed, 24 Sep 2008 09:31:13 -0700
Superseded in intrepid-release on 2008-09-24
module-init-tools (3.3-pre11-4ubuntu11) intrepid; urgency=low

  * Added a rule to actually copy blacklist-e1000e to the package directory.

 -- Tim Gardner <email address hidden>   Tue, 23 Sep 2008 19:23:29 +0000
Superseded in intrepid-release on 2008-09-23
module-init-tools (3.3-pre11-4ubuntu10) intrepid; urgency=low

  * Temporarily blacklist e1000e.
    The e1000e driver is currently believed to cause onboard flash checksum errors in
    the 2.6.26 through 2.6.27-rc7 series kernels. These checksum errors
    can become severe enough to permanently disable the operation of the
    ICH8/ICH9 based e1000e NICs.

    For reference, please see:

    http://bugzilla.kernel.org/show_bug.cgi?id=11382
    http://news.opensuse.org/2008/09/22/serious-e1000e-driver-issue-in-sle-11-beta-1-and-opensuse-111-beta-1
    https://bugs.launchpad.net/suse/+source/linux/+bug/263555

    This is hopefully a temporary measure.
    LP: #263555

 -- Tim Gardner <email address hidden>   Tue, 23 Sep 2008 16:43:51 +0000
Superseded in intrepid-release on 2008-09-23
module-init-tools (3.3-pre11-4ubuntu9) intrepid; urgency=low

  * extra/modprobe.d/blacklist: Blacklist snd_pcsp by default. It has an
    extraordinarily low quality and is not useful at all for real audio
    playback. It causes a lot of hangs and pain, and workarounds in ALSA and
    PulseAudio have been insufficient. (LP: #246969)

 -- Martin Pitt <email address hidden>   Tue, 12 Aug 2008 17:31:29 +0200
Superseded in intrepid-release on 2008-08-12
module-init-tools (3.3-pre11-4ubuntu8) intrepid; urgency=low

  * extra/modprobe.d/blacklist-framebuffer:
    - Add lxfb module.  LP: #237186.

 -- Scott James Remnant <email address hidden>   Mon, 14 Jul 2008 10:18:11 +0100
Superseded in intrepid-release on 2008-07-14
module-init-tools (3.3-pre11-4ubuntu7) intrepid; urgency=low

  * patches/last_good_boot: Detect when we are booted with last-good-boot in
    /proc/cmdline, and set-version appropriate (so we get the right modules).
    Can still be overriden by --set-version= and is ignored in initramfs (-d
    /scripts)

 -- Ben Collins <email address hidden>   Fri, 20 Jun 2008 14:21:20 -0400
Superseded in intrepid-release on 2008-07-08
module-init-tools (3.3-pre11-4ubuntu6) intrepid; urgency=low

  * Blacklist snd_aw2, which is a new driver that conflicts with an existing
    dvb driver.

 -- Ben Collins <email address hidden>   Wed, 18 Jun 2008 14:11:06 -0400
Superseded in intrepid-release on 2008-06-18
Obsolete in hardy-release on 2015-04-24
module-init-tools (3.3-pre11-4ubuntu5) hardy; urgency=low

  [ Luka Renko <email address hidden> ]

  * Blacklist garmin_gps driver: most applications now have
    proper Garmin USB support, so serial emulation is not
    needed anymore.
    LP #114565

 -- Tim Gardner <email address hidden>   Mon, 25 Feb 2008 20:47:50 +0000
Superseded in hardy-release on 2008-02-25
module-init-tools (3.3-pre11-4ubuntu4) hardy; urgency=low

  * Blacklist asus_acpi in favor of asus-laptop
    LP #184721

 -- Tim Gardner <email address hidden>   Wed, 13 Feb 2008 11:31:20 -0700
Superseded in hardy-release on 2008-02-13
module-init-tools (3.3-pre11-4ubuntu3) hardy; urgency=low

  * Create /etc/depmod.d/ubuntu.conf to control the order
    of module searching. This solves the problem where there
    are duplicate modules in the kernel as well as linux-ubuntu-modules.
    The search order is updates, ubuntu, built-in, then everything else.

 -- Tim Gardner <email address hidden>   Fri,  1 Feb 2008 10:13:50 -0700
Superseded in hardy-release on 2008-02-01
module-init-tools (3.3-pre11-4ubuntu2) hardy; urgency=low

  * Blacklist bcm43xx, prism54.
    LP #185719

 --  <email address hidden>   Fri, 01 Feb 2008 14:54:43 +0000
Superseded in hardy-release on 2008-02-01
module-init-tools (3.3-pre11-4ubuntu1) hardy; urgency=low

  * Merge from debian unstable, remaining changes:
    + extra/installarchconf:
      - Install i386 archmap on lpia as well.
    + debian/control:
      - DebianMaintainerField foo
      - Add Replaces: hotplug
    + debian/module-init-tools.postinst:
      - Add upgrade quirks (removing a pre-dapper one in the process)
    + debian/module-init-tools.init:
      - log_message_start that we're "loading manual drivers".
      - Remove /lib/modules/boot support.
      - Don't warn about modprobe.conf not including modprobe.d (since we
        include it regardless)
    + debian/rules:
      - Install the following files into etc/modprobe.d:
          extra/modprobe.d/blacklist
          extra/modprobe.d/blacklist-framebuffer
          extra/modprobe.d/blacklist-watchdog
          extra/modprobe.d/isapnp
          extra/modprobe.d/options
      - Add those modprobe.d files to the udeb, too.
      - Start at 15 S instead of 20 S.
    + extra/modprobe.d/blacklist-framebuffer:
      - Blacklist framebuffer modules.
    + extra/modprobe.d/isapnp:
      - Add some modaliases missing from the kernel modules.
    + extra/modprobe.d/blacklist:
      - Add additional blaclists (see rationale in the file).
    + extra/modprobe.d/blacklist-watchdog:
      - Don't load watchdog modules by default (should be loaded by a watchdog
        daemon).
    + extra/modprobe.d/options:
      - Add a few options to pass by default to certain modules. (see
        description in the file).
    + debian/patches/silence_modprobe:
      - Add -Q option to modprobe (to suppress warnings and errors).
    + debian/patches/modprobe_conf_and_directory:
      - Don't ignore the modprobe.d directory if modprobe.conf is present.

Superseded in hardy-release on 2007-10-23
Obsolete in gutsy-release on 2011-09-16
module-init-tools (3.3-pre4-2ubuntu4) gutsy; urgency=low

  * Remove mptbase mpt_channel_mapping workaround. Fixed in mptbase in
    recent kernels instead.

 -- Soren Hansen <email address hidden>   Mon, 01 Oct 2007 09:01:14 +0200
Superseded in gutsy-release on 2007-10-05
module-init-tools (3.3-pre4-2ubuntu3) gutsy; urgency=low

  * extra/installarchconf: Install i386 archmap on lpia as well.

 -- Adam Conrad <email address hidden>   Wed,  1 Aug 2007 23:02:27 +1000
Superseded in gutsy-release on 2007-08-01
module-init-tools (3.3-pre4-2ubuntu2) gutsy; urgency=low

  * Remove blacklist for 818x and 8180 drivers.
  * Default mptbase to mpt_channel_mapping=1 to workaround bug #112860

 -- Ben Collins <email address hidden>   Thu, 17 May 2007 20:24:50 -0400
Superseded in gutsy-release on 2007-05-18
module-init-tools (3.3-pre4-2ubuntu1) gutsy; urgency=low

  * Merge from debian unstable, remaining changes:
    - Add modprobe.d/options
          modprobe.d/isapnp
          modprobe.d/blacklist-watchdog
          modprobe.d/blacklist-framebuffer
          modprobe.d/blacklist
    - debian/rules:
      - install extra modprobe.d files
      - use the above modprobe.d files in udeb
      - start at 15 S instead of 20 S
    - Preserve debian/patches/silence_modprobe and modprobe_conf_and_directory.
    - Remove debian/patches/hotplug_blacklist.
    - debian/control Ubuntu maintainer foobar.
    - debian/module-init-tools.init: remove /lib/modules/boot support.
    - debian/module-init-tools.postinst: preserve ipv6 blacklist removal.

Superseded in gutsy-release on 2007-05-16
Obsolete in feisty-release on 2009-08-20
module-init-tools (3.3-pre3-1ubuntu7) feisty; urgency=low

  * yes another one to make it even harder..

 -- Fabio M. Di Nitto <email address hidden>   Tue, 03 Apr 2007 14:41:19 +0200
Superseded in feisty-release on 2007-04-03
module-init-tools (3.3-pre3-1ubuntu6) feisty; urgency=low

  * and make damn sure we remove the blacklist-ipv6 file.

 -- Fabio M. Di Nitto <email address hidden>   Tue, 03 Apr 2007 14:37:30 +0200
Superseded in feisty-release on 2007-04-03
module-init-tools (3.3-pre3-1ubuntu5) feisty; urgency=low

  * Revert change from 3.3-pre3-1ubuntu4

 -- Fabio M. Di Nitto <email address hidden>   Tue, 03 Apr 2007 14:30:19 +0200
Superseded in feisty-release on 2007-04-03
module-init-tools (3.3-pre3-1ubuntu4) feisty; urgency=low

  * blacklist ipv6.
  (Closes LP: #24828)

 -- Fabio M. Di Nitto <email address hidden>   Fri, 30 Mar 2007 09:07:04 +0200
Superseded in feisty-release on 2007-03-30
module-init-tools (3.3-pre3-1ubuntu3) feisty; urgency=low

  * Fix thinko in previous upload, proper names are r818x and
    r8187. (Ubuntu: #78255, #88430)

 -- Kyle McMartin <email address hidden>   Tue,  6 Mar 2007 22:06:29 +0000
Superseded in feisty-release on 2007-03-06
module-init-tools (3.3-pre3-1ubuntu2) feisty; urgency=low

  * Blacklist {rtl818x,rtl8187} drivers. (Ubuntu: #78255, #88430)

 -- Kyle McMartin <email address hidden>   Tue, 27 Feb 2007 15:05:15 -0500
Superseded in feisty-release on 2007-02-27
module-init-tools (3.3-pre3-1ubuntu1) feisty; urgency=low

  * Merge from debian unstable, remaining changes:
    - automatically combine /etc/modprobe.conf and /etc/modprobe.d
    - drop support for /lib/modules/boot
    - drop support for /etc/hotplug/blacklist.d
    - add -Q option to increase modprobe silence
    - various extra modprobe.d options, including blacklists

Superseded in feisty-release on 2006-11-28
module-init-tools (3.2.2-3ubuntu4) feisty; urgency=low

  * Remove blacklist-pata. Feisty kernel has switched some ide drivers to pata
    now, and we want them to work.

 -- Ben Collins <email address hidden>   Mon, 20 Nov 2006 08:47:28 -0500
Superseded in feisty-release on 2006-11-20
Obsolete in edgy-release on 2008-06-19
module-init-tools (3.2.2-3ubuntu3) edgy; urgency=low

  * Restore more dropped merge patches (this one went VERY wrong):
    - configuration files in the udev
    - changes to init position and script
    - replaces on hotplug

 -- Scott James Remnant <email address hidden>   Wed,  5 Jul 2006 00:49:01 +0100
Superseded in edgy-release on 2006-07-05
module-init-tools (3.2.2-3ubuntu2) edgy; urgency=low

  * Restore configuration files dropped by the merge.
  * Add blacklist-pata which we'll use to select between IDE subsystem and
    PATA/libata drivers for PATA/IDE controllers.

 -- Scott James Remnant <email address hidden>   Fri, 30 Jun 2006 01:17:05 +0100
Superseded in edgy-release on 2006-06-30
module-init-tools (3.2.2-3ubuntu1) edgy; urgency=low

  * Merge from Debian unstable.
    - Keep our modprobe_conf_and_directory and silence_modprobe patches.
    - Retain drop of hotplug_blacklist patch.

 -- Scott James Remnant <email address hidden>   Wed,  7 Jun 2006 23:14:21 +0100
Superseded in edgy-release on 2006-06-08
Obsolete in dapper-release on 2011-09-06
module-init-tools (3.2.2-1ubuntu7) dapper; urgency=low

  * Don't convert dashes to underscores within the shell glob choice
    characters, these are illegal in module names but quite useful in
    wildcards (mostly for usb_storage).

 -- Scott James Remnant <email address hidden>   Fri,  5 May 2006 15:51:16 +0100
Superseded in dapper-release on 2006-05-05
module-init-tools (3.2.2-1ubuntu6) dapper; urgency=low

  * Apply the blacklist to all aliases, not just those defined by the
    kernel.  We frequently ship some in /etc/modprobe.d (like the isapnp
    ones) and still want blacklisting to work.

 -- Scott James Remnant <email address hidden>   Wed, 12 Apr 2006 08:23:27 +0100
Superseded in dapper-release on 2006-04-12
module-init-tools (3.2.2-1ubuntu5) dapper; urgency=low

  * Don't ignore the modprobe.d directory if modprobe.conf is present,
    just load all of them; this behaviour is very confusing for most users.

 -- Scott James Remnant <email address hidden>   Mon,  3 Apr 2006 19:54:39 +0100
Superseded in dapper-release on 2006-04-03
module-init-tools (3.2.2-1ubuntu4) dapper; urgency=low

  * Set the default mode of hostap devices to managed in
    /etc/modprobe.d/options

 -- Scott James Remnant <email address hidden>   Mon,  3 Apr 2006 19:05:26 +0100
Superseded in dapper-release on 2006-04-03
module-init-tools (3.2.2-1ubuntu3) dapper; urgency=low

  * Change the third Loading modules to "Loading manual drivers"
Superseded in dapper-release on 2006-02-07
Superseded in dapper-release on 2006-02-03
module-init-tools (3.2.2-1ubuntu2) dapper; urgency=low


  * Add new /etc/modprobe.d/options file and include option for quickcam.ko
    to enable double-buffering and thus work with gstreamer and friends.

 -- Scott James Remnant <email address hidden>  Mon,  9 Jan 2006 07:54:28 +0000
Superseded in dapper-release on 2006-01-31
module-init-tools (3.2.2-1ubuntu1) dapper; urgency=low


  * Resynchronise with Debian.
    - Drop input_table_size patch, included upstream.
    - Drop use_blacklist patch, included upstream.

 -- Scott James Remnant <email address hidden>  Thu, 15 Dec 2005 02:27:23 +0000
Superseded in dapper-release on 2006-01-31
module-init-tools (3.2.1-0ubuntu6) dapper; urgency=low


  * Rename /etc/modprobe.d/framebuffer to blacklist-framebuffer.
  * Rename /etc/modprobe.d/watchdog to blacklist-watchdog.

 -- Scott James Remnant <email address hidden>  Mon,  5 Dec 2005 16:39:21 +0000
Obsolete in breezy-release on 2008-03-25
module-init-tools (3.2-pre7-0ubuntu4) breezy; urgency=low


  * make the init script not exit if depmod cant refresh modules.dep 
    so /etc/modules gets actually read (necessary to load modules
    on readonly filesystems i.e. LTSP)

 -- Oliver Grawert <email address hidden>  Tue, 20 Sep 2005 02:41:26 +0200
175 of 77 results