gmcs keeps crashing

Bug #61670 reported by Philipp A. Baer on 2006-09-21
8
Affects Status Importance Assigned to Milestone
mono
Fix Released
Unknown
mono (Ubuntu)
High
Unassigned

Bug Description

Starting with mono 1.1.17 in edgy, gmcs won't compile anymore. On three different systems I get the following errors:

Unhandled Exception: Mono.CSharp.InternalErrorException: RLActionHandler.cs(37,35): CarpeNoctem.RLActionHandler.GetNextState(ActionFrame, int) ---> System.ExecutionEngineException: Failed to create shadow copy (mkstemp).

or simply

Unhandled Exception: System.ExecutionEngineException: Failed to create shadow copy (mkstemp).

The code that produces this error was introduces in r64262.

Edgy (latest packages) on AMD64 and i386.

Sebastian Dröge (slomo) wrote :

It works with banshee for example with the latest version. Could you please attach a small testcase that reproduces this problem?

Changed in mono:
importance: Untriaged → High
status: Unconfirmed → Needs Info
Philipp A. Baer (phbaer) wrote :

Ok, I've had a look at the problem again. It seems that this is the problem:

Compile a piece of code (Hello World, for example) with a library reference, i.e.
# gmcs -r:MDTTools.dll test.cs

If the referenced library is not in the GAC but in the MONO_PATH, gmcs dies with the error message mentioned above. Using the absolute path for the library fixes this problem.

It seems that the new shadow copy mechanism only searches the GAC but does not take care of the MONO_PATH... don't actually know what it should do, but with mono 1.1.16.1 everything works just fine.

Maybe a bug report on mono-dev would be more appropriate?

Sebastian Dröge (slomo) wrote :

Yes... please forward this bug to bugzilla.ximian.org and link it here...

Explains why it works with banshee and banshee-official-plugins, both use absolute/relative paths to non-GAC libraries.

Changed in mono:
status: Needs Info → Confirmed
Philipp A. Baer (phbaer) wrote :

Added bug report on ximian bugzilla:
http://bugzilla.ximian.com/show_bug.cgi?id=79462

description: updated
Sebastian Dröge (slomo) wrote :

Thanks :)

Sebastian Dröge (slomo) wrote :

Hum, I should probably test it myself before confirming a bug :)
I can't reproduce it here with mono 1.1.17.1-1ubuntu5 and upstream says it's fixed with .1

Changed in mono:
status: Confirmed → Needs Info
Philipp A. Baer (phbaer) wrote :

Ok, I confirm that it works with 1.1.17.1-1ubuntu5.

I've updated this morning, so ... well, my report was a bit late it seems :)
... and the linux installer from http://www.mono-project.com/Downloads is slightly outdated :(

Sebastian Dröge (slomo) on 2006-09-21
Changed in mono:
status: Needs Info → Fix Released
Grugnog (grugnog) wrote :

I can also reproduce this problem:
System.ExecutionEngineException: Failed to create shadow copy (mkstemp).

This is using 1.1.17.1-ubuntu6~dhx1 (not official)

Philipp A. Baer (phbaer) wrote :

I've reopened the bug at http://bugzilla.ximian.com/show_bug.cgi?id=79462. It's at least a similar one.

Changed in mono:
status: Unknown → Fix Released
Joakim (jryden) wrote :

Was there ever a fixed package released for this? I just tried to compile the latest F-spot and got:

make[3]: Entering directory `/home/jryden/f-spot-0.3.1/Tao/Tao.OpenGl'
MONO_PATH=:../../Tao/Tao.OpenGl.ExtensionLoader:. mono ../../Tao/Tao.GlPostProcess/Tao.GlPostProcess.exe \
                Tao.OpenGl-pre.dll Tao.OpenGl.dll "Tao.OpenGl.snk" \
                Tao.OpenGl.Gl Tao.OpenGl.ContextGl

Unhandled Exception: System.ExecutionEngineException: Failed to create shadow copy (mkstemp).
make[3]: *** [Tao.OpenGl.dll] Error 1

Philipp A. Baer (phbaer) wrote :

A fix should have been released with Mono 1.2.1. The problem was that I added an empty path to the MONO_PATH environment variable, which was handled incorrectly by the Mono utilities (something like MONOPATH=:/path/to/something)

AFAIK f-spot also uses the MONO_PATH variable in its start script (/usr/bin/f-spot), even though it supposedly should only be used for debugging and development purposes.

Joakim (jryden) wrote :

Ah. so it didn't make it as a bug fix for Edgy? Also the the error above is from compiling F-spot, so I don't even get to the point of running it. I guess the question becomes.. with the version of Mono in Edgy, how would one go about compiling f-spot successfully?

Philipp A. Baer (phbaer) wrote :

Yes, it seems so. I've installed Mono 1.2.2 from self-built packages and it worked for me. I'm really looking forward to the release of feisty :)

It is a very nasty bug. I've had some ... discussions on this bug and other Mono-related things with two developers some months ago. You may probably want to use the distribution-independent installer from www.mono-project.org. However, afaik it only includes gtk-sharp 2.4.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.