Change log for msttcorefonts package in Ubuntu

135 of 35 results
Published in cosmic-release on 2018-09-03
Deleted in cosmic-proposed (Reason: moved to release)
msttcorefonts (3.7ubuntu4~really3.6ubuntu3) cosmic; urgency=medium

  * Revert to the last known good version.

 -- Simon Quigley <email address hidden>  Sun, 02 Sep 2018 23:23:37 -0500
Superseded in cosmic-release on 2018-09-03
Deleted in cosmic-proposed on 2018-09-04 (Reason: moved to release)
msttcorefonts (3.7ubuntu3) cosmic; urgency=medium

  * Verify cab sums as they are extracted.

 -- Walter Lapchynski <email address hidden>  Wed, 29 Aug 2018 21:47:18 -0700
Superseded in cosmic-proposed on 2018-08-30
msttcorefonts (3.7ubuntu2) cosmic; urgency=medium

  * Rename postinst to postinst.in for compatibility with rules.

 -- Walter Lapchynski <email address hidden>  Wed, 29 Aug 2018 00:12:19 -0700

Available diffs

Superseded in cosmic-proposed on 2018-08-29
msttcorefonts (3.7ubuntu1) cosmic; urgency=medium

  * Merge from Debian Sid. Remaining changes:
    - Ubuntu update-ms-fonts still has a delta, based on
      update-notifier, which is not necessarily available in
      Debian.

 -- Walter Lapchynski <email address hidden>  Tue, 28 Aug 2018 21:06:28 -0700

Available diffs

Superseded in cosmic-release on 2018-08-30
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-08-29
Deleted in artful-proposed (Reason: moved to release)
msttcorefonts (3.6ubuntu2) artful; urgency=medium

  * Remove useless stuff from previous upload.

 -- Gianfranco Costamagna <email address hidden>  Tue, 29 Aug 2017 23:20:04 +0200

Available diffs

Superseded in artful-release on 2017-08-29
Deleted in artful-proposed on 2017-08-31 (Reason: moved to release)
msttcorefonts (3.6ubuntu1) artful; urgency=medium

  * Merge from Debian Sid. Remaining changes:
    - Ubuntu preinst and postrm scripts have deltas.
    - Source the debconf confmodule before doing anything else in the preinst.
    - Move #DEBHELPER# substitution before preinst code that might exit.
    - Migrate to use an update-notifier hook, so that package data can be
      handled asynchronously and not cause install failures on network
      problems.
    - Add missing pre-depends for use of debconf in preinst.
    - Convert to dh(1).
    - Skip race between update-notifier and update-ms-fonts trying to delete
      the same files from the same locations.

Available diffs

Superseded in artful-release on 2017-07-27
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed (Reason: moved to release)
msttcorefonts (3.4+nmu1ubuntu2) utopic; urgency=medium

  * update-ms-fonts: Skip race between update-notifier and update-ms-fonts
    trying to delete the same files from the same locations (LP: #1354709)
 -- Adam Conrad <email address hidden>   Thu, 11 Sep 2014 00:08:50 -0600

Available diffs

Superseded in utopic-release on 2014-09-11
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed (Reason: moved to release)
msttcorefonts (3.4+nmu1ubuntu1) raring; urgency=low

  * Merge from Debian unstable. Remaining changes:
    - Ubuntu preinst and postrm scripts have deltas.
    - debian/control: Add Multi-Arch: foreign.
    - Use maintscript support in dh_installdeb rather than writing out
      dpkg-maintscript-helper commands by hand.  We now simply Pre-Depend on a
      new enough version of dpkg rather than using 'dpkg-maintscript-helper
      supports' guards, leading to more predictable behaviour on upgrades.
    - Source the debconf confmodule before doing anything else in the preinst.
    - Move #DEBHELPER# substitution before preinst code that might exit.
    - Migrate to use an update-notifier hook, so that package data can be
      handled asynchronously and not cause install failures on network
      problems.
    - Add missing pre-depends for use of debconf in preinst.
    - Convert to dh(1).
 -- Logan Rosen <email address hidden>   Thu, 29 Nov 2012 21:35:42 -0500

Available diffs

Superseded in raring-release on 2012-12-02
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2012-04-09
msttcorefonts (3.4ubuntu3) precise; urgency=low

  * Migrate to use an update-notifier hook, so that package data can be
    handled asynchronously and not cause install failures on network
    problems.  LP: #876298.
  * Add missing pre-depends for use of debconf in preinst.
  * Convert to dh(1).
 -- Steve Langasek <email address hidden>   Sun, 08 Apr 2012 22:36:25 -0700

Available diffs

Superseded in precise-release on 2012-04-09
msttcorefonts (3.4ubuntu2) precise; urgency=low

  * Use maintscript support in dh_installdeb rather than writing out
    dpkg-maintscript-helper commands by hand.  We now simply Pre-Depend on a
    new enough version of dpkg rather than using 'dpkg-maintscript-helper
    supports' guards, leading to more predictable behaviour on upgrades.
  * Source the debconf confmodule before doing anything else in the preinst.
  * Move #DEBHELPER# substitution before preinst code that might exit.
 -- Colin Watson <email address hidden>   Mon, 13 Feb 2012 13:05:47 +0000

Available diffs

Superseded in precise-release on 2012-02-13
msttcorefonts (3.4ubuntu1) precise; urgency=low

  * Merge from Debian testing with help of MOM.  Remaining changes:
    - Ubuntu preinst and postrm scripts have deltas
  * debian/control: Add Multi-Arch: foreign (LP: #905055)
 -- Scott Ritchie <email address hidden>   Thu, 19 Jan 2012 00:47:02 -0800

Available diffs

Superseded in precise-release on 2012-01-29
Obsolete in oneiric-release on 2015-04-24
msttcorefonts (3.3ubuntu4) oneiric; urgency=low

  * Create /usr/share/fonts/truetype/msttcorefonts in the postinst
    instead of packaging it to work around a bad interaction with
    fontconfig's postinst: see Ubuntu bug 819097. (LP: #670629)
 -- Geoffrey Thomas <email address hidden>   Sun, 31 Jul 2011 22:43:26 -0400

Available diffs

Obsolete in lucid-updates on 2016-10-26
Deleted in lucid-proposed on 2016-11-01 (Reason: moved to -updates)
msttcorefonts (3.2ubuntu0.1) lucid-proposed; urgency=low

  * Display the EULA for the fonts when installing the package. Do not
    fails the install if the EULA is not accepted, but instead do not
    download the fonts (LP: #670629)
 -- Michael Vogt <email address hidden>   Fri, 03 Dec 2010 18:08:16 +0100

Available diffs

Obsolete in maverick-updates on 2013-03-05
Deleted in maverick-proposed on 2013-03-05 (Reason: moved to -updates)
msttcorefonts (3.2ubuntu2) maverick-proposed; urgency=low

  * change EULA display so that on refusal fonts are removed
  * do not fails the install if the EULA is not accepted, but instead
    do not download the fonts (LP: #670629)
 -- Michael Vogt <email address hidden>   Thu, 25 Nov 2010 18:43:26 +0100

Available diffs

Superseded in oneiric-release on 2011-08-03
Obsolete in natty-release on 2013-06-04
msttcorefonts (3.3ubuntu3) natty; urgency=low

  * change EULA display so that on refusal fonts are removed
  * do not fails the install if the EULA is not accepted, but instead
    do not download the fonts
 -- Michael Vogt <email address hidden>   Thu, 25 Nov 2010 19:38:34 +0100

Available diffs

Superseded in natty-release on 2010-11-25
msttcorefonts (3.3ubuntu2) natty; urgency=low

  * update-ms-fonts: make wget use the proxy defined for apt (LP: #56880)
 -- Marc Deslauriers <email address hidden>   Fri, 19 Nov 2010 16:44:56 -0500

Available diffs

Superseded in maverick-proposed on 2010-11-26
msttcorefonts (3.2ubuntu1) maverick-proposed; urgency=low

  * display the EULA for the fonts when installing the
    package (LP: #670629)
 -- Michael Vogt <email address hidden>   Thu, 04 Nov 2010 21:52:26 +0100

Available diffs

Superseded in natty-release on 2010-11-19
msttcorefonts (3.3ubuntu1) natty; urgency=low

  * display the EULA for the fonts when installing the
    package (LP: #670629)
 -- Michael Vogt <email address hidden>   Thu, 04 Nov 2010 21:52:26 +0100

Available diffs

3.3
Superseded in natty-release on 2010-11-04
msttcorefonts (3.3) unstable; urgency=low

  * Add Slovak debconf translation, thanks Slavko Pozdravom
    (Closes: 591520).
 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  15 Oct 2010 14:23:03 +0000

Available diffs

3.2
Superseded in natty-release on 2010-10-15
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
msttcorefonts (3.2) unstable; urgency=low

  * Improve regex used for checking proxy syntax (closes: #567464).

Available diffs

Superseded in lucid-release on 2010-02-22
msttcorefonts (3.0ubuntu1) lucid; urgency=low

  * debian/postinst.in : Check validity of proxy setting (LP : #274421)
  * update-ms-font : improve error handling (LP: #431217)(LP: #464422)
    - Don't fail if the fonts failed to download and display a message
      to run dpkg-reconfigure ttf-mscorefonts-installer later
    - Retry all mirrors for all fonts
    - Drop --dns-timeout option of wget an rely on system timeout
    - Increase --connect-timeout for slow connections
 -- Jean-Baptiste Lallement <email address hidden>   Tue, 12 Jan 2010 22:23:40 +0100

Available diffs

3.0
Superseded in lucid-release on 2010-01-21
Obsolete in karmic-release on 2013-03-04
msttcorefonts (3.0) unstable; urgency=low

  * Use SF.net redirection instead of individual mirror names, as to be
    more robust against changes on the SF.net side.
  * Verify font and cab validity with SHA256 instead of MD5 for safety.
  * Verify downloaded cab files before extracting.
  * Remove obsolete transitional package 'msttcorefonts'.
  * Added Belarusian debconf translation, thanks Pavel Piatruk
    (closes: #516246).
  * Update to debhelper level 7 and other packaging cleanups, rename some
    more backend items from msttcorefonts to ttf-mscorefonts-installer.

Available diffs

2.6
Superseded in karmic-release on 2009-04-29
Obsolete in jaunty-release on 2013-02-28
msttcorefonts (2.6) unstable; urgency=low

  * Rename package to ttf-mscorefonts-installer.
    This is in line with all other TrueType fonts in Debian and makes
    it clear that the package doesn't actually include the fonts but
    is a downloader package (Closes: #286154).
  * Move ttf-liberation to Recommends and advertise it more prominently,
    now that it is in Debian main.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  10 Nov 2008 14:39:11 +0000

Available diffs

2.5
Superseded in jaunty-release on 2008-11-10
Obsolete in intrepid-release on 2013-02-20
msttcorefonts (2.5) unstable; urgency=low

  * Move defoma debconf template to README. Not having defoma configured but
    requiring it is getting rare, so debconf is overkill.
  * Checked for policy 3.8.0, updated debian/copyright. Add Lintian
    override for emtpy fonts dir. Updated to debhelper 6.
  * Suggest ttf-liberation, not available from Debian yet but is available
    to users of debian-multimedia.
  * Drop preinst script that was only present to clean up for unstable/testing
    users that installed 2.0 - we've given them a year and it shouldn't
    pollute stable.
  * Remove set -e from prerm, because if msttcorefonts is not properly
    installed defoma-font may fail and we're still well uninstalled.
    (Closes: #461926)
  * Update mirror list.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  19 Jun 2008 13:43:09 +0100

Available diffs

2.4
Superseded in intrepid-release on 2008-06-19
Obsolete in hardy-release on 2015-04-24
msttcorefonts (2.4) unstable; urgency=low

  * Fix typo in templates, unfuzzy translations.
  * Add Finnish translation by Esko Arajärvi (closes: #448957).
  * cd out of scratchdir before removing it to prevent warning messages;
    thanks Sven Joachim (closes: #438989, #425322).

2.2
Superseded in hardy-release on 2007-11-23
Obsolete in gutsy-release on 2011-09-16
msttcorefonts (2.2) unstable; urgency=low

  * Move debhelper defoma code down in postinst, so any script failures
    will happen before the fonts are registered.
  * Also deregister the removed Tahoma with defoma (Closes: #425228).

2.0
Superseded in gutsy-release on 2007-05-21
msttcorefonts (2.0) unstable; urgency=low

  * No longer install the update-ms-fonts command. It's only
    needed upon package installation/upgrade, so it's now part
    of the package postinst. In the rare case that it needs to
    be ran again, just dpkg-reconfigure (Closes: #401698).
  * Add new font: Tahoma. Based on patch from Michael Gilbert,
    thanks! This unfortunately nearly doubles the download size
    (Closes: #380294).
  * Add support for setting a HTTP proxy during installation.
    Unfortunately it turns out to be difficult to pass the
    http_proxy environment variable around properly between
    different shells, especially for those using sudo, so
    this is needed for some situations
    (Closes: #333012, #413646).
  * Update to debhelper compatibility level 5 (from 1).
  * Remove obsolete upgrading code causing warnings
    (Closes: #290856, #392544, #405658).
  * Checked for policy 3.7.2, no changes.
  * X config location is now xorg.conf, not XF86Config-4.
  * Fix some non-POSIX shell code (Closes: #354926).
  * Refactor debconf prompting: drop template 'blurb'
    as per policy 3.9.1 (no copyright messages in debconf),
    make baddldir of type error and some minor corrections
    (Closes: #388936).
  * Update the list of SF.net mirrors.

  [ Translations ]
  * Basque by Piarres Beobide (Closes: #420073).
  * Galician by Jacobo Tarrio (Closes: #420071).
  * Portuguese by Rui Branco.
  * Danish by Kenneth Nielsen.
  * Swedish by Daniel Nylander.
  * Polish by Emil Nowak.
  * Czech by Marcel Sebek.
  * Italian by Luca Monducci (Closes: #420303).
  * Spanish by Steve Lord Flaubert (Closes: #420386).
  * Japanese by Hideki Yamane (Closes: #420481).
  * Russian by Yuri Kozlov (Closes: #420509).
  * Dutch by self.
  * German by Helge Kreutzman (Closes: #421106).
  * Brazilian Portuguese by André Luís Lopes (Closes: #421515).
  * French by Yves Rutschle.
  * Romanian by Igor Stirbu (Closes: #421749).

 -- sascha h?lterhoff <email address hidden>   Fri,  18 May 2007 11:08:44 +0100
Superseded in gutsy-release on 2007-05-18
Obsolete in feisty-release on 2009-08-20
msttcorefonts (1.8ubuntu1) feisty; urgency=low

  * Merge from Debian unstable. Ubuntu changes:
     - Added the capability to specify an http proxy using debconf
     - Updated debconf config script to use http_proxy if it is set
  * Set Maintainer to Ubuntu MOTU Developers

Superseded in feisty-release on 2007-02-17
msttcorefonts (1.7ubuntu1) feisty; urgency=low

  * Merge from Debian unstable. Ubuntu changes:
     - See 1.5ubuntu1

 -- Adrien Cunin <email address hidden>   Tue, 16 Jan 2007 22:36:01 +0100
Superseded in feisty-release on 2007-01-16
msttcorefonts (1.6ubuntu1) feisty; urgency=low

  * Merge from Debian unstable. Ubuntu changes:
     - See 1.5ubuntu1

 -- Adrien Cunin <email address hidden>   Tue,  2 Jan 2007 17:33:46 +0100
Superseded in feisty-release on 2007-01-02
msttcorefonts (1.5ubuntu1) feisty; urgency=low

  * Re-sync with Debian
  * Re-merge the following changes:
    * msttcorefonts (1.2ubuntu3) dapper; urgency=low
      * updated debconf config script to use http_proxy if it is set
    *  -- Benjamin Montgomery <email address hidden>  Fri, 26 May 2006 15:54:45 -0500
    * msttcorefonts (1.2ubuntu2) breezy; urgency=low
      * added the capability to specify an http proxy using debconf
    * -- Benjamin Montgomery <email address hidden>  Mon,  3 Oct 2005 21:48:50 -0500

 -- Barry deFreese <email address hidden>   Sun, 10 Dec 2006 00:17:05 -0500
Superseded in feisty-release on 2006-12-10
Obsolete in edgy-release on 2008-06-19
Obsolete in dapper-release on 2011-09-06
msttcorefonts (1.2ubuntu3) dapper; urgency=low

  * updated debconf config script to use http_proxy if it is set

 -- Benjamin Montgomery <email address hidden>   Fri, 26 May 2006 15:54:45 -0500
Superseded in dapper-release on 2006-05-26
Superseded in dapper-release on 2006-02-03
Obsolete in breezy-release on 2008-03-25
msttcorefonts (1.2ubuntu2) breezy; urgency=low


  * added the capability to specify an http proxy using debconf

 -- Benjamin Montgomery <email address hidden>  Mon,  3 Oct 2005 21:48:50 -0500
Obsolete in hoary-release on 2008-03-19
msttcorefonts (1.2ubuntu1) hoary; urgency=low


  * tightened build-depend on defoma (>= 0.8.11ubuntu2)

 -- Daniel Holbach <email address hidden>  Fri, 18 Mar 2005 22:05:09 +0100
Obsolete in warty-release on 2008-01-09
msttcorefonts (1.1.11) unstable; urgency=low


  * Handle the case of /usr/X11R6/lib/X11/TrueType being a broken symlink in
    preinst.  (closes: #272939, hopefully)

 -- Tollef Fog Heen <email address hidden>  Sun, 26 Sep 2004 23:53:15 +0200
135 of 35 results