Ubuntu

Selecting mozilla-thunderbird as the preferred mail app still launches evolution

Reported by Richard Kut on 2005-10-05
46
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Wishlist
nautilus-sendto (Ubuntu)
Wishlist
Ubuntu Desktop Bugs
Declined for Gutsy by Sebastien Bacher

Bug Description

I access System --> Preferences --> Preferred Applications. I select the Mail
Reader tab. I select custom. I enter the following :
/usr/bin/mozilla-thunderbird, and then I close the Preferred Applications
applet. Now when I go to Nautilus and right-click with the mouse on a file and
select Send To... I still get Evolution showing up as the default mailer.

http://bugs.gnome.org/show_bug.cgi?id=318052: http://bugs.gnome.org/show_bug.cgi?id=318052

Daniel Holbach (dholbach) wrote :

Thanks for the report. That's an issue with nautilus-sendto. I opened a bug
report about that upstream: http://bugs.gnome.org/show_bug.cgi?id=318052

gatis-abele (gatis-abele) wrote :

The temporary solution would be nautilus script, but there is another problem
with Thunderbird – no command line option exists to automatically add the
attachment. http://forums.mozillazine.org/viewtopic.php?t=241131

gatis-abele (gatis-abele) wrote :

My concerns where unfounded, temporary workaround script is available through
mozilla-thunderbird -compose.

Daniel Holbach (dholbach) wrote :

Thanks for following up on this - the discussion seems to go on in the upstream
bug I pointed out.

Daniel Holbach (dholbach) wrote :

Upstream bug has a patch attached now.

Changed in nautilus-sendto:
status: Unconfirmed → Confirmed

When will we see this feature in action?

dominik (dominik-holler) wrote :

problem is still in Ubuntu Feisty Fawn Herd 4.

why is /nautilus-sendto/src/plugins/thunderbird.c disabled ?

Ubuntu Feisty Fawn Herd 5

has still no sendto support for Thunderbird

Whoopie (whoopie79) wrote :

Hi,

I made a patch for nautilus-sendto 0.10: http://bugzilla.gnome.org/show_bug.cgi?id=356258

Best regards,
Whoopie

Philip Axer (paxer) wrote :

Still unsolved for me ...any chance to see a progress in this? Or will it be solved within the next major upstream release?

Philip Axer (paxer) wrote :

I found some bugs in the patch commited by Whoopie!

- t_cmd = g_find_program_in_path ("mozilla-thunderbird");
+ t_cmd = g_find_program_in_path ("thunderbird");

This is wrong, since the executable is "mozilla-thunderbird" and NOT "thunderbird"! I modified the source myself and voila it works voila!
This is the interesting line:
-enable_thunderbird=no
+enable_thunderbird=yes

it would be quite nice to see that in feisty, cause this is pretty much a one line thingy...

Changed in nautilus-sendto:
assignee: dholbach → desktop-bugs
Tangui (tanguim) wrote :

To automatically add the attachment :

mozilla-thunderbird -compose "attachment=file:///tmp/file.pdf"

Sebastien Bacher (seb128) wrote :

This upload fixes the bug:

 nautilus-sendto (0.10-2ubuntu2) gutsy; urgency=low
 .
   * debian/control.in:
     - use pidgin
   * debian/patches/nautilus-sendto-0.7-thunderbird.patch:
     - patch from fedora, fix thunderbird usage (Ubuntu: #23281)
   * debian/patches/nautilus-sendto-0.10-pidgin.patch:
     - patch from fedora to build with pidgin

Changed in nautilus-sendto:
status: Confirmed → Fix Released

great

will there be a backport for feisty?

Whoopie (whoopie79) wrote :

@Philip Axer:
It's not my patch which has this bug. It's the patch which is in the Fedora CVS: http://cvs.fedora.redhat.com/viewcvs/devel/nautilus-sendto/nautilus-sendto-0.7-thunderbird.patch?root=core&rev=1.1&view=auto

@Sebastien Bacher:
Did you test the Fedora patch? This one didn't work for me, so I re-wrote it. Could you please have a look at my version (http://bugzilla.gnome.org/attachment.cgi?id=84428&action=view)? Since it also works when compressing the files (via file-roller).

Thanks in advance.

Best regards,
Whoopie

Whoopie (whoopie79) wrote :

Hi,
the thunderbird patch doesn't work. please consider applying my patch. I'll attach a patch which works with thunderbird in gutsy.

Changed in nautilus-sendto:
status: Fix Released → Confirmed
Whoopie (whoopie79) wrote :

the attached patch works for me. Thanks for reviewing it.

deepak (deepak-ezrs) wrote :

Can you tell me how to use this patch? Thanks

Sebastien Bacher (seb128) wrote :

could you explain what doesn't work on gutsy? thunderbird is listed correctly and using it seems to work correctly on my desktop

Changed in nautilus-sendto:
status: Confirmed → Needs Info

Doesn't work on Feisty. Send to still links to Evolution (only) despite
Thunderbird having been selected as default application.

Sebastien Bacher wrote:
> could you explain what doesn't work on gutsy? thunderbird is listed
> correctly and using it seems to work correctly on my desktop
>
> ** Changed in: nautilus-sendto (Ubuntu)
> Status: Confirmed => Needs Info
>
>

Whoopie (whoopie79) wrote :

Attached a screenshot with the error.

Changed in nautilus-sendto:
status: Incomplete → New
Changed in nautilus-sendto:
status: New → Triaged

Hi Sebastien;

Desirable change. But, then I have know idea where to start changing.
Realize must be with terminal, but then no experience/knowledge - worse
still knowing.

If you have time to assist, appreciate it.

I have not run across any grouped examples of terminal entry, file access,
safe techniques for modifying. Back in my years of CPM and DOS there were
numerous example sources for specific information. Linux, however well
intended, seems a step backward to the early days of DOS with a multitude of
opinions with more inter opposition than directed reference.

There actually feels to me like "If you don't know your stupid - or using
wrong Linux program"!

Appreciate you efforts, however lost I am. Phil, Sonoma CA

On 8/13/07, Sebastien Bacher <email address hidden> wrote:
>
> ** Changed in: nautilus-sendto (Ubuntu)
> Status: New => Triaged
>
> --
> Selecting mozilla-thunderbird as the preferred mail app still launches
> evolution
> https://bugs.launchpad.net/bugs/23281
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Phil Jr..

Sebastien Bacher (seb128) wrote :

you can ask questions on the support tracker of on the users lists

Sebastien Bacher (seb128) wrote :

Some precisions on the previous comment, the bug is tracker is there to work on getting issues fixed. The discussions on how to start and where to learn would be better located on the users medias

François Montel (zerohalo) wrote :

Woopie, your patch works, but only if TBird is not running. Is it possible to fix it so that it will create a new compose window even if TBird is running? Thanks!

deepak (deepak-babel) wrote :

 François ...

Can you tell me how to apply the patch?

Colo505-at-freeuk-dot-com

Whoopie (whoopie79) wrote :

Hi,

I attach a updated patch for nautilus-sendto 0.12.

Francois: The patch also works here with a running Thunderbird. So, we need to find out why it's not working for you. What else infos can you give me?

Whoopie (whoopie79) wrote :

Sorry, last patch had a bug. Please use this one.

Whoopie (whoopie79) wrote :

Hi,

this patch fixes the thunderbird name and the escaping for the attachment parameter.

@Sebastian: is this patch OK for you?

Best regards,
Whoopie

Hi,

I am not quiet sure concerning the patches. I first replaced the nautilus-sendto-0.7 patch with nautilus-sendto-0.12-thunderbird.patch and the package built fine. And the thunderbird-bug seems to befixed.

But trying nautilus-sendto-0.12-thunderbird-2.patch, I can not build the package.

Regards
Christian

Whoopie (whoopie79) wrote :

Christian, please post or attach the build errors. Thanks!

Sorry, was my misstake. I removed the 0.7 patch and everything worked fine.

deepeshrajpal (deepeshrajpal) wrote :

Whoopie your patch worked for me and it should included in gutsy.

Sebastien Bacher (seb128) wrote :

nautilus-sendto (0.12-0ubuntu4) gutsy; urgency=low

  * debian/patches/nautilus-sendto-0.7-thunderbird.patch:
    - update from Whoopie to list thunderbird attachments correctly (LP: #23281)

 -- Sebastien Bacher <email address hidden> Thu, 20 Sep 2007 10:47:54 +0200

Changed in nautilus-sendto:
status: Triaged → Fix Released
Changed in nautilus:
status: Confirmed → Fix Released
John Pye (jdpipe) wrote :

I am seeing this bug after an update to Jaunty. Is it possible there's been a regression?

My "Send To" dialog does not contain "Thunderbird" any more.

Also, strangely, my "Preferred Applications" box contains both "Thunderbird" and "Mozilla Thunderbird".

Some more info:
john@thunder:~$ dpkg -l nautilus-sendto
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii nautilus-sendt 1.1.2-0ubuntu1 integrates Evolution and Pidgin into the Nau
john@thunder:~$ dpkg -L nautilus-sendto
/.
/usr
/usr/lib
/usr/lib/nautilus-sendto
/usr/lib/nautilus-sendto/plugins
/usr/lib/nautilus-sendto/plugins/libnstbluetooth.so
/usr/lib/nautilus-sendto/plugins/libnstevolution.so
/usr/lib/nautilus-sendto/plugins/libnstgajim.so
/usr/lib/nautilus-sendto/plugins/libnstburn.so
/usr/lib/nautilus-sendto/plugins/libnstpidgin.so
/usr/lib/nautilus-sendto/plugins/libnstremovable_devices.so
/usr/lib/nautilus
/usr/lib/nautilus/extensions-2.0
/usr/lib/nautilus/extensions-2.0/libnautilus-sendto.so
/usr/lib/pidgin
/usr/lib/pidgin/nautilus.so
/usr/lib/evolution
/usr/lib/evolution/2.26
/usr/lib/evolution/2.26/plugins
/usr/lib/evolution/2.26/plugins/org-gnome-evolution-send-attachments-to.eplug
/usr/lib/evolution/2.26/plugins/liborg-gnome-evolution-send-attachments-to.so
/usr/bin
/usr/bin/nautilus-sendto
/usr/share
/usr/share/nautilus-sendto
/usr/share/nautilus-sendto/glade
/usr/share/nautilus-sendto/glade/nautilus-sendto.glade
/usr/share/man
/usr/share/man/man1
/usr/share/man/man1/nautilus-sendto.1.gz
/usr/share/doc
/usr/share/doc/nautilus-sendto
/usr/share/doc/nautilus-sendto/AUTHORS
/usr/share/doc/nautilus-sendto/README.Debian
/usr/share/doc/nautilus-sendto/copyright
/usr/share/doc/nautilus-sendto/buildinfo.gz
/usr/share/doc/nautilus-sendto/NEWS.gz
/usr/share/doc/nautilus-sendto/changelog.Debian.gz
/usr/share/gconf
/usr/share/gconf/schemas
/usr/share/gconf/schemas/nst.schemas
john@thunder:~$ dpkg -l "thunderbird*"
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii thunderbird 2.0.0.21+nobin mail/news client with RSS and integrated spa
ii thunderbird-gn 2.0.0.21+nobin Support for Gnome in Mozilla Thunderbird
ii thunderbird-lo 1:2.0.0.14+1-0 Thunderbird English language/region package
john@thunder:~$

Ben (ben2talk) wrote :

BUMP - I used to send via Thunderbird using nautilus right click with ubuntu 8.10 - now it's taken out!

/.
/usr
/usr/lib
/usr/lib/nautilus-sendto
/usr/lib/nautilus-sendto/plugins
/usr/lib/nautilus-sendto/plugins/libnstbluetooth.so
/usr/lib/nautilus-sendto/plugins/libnstevolution.so
/usr/lib/nautilus-sendto/plugins/libnstgajim.so
/usr/lib/nautilus-sendto/plugins/libnstburn.so
/usr/lib/nautilus-sendto/plugins/libnstpidgin.so
/usr/lib/nautilus-sendto/plugins/libnstremovable_devices.so
/usr/lib/nautilus
/usr/lib/nautilus/extensions-2.0
/usr/lib/nautilus/extensions-2.0/libnautilus-sendto.so
/usr/lib/pidgin
/usr/lib/pidgin/nautilus.so
/usr/lib/evolution
/usr/lib/evolution/2.26
/usr/lib/evolution/2.26/plugins
/usr/lib/evolution/2.26/plugins/org-gnome-evolution-send-attachments-to.eplug
/usr/lib/evolution/2.26/plugins/liborg-gnome-evolution-send-attachments-to.so
/usr/bin
/usr/bin/nautilus-sendto
/usr/share
/usr/share/nautilus-sendto
/usr/share/nautilus-sendto/glade
/usr/share/nautilus-sendto/glade/nautilus-sendto.glade
/usr/share/man
/usr/share/man/man1
/usr/share/man/man1/nautilus-sendto.1.gz
/usr/share/doc
/usr/share/doc/nautilus-sendto
/usr/share/doc/nautilus-sendto/AUTHORS
/usr/share/doc/nautilus-sendto/README.Debian
/usr/share/doc/nautilus-sendto/copyright
/usr/share/doc/nautilus-sendto/buildinfo.gz
/usr/share/doc/nautilus-sendto/NEWS.gz
/usr/share/doc/nautilus-sendto/changelog.Debian.gz
/usr/share/gconf
/usr/share/gconf/schemas
/usr/share/gconf/schemas/nst.schemas

Sebastien Bacher (seb128) wrote :

don't comment on closed bugs, there is a bug about the jaunty issue which has nothing to do with this one

Id2ndR (id2ndr) wrote :

About the bug on jaunty : "Preferred Applications" box contains both "Thunderbird" and "Mozilla Thunderbird", look at bug #373167

Changed in nautilus:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.