Ubuntu

Ubuntu desktop doesn't know what to do with already mounted video-DVDs

Reported by Shaya Potter on 2004-11-29
66
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
Baltix
Undecided
Unassigned
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

so gnome-volume-manager does a good job launching totem and mounting my DVD when
I insert it. However, instead of launching totem when I open a dvd mounted to
the desktop, it just opens in Nautilus. I doubt this is what should really happen.

http://bugzilla.gnome.org/show_bug.cgi?id=161004: http://bugzilla.gnome.org/show_bug.cgi?id=161004

Shaya Potter (spotter) wrote :

this is running hoary.

Sebastien Bacher (seb128) wrote :

I've opened a bug upstream about it:
http://bugzilla.gnome.org/show_bug.cgi?id=161004

Phil Housley (undeconstructed) wrote :

With some reference to this blog post:

http://www.gnome.org/~fherrera/blog//Applications_instead_of_commands

I think this really should be a deeper issue. I think it would be very helpful
if Gnome had an idea of the preferred dvd/other video disc player, and the
prefered audio-cd player, in the same way as it knows the preferred browser etc.
 This would mean that all gnome-volume-manager would need to ask is whether to
play the disc, not what command to run. The same would then be true of nautilus:

-------------
Play Video
Open
Browse Folder
-------------
etc

(I don't feel inclined to open a b.g.o account at the moment; if anyone agrees
with me, please send this upstream.)

Lionel Dricot (ploum) wrote :

This is IMHO a big usability issue since there's no obvious way at all to play an already inserted DVD except ejecting/reinserting (wich is ugly)

Changed in nautilus:
status: Unconfirmed → Confirmed
Changed in nautilus:
status: Unconfirmed → Confirmed
Duncan Lithgow (duncan-lithgow) wrote :

My bug was marked as a duplicate of this one so I'll add my comment here. I'm not quite sure I've understood the previous comments but my view is that inserted media (included USB media) sould be treated just as any other type of file. The context menu should include 'Open with another application ...' so users can decide what app they want to use for each task. I don't think automounting and autoplaying are such a big deal as letting people specify the player they want to use.

Changed in nautilus:
status: Confirmed → Triaged
Duncan Lithgow (duncan-lithgow) wrote :

Still present in Gutsy (installed from Tribe 3 desktop CD)

The right-click context menu for a mounted DVD on the desktop does not even provide an 'Open with Movie Player' or 'Open with Other Application...' option. The addition of those options would be my preferred solution.

Changed in nautilus:
assignee: seb128 → desktop-bugs
importance: Medium → Low
Sebastien Bacher (seb128) wrote :

Using hardy there is a button saying that the disk has video content you can use to start the player, do you consider that as a good solution?

Changed in nautilus:
status: Triaged → Incomplete
Sebastien Bacher (seb128) wrote :

untagging from the hardy desktop list since the issue is a small one and hardy makes it easy to open the player already

Dan Trevino (dantrevino) wrote :

the process flow should be:

1. insert video dvd
2. dvd plays

1. insert data dvd
2. dvd opens in nautilus

A 'video content' button is not what 'humans' want to see.

Sebastien Bacher (seb128) wrote :

What you describe is what the software is doing right now, the question is what to do when browsing the mount directory using nautilus, some users want to be able to get multimedia content from there so you can't say users should be allowed to do that and the video player should always be started

Sebastian. As of now I seem to be getting three behaviours. When I insert a dvd it plays automatically in Totem Movie Player. I also get the desktop icon which has a a right click option to 'Open with "Movie Player" ' ( should I report as a bug that it's not named "Totem Movie Player" in that text?). If I just open the DVD the button appears at the top to "Open Movie Player". This seems okay, time will show if people want video content automatically played.

Sebastien Bacher (seb128) wrote :

is that still an issue in hardy?

Sebastien Bacher (seb128) wrote :

the current version make easy to browse the DVD content and to start playing the video, closing the bug

Changed in nautilus:
status: Incomplete → Fix Released
Changed in nautilus:
status: Confirmed → Fix Released
Changed in nautilus:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.