High CPU usage

Bug #54684 reported by slow on 2006-07-31
116
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Critical
gnome-vfs2 (Ubuntu)
High
Ubuntu Desktop Bugs
Edgy
High
Sebastien Bacher
nautilus (Ubuntu)
Undecided
Unassigned

Bug Description

1. Go to a directory where something is being downloaded.
2. Refresh a couple of times.

CPU usage jumps to 100% and stays that way even after switching to another directory.

Using 386 kernel by the way.

Sebastien Bacher (seb128) wrote :

Thanks for your bug. What version of Ubuntu do you use? Does it depends of the format of the file you download? Could you get a backtrace with nautilus-dbg installed when that happens, using gdb:
- gdb -p $(pidof nautilus)
(gdb) thread apply all bt

Changed in nautilus:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info
slow (no1wantdthisname) wrote :

I'm using edgy.
Nautilus 2.15.90.
Happens regardless of file being downloaded.

The backtrace:
Thread 2 (Thread -1242137696 (LWP 8497)):
#0 0xffffe410 in __kernel_vsyscall ()
#1 0x4669103e in __lll_mutex_lock_wait ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2 0x4668d6c4 in _L_mutex_lock_49 () from /lib/tls/i686/cmov/libpthread.so.0
#3 0xb5f671e8 in ?? ()
#4 0x466df9b2 in g_main_context_default () from /usr/lib/libglib-2.0.so.0
#5 0x466e0c0f in g_source_attach () from /usr/lib/libglib-2.0.so.0
#6 0x466e0d6e in g_idle_add_full () from /usr/lib/libglib-2.0.so.0
#7 0x466e0dd0 in g_idle_add () from /usr/lib/libglib-2.0.so.0
#8 0x41167458 in gnome_vfs_job_get_count () from /usr/lib/libgnomevfs-2.so.0
#9 0x41167968 in gnome_vfs_job_get_count () from /usr/lib/libgnomevfs-2.so.0
#10 0x41166f53 in gnome_vfs_async_set_job_limit ()
   from /usr/lib/libgnomevfs-2.so.0
#11 0x466fccf0 in g_thread_pool_push () from /usr/lib/libglib-2.0.so.0
#12 0x466fb545 in g_thread_create_full () from /usr/lib/libglib-2.0.so.0
#13 0x4668b534 in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#14 0x4650521e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread -1210849616 (LWP 8450)):
#0 0x4668d423 in pthread_mutex_lock () from /lib/tls/i686/cmov/libpthread.so.0
#1 0x466e18d6 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#2 0x466e1c28 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#3 0x466e220c in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#4 0x414e1072 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#5 0x0807b085 in main (argc=1, argv=0xbf996d94) at nautilus-main.c:367
#6 0x4644c8b8 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#7 0x080678a1 in _start ()
#0 0x4668d423 in pthread_mutex_lock () from /lib/tls/i686/cmov/libpthread.so.0

slow (no1wantdthisname) on 2006-08-02
description: updated
Matti Lindell (mlind) wrote :

I'm able to reproduce this using slow's instruction.

$ cd /tmp
$ nautilus .
$ wget http://download.nvidia.com/XFree86/Linux-x86/1.0-8774/NVIDIA-Linux-x86-1.0-8774-pkg1.run

Hit refresh button on nautilus view couple of times and cpu usage goes high.

Changed in nautilus:
status: Needs Info → Confirmed
Michael Monreal (mimox) wrote :

I'm also seeing this. I still use Ubuntu Dapper on this machine but I have compiled nautilus 2.16 from source.

Changed in nautilus:
status: Unknown → Unconfirmed
John Dong (jdong) wrote :

On Edgy, I am also seeing this with AVI's. To reproduce, use Acidrip to rip something to an AVI (default settings are fine, 1-pass is faster). Have Nautilus go into the directory where the AVI is being outputted. Press refresh a few times, then close the nautilus window, then close acidrip. Now nautilus is stuck at 100% CPU.

Doing a backtrace, I get:
Thread 1 (Thread -1227446608 (LWP 27640)):
#0 0xb75f9448 in pthread_mutex_lock () from /lib/tls/i686/cmov/libpthread.so.0
#1 0xb758bf39 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#2 0xb758d451 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#3 0xb758db89 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#4 0xb7aca574 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#5 0x0807bb4a in main (argc=2, argv=0xbf819054) at nautilus-main.c:372
#6 0xb73118cc in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#7 0x08067621 in _start ()
#0 0xb75f9448 in pthread_mutex_lock () from /lib/tls/i686/cmov/libpthread.so.0

GonzO (gonzo) wrote :

A big "me too" on this one.

It's a shame; its the only thing about Edgy that I'd call a showstopper. Everything else is working swimmingly for me.

Changed in nautilus:
importance: Undecided → High
Jason Gerard DeRose (jderose) wrote :

I'm experiencing the same problem using Thoggen under Edgy.

It isn't necessary to hit refresh to trigger this. Simply opening nautilus to a directory containing a file that is being updated, and then immediately closing the nautilus window or changing to anther directory (like home) does the same thing... the CPU usage will shoot up to near 100% and will stay there till the process is killed (with "killall nautilus" or the like).

Pierre-Charles David (pcdavid) wrote :

I confirm this on a current Edgy (as of 2006-10-21), with nautilus 2.16.1-0ubuntu3. This is on AMD64 but in 32bit mode. This happens to me when downloading AVIs or ISOs, with Firefox or wget, i.e. basically any time there is a constantly growing file.

I don't know if this can help, but I attach the first 50 lines of an "strace $(pidof nautilus)" after the problem occured.

Christoffer Karvonen (xopher) wrote :

Confirmed here too, running Edgy amd64.

Have had this problem for a while now :/

Rhubarb (cdawdy) wrote :

Confirmed here too.
Running Edgy i386
While downloading a file with the default bittorrent manager,
clicking (once) on the incomplete file in Nautilus in the directory causes 100% cpu usage on one core - am running on a core duo here.

dedalus (dedal34) wrote :

I got this bug too
running edgy on a centrino inspiron 8600c

this happen when opening a folder with video in it.

John Dong (jdong) wrote :

I don't think there's much of a need to echo confirmations... It's pretty consistently reproducible and I've experienced this in all the GNOME 2.16's I've tried.

Artemis3 (artemis3) wrote :

Oh, i have seen this since Edgy Eft Beta; just by pluging my digital photo camera, importing a couple of pics and then turning off the camera triggers it. To fix, i simply kill the nautilus process and remember next time when importing pictures not to turn off the camera but wait whatever timeout exists...

Sebastien Bacher (seb128) wrote :

not a nautilus issue

Changed in nautilus:
status: Unconfirmed → Rejected
Sebastien Bacher (seb128) wrote :

fixed upstream

Changed in gnome-vfs2:
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :

I'll look at backporting that to edgy

Changed in nautilus:
assignee: nobody → seb128
importance: Undecided → High
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :
Sebastien Bacher (seb128) wrote :
Sebastien Bacher (seb128) wrote :

I've uploaded i386 packages with the patch to http://people.ubuntu.com/~seb128/debug/54684/ if somebody wants to test and comment on whether it fixes the bug for him too, they work fine for me

John Dong (jdong) wrote :

Fixes the problem for me! Requires a killall nautilus to take effect after installing, but I can no longer reproduce this bug :). Thank you so much!

Pierre-Charles David (pcdavid) wrote :

The fix works for me too. Thanks Sebastien.

Changed in nautilus:
status: Unconfirmed → Fix Released
Matti Lindell (mlind) wrote :

Fixes the issue here aswell =) Thanks seb.

Paul Bell (launchpad-dpb) wrote :

Any chance of an x86_64 deb please? This is driving me bonkers!

Many thanks!

Sebastien Bacher (seb128) wrote :

This upload fixes the issue:

 gnome-vfs2 (2.16.2-0ubuntu1) feisty; urgency=low
 .
   * New upstream version:
     - Add a "--replace" commandline argument to gnome-vfs-daemon
       to replace the current daemon. (Mostly for debugging use)
     - Make translations work in gnome-vfs-daemon
     - Handle IPv6 addresses when creating dav uris (DNS-SD)
     - Don't crash if there is no session dbus
     - Support sun ssh server
     - Don't fail getting selinux context
     - Allow operations on file handles that were created in another
       DaemonConnection. (This fixes e.g. smb browsing) (Ubuntu: #60277)
     - Fixes to gnome_vfs_xfer and monitoring (Ubuntu: #54684)
   * debian/patches/24_daemon_set_locale.patch:
     - fixed with the new version
   * debian/patches/90_from_cvs_fix_exit_handler_ordering.patch:
     - patch from CVS, possible fix for an ekiga crashing on closing

Changed in gnome-vfs2:
status: Fix Committed → Fix Released
Sebastian Breier (tomcat42) wrote :

Any chances that this will be officially fixed in edgy? Or do I have to get the packages manually?

Sebastien Bacher (seb128) wrote :

Maybe you could read the comments on a bug before adding a new one? That question has already been asked and there is a reply to it, extra comments on the same topic only create extra bug load for the maintainer who doesn't work on fixing the bug while ready that new comment

Jad Madi (jad) wrote :
Download full text (4.6 KiB)

hmm, weird,
I have same problem and when I tried to install the patches I got broken dependencies warning and it was suggested to execute 'apt-get install -f' to fix it but when I tried that I got this

jad@syntux:~/Desktop/nautilus$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies...Done
The following packages were automatically installed and are no longer required:
  f-spot libgnomecupsui1.0-1c2a libcamel1.2-8 libgtkhtml3.8-15 tomboy evolution-webcal ekiga libmono2.0-cil openoffice.org-gnome libgnomevfs2-0 gcalctool gthumb
  libmono-data-tds2.0-cil python-gnome2 gnome-media nautilus libgnome2-0 libmono-system-data2.0-cil libdevhelp-1-0 network-manager-pptp python-gnome2-extras gucharmap
  hwdb-client-gnome evolution-exchange gnome-bluetooth evolution libgbf-1-0 gnome-power-manager libexchange-storage1.2-2 php5-mysqli gnome-screensaver rhythmbox
  banshee-daap alacarte gedit gnome-menus python-pymad gnome-control-center libgnokii3 libipod-cil libbonoboui2-0 ubuntu-desktop libgnome2-perl anjuta-common python-pyogg
  gnome-pilot-conduits libsgutils1 gnome-pilot libedata-cal1.2-6 update-notifier libgnome-menu2 banshee gnome-terminal gnomebaker libmono-cairo2.0-cil pptp-linux kinoplus
  network-manager-gnome democracyplayer libpanel-applet2-0 python-pyvorbis libgnome2.0-cil gnome-utils libipodui-cil anjuta gnome-btdownload devhelp-common gnome-about
  gnome-volume-manager nautilus-cd-burner libmono-sharpzip0.6-cil libmono-security2.0-cil eog libgnome2-vfs-perl libwv-1.2-1 gnome-phone-manager beagle gnome-spell
  bug-buddy libgnomeui-0 beagle-backend-evolution libecal1.2-7 tsclient vino gnome-keyring-manager gnome-system-monitor libmono-sqlite2.0-cil firefox-gnome-support evince
  libgbf-1-common python-pysqlite2 libmono-system-web2.0-cil libebook1.2-9 evolution-plugins libmono-sharpzip2.84-cil gtkhtml3.8 libedataserverui1.2-8
  contact-lookup-applet libmono-corlib2.0-cil libgnome-window-settings1 libedata-book1.2-2 evolution-data-server libgnomevfs2-bin libipoddevice0 libgd2-xpm
  libgnomevfs2-extra liblpint-bonobo0 yelp gnome-main-menu libeel2-2 libavahi1.0-cil gnome-netstatus-applet libevolution-cil hal-device-manager libgucharmap5
  gnome-applets totem-xine python-gmenu libmono-system-runtime1.0-cil gconf-editor libtotem-plparser1 gnome-system-tools libgnomebt0 sbackup gnome-panel listen
  gmail-notify gstreamer0.10-gnomevfs totem deskbar-applet python-gnome2-desktop libnautilus-extension1 ipod libgsf0.0-cil gnome-session libgnome-desktop-2 totem-mozilla
  libnjb5 libmono-system2.0-cil libgdl-1-0 automatix2 file-roller serpentine nautilus-sendto gnome-cups-manager sound-juicer libgdl-1-common
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED
  alacarte anjuta automatix2 banshee banshee-daap beagle beagle-backend-evolution bug-buddy contact-lookup-applet democracyplayer deskbar-applet ekiga eog evince
  evolution evolution-data-server evolution-exchange evolution-plugins evolution-webcal f-spot file-roller firefox-gnome-support gcalctool gconf-editor gedit gmail-notify
  gnome-about gnome-applets gnome-bluetooth gno...

Read more...

Dan (digifork) wrote :

>Maybe you could read the comments on a bug before adding a new one?

Well Sebastian, I too am asking the same question as Mr. Breier because I don't see an obvious answer in the posts.

Do you happen to know when will this patch be integrated into the official edgy distro?

The release notes for the libgnomevfs2 that is installed on my edgy system does not mention your fixes and it is up to date according to Synaptic. If the answer is in the posts somewhere and I somehow missed it, could you humor me and answer the question anyways?

Matt Zimmerman (mdz) wrote :

OK for -proposed

Sebastien Bacher (seb128) wrote :

Package uploaded

Colin Watson (cjwatson) wrote :

Accepted into edgy-proposed. Please contact the QA team via Simon Law so that they can verify that this bug has been fixed and that there are no regressions.

Changed in gnome-vfs2:
status: Confirmed → In Progress
juantovar (juantovarm) wrote :

I have the same problem a Jad. I get broken dependencies error. I ran sudo apt-get install -f and it totally killed my installation. I had to reinstall Ubuntu completely, and on reinstalling libgnomevfs2-common_2.16.1-0ubuntu3_all.deb i got the same problem again. How do i fix this?

Sebastien Bacher (seb128) wrote :

did you try to install from edgy-proposed?

juantovar (juantovarm) wrote :

I installed the ones in this page
http://people.ubuntu.com/~seb128/debug/54684/. The other ones gave me source code and i do not know what to do with that. And to be more precise it is the package.

juantovar (juantovarm) wrote :

ooops, hit the save changes button too early, this is the package that give me problems

      libgnomevfs2-common_2.16.1-0ubuntu3_all.deb

Sebastien Bacher (seb128) wrote :

those packages were just for testing, upgrade with the edgy-proposed version, that should be easier

This should get you upgraded from a shell. You must reboot to get changes (or restart gnome/X?)...haven't tested non-reboot scenario...

mkdir /tmp/fix && cd /tmp/fix && wget http://people.ubuntu.com/~seb128/debug/54684/libgnomevfs2-common_2.16.1-0ubuntu3_all.deb && wget http://people.ubuntu.com/~seb128/debug/54684/libgnomevfs2-0_2.16.1-0ubuntu3_i386.deb && wget http://people.ubuntu.com/~seb128/debug/54684/libgnomevfs2-bin_2.16.1-0ubuntu3_i386.deb && wget http://people.ubuntu.com/~seb128/debug/54684/libgnomevfs2-extra_2.16.1-0ubuntu3_i386.deb && sudo dpkg -i libgnomevfs2-common_2.16.1-0ubuntu3_all.deb && rm libgnomevfs2-common_2.16.1-0ubuntu3_all.deb && for i in *.deb; do sudo dpkg -i "$i"; done

Le jeudi 23 novembre 2006 à 22:25 +0000, Kristian Hermansen a écrit :
> This should get you upgraded from a shell. You must reboot to get
> changes (or restart gnome/X?)...haven't tested non-reboot scenario...

why not using edgy-proposed which is an official apt source?

Hi

will those patches enter edgy-updates once the QA team is happy with them?

juantovar (juantovarm) wrote :

I am sorry Sebastien, I have looked everywhere in this page but haven't found package....where is it?

Sebastien Bacher (seb128) wrote :

Le vendredi 24 novembre 2006 à 12:35 +0000, kmon a écrit :
> Hi
>
> will those patches enter edgy-updates once the QA team is happy with
> them?

if the QA team is happy with them and people tries the edgy-proposed
update and confirm it works fine they will be uploaded to edgy-updates
then

Sebastien Bacher (seb128) wrote :

Le vendredi 24 novembre 2006 à 13:09 +0000, juantovar a écrit :
> I am sorry Sebastien, I have looked everywhere in this page but haven't
> found package....where is it?

edgy-proposed:
"deb http://archive.ubuntu.com/ubuntu/ edgy-proposed main restricted
universe multiverse" to your sources.list

Paul Bell (launchpad-dpb) wrote :

Just updated...
libgnomevfs2-0
libgnomevfs2-common
libgnomevfs2-extra
libgnomevfs2-bin

and it appears to be fixed! Excellent work, a big thank you to everyone concerned :o)

OT: where can I find out what's fixed/new with the other packages in edgy-proposed? I don't want update anything else unless I have a reason to.

Many thanks once again ... Paul

Matti Lindell (mlind) wrote :

@Paul Bell

packages uploaded for edgy-proposed are announced also on
https://lists.ubuntu.com/archives/edgy-changes/

You can also try: aptitude changelog package
(There's usually slight delay before changelogs appear to http://changelogs.ubuntu.com)

Sebastien Bacher (seb128) wrote :

Le vendredi 24 novembre 2006 à 16:20 +0000, Paul Bell a écrit :

> OT: where can I find out what's fixed/new with the other packages in
> edgy-proposed? I don't want update anything else unless I have a reason
> to.

Read the edgy-changes list or try to dist-upgrade with that source
listed and see what is going to be updated. If you don't want to use it
for something else you should probably comment it

Changed in gnome-vfs2:
status: In Progress → Fix Committed
Simon Law (sfllaw) wrote :

Tested and ready for -updates on the 28th.

Sebastien Bacher (seb128) wrote :

fixed uploaded to edgy-updates now

I'm running Edgy and I have the edgy-updates source in my sources.list, but 'aptitude changelog gnome-vfs2' doesn't show this fix as being there. What am I missing?

I've tried reloading with Synaptic and there are no new packages. When I added edgy-proposed I saw the libgnome-vfs packages there, is it still not in edgy?

Adam Conrad (adconrad) wrote :

Upload checked, confirmed, and accepted to -updates.

Changed in gnome-vfs2:
status: Fix Committed → Fix Released
BJizzle (redflag-420) wrote :

I have this problem as well. I downloaded all the patches and got them installed and my CPU still goes up to 100% and stays there until reboot. I can reproduce this problem by just open Firefox, OpenGL apps, and a few other programs. Any other ideas?

I do not know if this is the correct place to post this, but to answer BJizzle's question, it might help. I have been having a weird problem with my pc and it is that all my apps just went to sleep, nothing ran, impossible to do anything but surf the web with firefox...until i installed beryl...i don't have to be running it, just have it installed. why? i don't know but it works for me

El Buda dijo que todo es el reflejo de nuestro Corazon

---------------------------------
Any questions? Get answers on any topic at Yahoo! Answers. Try it now.

Sebastian Breier (tomcat42) wrote :

BJizzle: If you're not using Nautilus to get high CPU usage, your problems have nothing to do with this bug. You should open a new bug for it.

juantovar: Sorry to say, but this is the wrong place. You might want to check ubuntuforums.org or #ubuntu on FreeNode (IRC) if you want to analze the problem, then post bug new reports when you need to. Or just don't, as your solution seems to work quite well for you. ;)

Michael Vogt (mvo) wrote :

I did a successful sru-verifcation for this bug. I verified that "reload" a couple of times triggers the problem. After applying the update I was not able to trigger the problem anymore.

I mark this verification-done now.

voldemarvb (voldemarvb) wrote :

Second day , full time ~100% CPU usage, 8.04 beta, nautilus 2.22.0 0-ubuntu3

Changed in nautilus:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.