Ubuntu

Intermittant failures to connect to ssh servers

Reported by Mary Gardiner on 2004-10-19
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nautilus
Expired
Medium
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

I'm experiencing intermittant difficulty connecting to SSH remote hosts using
Nautilus.

Method of connection:
 * File -> Connect to server
 * Select "SSH" from service type
 * Put in host name value ("trogdor", "192.168.1.34") -- the particular host is
on a 10MBps LAN
 * Click "connect"
 * Double click on appropriately named desktop icon

One of four things will happen (assuming I've already used ssh-add to provide the
 * A window will immediately open containing the remote files (ie, the working
condition)
 * A window will immediately appear with the titlebar "Nautilus" and it is
empty. Usually after two minutes or so of this, all Nautilus icons disappear
from the desktop and evern *local* Nautilus windows stop rendering.
 * A dialog box will appear saying "Opening [remote host]..." and stay there
(for at least 5 minutes or more, until I press Cancel)
 * An error message will appear about an error in handling the sftp:// protocol,
and will suggest using an alternative viewer.

I've tried this under varying conditions involving:
 * Either or both hosts having each other or not having each other in /etc/hosts
(there is no DNS for this network)
 * Having my public key added via ssh add
 * Telling nautilus my passphrase
 * Using my password instead of my public key

It doesn't appear to entirely depend on any of these factors.

http://bugzilla.gnome.org/show_bug.cgi?id=157738: http://bugzilla.gnome.org/show_bug.cgi?id=157738

Sebastien Bacher (seb128) wrote :

do you have slow reply time on your network ?

Mary Gardiner (puzzlement) wrote :

I'm not exactly sure what you meant, but if you meant "time to send packets",
here's ping output to the relevant host:

$ ping 192.168.1.33
PING 192.168.1.33 (192.168.1.33) 56(84) bytes of data.
64 bytes from 192.168.1.33: icmp_seq=1 ttl=64 time=0.058 ms
64 bytes from 192.168.1.33: icmp_seq=2 ttl=64 time=0.050 ms
64 bytes from 192.168.1.33: icmp_seq=3 ttl=64 time=0.038 ms
64 bytes from 192.168.1.33: icmp_seq=4 ttl=64 time=0.030 ms
64 bytes from 192.168.1.33: icmp_seq=5 ttl=64 time=0.041 ms
64 bytes from 192.168.1.33: icmp_seq=6 ttl=64 time=0.041 ms

Sebastien Bacher (seb128) wrote :

(In reply to comment #2)

> 64 bytes from 192.168.1.33: icmp_seq=6 ttl=64 time=0.041 ms

ok, so the problem is not due to a slow network, thanks

Sebastien Bacher (seb128) wrote :

I've opened a bug upstream about this:
http://bugzilla.gnome.org/show_bug.cgi?id=157738

Carthik Sharma (carthik) wrote :

Changing to Confirmed since Upstream has acknowledged the bug.

Thank you for reporting this.

Changed in nautilus:
status: Unconfirmed → Confirmed
Changed in nautilus:
status: Unconfirmed → Confirmed
Martin Jensen (martin-mdc) wrote :

I just write to confirm the above behaviour.

One odd thing I noticed is that I have no problems whatsover with a server using:

OpenSSH_3.6.1p2 (runs centos 3 something)

While another server is causing the above symptons very often:

OpenSSH_3.9p1 (runs centos 4 something)

Both machines are in the same hosting center

I work with those two servers several days a week. I am using this function extensively on my job. Behaviour is consistent no matter if I am using my ubuntu machine at work or at home. Both run fully updated edgy.

Regards

/Martin

Changed in nautilus:
assignee: seb128 → desktop-bugs
importance: Medium → Low
HDunix (hdunix) wrote :

Hi

I had a simular issue, till I uninstalled sea-horse

Steve P

Luca Gervasio (gervasio) wrote :

Ok,
I confirm I have the same problem. I noticed that if I use FTP everything goes fine.
In particular I connect my PC, through Nautilus, to an external server located outside my lan.

Sebastien Bacher (seb128) wrote :

does anybody still get this issue in hardy?

Changed in nautilus:
status: Confirmed → Triaged
Spoilerhead (spoilerhead) wrote :

i'm getting this in hardy
nautilus says ~ "connection timed out"
works fine on command line with ssh and scp

server side reports:
bash-2.04$ ssh -V
ssh: SSH Secure Shell 3.2.3 (non-commercial version) on hppa2.0w-hp-hpux11.00
it worked in all previous ubuntu versions

connecting to my local ssh server still works fine

Motin (motin) wrote :

@Spoilerhead: That's at least the symptons I am having. I can use scp and ssh without problems, but sftp in nautilus or filezilla just ends up with connection timed out messages...

Is this a problem related to SFTP only then?

Hardy users: This bug report is about 4 years old - we are probably not being affected by the same bug, but most likely a new one - maybe one related to Hardy's use of GVFS?

Motin (motin) wrote :

Note: I can still use sshfs - for instance:
sshfs 192.168.1.3:/home/motin /home/motin/pavilion-sshfs/home/motin

Changed in nautilus:
status: Confirmed → Invalid

We would like to know if this is still an issue for you with Ubuntu 10.04? Thanks in advance.

Changed in nautilus (Ubuntu):
status: Triaged → Incomplete
Mary Gardiner (puzzlement) wrote :

I have not seen the issue in 10.04, or for some years in fact.

Thanks. I am closing this bug due to your last comment.

Changed in nautilus (Ubuntu):
status: Incomplete → Invalid
Changed in nautilus:
importance: Unknown → Medium
status: Invalid → Expired

Hi,
I still face the same problem in Ubuntu 10.10 64-bit. I can ssh using terminal but not with nautilus. I can ping the remote machine. In fact, the remote machine is in my LAN only.

Any ideas?

Thanks,
emorkay

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.