Ubuntu

Nautilus does not preview images if permissions are changed to allow it

Reported by Mary Gardiner on 2004-10-19
12
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Low
nautilus (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

I have the following settings in my Edit -> Preferences -> Preview tab:

Show text in icons: Always
Show thumbnails: Always
Only for files smaller than: 5MB
Preview sound files: Always
Count number of items: Always

I connect to an sftp:// url -- a directory containing a number of JPG images.
Despite these settings, that suggest that Nautilus should show me thumbnails of
these images (which are about 800k in size), they do not have thumbnails, they
are all displayed as the generic JPG icon.

I have read access but not write access to these files on the remote host.

Mary Gardiner (puzzlement) wrote :

Actually, this is incorrect: it didn't preview images only because I didn't have
read permissions on those files when I originally tried.

Having changed the permissions...

I can't figure out how to alert it to recheck the ownership and attempt to
preview again though (on an sftp:// directory) -- pressing Ctrl-R seems to
reload the file list fine, but Nautilus has somehow "remembered" that it can't
preview these particular files, and refuses to try again.

[Retitling bug]

Sebastien Bacher (seb128) wrote :

known problem here for a long time. The thumbnailers use the timestamp to
know if it should update the thumbnails.

2 possible workarounds:
- "touch *" in the dir (basically "touch file" to update the timestamp of the file
and force the refresh)
- "rm ~/.thumbnails/fail/gnome-thumbnail-factory/*", you need to restart nautilus
after that ("killall nautilus" for example)

Phil Housley (undeconstructed) wrote :

Isn't this intentional? Surely previewing images over sftp involves downloading
them all, which is always going to be counter-productive.

Mary Gardiner (puzzlement) wrote :

(In reply to comment #3)

Nautilus sensibly does not preview remote images by default: see Edit ->
Preferences -> Preview tab -> Show thumbnails, which I think is sent to "Local
files only" by default for reasons that I'd guess are the same as your comments.

But, for various reasons I had *chosen* to set that to "Always" rather than
"Local files only", and because Nautilus didn't notice a subsequent permission
change on the files, I didn't get the previews.

Lionel Dricot (ploum) wrote :

Is this bug still present ? If yes, it should be filled upstream as it is a nautilus bug.

Simon Law (sfllaw) on 2006-04-28
Changed in nautilus:
status: Unconfirmed → Confirmed
Changed in nautilus:
status: Confirmed → Fix Released
Changed in nautilus:
assignee: seb128 → desktop-bugs
Pedro Villavicencio (pedro) wrote :

fixed upstream, thanks for reporting.

Changed in nautilus:
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :

the new version fixing the issue has been uploaded now

Changed in nautilus:
status: Fix Committed → Fix Released
Changed in nautilus:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.