In list view, the columns' size is not remembered

Bug #94014 reported by Murray Cumming on 2007-03-20
76
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Nautilus
Confirmed
Wishlist
One Hundred Papercuts
Undecided
Papercuts Ninjas
nautilus (Debian)
Confirmed
Unknown
nautilus (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: nautilus

This affects list view in non-browser mode, probably used by a large percentage of Ubuntu users, and is quickly annoying.

Since bug #89031 was fixed (List views start with too-narrow name column), the name column size seems to be hard-coded, and usually not large enough. Resizing the name column does not result in the new column width being used when reopening the folder, as should normally happen with "spatial nautilus".

Furthermore, the name column width does not increase when increasing the size of the window, as used to happen.

Andrew (at-macmillan) wrote :

I have the same problem with nautilus in Feisty.

It appears to be a problem with all the columns. At least I checked name and size. Both column widths go back to their default size whenever I restart nautilus.

When trying to search for if this bug was reported or not, I also found somebody reported it in the comments of this bug:

https://launchpad.net/ubuntu/+source/nautilus/+bug/93381

I added a comment to confirm that I had the problem there before I found this bug report which seems more directly related.

Sebastien Bacher (seb128) wrote :

Thank you for your bug. That's known upstream: http://bugzilla.gnome.org/show_bug.cgi?id=410361

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Unconfirmed → Confirmed
Changed in nautilus:
status: Unknown → Confirmed
Paul Betts (paul-betts) wrote :

Didn't mean to cross-post (and upstream post too!), wasn't sure if people paid attention to closed bugs. I've made a better fix in the upstream bug for the intermediate problem of the name column size not being very usable.

Fabio Ornellas (fabio-ornellas) wrote :

Same problems with me on 7.04. Hope there comes a bugfix update for it soon, it is VERY annoying...

This bug has reappeared in Hardy. Please re-fix it!

hotani (hotani) wrote :

I am unable to do anything with the name column. Currently nautilus is set to display list view with name | size | date. Attempting to resize name|size does nothing. Resizing size|date resizes name in a crazy unintuitive way. For example: moving to the right with the size|date line causes the name column to shrink while the size column expands to the left. Probably not the expected behavior.

Changed in nautilus:
status: Confirmed → Triaged
Changed in nautilus:
status: New → Unknown
Changed in nautilus:
status: Unknown → Confirmed
Sebastien Bacher (seb128) wrote :

would be interesting to fix but that's probably not the most trivial hundredpapercut task, we can keep it on the list but it doesn't seem an easy target for karmic

Mat Tomaszewski (mat.t.) wrote :

Seb, I'll mark it as a Wishlist item

Changed in hundredpapercuts:
importance: Undecided → Wishlist
status: New → Confirmed
summary: - List View: Name column size not remembered
+ In list view, the name column's size is not remembered
Changed in hundredpapercuts:
milestone: none → round-4

I hope you guys are able to fix this as a papercut (even if you just increase the default width of the column) everytime I open a new nautilus window I have to resize the column, it's become second nature, but still annoying.

It's the very definition of a papercut.

This is too complex to be considered a paper cut.

Changed in hundredpapercuts:
milestone: round-4 → none
status: Confirmed → Invalid

Hi David,
while it may be too complex to "fix" this as a papercut, a quick win would be just to double the width of this column and that surely can't be THAT hard?

This is an extremely annoying bug, if for instance you're browsing through a dir filled with files with similar names, such as TV episodes or log files. I know that almost everytime I open a new nautilus window (or worse a new tab) I have to resize this column because I can't tell which file is which.

While it would be better to fix it properly, I can see from earlier comments on the ticket that this is a more complex issue than it appears to the user, but I think most people would be happy with the quick win.

Hope this helps,
Matt

Quoting David Siegel <email address hidden>:

> This is too complex to be considered a paper cut.
>
> ** Changed in: hundredpapercuts
> Status: Confirmed => Invalid
>
> ** Changed in: hundredpapercuts
> Milestone: round-4 => None
>
> --
> In list view, the name column's size is not remembered
> https://bugs.launchpad.net/bugs/94014
> You received this bug notification because you are a direct
> subscriber
> of the bug.
>
> Status in One Hundred Paper Cuts: Invalid
> Status in Nautilus: Confirmed
> Status in “nautilus” package in Ubuntu: Triaged
> Status in “nautilus” package in Debian: Confirmed
>
> Bug description:
> Binary package hint: nautilus
>
> This affects list view in non-browser mode, probably used by a
> large percentage of Ubuntu users, and is quickly annoying.
>
> Since bug #89031 was fixed (List views start with too-narrow name
> column), the name column size seems to be hard-coded, and usually
> not large enough. Resizing the name column does not result in the
> new column width being used when reopening the folder, as should
> normally happen with "spatial nautilus".
>
> Furthermore, the name column width does not increase when
> increasing the size of the window, as used to happen.
>

For those of you suffering with this issue, one "work-around" is to only display the columns you really care about. For me, that is Name, Size, and Date Modified. (go to View->Visible Columns and shut off anything you don't need.)

Changed in nautilus:
importance: Unknown → Wishlist
Mathias (mathias-me) wrote :

Unbelievable that this bug is still open.
There is a patch for Nautilus 3.
https://bugzilla.gnome.org/show_bug.cgi?id=410361#c29
http://bugzilla-attachments.gnome.org/attachment.cgi?id=192024
Any chance someone can patch that into the current one ?

Thanks a lot
Mathias

summary: - In list view, the name column's size is not remembered
+ In list view, the columns' size is not remembered
Changed in nautilus (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Changed in nautilus:
status: Confirmed → Invalid
Changed in nautilus:
importance: Wishlist → Unknown
status: Invalid → Unknown
Changed in nautilus:
importance: Unknown → Wishlist
status: Unknown → Confirmed
gianni (giannife) wrote :

still present in 12.04

Stuart Gillies (gillies) wrote :

The problem now seems to be that the name column is set to the width of the longest file name. If you have a rogue filename then the column can be off the screen and very hard to correct. When corrected the new column width does not stick so next time you open the same directory you have to do it all again. It just needs to remember the last width used for the directory or set a maximum initial width that is less than the width of the screen.

(12.04 LTS)

I'm going to reopen the paper cut task on this since Nautilus and GTK have changed a lot recently so maybe this could be fixable.

Changed in hundredpapercuts:
status: Invalid → Confirmed
importance: Wishlist → Undecided
milestone: none → papercuts-nautilus
assignee: nobody → Paper Cuts Ninja (papercuts-ninja)
Dario Ruellan (druellan) wrote :

Seems to be several duplicates of this bug, in fact, THIS bug seems to be a duplicate of #89031, on where you can find a lists of duplicates: https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/89031/comments/14

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.