Ubuntu

Ndiswrapper no longer works with Netgear MA111 in Dapper Flight CD 4 (worked in Breezy)

Reported by David Khabie-Zeitoune on 2006-02-21
12
Affects Status Importance Assigned to Milestone
ndiswrapper (Ubuntu)
High
Unassigned

Bug Description

The procedure for installing the Windows drivers for the Netgear MA111 USB wireless device using ndiswrapper, which worked fine with Ubuntu Breezy, now no longer works with the Dapper Drake alpha.

In Breezy, I used to get my wireless USB dongle (Netgear MA111) working as follows:

Install ndiswrapper-utils

> sudo ndiswrapper -i NETMA111.inf
> sudo depmod -a
> sudo modprobe ndiswrapper
> sudo ndiswrapper -m
Then I added ndiswrapper to /etc/modules
Then I reboot
Et voila! I would see a wlan0 entry under Networking

This no longer works under Dapper Drake. I see no wlan0 entry. I tried recompiling the latest version of ndiswrapper from source but to no avail.

Related branches

description: updated
summary: + The procedure for installing the Windows drivers for the Netgear MA111
+ USB wireless device using ndiswrapper, which worked fine with Ubuntu
+ Breezy, now no longer works with the Dapper Drake alpha.
nd (ndd) wrote :

It always tells me that the driver is invalid, no matter if I use the winXP driver, the win98se driver etc. This worked perfectly before the upgrade to dapper (before the ndiswrapper upgrade!).

nd (ndd) on 2006-03-06
Changed in ndiswrapper:
status: Unconfirmed → Confirmed
Sean D. Quinn (sdquinn) wrote :

This also does not work on an upgrade from Breezy. A fix ASAP would be desirable.

Thanks.

Sean D. Quinn (sdquinn) wrote :

Is it possible that a fix can be released for this in the next Flight or before the final version is released?

sonmez (sonmezsahut) wrote :

I am having a similar problem. One thing I noticed after installing ndiswrapper is that it names the wireless connection as eth1 instead of wlan0. I used the same drivers as before and they worked before. I use ndisgtk to install the driver and it seems to install it but i can get it to work.... the everything is the same as before but it doesn't work. Please fix this ASAP....

Sonmez

sonmez (sonmezsahut) wrote :

I forgot to mention that i sude Linksys card with broadcom driver.

Sonmez

Sitsofe Wheeler (sitsofe) wrote :

sonmez:
Could you spin your issue out as another issue and can you include the output of lspci in your bug.

Sean:
If you want a fix quickly, you might be better off talking to the ndiswrapper folks directly - http://ndiswrapper.sourceforge.net/support.html . They may have ideas about how to debug the problem.

I have a problem with my MA111 when I use to much the network over wlan0 the krenel freezes before it did it when I unplug the MA111 and now it do it when the card is plugged. Perhaps it is not a problem which come from the usb card but doubt ... I think rather that the MA111 is the worst usb card !!!

Jacob Godserv (fun2program8) wrote :

I have the same issue with my Linksys WMP54GS card! It worked in Ubuntu 5.10 (Breezy), so it's got to be something about the new version...

steph_Z (polariscorp) wrote :

same here with a linksys WUSB54G, worked fine in breezy and dapper flight 3. But after an update the interface became eth1 instead of wlan0. And the driver seems confuse.

steph_Z (polariscorp) wrote :

it worked again but i had to switch back to :
Linux ubuntu 2.6.15-18-386 #1 PREEMPT Thu Mar 9 14:41:49 UTC 2006 i686 GNU/Linux

Dennis Kaarsemaker (dennis) wrote :

If you want to use ndiswrapper, blacklist bcm43xx. This is not a bug. If you need assistance with the disabling, please file a support request.

Changed in ndiswrapper:
status: Confirmed → Rejected
Shane S. (frostoftheblack) wrote :

"If you want to use ndiswrapper, blacklist bcm43xx. This is not a bug. If you need assistance with the disabling, please file a support request."

Just suddenly with Dapper? I have a bcm43xx driver that work marvelously with Breezy but not with dapper.

Results of ndiswrapper -l

Installed ndis drivers:
bcmwl5a driver present, hardware present

David Khabie-Zeitoune (dmskz) wrote :

Dennis

I think your comment is misleading and misses the point. Why have you rejected the initial bug request? This is definitely a bug. I blacklisted the bcm43xx drivers as you suggest (even though I am not using a Broadcom device) and I still have the same problem. This is a BUG with ndiswrapper, and it is still affecting many users. This worked fine in Breezy.

Changed in ndiswrapper:
importance: Medium → Critical
status: Rejected → Confirmed

I agree with that last post. This is 100% an issue. I have trawled the forums and tried maybe 7 or 8 different "fixes" but nothing has worked. I had my Belkin 7001 wifi card working totally fine in 5.10 but in 6.06 it's broken. I was using an older version of ndiswrapper, but this was not installable on 6.06 so I used the newer version. Broken broken broken! This is so critical, that if it isn't fixed, I will look for a different wifi card, or maybe even a new Linux distro instead

Gareth Holmes (garhol) wrote :

The MA111 in breezy was fine when you blacklisted a couple of entries.
It also works in Dapper with same blacklisted modules.
I haven't blacklisted bcm43xx drivers and it is working, (although there is the bug where it stops working after a while, system doesn't freeze but t inbound traffic on wlan0 stops ), the only drivers I blacklisted were prism2_usb and something else (I'll check when I get home)
Note that there are 2 versions of the MA111 usb dongle. I'm unsure if there is a difference when using them with Ndiswrapper.

Gareth Holmes (garhol) wrote :

Just checked, my blacklist file only contains:
#Netgear MA111 drivers need these disabled
blacklist prism2_usb
blacklist p80211

Thank you very much. Adding these two to the blacklist file did indeed
solve the problem. Thanks again - I was very close to giving up!

Gareth Holmes wrote:
> Just checked, my blacklist file only contains:
> #Netgear MA111 drivers need these disabled
> blacklist prism2_usb
> blacklist p80211
>
>

Gareth Holmes (garhol) wrote :

With those drivers blacklisted ndiswrapper seems to drop out after passing a set amount of data. I've noticed there is no problem based on the amount of time that the connection is active but on downloading a large file inbound traffic halts after 10Mb or so.

To work around it temporarily:
Open System/Administration/Networking
Deactivate Wlan0
Unplug the MA111
Replug the MA111
Re-activate Wlan0

Synaptic etc. seem to pick up where they left off without reactivating wlan0 but firefox etc. require that last step.
I hope this helps a little until the bug is resolved.

Matt Zimmerman (mdz) on 2006-08-08
Changed in ndiswrapper:
importance: Critical → High
Andreas Gnau (rondom) wrote :

Is this still a problem under feisty? If yes, I recommend to try the latest version of ndiswrapper to see if it is fixed. If it is not, report a bug upstream. Instructions on how to do this including a link to the actual bugtracker can be found at
http://ndiswrapper.sf.net/wiki/Bugs

Timo Aaltonen (tjaalton) wrote :

fixed with this upload:

 ndiswrapper (1.38-1ubuntu1) feisty; urgency=low
 .
   * Merge from debian unstable, remaining changes:
     debian/control:
     - Update description to point out that the kernel source package is not required with the standard Ubuntu kernel.
     - Change the Maintainer address.
   * Closes many bugs (LP: #32275, #65779, #92155, maybe others)

Changed in ndiswrapper:
status: Confirmed → Fix Released
Timo Aaltonen (tjaalton) wrote :

Oops. closed a wrong bug.

Changed in ndiswrapper:
status: Fix Released → Confirmed
Andreas Gnau (rondom) wrote :

Changing this to needs info. To produce more info try the latest version of ndiswrapper. If it still doesn't work, paste dmesg. Also read http://ndiswrapper.sourceforge.net/joomla/index.php?/component/option,com_openwiki/Itemid,33/id,bugs/ . If you are sure you've experienced a bug, report it upstream (i.e. to the ndiswrapper-devs)

Changed in ndiswrapper:
status: Confirmed → Needs Info
Nanley Chery (nanoman) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in ndiswrapper:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers