ndiswrapper in edgy broken

Bug #59983 reported by discord on 2006-09-11
76
Affects Status Importance Assigned to Milestone
ndiswrapper (Ubuntu)
Low
Unassigned
Edgy
Undecided
Unassigned

Bug Description

ndiswrapper-utils in Edgy has a lower version number than the one in Dapper.

Plus, it depends on ndiswrapper-utils-1.1 instead of -1.8.

We should fix those.

Dana Olson (adolson) wrote :

I also have this issue.

Changed in ndiswrapper:
status: Unconfirmed → Confirmed
discord (colin.williams) wrote :

I have a possible solution. try typing ndiswrapper-1.8 . If it works then delete /usr/sbin/ndiswrapper and make a link ln -s /usr/sbin/ndiwswrapper-1.8 /usr/sbin/ndiswrapper ...

Brynjar Harðarson (brynjar) wrote :

"sudo modprobe ndiswrapper" also gives me
"FATAL: Error inserting ndiswrapper (/lib/modules/2.6.17-7-generic/kernel/drivers/net/ndiswrapper/ndiswrapper.ko): Invalid argument"

did you try the possible solutioin. I have it working on my laptop.

On 9/17/06, Brynjar Harðarson <email address hidden> wrote:
>
> "sudo modprobe ndiswrapper" also gives me
> "FATAL: Error inserting ndiswrapper
> (/lib/modules/2.6.17-7-generic/kernel/drivers/net/ndiswrapper/ndiswrapper.ko):
> Invalid argument"
>
> --
> ndiswrapper in edgy broken
> https://launchpad.net/bugs/59983
>

Brynjar Harðarson (brynjar) wrote :

I did that and installed the new ndiswrapper package (ndiswrapper-utils-1.8) and it worked, so I don't know which change fixed it.

ayoli (ayolinux) wrote :

add the issue too, and the "possible solution" works too. so have linked /usr/sbin/ndiwswrapper-1.8 to /usr/sbin/ndiwswrapper.
btw if ndiwswrapper-1.1 doesn't work and there is a newer version, why we keep the old as default install ?

discord (colin.williams) wrote :

I didn't keep that ndiswrapper-1.1 maybe i forgot to mention to remove it.

On 9/20/06, ayoli <email address hidden> wrote:
>
> add the issue too, and the "possible solution" works too. so have linked
> /usr/sbin/ndiwswrapper-1.8 to /usr/sbin/ndiwswrapper.
> btw if ndiwswrapper-1.1 doesn't work and there is a newer version, why we
> keep the old as default install ?
>
> --
> ndiswrapper in edgy broken
> https://launchpad.net/bugs/59983
>

ayoli (ayolinux) wrote :

@discord: i meant why edgy keep version 1.1 in the repos as default version installed when apt-get install ndiswrapper-utils.

discord (colin.williams) wrote :

good question. I guess maybe compatibility? Anyways maybe ask the package
maintainer. Would be nice to see the wireless working better under linux.

On 9/21/06, ayoli <email address hidden> wrote:
>
> @discord: i meant why edgy keep version 1.1 in the repos as default
> version installed when apt-get install ndiswrapper-utils.
>
> --
> ndiswrapper in edgy broken
> https://launchpad.net/bugs/59983
>

I found a something in the /usr/sbin/ndiswrapper script.

for x in /usr/sbin/ndiswrapper-[^b]*

I'm a newbie really but if I take the [^b] out it works.

What is this reg' exp' meant to do exactly?

I think this bug may also be linked to #45909 and #60630 ?

pelle.k (pele2) wrote :

I'm the author of #60630, and it seems it's the same bug were talking about. I've updated it and pointed it here...

Collin Doering (rekahsoft) wrote :

I have the same problem as the rest of you...my fix was to unistall the ndiswrapper-1.1 stuff and install the new 1.8 ndiswrapper...then i have to use the command ndiswrapper-1.8 in my terminal to configure it.

James W. Dumay (jdumay) wrote :

I also get the module loading error.

Im running off of the first Beta release.

James W. Dumay (jdumay) wrote :

I can confirm that version 1.8 works correctly

Collin Doering (rekahsoft) wrote :

I can configure ndiswrapper by using ndiswrapper-1.8 but when i modprobe the module i am also getting an error: FATAL: Could not open '/lib/modules/2.6.17-10-generic/misc/ndiswrapper.ko': No such file or directory Does anybody have a fix?

Collin Doering (rekahsoft) wrote :

could somebody who is not having the error when trying to modprobe ndiswrapper upload thier /lib/modules/2.6.17-10-generic/misc/ndiswrapper.ko

James W. Dumay (jdumay) wrote :

Collin, the driver doesn't exist at that location but at
/lib/modules/2.6.17-10-generic/kernel/drivers/net/ndiswrapper/ndiswrapper.ko

Here it is

Jonathan Michaels (jhmichaels) wrote :

This bug has been preventing me from using Edgy. I propose that the importance is upgraded to CRITICAL. This needs to be fixed before Edgy ships.

The bcm43xx/fwcutter solution is not a replacement for a working ndiswrapper. That solution has it's own set of bugs and problems.

discord (colin.williams) wrote :

Have another fix for everybody thanks to the network manager mailing list now we can have working network manager! You must first make sure you have working ndiswrapper-1.8 as I posted above

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get build-dep network-manager
sudo apt-get install cvs
sudo apt-get remove network-manager
cvs -d :pserver:<email address hidden>:/cvs/gnome login #press <enter>
cvs -d :pserver:<email address hidden>:/cvs/gnome co NetworkManager
cd NetworkManager
./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
make
sudo make install

###################
# Optional: Plugins
###################

cd vpn-daemons/vpnc
./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
make
sudo make install
cd ../openvpn
./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
make
sudo make install
cd ../pptp
./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
make
sudo make install

sudo gtk-update-icon-cache -f /usr/share/icons/hicolor

Add nm-applet --sm-disable to Sessions > Startup Programs

depp (li-sun) wrote :

the livecd should really contain a working version of ndiswrapper, otherwise for the people like me, who are going to access internet through wireless-router and whose wifi-card cannot work without ndiswrapper, after install, they'll have a no-internet system!

discord (colin.williams) wrote :

Good news to owners of the dell 1390 / broadcom 4311 card. It looks like the
card will soon be supported maybe in the next linux kernel. If you cannot
wait untill then you can get it working yourself. Details are at this forum
http://bcm43xx.spugna.org/index.php?board=2.0

-C

Gerald Zehetner (zege) wrote :

I've also got the Problem with ndiswrapper, and i can also confirm that ndiswrapper-1.8 works fine, why don't make it default?

Carthik Sharma (carthik) wrote :

ndiswrapper-utils-1.8 works fine. The upgrading process (from dapper to edgy) should include using the new 1.8 version when the bcm4318 card and other similar cards are involved. Changing importance to Medium.

Changed in ndiswrapper:
importance: Undecided → Medium
zdenek smetana (zyghom) wrote :

and the problem is: while installing Edgy on the machine which has only WLAN than not working ndiswrapper makes complete box unusable
so, where to find "working" package for ndiswrapper (and utils) ?
compiling from the source just after installation of fresh Edgy might fail as there are no packages needed on installation CD (and no access to net)

thanks

depp (li-sun) wrote :

ye, add an usable ndiswrapper-util package in live-cd, please

Changed in ndiswrapper:
assignee: nobody → kamion
Andre Noel (andrenoel) wrote :

I agree that it would be upgraded to CRITICAL.

The CD only has the ndiswrapper-1.1. I have to download the 1.8 in another PC to install it here.

Colin Watson (cjwatson) on 2006-10-18
Changed in ndiswrapper:
assignee: kamion → nobody
Simon Law (sfllaw) on 2006-10-18
description: updated
Matt Zimmerman (mdz) on 2006-10-18
Changed in ndiswrapper:
assignee: nobody → adconrad

I can confirm the bug. Same behavior as the bug description. Installing ndiswrapper-utils-1.8 fixed it for me too.

Colin Watson (cjwatson) wrote :

The upgrade issue (ndiswrapper-utils having a lower version in Edgy than in Dapper) is sucky, but unfortunately it's incredibly hard to fix due to automatically-generated module dependencies on a version of ndiswrapper-utils earlier than that in Dapper. I've been staring at this for a couple of hours spread over two days, and the best fix I can think of is to mention it in the release notes. :-(

I've added ndiswrapper-utils-1.8 to the CDs, though; at least that much is easy.

Colin Watson (cjwatson) wrote :

ndiswrapper-utils is meant to depend on ndiswrapper-utils-1.1, by the looks of things - it's a transitional package to make sure your networking keeps working during upgrades. You can install both ndiswrapper-utils-1.1 and ndiswrapper-utils-1.8 concurrently now, though.

Colin Watson (cjwatson) wrote :

Removing ubuntu-6.10 milestone as we've given up on the version numbering thing as unfixable at this point now.

Paolo Sammicheli (xdatap1) wrote :

my Kubuntu 6.10 Edgy too, after upgrading from dapper, got this problem. My wifi usb card "US ROBOTICS USR805422 802.11g Wireless USB Adapter" doesn't work anymore, getting error "Invalid argument" on modprobe.

After installing ndiswrapper-utils-1.8

# apt-get install ndiswrapper-utils-1.8

everythings works fine. Btw there's a strange version problem on ndiswrapper command, after installed the package 1.8:

# ndiswrapper -v
utils Error: no version specified!
driver version: 1.22
vermagic: 2.6.17-10-generic SMP mod_unload 586 REGPARM gcc-4.1

Before that the version number was 1.7.

I hope this information may be useful for someone.

Paul Bartell (paul-bartell) wrote :

thanks for the fix. I too had this issue.
well off to edit the wiki.

Matt Zimmerman (mdz) wrote :

Fabio, please look at this and see if it can be fixed for edgy upgrades with access to -updates

Changed in ndiswrapper:
assignee: adconrad → fabbione
Herman (herman-solcon) wrote :

All, I had the same problem ("FATAL: Error inserting ndiswrapper (/lib/modules/2.6.17-7-generic/kernel/drivers/net/ndiswrapper/ndiswrapper.ko): Invalid argument") when trying to install the SMC 2802 V2.

I installed ndiswrapper 1.8, but no success. Searched for hours on the internet, but could not find the solution.

Then I found in /var/log/messages this line:
loadndisdriver: loadndisdriver: main(638): version 1.7 doesn't match driver version 1.8
I guessed the 1.8 was ndiswrapper.
I was desperate enough to open loaddnsdriver (it's in /usr/sbin) in vi to see what it did. I still have no idea, but I found the string 1.7 and changed it into 1.8.
After this change I could run sudo modprobe ndiswrapper - and after adding my ESSID and enabling the wireless network I am online!

Matt regarding the dapper -> edgy upgrade, I agree with Colin. There is no sane way to do it without re-introducing meta packages and possibly take down the network during the upgrade. I don't have the hw to test if the latter might/can/will happen so i can only assume the worst.

Fabio

Changed in ndiswrapper:
importance: Medium → Low
status: Unconfirmed → Confirmed

<fabbione> mvo: the short version is: we need to teach feisty upgrader to pull in ndiswrapper-utils-1.9 if ndiswrapper-utils-1.8 is installed
<fabbione> mvo: do you think you can do that before Herd 1 ?
<fabbione> mvo: the rest of the bug is related to dapper -> edgy and it doesn't matter to you for now.. it's basically unsolvable

and again LP wins losing another comment.. readding.

Michael Vogt (mvo) wrote :

I uploaded a new release-upgrader that will install ndiswrapper-utils-1.9 if ndiswrapper-utils-1.8 is installed.

b (ben-ekran) wrote :

I seem unable to install ndiswrapper-utils-1.8 either, I did an apt-get update.

Ah, according to packages.ubuntu.com that version of ndiswrapper-utils is only available for i386 and amd64, I'm on a ppc machine. How can I get this to work on my ppc machine? I'll be happy to compile and build a new package for ppc is someone provides instructions.

Thanks.

James W. Dumay (jdumay) wrote :

It will not work for powerpc as all drivers are built for windows x86 and
amd64 only.

James

On 12/28/06, b <email address hidden> wrote:
>
> I seem unable to install ndiswrapper-utils-1.8 either, I did an apt-get
> update.
>
> Ah, according to packages.ubuntu.com that version of ndiswrapper-utils
> is only available for i386 and amd64, I'm on a ppc machine. How can I
> get this to work on my ppc machine? I'll be happy to compile and build a
> new package for ppc is someone provides instructions.
>
> Thanks.
>
> --
> ndiswrapper in edgy broken
> https://launchpad.net/bugs/59983
>

pirast (pirast) wrote :

So, why not let ndiswrapper-utils depend on ndiswrapper-utils-1.9 in Feisty and close this bug? :-)

Andreas Gnau (rondom) wrote :

The kernel module expects a certain version of loadndisdriver which is part of ndiswrapper-utils. Otherwise it fails.

If you really want this backward-compatibility (running an older stock kernel/older ndiswrapper while using the ndiswrapper-utils-1.1 or ndiswrapper-utils-1.8 packages) the module has to be patched to choose the right loadndisdriver (if installed).

I agree that installing 1.1 by default is _nonsense_.

Andreas Gnau (rondom) wrote :

I've just found out that this is already done using a script.

pirast (pirast) wrote :

ndiswrapper-utils' source package is ndiswrapper-utils-1.1

So I would suggest to remove ndiswrapper-utils-1.1 from the archive.

This would remove confusion, as there would be no ndiswrapper-utils package anymore then, which installs an ancient version of ndiswrapper (the name does not suggest that it installs something old). The ndiswrapper-utils-1.1 does not work, anyway.

Any concerns?

pirast (pirast) wrote :

Seems that there are no concerns. Remove request filed at bug 92622

pirast (pirast) wrote :

Should be fixed in Feisty now.

- ndiswrapper-utils-1.1 got removed from the archives, as it does not work (bug 92622)

- ndisgtk works with ndiswrapper-utils-1.9 now and depends on ndiswrapper-utils-1.9 instead of ndiswrapper-utils-1.1 (bug 45909)

- the upgrade tool upgrades ndiswrapper-utils-1.8 to ndiswrapper-utils-1.9

Changed in ndiswrapper:
assignee: fabbione → nobody
status: Confirmed → Fix Released
Changed in ndiswrapper:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments