Change log for ndiswrapper package in Ubuntu

145 of 45 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2019-01-28
Deleted in disco-proposed (Reason: moved to release)
ndiswrapper (1.60-8) unstable; urgency=medium

  * debian/rules: Pass --sort=name to tar for reproducible build

 -- Julian Andres Klode <email address hidden>  Sat, 26 Jan 2019 09:28:54 +0100

Available diffs

Published in xenial-updates on 2018-07-23
Deleted in xenial-proposed (Reason: moved to -updates)
ndiswrapper (1.60-3~ubuntu16.04.3) xenial; urgency=medium

   Upload to xenial for kernel 4.15 (LP: #1777652)
    - 0008-Build-fixes-for-Linux-4.15.patch

 -- Marcelo Henrique Cerri <email address hidden>  Tue, 19 Jun 2018 10:24:07 -0300
Superseded in disco-release on 2019-01-28
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2018-01-11
Deleted in bionic-proposed (Reason: moved to release)
ndiswrapper (1.60-6) unstable; urgency=medium

  [ Seth Forshee ]
  * Build fixes for 4.15 (LP: #1737749)

 -- Julian Andres Klode <email address hidden>  Wed, 10 Jan 2018 19:14:21 +0100

Available diffs

Superseded in bionic-release on 2018-01-11
Deleted in bionic-proposed on 2018-01-12 (Reason: moved to release)
ndiswrapper (1.60-5) unstable; urgency=medium

  [ Seth Forshee ]
  * Build fix for 4.13 (LP: #1706430)

  [ Julian Andres Klode ]
  * Drop transitional ndiswrapper-utils-1.9 package
  * Bump Standards-Version to 4.1.1

 -- Julian Andres Klode <email address hidden>  Sun, 05 Nov 2017 14:38:21 +0100
Superseded in xenial-updates on 2018-07-23
Deleted in xenial-proposed on 2018-07-24 (Reason: moved to -updates)
ndiswrapper (1.60-3~ubuntu16.04.2) xenial; urgency=medium

  * Upload to xenial for kernel 4.11 and 4.13 (LP: #1724869)
    - 0006-Build-fixes-for-Linux-4.11.patch
    - 0007-Build-fixes-for-Linux-4.13.patch

 -- Marcelo Henrique Cerri <email address hidden>  Fri, 27 Oct 2017 14:03:22 -0200
Superseded in bionic-release on 2017-11-13
Published in artful-release on 2017-08-17
Deleted in artful-proposed (Reason: moved to release)
ndiswrapper (1.60-4ubuntu1) artful; urgency=medium

  * Build fix for 4.13 (LP: #1706430)
    - debian/patches/0007-Build-fixes-for-Linux-4.13.patch

 -- Seth Forshee <email address hidden>  Wed, 16 Aug 2017 10:34:30 -0500
Superseded in artful-release on 2017-08-17
Deleted in artful-proposed on 2017-08-18 (Reason: moved to release)
ndiswrapper (1.60-4) experimental; urgency=medium

  [ Seth Forshee ]
  * Build fixes for Linux 4.11 (LP: #1691838)

 -- Julian Andres Klode <email address hidden>  Fri, 09 Jun 2017 16:30:49 +0200

Available diffs

Superseded in xenial-updates on 2018-01-24
Deleted in xenial-proposed on 2018-01-25 (Reason: moved to -updates)
ndiswrapper (1.60-3~ubuntu16.04.1) xenial; urgency=medium

  * Upload to xenial for kernel 4.8 (LP: ##1625089)

Superseded in artful-release on 2017-06-12
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-06-22 (Reason: moved to release)
ndiswrapper (1.60-3) unstable; urgency=medium

  * Use netif_trans_update() for kernels >= 4.7 (Closes: #837329) (LP: #1625089)

 -- Julian Andres Klode <email address hidden>  Thu, 22 Sep 2016 11:01:46 +0200

Available diffs

Superseded in yakkety-release on 2016-09-25
Deleted in yakkety-proposed on 2016-09-26 (Reason: moved to release)
ndiswrapper (1.60-2) unstable; urgency=medium

  [ Julian Andres Klode ]
  * Fix FTBFS of userspace stuff by not using kernel variables
  * Build with full hardening enabled

  [ Reiner Herrmann ]
  * make the build reproducible (Closes: #803583)

 -- Julian Andres Klode <email address hidden>  Thu, 30 Jun 2016 13:56:14 +0200

Available diffs

Superseded in yakkety-release on 2016-07-01
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed (Reason: moved to release)
ndiswrapper (1.59-6) unstable; urgency=medium

  * Add support for Kernel 4.2.
    Thanks to Tim Gardner at Canonical

 -- Julian Andres Klode <email address hidden>  Thu, 13 Aug 2015 15:55:01 +0200

Available diffs

Superseded in wily-release on 2015-08-15
Deleted in wily-proposed on 2015-08-16 (Reason: moved to release)
ndiswrapper (1.59-5ubuntu1) wily; urgency=medium

  * Fix FTBS against linux 4.2
    debian/patches/Support-kernel-4.2.patch

 -- Tim Gardner <email address hidden>  Thu, 06 Aug 2015 09:07:46 -0600

Available diffs

Superseded in wily-release on 2015-08-06
Deleted in wily-proposed on 2015-08-07 (Reason: moved to release)
ndiswrapper (1.59-5) unstable; urgency=medium

  * ndiswrapper: postrm: Fix test for /etc/ndiswrapper existence
  * ndiswrapper: postrm: Delete /etc/modprobe.d/ndiswrapper.conf on purge
    (LP: #712120)

 -- Julian Andres Klode <email address hidden>  Mon, 18 May 2015 21:12:36 +0200

Available diffs

Superseded in wily-release on 2015-05-20
Deleted in wily-proposed on 2015-05-22 (Reason: moved to release)
ndiswrapper (1.59-3) unstable; urgency=medium

  [ Julian Andres Klode ]
  * Rename patch files using patch queue
  * Add support for kernel 4.0
  * debian/control: Bump Standards-Version to 3.9.6
  * debian/copyright: Fix some patterns and update copyright year
  * debian/control: Use canonical Vcs URLs
  * debian/patches: Re-add lost bug-tracker entries
  * debian/gbp.conf: Add

  [ Chris Lamb ]
  * debian/rules: Make the build reproducible (Closes: #778222)

 -- Julian Andres Klode <email address hidden>  Tue, 12 May 2015 17:26:17 +0200

Available diffs

Superseded in wily-release on 2015-05-12
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2014-03-20
Deleted in trusty-proposed (Reason: moved to release)
ndiswrapper (1.59-2) unstable; urgency=medium


  * Only support modprobe.d (Closes: #724890)
  * debian/control: Set Standards-Version to 3.9.5
  * Recommend ndiswrapper-dkms in Ubuntu builds as well
  * kernel-3.14.patch: Add support for kernel 3.14

 -- Julian Andres Klode <email address hidden>  Wed, 19 Mar 2014 16:08:06 +0100

Available diffs

Superseded in trusty-release on 2014-03-20
Deleted in trusty-proposed on 2014-03-21 (Reason: moved to release)
ndiswrapper (1.59-1) unstable; urgency=medium


  * Imported Upstream version 1.59
  * Drop unused patches and fixup the remaining ones

 -- Julian Andres Klode <email address hidden>  Fri, 27 Dec 2013 16:28:41 +0100

Available diffs

Superseded in trusty-release on 2014-01-10
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
ndiswrapper (1.58-2) unstable; urgency=low


  * Add Support for Kernel 3.10; patch by Canonical (Closes: #717152)
  * Update Ubuntu patch to re-add support for older kernels

 -- Julian Andres Klode <email address hidden>  Sun, 04 Aug 2013 13:41:30 +0200
Superseded in saucy-release on 2013-08-05
Deleted in saucy-proposed on 2013-08-06 (Reason: moved to release)
ndiswrapper (1.58-1ubuntu1) saucy; urgency=low

  * update-for-linux-3.10.patch: Fix build with 3.10 and later kernels
 -- Seth Forshee <email address hidden>   Sun, 04 Aug 2013 11:41:02 +0100
Superseded in saucy-release on 2013-08-04
Deleted in saucy-proposed on 2013-08-05 (Reason: moved to release)
ndiswrapper (1.58-1) unstable; urgency=low


  * Imported Upstream version 1.58 (Closes: #707665)
  * Use $KERNELRELEASE as target kernel version (Closes: #693638)
  * Add BUILT_MODULE_NAME to dkms config file (Workaround for: #690747)
  * Add support for kernel 3.9
  * Patch userland for 3.X kernels
  * Set Standards-Version to 3.9.4

 -- Julian Andres Klode <email address hidden>  Sun, 14 Jul 2013 20:02:35 +0200
Superseded in saucy-release on 2013-07-21
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
ndiswrapper (1.58-0ubuntu1) raring; urgency=low

  * New upstream release adding support for 3.8 kernels (LP: #1106051)
   - drop fix-3.7-kernels.patch (fixed upstream)
 -- Dave Lentz <email address hidden>   Sat, 30 Mar 2013 07:03:57 -0400
Superseded in raring-release on 2013-04-19
Deleted in raring-proposed on 2013-04-21 (Reason: moved to release)
ndiswrapper (1.58~rc1-0ubuntu1) raring; urgency=low

  * New upstream release. (LP: #1023645)
   - add a patch to fix for 3.6+ kernels, maybe.
 -- Dmitrijs Ledkovs <email address hidden>   Thu, 20 Dec 2012 22:44:06 +0000
Superseded in raring-release on 2012-12-21
Superseded in raring-release on 2012-11-10
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2012-04-12
ndiswrapper (1.57-1ubuntu1) precise; urgency=low

  * patch from  Joerg Schirottke <email address hidden> to fix (LP: #978920)
   - patches/kernel-3-userspace-support.patch: Allow kernel 3.0+
   - Fix debian/ndiswrapper-dkms.dkms.in
 -- Oliver Grawert <email address hidden>   Thu, 12 Apr 2012 16:16:51 +0200

Available diffs

Superseded in precise-release on 2012-04-12
ndiswrapper (1.57-1) unstable; urgency=low


  * Imported Upstream version 1.57
    - Fixes build with kernel 3.2 (Closes: #655223, LP: #910597)
  * Enable hardening build flags (Closes: #655249)
  * patches/ndiswrapper-harden.patch: Use $(shell X) instead of `X`
  * Update to Policy 3.9.3, copyright-format 1.0

 -- Julian Andres Klode <email address hidden>  Mon, 05 Mar 2012 16:49:02 +0100

Available diffs

Superseded in precise-release on 2012-03-09
ndiswrapper (1.57~rc1-1) unstable; urgency=low

  * Imported Upstream version 1.57~rc1
    - Fixes build with newer kernel version (Closes: #650012)
  * Set Standards-Version to 3.9.2
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  12 Dec 2011 12:00:46 +0000

Available diffs

Superseded in precise-release on 2011-12-12
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
ndiswrapper (1.56+r2729-1) unstable; urgency=low

  * Imported Upstream version 1.56+r2729
    - Support for Kernels 2.6.36 - 2.6.38 (LP: #660664, Closes: #604880)
  * Drop patch for Linux 2.6.35, included in snapshot
 -- Julian Andres Klode <email address hidden>   Mon,  04 Apr 2011 13:28:42 +0000

Available diffs

Superseded in natty-release on 2011-04-04
Obsolete in maverick-release on 2013-03-05
ndiswrapper (1.56-3) unstable; urgency=low

  * Use a reworked and working Linux 2.6.35 support patch (LP: #613796)
 -- Julian Andres Klode <email address hidden>   Mon,  20 Sep 2010 17:06:09 +0000

Available diffs

Superseded in maverick-release on 2010-09-20
ndiswrapper (1.56-2) unstable; urgency=low

  * Only suggest ndiswrapper-dkms on Ubuntu
  * Add support for Linux 2.6.35 (LP: #590090)
  * Set Standards-Version to 3.9.1
 -- Julian Andres Klode <email address hidden>   Wed,  04 Aug 2010 20:17:35 +0100

Available diffs

Superseded in maverick-release on 2010-08-04
ndiswrapper (1.56-1) unstable; urgency=low

  * Imported Upstream version 1.56
  * Drop all patches, they are shipped upstream now.
  * debian/ndiswrapper.8, debian/loadnsisdriver.8: Escape the "-".

Available diffs

Superseded in maverick-release on 2010-05-22
Obsolete in lucid-release on 2016-10-26
Obsolete in karmic-release on 2013-03-04
ndiswrapper (1.54-2ubuntu1) karmic; urgency=low

  * Merge from debian unstable, remaining changes: LP: #369841
    - Build for lpia.
    - debian/control:
      + Change the Maintainer address.
    - debian/control:
      + Drop ndiswrapper-source.

Available diffs

Superseded in karmic-release on 2009-04-30
Obsolete in jaunty-release on 2013-02-28
ndiswrapper (1.53-2ubuntu1) jaunty; urgency=low

  * Merge with Debian; remaining changes:
    - Build for lpia.
    - debian/control:
      + Update description to point out that the kernel source package is
        not required with the standard Ubuntu kernel.
      + Change the Maintainer address.
    - debian/control:
      + Drop ndiswrapper-source.

Available diffs

Superseded in jaunty-release on 2008-11-22
Obsolete in intrepid-release on 2013-02-20
ndiswrapper (1.52-1ubuntu1) intrepid; urgency=low

  * Merge with Debian; remaining changes:
    - Build for lpia.
    - debian/control:
      + Update description to point out that the kernel source package is
        not required with the standard Ubuntu kernel.
      + Change the Maintainer address.
    - debian/control:
      + Drop ndiswrapper-source.

Available diffs

Superseded in intrepid-release on 2008-06-23
Obsolete in hardy-release on 2015-04-24
ndiswrapper (1.50-1ubuntu1) hardy; urgency=low

  * Merge with Debian; remaining changes:
    - Build for lpia.
    - debian/control:
      + Update description to point out that the kernel source package is
        not required with the standard Ubuntu kernel.
      + Change the Maintainer address.
    - debian/control:
      + Drop ndiswrapper-source.

Superseded in hardy-release on 2007-12-07
Obsolete in gutsy-release on 2011-09-16
ndiswrapper (1.43-1ubuntu2) gutsy; urgency=low

  * Nuild for lpia.

 -- Matthias Klose <email address hidden>   Fri, 24 Aug 2007 01:29:48 +0000
Superseded in gutsy-release on 2007-08-24
ndiswrapper (1.43-1ubuntu1) gutsy; urgency=low

  * Merge from debian unstable, remaining changes:
    - debian/control:
      + Update description to point out that the kernel source package is
        not required with the standard Ubuntu kernel.
      + Change the Maintainer address.
  * debian/control:
    - Drop ndiswrapper-source.

 -- Timo Aaltonen <email address hidden>   Tue, 29 May 2007 11:30:42 +0300
Superseded in gutsy-release on 2007-05-29
Obsolete in feisty-release on 2009-08-20
ndiswrapper (1.38-1ubuntu1) feisty; urgency=low

  * Merge from debian unstable, remaining changes:
    debian/control:
    - Update description to point out that the kernel source package is
      not required with the standard Ubuntu kernel.
    - Change the Maintainer address.
  * Closes many bugs (LP: #32275, #65779, #92155, maybe others)

 -- Timo Aaltonen <email address hidden>   Thu, 29 Mar 2007 11:04:29 +0300
Superseded in feisty-release on 2007-03-29
ndiswrapper (1.30-1ubuntu1) feisty; urgency=low

  * Merge from debian unstable, remaining changes:
    - debian/control: Update description to point out that the kernel
      source package is not required with the standard Ubuntu kernel.

Superseded in feisty-release on 2006-12-20
ndiswrapper (1.28-1ubuntu1) feisty; urgency=low

  * Sync with Debian.
  * debian/control: Update description to point out that the kernel source
    package is not required with the standard Ubuntu kernel.

 -- Ben Collins <email address hidden>   Thu, 23 Nov 2006 01:45:25 -0500
Superseded in feisty-release on 2006-11-23
Obsolete in edgy-release on 2008-06-19
ndiswrapper (1.18-1ubuntu2) edgy; urgency=low

  * Fix bashisms in debian/ndiswrapper and debian/rules (closes: Malone
    #63740).

 -- Colin Watson <email address hidden>   Tue,  3 Oct 2006 16:38:08 +0100
Superseded in edgy-release on 2006-10-03
ndiswrapper (1.18-1ubuntu1) edgy; urgency=low

  * Sync with Debian.

Superseded in edgy-release on 2006-07-10
Obsolete in dapper-release on 2011-09-06
ndiswrapper (1.8-0ubuntu2) dapper; urgency=low


  * Stop depending on ndiswrapper-modules - we ship the module in our 
    kernel package.

 -- Matthew Garrett <email address hidden>  Thu,  2 Feb 2006 05:46:19 +0000
Superseded in dapper-release on 2006-02-04
Superseded in dapper-release on 2006-02-04
Superseded in dapper-release on 2006-02-03
ndiswrapper (1.8-0ubuntu1) dapper; urgency=low


  * New upstream version.

 -- Matthias Klose <email address hidden>  Thu, 19 Jan 2006 13:03:08 +0000
Superseded in dapper-release on 2006-01-31
ndiswrapper (1.5-1ubuntu1) dapper; urgency=low


  * Resynchronise with Debian.  (Totally me!)

 -- Scott James Remnant <email address hidden>  Wed, 16 Nov 2005 23:39:48 +0000
Obsolete in breezy-release on 2008-03-25
ndiswrapper (1.1-4ubuntu2) breezy; urgency=low


  * debian/control: Update description to point out that the kernel source
    package is not required with the standard Ubuntu kernel.

 -- Martin Pitt <email address hidden>  Fri, 30 Sep 2005 14:56:14 +0200
Obsolete in hoary-release on 2008-03-19
ndiswrapper (0.12+1.0rc2-1) unstable; urgency=low


  * New upstream release.

 -- Andres Salomon <email address hidden>  Sun, 09 Jan 2005 19:40:16 -0500
Obsolete in warty-release on 2008-01-09
ndiswrapper (0.10-1) warty; urgency=low


  * Initial release.'

 -- Herbert Xu <email address hidden>  Sat,  2 Oct 2004 17:23:29 +1000
145 of 45 results