Keyboard input not accepted after copying selection with Control-C

Bug #1027 reported by John Clarke on 2005-06-15
This bug report is a duplicate of:  Bug #72798: Nedit bug attributed to lesstif. Edit Remove
6
Affects Status Importance Assigned to Milestone
nedit (Ubuntu)
Medium
MOTU

Bug Description

After selecting text with the keyboard and copying it with Control-C, the edit window will (more than 90% of the time) not accept keyboard input

After selecting text with the keyboard and copying it with Control-C, the edit window will (more than 90% of the time) not accept keyboard input. Recovery is either by mouse click on the edit window, or sometimes by pasting the text with Control-V -- this is the only keyboard input I've been able to have accepted, but doesn't always work. Sometimes only the mouse will work.

A similar loss of keyboard input often (~50% of the time) occurs when the find dialog is opened with Control-F. The only way to continue is to cancel (with the mouse) and try again, and keep trying until it works. I've not yet had to try more than three times.

I've built nedit-5.5 from the breezy source package with identical results.

I've been using the v5.5 binary from nedit.org on Redhat 7.3 for over six months and it works perfectly. The most obvious difference is that it's statically linked with openmotif 2.1.30. I've tried it on Ubuntu Hoary but it won't run -- it reports "locale is not supported" on startup then crashes when I try to open a file.

John Clarke (jrc61) wrote :

Tonight I rebuilt nedit-5.5 with openmotif (libmotif-dev) instead of lesstif (lesstif2-dev). This new version seems not to have the bugs I reported earlier. It looks like the bugs are not due to nedit itself but rather are due to lesstif.

There is one minor problem with openmotif. Depending upon the value of $LANG, I get various "locale not supported" messages on startup.

If LANG="en_AU.UTF-8", it says "locale UTF8 not supported" and prints lots of messages like this when I try to open a file (but it doesn't crash):

    Name: FilterText
    Class: XmTextField
    Character '\143' not supported in font. Discarded.

If LANG="en_AU", it says "locale not supported by C library, locale unchanged", but that's all.

If LANG is unset, there are no messages and it *appears* to work perfectly. I haven't done enough to be sure it's OK, but so far it looks good.

Changed in nedit:
assignee: nobody → motu
Gauvain Pocentek (gpocentek) wrote :

Hi John,

I can't reproduce these issues with the current package in dapper (1:5.5-1ubuntu1).
Could you test this package, and close the bug if it's fixed?

Thanks

Changed in nedit:
status: Unconfirmed → Needs Info
John Clarke (jrc61) wrote :

I'm not running dapper anywhere, nor do I have a spare machine to install it, but I've tested it on breezy (nedit-1:5.5-1ubuntu1) and can't reproduce the problem.

As I said earlier, I believe it's a bug in lesstif rather than nedit, and it appears that the bug has been fixed.

Changed in nedit:
status: Needs Info → Fix Released
John Clarke (jrc61) wrote :

I was wrong about it having been fixed.

I couldn't reproduce it on the Dell D400 I was using at the time, but I've recently installed dapper on an HP Pavilion dv5230tx and the bug is still there. I've also been able to reproduce it on a desktop machine running breezy.

Changed in nedit:
status: Fix Released → Unconfirmed
John Clarke (jrc61) wrote :

The almost working version (except for "UTF8 not supported") built with openmotif is here:

http://kirriwa.net/john/software/nedit/nedit-dmotif_5.5-1ubuntu1_i386.deb

Unsetting LANG removes the "UTF8 not supported" error and it works perfectly. I've been using nedit-dmotif for over 12 months now and it's been fine.

Ryan O'Connor (ryanoc) wrote :

Hi John. Is using this openmotif version a complete alternative to the lesstif version?

Colin Watson (cjwatson) wrote :

openmotif is non-free (it's in multiverse), so is very much not an ideal option; it would require moving nedit to multiverse too. It would be much better to try to fix this in nedit (or lesstif if necessary) instead.

Ryan O'Connor (ryanoc) wrote :

It's been brought up that openmotif is non-free, so it must be a bug with lesstif. But I can't reproduce this behaviour eitehr on dapper 6.06 with the latest nedit...

On Thu, Aug 24, 2006 at 11:56:29 -0000, rocifier wrote:

> Hi John. Is using this openmotif version a complete alternative to the
> lesstif version?

Pretty much. The only caveat is that libmotif3 (openmotif) is in
multiverse, but nedit is in universe. If all you care about is
functionality, then openmotif is the better choice. In my experience,
nedit is completely unusable with lesstif so openmotif is the *only*
real choice right now.

Cheers,

John
--
You are making the assumption that a complete novice should be able to set
up a mail server. Oh, that's right, they can. Webservers too. Just today
I got 366 requests for default.ida from complete novice webservers.
            -- Jamie Wilkinson

John Clarke (jrc61) wrote :

On Thu, Aug 24, 2006 at 12:04:34 -0000, Colin Watson wrote:

> It would be much better to try to fix this in nedit (or lesstif if necessary)

Yes, definitely. However, it may be sensible to link nedit with
openmotif in the meantime though, even if it means moving it to
multiverse, because there's little point in shipping a completely
useless program just so that it's free.

Non-free + functional beats free + non-functional any day :-)

Cheers,

John
--
I'm proud to be an old-fashioned bigoted unixoid. They'll take my
keyboard away from me when they pry it from the shattered skulls of my
enemies.
            -- Mark 'Kamikaze' Hughes

John Clarke (jrc61) wrote :

On Thu, Aug 24, 2006 at 12:17:40 -0000, rocifier wrote:

> with lesstif. But I can't reproduce this behaviour eitehr on dapper 6.06
> with the latest nedit...

I had two computers (an old dual PII-350 which is now dead and a Dell
D400 laptop which I no longer have) on which I couldn't reproduce it,
and I now have two (different computers, a P4-3GHz and an HP dv5230tx
laptop) on which I can. Reliably, repeatably, every time.

I'd offer to help debug it but I'm heading off for a very long holiday
tomorrow which will include long periods without 'net access (and
anyway, I'm escaping from s/w development!). If there's been no
progress by the time I return (mid-October) I'll be happy to do what I
can to help fix it.

Cheers,

John
--
Read Qoheleth and weep. What we have been seeing on the WWW for lo
these many years is a rehash of what we saw in drektop publishing;
the technical prowess of a lichen and the aesthetic sense of a warthog.
            -- Shmuel (Seymour J.) Metz

Alberto Cerpa (acerpa+ubuntu) wrote :
Download full text (3.7 KiB)

Just a follow up on this (and some others) bug(s).

acerpa@jupiter:~$ uname -r
2.6.15-27-amd64-generic

I am running Ubuntu 6.06 LTS Dapper Drake distribution. It comes with the nedit binary compiled to use the LessTif clone.

NEdit 5.5
Sep 30, 2004

     Built on: Linux, x86-64, GNU C
     Built at: Oct 8 2005, 20:15:23
   With Motif: 2.1.0 [@(#)GNU/LessTif Version 2.1 Release 0.93.94] (UNTESTED)
Running Motif: 2.1 [unknown]
       Server: The X.Org Foundation 70000000
       Visual: 24-bit TrueColor (ID 0x21, Default)
       Locale: C

I am also running a box with dual-head system, running the nvidia drivers, render acceleration, xinerama, etc. As a long time nedit user I had to track down this and some other bugs to make my new system work. These are my findings so far:

1) Dual Head Bug:
===========

acerpa@jupiter:~$ which nedit
/usr/bin/nedit
acerpa@jupiter:~$ nedit
X Error of failed request: BadValue (integer parameter out of range for operation)
  Major opcode of failed request: 78 (X_CreateColormap)
  Value in failed request: 0x24a
  Serial number of failed request: 11
  Current serial number in output stream: 13

Problem:
32-bit visual in X make the *Tif library (and Nedit) to crash.

Workaround:
nedit -xrm '*visualID: default'
OR
(using tcsh)
setenv XLIB_SKIP_ARGB_VISUALS 1; nedit

Prevent the system to use the 32-bit visual.

Follow up on the bug can be found here:
https://sourceforge.net/tracker/?func=detail&atid=111005&aid=1030467&group_id=11005

2) Locked clipboard bug (this launchpad's bug):
============================

When attempting to copy something to the clipboard using nedit Ctrl+c I get:
Attempt to copy to unlocked clipboard!

Problem:
This is a bug on LessTif that has not been fixed :-(

Workaround:
Compile nedit from source using the libmotif-dev Open Motif libraries, using 2.2.3-1.2ubuntu2. I created a statically compiled binary to prevent any dependency on libmotif (just in case I want to remove the library).

acerpa@jupiter:~/nedit-5.5/source$ ./nedit -xrm '*visualID: default' -V
NEdit 5.5
Sep 30, 2004

     Built on: Linux, x86-64, GNU C
     Built at: Sep 20 2006, 21:22:30
   With Motif: 2.2.3 [@(#)Motif Version 2.2.3] (UNTESTED)
Running Motif: 2.2 [unknown]
       Server: The X.Org Foundation 70000000
       Visual: 24-bit TrueColor (ID 0x21, Default)
       Locale: C

acerpa@jupiter:~/nedit-5.5/source$ printenv LANG
en_US.UTF-8
acerpa@jupiter:~/nedit-5.5/source$ ./nedit -xrm '*visualID: default'
UTF8 locale not supported.

Follow up on the bug can be found here:
https://sourceforge.net/tracker/?func=detail&atid=111005&aid=1440331&group_id=11005

Almost there...

3) Bug in Nedit to support the locale
======================

Problem: User have a locale define, but Nedit is not taking it. It happens only with the motif libraries (not lessmotif).

Workaround: unset the LANG environmental variable before invoking nedit.

Follow up on the bug can be found here:
https://sourceforge.net/tracker/index.php?func=detail&aid=1543796&group_id=11005&atid=111005

4) Copy & Paste not working between nedit and firefox:
=================================

Problem: self explanatory

Workaround: just select the text t...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers