Ubuntu

nedit does not start

Reported by Martin Gustafsson on 2006-08-26
18
Affects Status Importance Assigned to Milestone
nedit (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: nedit

Nedit does not start anymore. Running Ubuntu Edgy Eft.
~$ nedit
X Error of failed request: BadMatch (invalid parameter attributes)
  Major opcode of failed request: 70 (X_PolyFillRectangle)
  Serial number of failed request: 310
  Current serial number in output stream: 320

Vassilis Pandis (pandisv) wrote :

Cannot reproduce with nedit 5.5-2ubuntu1 on x86.It starts fine.

It's a known bug according to the nedit developers. A workaround also exist in cvs. Three options are available and I have verified the first two of them.

* nedit -xrm '*visualID: default'
* XLIB_SKIP_ARGB_VISUALS=1 nedit
* compile nedit from the latest CVS sources

I don't have this bug anymore. I guess the issue was solved after a couple of dist-upgrades..

Vassilis Pandis (pandisv) wrote :

Thanks for reporting back. If it reappears, feel free to reopen this bug (or file another one). Thanks again.

Changed in nedit:
status: Unconfirmed → Fix Released

I recently made a reinstall of my system and now I got this bug again. When I look in the repository today 01-oct I see that 1:5.5-1ubuntu1 is the version for Edgy. nedit_5.5-2 from Debian Unstable works though.

Changed in nedit:
status: Fix Released → Unconfirmed
Gerv (gerv) wrote :

I also have this problem now I've upgraded to Edgy.

This Firefox bug outlines the exact conditions for triggering this problem:
https://bugzilla.mozilla.org/show_bug.cgi?id=304370

You need Composite turned on, and a 16-bit colour depth.

Ubuntu needs to either apply a patch to nedit to work around the issue, or make sure nedit is always started with XLIB_SKIP_ARGB_VISUALS=1 set.

So it's confirmed. Why is 5.5-1ubuntu1 still (back) in the edgy repository?

Jeffrey Baker (jwbaker) wrote :

Triple confirmed with 5.5-1ubuntu1

Hi!

I am currently having this problem on three different computers, all updated from Dapper to Edgy, all using the 5.5-1ubuntu1 package.

BR,
Lars

Daniel Pirch (dpirch) wrote :

Another confirmation here, also on Edgy upgraded from Dapper. Running `XLIB_SKIP_ARGB_VISUALS=1 nedit' works.

Ditto here. nedit worked under Dapper. Doesn't under Edgy. XLIB_SKIP_ARGB_VISUALS=1 nedit is a workaround.

Changed in nedit:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Sridhar Dhanapalan (sridhar) wrote :

Confirmed here as well. Running 'XLIB_SKIP_ARGB_VISUALS=1 nedit' works for me as well. Unlike Gerv's report, I am using a 24-bit colour depth but I am using Composite.

Vassilis Pandis (pandisv) wrote :

5.5-2 is in the edgy and feisty repos - is it still a problem with this package?

Vassilis Pandis (pandisv) wrote :

I don't really understand actually. Martin Gustafsson at 2006-10-02 17:27:50 UTC complained that 5.5-1 was in edgy, but 5.5-2 has been in edgy since July according to https://launchpad.net/distros/ubuntu/+source/nedit/ . 'aptitude show nedit' informs me that Edgy still has 5.5-1 though .

Vassilis Pandis (pandisv) wrote :

5.5-2 didn't build on edgy/feisty because build-deps were changed from lesstif2 to libmotif-dev which is in multiverse. Since the package doesn't work with lesstif2 according to the debian changelog, nedit needs to be moved to multiverse. I opened bug 76571 about this.

Vassilis Pandis (pandisv) wrote :

nedit has been moved to multiverse for feisty so this should no longer be a problem for anybody running feisty. If it is, please reopen the bug. Thanks to everybody!

Changed in nedit:
status: Confirmed → Fix Released
freebird54 (midnightlogic) wrote :

I am not sure I blame nedit for this. I downloaded it last night and got this error - but *IF* I am not running Beryl it appears to be FINE.

Blame Beryl - it's the less stable of the 2!

BTW - the nedit was from the Edgy repositories...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers