net-snmp 5.3.1-6ubuntu2.2 source package in Ubuntu

Changelog

net-snmp (5.3.1-6ubuntu2.2) gutsy-security; urgency=low

  * SECURITY UPDATE: authentication bypass via spoofed SNMPv3 packets.
    - 51_CVE-2008-0960.patch: fixes thanks to Nico Golde.
  * SECURITY UPDATE: arbitrary code execution via buffer overflow.
    - 52_CVE-2008-2292.patch: fixes thanks to Jochen Friedrich.
  * SECURITY UPDATE: denial of service via number of getbulk responses.
    - 53_CVE-2008-4309.patch: ported fixes from Jochen Friedrich.

 -- Kees Cook <email address hidden>   Tue, 18 Nov 2008 12:28:59 -0800

Upload details

Uploaded by:
Kees Cook on 2008-11-19
Uploaded to:
Gutsy
Original maintainer:
Ubuntu Development Team
Architectures:
any
Section:
net
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
net-snmp_5.3.1.orig.tar.gz 4.0 MiB fb6d5113ccdd8c4661fe5d825160e45a7c5035b145e24ec18f71a509ecb0fe43
net-snmp_5.3.1-6ubuntu2.2.diff.gz 92.4 KiB 2b9694fcb02abb6bace5587ff4e0c813e2572dc2d37408bfc933264ced55d9f6
net-snmp_5.3.1-6ubuntu2.2.dsc 1.3 KiB 52c42ac1306b91683b6e995cd28c36cab7c517efb8c4dffeed9f989f8dcbfaac

View changes file

Binary packages built by this source

libsnmp-base: No summary available for libsnmp-base in ubuntu gutsy.

No description available for libsnmp-base in ubuntu gutsy.

libsnmp-dev: No summary available for libsnmp-dev in ubuntu gutsy.

No description available for libsnmp-dev in ubuntu gutsy.

libsnmp-perl: No summary available for libsnmp-perl in ubuntu gutsy.

No description available for libsnmp-perl in ubuntu gutsy.

libsnmp10: No summary available for libsnmp10 in ubuntu gutsy.

No description available for libsnmp10 in ubuntu gutsy.

snmp: No summary available for snmp in ubuntu gutsy.

No description available for snmp in ubuntu gutsy.

snmpd: No summary available for snmpd in ubuntu gutsy.

No description available for snmpd in ubuntu gutsy.

tkmib: No summary available for tkmib in ubuntu gutsy.

No description available for tkmib in ubuntu gutsy.