Icon cache not updated in post-install

Bug #37128 reported by Christian Assing
208
This bug affects 1 person
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Medium
Unassigned

Bug Description

hi,

if i try to start the nm-applet the following error message appears in a new window:

"The NetworkManager applet could not find some required resources. It cannot continue."

versions:
network-manager 0.6.1-0ubuntu4
network-manager-gnome 0.6.1-0ubuntu4

Revision history for this message
John Cooper (choffee) wrote :

I am getting the same and these errors at the console:

** (nm-applet:7038): WARNING **: Icon nm-vpn-lock missing: Icon 'nm-vpn-lock' not present in theme

Then a load of these errors.

(nm-applet:7038): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

description: updated
Revision history for this message
Joachim Sauer (saua) wrote :

I've had the same problem and solved it by running gtk-update-icon-cache on all directories in /usr/share/icons.

The package should probably run it on the directory where it adds its icons.

Revision history for this message
Christian Assing (chassing) wrote :

i have running gtk-update-icon-cache on all directories in /usr/share/icons and that solve the problem with
"** (nm-applet:7038): WARNING **: Icon nm-vpn-lock missing: Icon 'nm-vpn-lock' not present in theme"

and

"(nm-applet:7038): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed"

now the nm-applet process is running but doesnt appear in the gnome-panel

i straced the process but there is nothing noticeable.

Revision history for this message
Christian Assing (chassing) wrote :

i found the problem... the network-manager isnt running!

i try to start the network-manager and it is crashing:

root@alpha:~# NetworkManager --no-daemon
NetworkManager: <information> starting...
NetworkManager: <WARNING> main (): nm_data_new: Setting up dbus filter
NetworkManager: <information> eth0: Device is fully-supported using driver 'tg3'.
NetworkManager: <information> nm_device_init(): waiting for device's worker thread to start
NetworkManager: <information> nm_device_init(): device's worker thread started, continuing.
NetworkManager: <information> Now managing wired Ethernet (802.3) device 'eth0'.
NetworkManager: <WARNING> nm_signal_handler (): Caught signal 11. Generating backtrace...
NetworkManager: ******************* START **********************************
NetworkManager: (no debugging symbols found)
NetworkManager: Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: [Thread debugging using libthread_db enabled]
NetworkManager: [New Thread -1212082496 (LWP 9159)]
NetworkManager: [New Thread -1212085328 (LWP 9161)]
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: 0xffffe410 in __kernel_vsyscall ()
NetworkManager: ******************* END **********************************

Revision history for this message
Jorge Castro (jorge) wrote :

I get the same problem in my syslog, confirming.

Changed in network-manager:
status: Unconfirmed → Confirmed
Revision history for this message
Thomas Schwinge (tschwinge) wrote :

Most probably related to <URL:http://launchpad.net/bugs/37961/>.

Revision history for this message
JLu (jlutgen) wrote :

I have the same problem in version 0.6.2-0ubuntu3. As rentar suggests above, I ran "gtk-update-icon-cache" on all directories in /usr/share/icons, but the problem remained. What finally worked for me was to run "gtk-update-icon-cache --force" on all those directories.

Revision history for this message
Paul Drain (pd) wrote :

Had the same problem after removing network-manager-gnome and re-installing it after a week.

Running "gtk-update-icon-cache -f /usr/share/icons/hicolor/" fixed the problem.

Revision history for this message
Philipp Kern (pkern) wrote : Re: Icon nm-vpn-lock missing: Icon 'nm-vpn-lock' not present in theme

I needed the same command, i.e. "gtk-update-icon-cache -f /usr/share/icons/hicolor/", to successfully fix the problem.

Revision history for this message
Luka Renko (lure) wrote :

From bug 40159: please call dh_iconcache in debian/rules

network-manager is still on the list on https://wiki.ubuntu.com/DhIconCacheChanges - please make sure you do it in one of the next uploads.

Matt Zimmerman (mdz)
Changed in network-manager:
assignee: nobody → keybuk
Revision history for this message
Manuel Siggen (manuel-siggen) wrote :

Same problem here : cache wasn't up-to-date (fixed) and network manager doesn't start (not fixed) :

msi@x40:~$ sudo NetworkManager --no-daemon
NetworkManager: <information> starting...
NetworkManager: <WARNING> main (): nm_data_new: Setting up dbus filter
NetworkManager: <information> eth0: Device is fully-supported using driver 'e1000'.
NetworkManager: <information> nm_device_init(): waiting for device's worker thread to start
NetworkManager: <information> nm_device_init(): device's worker thread started, continuing.
NetworkManager: <information> Now managing wired Ethernet (802.3) device 'eth0'.
NetworkManager: <WARNING> nm_signal_handler (): Caught signal 11. Generating backtrace...
NetworkManager: ******************* START **********************************
NetworkManager: (no debugging symbols found)
NetworkManager: Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: [Thread debugging using libthread_db enabled]
NetworkManager: [New Thread -1211447616 (LWP 6069)]
NetworkManager: [New Thread -1211450448 (LWP 6071)]
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: (no debugging symbols found)
NetworkManager: 0xffffe410 in __kernel_vsyscall ()
NetworkManager: ******************* END **********************************

Revision history for this message
Manuel Siggen (manuel-siggen) wrote :

Well, commenting out all interfaces (except loopback) from /etc/network/interfaces fixed the problem. Everything's working fine now !

Revision history for this message
Kuropka (d2) wrote :

I used "tk-update-icon-cache -f /usr/share/icons/hicolor/". I get no error message any more, but also no applet appears. Manually starting "nm-applet" start the programm but noting happens, no applet appears on the applet panel.

Changed in network-manager:
status: Confirmed → Fix Committed
Changed in network-manager:
status: Fix Committed → Fix Released
Revision history for this message
diegoe (diegoe-deactivatedaccount-deactivatedaccount) wrote :

Read above about /etc/network/interfaces problems. I suggest you to use netapplet if you are going to use static interfaces, but if you don't mind having dhcp'd ones then use NM.

Revision history for this message
magilus (magilus) wrote :

This reappears to me on a fresh Edgy install.

Running gtk-update-icon-cache -f /usr/share/icons/hicolor/
fixes the problem.. This has been reported in the Forums for several times.

Could we have the fix in edgy-updates please?

Changed in network-manager:
status: Fix Released → Confirmed
Revision history for this message
Daniel Holbach (dholbach) wrote :

This is in debian/rules:

binary-install/network-manager-gnome::
        dh_iconcache

Revision history for this message
magilus (magilus) wrote :

But it did not work for me two times.. I will retry again.

Revision history for this message
Daniel Holbach (dholbach) wrote :

I looked at the postinst that was generated for network-manager-gnome - it does call gtk-update-icon-cache.

Revision history for this message
Aaron Whitehouse (aaron-whitehouse) wrote :

It looks to me as though Bug #45609 and Bug #6473 are duplicates of Bug #37128.

Changed in network-manager:
assignee: keybuk → nobody
Revision history for this message
Sebastian Breier (tomcat42) wrote :

Seems to be fixed in feisty. At least I didn't encounter the error minutes ago.

Revision history for this message
Sebastian Breier (tomcat42) wrote :

Not fixed in feisty herd-2. Sorry.

Revision history for this message
Sebastian Breier (tomcat42) wrote :

Seems to be fixed now for me. Just reinstalled herd-2, then installed a couple of things, including nm. Can anybody confirm this please?

Revision history for this message
miro (mirobaka) wrote :

I just installed herd 2, and installed network manager and updated at the same time. I had the same problem

"gtk-update-icon-cache -f /usr/share/icons/hicolor/" fixed the issue.

this bug has been in since dapper and certainly hope it gets fixed by the time feisty comes out (or even better would be to have network manager installed by default. I still don't understand why Ubuntu is behind almost every other distro in this sense)

Revision history for this message
Sebastian Breier (tomcat42) wrote :

miro: NetworkManager never was at a quality level that Ubuntu needed, while it was enough for other distros (and that's what makes Ubuntu different). Before feisty, when you used NetworkManager, there was no way for regular users to guess when you had to use the gnome network configuration dialog and when to use nm. That has changed, so I guess it will be default in feisty or feisty+1.

Revision history for this message
Sebastian Breier (tomcat42) wrote :

Can I close this one? herd-3 has n-m as default, so I never experienced the bug.

Revision history for this message
Daniel Holbach (dholbach) wrote :

Closing bug. Marked as fixed.

Changed in network-manager:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers