Ubuntu

[dapper] Crashes when a Netgear MA111v2 with ndiswrapper

Reported by Paulus on 2006-07-16
6
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: network-manager

Running ndiswrapper 1.21 (built from upstram), but exact problem exists using ndiswrapper in dapper

Running dapper with current updates:
ii network-manager 0.6.2-0ubuntu7

Using netgear MA111v2 usb wlan stick:
Bus 003 Device 002: ID 0846:4230 NetGear, Inc. MA111 WiFi

When running NetworkManager with the wlan device available for NM (commented out in /etc/network/interfaces), it crashes in nm-device-802-11-wireless.c:916 (nm_device_802_11_wireless_get_mode()). Consequently, nm-applet disappears from the system tray.

I can bring up the interface manually (iwconfig &c.) without problems. Possibly fixed in current NetworkManager (suggested by http://bugzilla.gnome.org/show_bug.cgi?id=341263).

Paulus (donmatteo) wrote :

Incidently, this seems related, but not quite identical, to #44009. Attaching gdb session and ifconfig -a output (after successfuly bringing up the interface manually).

Scott Robinson (scott-ubuntu) wrote :

Does this occur in edgy? If it is related to the above bug, then it should be fixed there.

Glyph Lefkowitz (glyph) wrote :

I have this exact same problem using ndiswrapper on a rev 2 black macbook, using the latest updated edgy.

Do you still have this issue with the latest release of Ubuntu ?

Changed in network-manager:
importance: Undecided → High
status: Unconfirmed → Needs Info
Glyph Lefkowitz (glyph) wrote :

I do intermittently, but that's because the packaged ndiswrapper, 1.38, doesn't support the card in the C2D macbooks. This has been rectified in a later release, 1.43: http://ndiswrapper.sourceforge.net/joomla/index.php?/content/view/13/2/

I built that myself and replaced just ndiswrapper.ko and now it seems to work completely reliably.

Ok, thank you. I'm marking this as fix committed.

Changed in network-manager:
status: Needs Info → Fix Committed
Alexander Sack (asac) wrote :

closing as this is most likely fixed in gutsy. If you still see it in latest gutsy, please reopen.

Changed in network-manager:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers