Change log for node-expat package in Ubuntu

116 of 16 results
Published in focal-release on 2019-10-18
Published in eoan-release on 2019-07-15
Deleted in eoan-proposed (Reason: moved to release)
node-expat (2.3.18-1) unstable; urgency=medium

  [ upstream ]
  * New release.

  [ Jonas Smedegaard ]
  * Declare compliance with Debian Policy 4.4.0.

 -- Jonas Smedegaard <email address hidden>  Mon, 15 Jul 2019 00:43:45 -0300

Available diffs

Superseded in eoan-release on 2019-07-15
Published in disco-release on 2019-02-05
Deleted in disco-proposed (Reason: moved to release)
node-expat (2.3.17-1) unstable; urgency=medium

  * New upstream version 2.3.17
  * Move to dh 10, build against libnode, node-gyp 3.8.0-2
  * Depends nodejs, node-bindings
  * AMAU since Jonas only handles cdbs
  * Update Vcs-* fields
  * Drop nodejs rename patch
  * https url in copyright
  * Standards-Version 4.3.0
  * Add autopkgtests
  * DEP-3 format patch
  * Copyright: update and use stricter format, drop unused
    lintian overrides

 -- Jérémy Lal <email address hidden>  Fri, 25 Jan 2019 00:47:40 +0100
Superseded in disco-release on 2019-02-05
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2018-04-06
Deleted in bionic-proposed (Reason: moved to release)
node-expat (2.3.15-4build2) bionic; urgency=medium

  * No-change rebuild to pick up nodejs-abi-57

 -- Graham Inggs <email address hidden>  Fri, 06 Apr 2018 10:04:20 +0000

Available diffs

Superseded in bionic-release on 2018-04-06
Published in artful-release on 2017-08-29
Deleted in artful-proposed (Reason: moved to release)
node-expat (2.3.15-4build1) artful; urgency=medium

  * No-change rebuild to pick up nodejs-abi-48

 -- Graham Inggs <email address hidden>  Fri, 18 Aug 2017 15:41:11 +0000
Superseded in artful-release on 2017-08-29
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
node-expat (2.3.15-4) unstable; urgency=medium

  * Let tests not fail (new failures emerged with 2.3.15-3 on mips -
    possibly timing-related but too close to freeze to investigate).
  * Modernize Vcs-* fields:
    + Use git subdir.
    + Use .git suffix.

 -- Jonas Smedegaard <email address hidden>  Mon, 23 Jan 2017 19:07:24 +0100

Available diffs

Superseded in zesty-proposed on 2017-01-23
node-expat (2.3.15-3) unstable; urgency=medium

  * Update watch file: Use substitution string @PACKAGE@.
  * Cleanup gyp only if built, to simplify bootstrapping a build.
  * Drop obsolete lintian override regarding debhelper 9.
  * Update copyright info: Extend coverage of Debian packaging.
  * Extract metadata from png file for copyright check.
    Build-depend on libregexp-assemble-perl libimage-exiftool-perl
    libfont-ttf-perl.
    Tighten to build-depend versioned on cdbs.

 -- Jonas Smedegaard <email address hidden>  Tue, 10 Jan 2017 20:04:51 +0100

Available diffs

Superseded in zesty-proposed on 2017-01-10
node-expat (2.3.15-2) unstable; urgency=medium

  * Team Upload
  * Call dh_nodejs

 -- Jérémy Lal <email address hidden>  Wed, 21 Dec 2016 16:32:54 +0100

Available diffs

Superseded in zesty-release on 2017-02-10
Deleted in zesty-proposed on 2017-02-11 (Reason: moved to release)
node-expat (2.3.15-1) unstable; urgency=medium

  [ upstream ]
  * New release(s).
    + Benchmark.
    + Bump dependencies.
    + Fix test randomly failing.
    + Add Windows notice.
    + Bump dependencies and update README benchmark.
    + Move back to astro github account.
    + Delint.
    + Update dependencies.
    + Upgrade libexpat to version 2.2.0.
    + Fix add missing standard dependency (lint script).
    + Add many contributors to package.json.
    + Remove duplicated API method in documentation.

  [ Jonas Smedegaard ]
  * Stop suppress versioned debhelper build-dependency (done in CDBS
    now).
  * Stop track upstream source with CDBS (use gpb --uscan).
  * Update watch file:
    + Use Github pattern.
    + Mention gpb --uscan in usage comment.
  * Modernize git-buildpackage config:
    + Avoid git- prefix.
    + Filter any .gitignore file.
  * Declare compliance with Debian Policy 3.9.8.
  * Fix Vcs-Git field URL.
  * Build-depend on licensecheck (not devscripts).
  * Fix use http protocol (not https) for Homepage URL.
  * Unfuzz patch 1001.

 -- Jonas Smedegaard <email address hidden>  Wed, 31 Aug 2016 12:47:35 +0200

Available diffs

Superseded in zesty-release on 2016-11-03
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
node-expat (2.3.12-1) unstable; urgency=medium

  [ upstream ]
  * New release(s).
    + Refactor.
    + Update dependencies.
    + Update homepage URL + use https for Github links.
    + Upgrade to NANv2.
      Closes: Bug#799774. Thanks to Chris Lamb and Jurica Stanojkovic.

  [ Jonas Smedegaard ]
  * Update package relations:
    + Tighten to (build-)depend versioned on node-nan.
    + Tighten to build-depend versioned on node-vows.
    + Build-depend on node-debug.
  * Update upstream URLs to consistently use https protocol.
  * Modernize Vcs-* fields: Use https protocol.
  * Move packaging git to pkg-javascript team.
  * Declare compliance with Debian Policy 3.9.7.
  * Update copyright info:
    + Fix use full path in autotools Files sections.
    + Use License short-name FSFUL (and derivatives).
    + Fix list aclocal.m4 as FSFUL~file licensed.
    + Use License-Grant and License-Reference fields.
      Thanks to Ben Finney.
    + Extend copyright of packaging to cover current year.
  * Add lintian overrides regarding license in License-Reference field.
    See bug#s786450.
  * Bump debhelper compatibility level to 9.
  * Add lintian override regarding debhelper 9.
  * Bump watch file format version to 4.
  * Add lintian override regarding outdated but unused autotools files.
  * Improve build: Invoke vows explicitly.
  * Update patch 1001.
  * Install README.md (no longer README.markdown).

 -- Jonas Smedegaard <email address hidden>  Sun, 28 Feb 2016 10:54:32 +0100

Available diffs

Superseded in yakkety-release on 2016-04-27
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed (Reason: moved to release)
node-expat (2.3.1-1) unstable; urgency=medium

  [ upstream ]
  * New release(s).

  [ Leo Iannacone ]
  * Handle eventual prereleases and repackaging in watch file.

  [ Jonas Smedegaard ]
  * Add README.source emphasizing that control.in file is *not* a
    show-stopper for contributions, referring to wiki page for details.
  * Update URLs to reflect upstream reorganisation.
  * Bump compatibility claim to Policy 3.9.6.
  * Extend git-buildpackage config to suppress upstream gitignore file.
  * Stop track checksum of upstream tarballs.
  * Stop suppress optional build-dependencies: Satisfied even in
    oldstable.
  * Update copyright info:
    + Add Files and License sections for convenience code copy of Expat.
    + Extend coverage for myself.
    + Bump packaging copyright to GPL-3+.
  * Update package relations:
    + Stop conflict/replace/provide libnode-node-expat.
    + (Build-)depend on node-bindings and node-nan.
    + Build-depend on node-iconv, pkg-config and devscripts.
  * Use and build-depend on node-gyp.
    Install all code in subdirs referenced by package.json.
    Thanks to Jérémy Lal (see bug#784439).
  * Fix use nodejs (not node) when executing testsuite.
    Closes: bug#707510. Thanks to Lucas Nussbaum.
  * Add patch 2001 to use nodejs (not node) when resolving nan.
  * Add patch 2002 to have node-gyp link against system shared expat.
  * Unfuzz patch 1001.
  * Update Vcs-* fields to use canonical URLs and cgit browser.
  * Update homepage.

 -- Jonas Smedegaard <email address hidden>  Tue, 19 May 2015 23:06:37 +0200
Superseded in wily-release on 2015-05-26
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2014-03-30
Deleted in trusty-proposed (Reason: moved to release)
node-expat (1.6.0-2ubuntu2) trusty; urgency=medium

  * 9999_switch_to_gyp.patch: Switch from node-waf to node-gyp.
  * debian/*: Adjust build-deps, debhelper, and rules for gyp.
 -- Adam Conrad <email address hidden>   Sat, 29 Mar 2014 23:16:08 -0600

Available diffs

Superseded in trusty-release on 2014-03-30
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
node-expat (1.6.0-2ubuntu1) quantal; urgency=low

  * Merge with Debian unstable. Remaining changes:
    - Cope with node -> nodejs renaming.

Available diffs

Superseded in quantal-release on 2012-10-01
node-expat (1.6.0-1ubuntu1) quantal; urgency=low

  * Cope with node -> nodejs renaming.
 -- Michael Bienia <email address hidden>   Mon, 01 Oct 2012 13:52:11 +0200
Superseded in quantal-release on 2012-10-01
node-expat (1.6.0-1) unstable; urgency=low


  * New upstream release.

  * Directly use github.com URL (not githubredir.debian.net redirector)
    when fetching upstream source.
  * Add debian/patches/README documenting patch numbering micro-policy.
  * Refresh patch.
  * Improve build routines:
    + Add stamp files to avoid double configure or build.
    + Build verbosely, and avoid ANSI colors.
    + Fix resolve and apply security hardening build flags.

 -- Jonas Smedegaard <email address hidden>  Fri, 22 Jun 2012 20:08:42 +0200

Available diffs

Superseded in quantal-release on 2012-06-23
node-expat (1.5.0-2) unstable; urgency=low


  * Use anonscm.debian.org for Vcs-Browser field.
  * Relax timing tolerance of test to avoid failure on slow
    architectures.
    Closes: bug#670678. Thanks to Aaron M. Ucko.

 -- Jonas Smedegaard <email address hidden>  Thu, 10 May 2012 14:42:55 +0200

Available diffs

Superseded in quantal-release on 2012-05-24
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
node-expat (1.3.0-1) unstable; urgency=low

  * New upstream release.
  * Bump copyright file format to draft 174 of DEP-5.
  * Bump policy compliance to standards-version 3.9.2.

116 of 16 results