nss 3.13.1.with.ckbi.1.88-1ubuntu1 source package in Ubuntu

Changelog

nss (3.13.1.with.ckbi.1.88-1ubuntu1) precise; urgency=low

  * Merge from Debian testing. Remaining changes:
    - Ship the main SO files in an unversioned binary, as we don't have
      versioned SO's in Ubuntu. Maintain a transitional versioned binary
      package containing the versioned symlinks, to maintain compatibility
      with Debian
      * update control, rules
      * mass rename libnss3-1d* => libnss3*
    - Fix postinst-must-call-ldconfig - dh_makeshlibs doesn't seem to add
      the maintainer script hooks with the unversioned SO files, so add
      them manually
      * add libnss3.postinst, libnss3.postrm
    - rules: Add support for mozilla-devscripts.
    - control: Change Vcs-* to XS-Debian-Vcs-*.
  * control: Fix typo (LP: #855424)
  * Bugs fixed by the merge:
    - Using dh now (LP: #613477)
    - Adds 85_security_load.patch (LP: #315096)

nss (3.13.1.with.ckbi.1.88-1) unstable; urgency=low

  * New upstream release.
    - Distrusts malaysian Digicert Sdn. Bhd CA certificate.
    - Addresses CVE-2011-3640 (Untrusted search path vulnerability).
      Closes: #647614.
  * debian/patches/*: Refreshed patches.
  * debian/libnss3-1d.symbols: Add NSS 3.13 symbols.

nss (3.12.11-3) unstable; urgency=high

  * mozilla/security/nss/lib/ckfw/builtins/certdata.*:
    Explicitely distrust various DigiNotar CAs:
    - DigiNotar Root CA
    - DigiNotar Services 1024 CA
    - DigiNotar Cyber CA
    - DigiNotar Cyber CA 2nd
    - DigiNotar PKIoverheid
    - DigiNotar PKIoverheid G2

nss (3.12.11-2) unstable; urgency=high

  * mozilla/security/nss/lib/ckfw/builtins/certdata.*:
    Remove DigiNotar Root CA.

nss (3.12.11-1) unstable; urgency=low

  * New upstream release.
  * mozilla/security/nss/lib/ckfw/builtins/certdata.*,
  * mozilla/security/coreconf/{config,Linux}.mk: Refreshed.
  * debian/copyright: Update dbm license according to that in the source.
    Closes: #624310

nss (3.12.10-3) unstable; urgency=low

  * debian/nss-config.in, debian/nss.pc.in, debian/rules: Return the multiarch
    path in nss-config and nss.pc.

nss (3.12.10-2) unstable; urgency=low

  * debian/control, debian/libnss3-1d.dirs,
    debian/libnss3-1d.lintian-overrides.in, debian/libnss3-dev.dirs,
    debian/libnss3-1d.links.in, debian/libnss3-dev.links.in,
    debian/rules: Switch to multi-arch while keeping backports easy.
    Closes: #497088.

nss (3.12.10-1) unstable; urgency=low

  * New upstream release.
  * mozilla/security/nss/lib/ckfw/builtins/certdata.*: Refreshed.
  * debian/control: Build depend on libnspr4-dev >= 4.8.8.
  * debian/libnss3-1d.symbols: Add new symbol version.

nss (3.12.9.with.ckbi.1.82-1) unstable; urgency=low

  * New upstream release.
    - Marks fraudulent Comodo certificates as untrusted.
  * mozilla/security/nss/lib/ckfw/builtins/certdata.*: Refreshed.
 -- Timo Aaltonen <email address hidden>   Wed, 30 Nov 2011 11:16:39 +0200

Upload details

Uploaded by:
Timo Aaltonen on 2011-12-12
Uploaded to:
Precise
Original maintainer:
Ubuntu-Mozilla-Team
Architectures:
any
Section:
libs
Urgency:
Very Urgent

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
nss_3.13.1.with.ckbi.1.88.orig.tar.gz 5.8 MiB 456fd2ad036976660ae7e4e24edddc49f2f47e7ca490c1c5372771bbb5207879
nss_3.13.1.with.ckbi.1.88-1ubuntu1.debian.tar.gz 78.1 KiB 6fd275417e662af44578c33bb8341376074b2661f3c8d6a2c4d43dc0f066a3d7
nss_3.13.1.with.ckbi.1.88-1ubuntu1.dsc 1.6 KiB 7b9f02e804590e436763f5044275e9fc4efae2af5dee1e723b28e080e5847a4a

View changes file

Binary packages built by this source

libnss3: Network Security Service libraries

 This is a set of libraries designed to support cross-platform development
 of security-enabled client and server applications. It can support SSLv2
 and v4, TLS, PKCS #5, #7, #11, #12, S/MIME, X.509 v3 certificates and
 other security standards.

libnss3-1d: Network Security Service libraries

 This is a set of libraries designed to support cross-platform development
 of security-enabled client and server applications. It can support SSLv2
 and v4, TLS, PKCS #5, #7, #11, #12, S/MIME, X.509 v3 certificates and
 other security standards.
 .
 This package contains versioned symbolic links for Debian compatibility.

libnss3-dbg: Debugging symbols for the Network Security Service libraries

 This is a set of libraries designed to support cross-platform development
 of security-enabled client and server applications. It can support SSLv2
 and v4, TLS, PKCS #5, #7, #11, #12, S/MIME, X.509 v3 certificates and
 other security standards.
 .
 This package provides the debugging symbols for the library.

libnss3-dev: Development files for the Network Security Service libraries

 This is a set of libraries designed to support cross-platform development
 of security-enabled client and server applications. It can support SSLv2
 and v4, TLS, PKCS #5, #7, #11, #12, S/MIME, X.509 v3 certificates and
 other security standards.
 .
 Install this package if you wish to develop your own programs using the
 Network Security Service Libraries.

libnss3-tools: Network Security Service tools

 This is a set of tools on top of the Network Security Service libraries.
 This package includes:
  * certutil: manages certificate and key databases (cert7.db and key3.db)
  * modutil: manages the database of PKCS11 modules (secmod.db)
  * pk12util: imports/exports keys and certificates between the cert/key
    databases and files in PKCS12 format.
  * shlibsign: creates .chk files for use in FIPS mode.
  * signtool: creates digitally-signed jar archives containing files and/or
    code.
  * ssltap: proxy requests for an SSL server and display the contents of
    the messages exchanged between the client and server.