Ubuntu

“nvidia-common” 20110426+1 source package in Ubuntu

Changelog

nvidia-common (20110426+1) unstable; urgency=low

  [ Russ Allbery ]
  * Mark the substituted list of conflicting files as not translatable and
    add a comment for translators.

  [ Andreas Beckmann ]
  * Debconf translations:
    - Chinese (zh_CH): Aron Xu           (Closes: #614630)
    - Czech (cs): Michal Simunek         (Closes: #614827)
    - Finnish (fi): Esko Arajärvi        (Closes: #618944)
    - French (fr): Steve R. Petruzzello  (Closes: #616065)
    - German (de): Chris Leick           (Closes: #615597)
    - Portuguese (pt): Américo Monteiro  (Closes: #614993)
    - Russian (ru): Yuri Kozlov          (Closes: #619818)
    - Slovak (sk): Slavko                (Closes: #622120)

nvidia-common (20110213+1) unstable; urgency=low

  [ Andreas Beckmann ]
  * Rename source package to nvidia-common.
  * Add debconf/po-debconf infrastructure to interactively resolve conflicts
    with previous usage of the nvidia-installer.
  * Add nvidia-common package that cleans up old installations that were done
    using nvidia-installer and prevents using nvidia-installer again.  Using
    nvidia-installer and Debian packages at the same time does not work.
  * The nvidia-common package is intended to be added to the Pre-Depends of
    most other nvidia-graphics-drivers packages, including the legacy drivers,
    nvidia-settings and nvidia-xconfig.
  * When configuring nvidia-common check for /usr/bin/nvidia-installer and ask
    the user whether to run 'nvidia-installer --uninstall'.  If that fails,
    offer to just delete the remaining files.  If the user chooses to do the
    cleanup himself, the configuration fails as long as nvidia-installer is
    still found on the system, blocking installation of nvidia-glx and related
    packages.
  * Install a pre-install hook for the nvidia-installer, giving a warning to
    users running a NVIDIA-Linux-*.run file directly while Debian packages
    providing the driver are installed.  This hook fails intentionally, but
    unfortunately the default choice if the hook failed is to continue anyway.
    Therefore try to kill the nvidia-installer process.
  * Add to nvidia-common the new script check-for-conflicting-opengl-libraries
    to be called from the postinst of nvidia-glx{,-legacy-*} to clean up
    conflicting ancient copies of the OpenGL libraries.  ldconfig usually
    picks up these old variants and breaks the libGL.so.* symlinks.
    (Currently the conflicting libraries are moved to
    /var/lib/nvidia-backup.XXXXXX instead of deleting them.)
  * nvidia-kernel-common.postinst: run update-initramfs -u to activate
    blacklisting of nouveau module.  (Closes: #613951)
  * nvidia-kernel-common.postrm: run update-initramfs -u after purging to
    remove the nouveau blacklisting from the initrd.
  * Switch to debhelper 8.1 to get support for package.maintscript files.

nvidia-kernel-common (20100522+2) unstable; urgency=low

  [ Andreas Beckmann ]
  * Switch to dpkg-maintscript-helper for renaming config files.
  * Put the common rename/remove conffile code fragment into
    debian/nvidia-kernel-common.dpkg-maintscript-helper and copy it to
    {preinst,postinst,postrm}.debhelper.
  * Add Vcs-* URLs.
  * Update Standards-Version to 3.9.1, no changes needed.
  * Switch to debhelper compat level 8.

  [ Russ Allbery ]
  * Add Andreas Beckmann to Uploaders.

nvidia-kernel-common (20100522+1) unstable; urgency=low

  [ Andreas Beckmann ]
  * Remove Randall Donald from Uploaders per his request.
  * Add Russ Allbery to Uploaders.
  * Blacklist the nouveau kernel module. (Closes: #580894)
  * Simplify package build.
  * Rename modprobe config to nvidia-kernel-common.conf and use
    dh_installmodules for installation.
  * Adjust transition code in maintainer scripts to take cake of both old
    names nvidia-kernel-nkc and nvidia-kernel-nkc.conf.

  [ Russ Allbery ]
  * Expand the package long description.
  * Rewrite debian/copyright in the DEP-5 format and clarify that the
    package is licensed under the GPL version 2 or later.  Add the
    Policy-requested disclaimer explaining why the package is in contrib.

nvidia-kernel-common (20100216+3+nmu1) unstable; urgency=critical

  [ Jean-Christophe Dubacq ]
  * Non-maintainer upload.
  * fix security bug for console users (closes: #574255)

  [ Vincent Danjean ]
  * Non-maintainer upload.
  * Upload to delayed-2 queue

nvidia-kernel-common (20100216+3) unstable; urgency=low

  * fix executable nvidia_helper (closes: #570191) 

nvidia-kernel-common (20100216+2) unstable; urgency=low

  * fix typo in init file 

nvidia-kernel-common (20100216+1) unstable; urgency=low

  [ Jean-Christophe Dubacq ]
  * Non-maintainer upload.
  * Switch to rules.tiny style
  * Switch to 3.0 (native) format
  * Rename modprobe config file to nvidia-kernel-nkc.conf, thanks Sven
    Joachim! patch inspired from the Ubuntu package (closes: #518566).
  * Do not stop the init script (stop is a no-op) (closes: #547727)
  * Provide skeleton for enabling FastWrite and SideBand (closes: #278104)
  * Add ConsoleKit support (closes: #568999)
  * Add documentation on new features in README.Debian
  * Upgrade to Standards-Version: 3.8.4
  * Change section to contrib/kernel

nvidia-kernel-common (20080825+1) unstable; urgency=medium

  * Change maintainer. 
  * Remove Recommends. (closes: #400202)
  * Apply stop links patch. (closes: #495552, #495548)

nvidia-kernel-common (20051028+1+nmu2) unstable; urgency=low

  * Non-maintainer upload.
  * Added LSB init script headers (closes: #479243)
  * Moved debhelper to Build-Depends, because it is used in clean
  * Use debian/rules target binary-indep instead of binary-arch
  * Updated debhelper level
  * Updated standards version
  * Removed traces of modutils and devfs support (closes: #441412, #421406)
  * Removed redundant README.Debian

nvidia-kernel-common (20051028+1-0.1) unstable; urgency=high

  * Non-maintainer upload by testing security team.
  * Added option to /etc/modprobe.d/nvidia-kernel-nkc to set
    correct device permissions (CVE-2007-3532) (Closes: #434398).

nvidia-kernel-common (20051028+1) unstable; urgency=low

  * really fix script (closes: #335976) 

nvidia-kernel-common (20051026+1) unstable; urgency=low

  * fix bashism in init script (closes: #335976) 

nvidia-kernel-common (20051025+1) unstable; urgency=low

  * Add script to make devices now that sysfs is GPL only (>=2.6.13)
    Thanks to Rob Sims <email address hidden> 
    (closes: #334531, #322021, #331465, #335398)

nvidia-kernel-common (20050829+1) unstable; urgency=low

  * Changed versioning scheme so that it is independant of driver version.
  * Update standards version

nvidia-kernel-common (1.0.7667+1) experimental; urgency=low

  * New Upstream (1.0.7667) 

nvidia-kernel-common (1.0.7664-1) experimental; urgency=low

  * New upstream (1.0.7664) 

nvidia-kernel-common (1.0.7174-1) unstable; urgency=low

  * New upstream (1.0.7174) 

nvidia-kernel-common (1.0.7167-1) unstable; urgency=low

  * New upstream (1.0.7167) 

nvidia-kernel-common (1.0.6629+1) unstable; urgency=low

  * New upstream (1.0.6629) 

nvidia-kernel-common (1.0.6111+1) unstable; urgency=low

  * New upstream (1.0.6111)
  * not installing /etc/devfs/devices.d/nvidia-kernel-nkc 
    from a suggestion made in #257809.
  * add executable check for update-devfsd (closes: #260442)

nvidia-kernel-common (1.0.6106-1) unstable; urgency=low

  * New upstream (1.0.6106) 

nvidia-kernel-common (1.0.5336-1) unstable; urgency=low

  * New upstream.  

nvidia-kernel-common (1.0.5328-1) unstable; urgency=low

  * New upstream version.  

nvidia-kernel-common (1.0.4496-7) unstable; urgency=low

  * Separate kernel alias files and keep '*' in 2.6 file. (closes: #224280) 

nvidia-kernel-common (1.0.4496-6) unstable; urgency=low

  * Remove * fromchar-major-195. (closes: #223561)
  * Add depends on modutils | module-init-tools. (closes: #223985)

nvidia-kernel-common (1.0.4496-5) unstable; urgency=low

  * Add devfs module alias to a separate file that is symlinked in on
    detection of /dev/.devfsd (closes: #223561) 

nvidia-kernel-common (1.0.4496-4) unstable; urgency=low

  * Correct module aliases for autoloading problems. Thanks to Ryan Murray
    <email address hidden>.
  * Add /etc/devfsd/devices file (closes: #205472)  

nvidia-kernel-common (1.0.4496-3) unstable; urgency=low

  * rename module file since filename conflicts with one used in
    one version of the old nvidia-kernel-src package. (closes: #209249)

nvidia-kernel-common (1.0.4496-2) unstable; urgency=low

  * Create modprobe.d entry for 2.6 kernels 

nvidia-kernel-common (1.0.4496-1) unstable; urgency=low

  * New upstream. 

nvidia-kernel-common (1.0.4363-1) unstable; urgency=low

  * New upstream.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  10 May 2011 12:37:49 +0000

Upload details

Uploaded by:
Ubuntu Archive Auto-Sync on 2011-05-10
Uploaded to:
Oneiric
Original maintainer:
Debian NVIDIA Maintainers
Component:
main
Architectures:
amd64 i386
Section:
x11
Urgency:
Critically Urgent

See full publishing history Publishing

Series Pocket Published Component Section

Builds

Oneiric: [FULLYBUILT] amd64 [FULLYBUILT] i386

Downloads

File Size MD5 Checksum
nvidia-common_20110426+1.tar.gz 16.1 KiB 863c3c196c041278b3f064620b64976d
nvidia-common_20110426+1.dsc 1.3 KiB c3a05489a82eaf8dce0c54d0e11abb64

Available diffs

Binary packages built by this source

nvidia-common: Find obsolete NVIDIA drivers

 This package will find obsolete NVIDIA drivers in use,
 detect the hardware and recommend the most appropriate
 driver.

nvidia-kernel-common: No summary available for nvidia-kernel-common in ubuntu oneiric.

No description available for nvidia-kernel-common in ubuntu oneiric.