Change log for nvidia-graphics-drivers-173 package in Ubuntu

175 of 75 results
Deleted in utopic-release on 2014-09-12 (Reason: lp: #1368330, remove nvidia-graphics-drivers-173 )
Deleted in utopic-proposed on 2014-09-12 (Reason: moved to release)
nvidia-graphics-drivers-173 (173.14.39-0ubuntu4) utopic; urgency=medium

  * debian/dkms.conf.in,
    debian/dkms/patches/fix-build-with-linux-3.16.patch:
    - Add support for Linux 3.16.
 -- Alberto Milone <email address hidden>   Mon, 30 Jun 2014 16:51:42 +0200
Superseded in utopic-release on 2014-06-30
Published in trusty-release on 2014-01-19
Deleted in trusty-proposed (Reason: moved to release)
nvidia-graphics-drivers-173 (173.14.39-0ubuntu3) trusty; urgency=low

  * debian/control.in:
    - Change the description of the driver. It will be more
      usable in the UI now.
 -- Alberto Milone <email address hidden>   Sat, 18 Jan 2014 22:59:50 +0100
Superseded in trusty-release on 2014-01-19
Deleted in trusty-proposed on 2014-01-20 (Reason: moved to release)
nvidia-graphics-drivers-173 (173.14.39-0ubuntu2) trusty; urgency=low

  * debian/dkms.conf.in,
    debian/dkms/patches/fix-build-with-linux-3.13.patch:
    - Add support for Linux 3.13.
 -- Alberto Milone <email address hidden>   Thu, 09 Jan 2014 15:37:51 +0100
Published in precise-updates on 2014-02-03
Deleted in precise-proposed (Reason: moved to -updates)
nvidia-graphics-drivers-173 (173.14.39-0ubuntu0.0.1) precise-proposed; urgency=low

  * New upstream release (LP #1259237):
    - Add support for X.org xserver ABI 15 (xorg-server 1.15).
  * debian/rules:
    - Make it possible to set the xserver ABIs in debian/substvars.
    - Add the download-sources target.
    - Update the modules blacklist.
  * debian/substvars:
    - Add support for xserver-xorg-core-lts-quantal,
      xserver-xorg-core-lts-raring, xserver-xorg-core-lts-saucy,
      xorg-video-abi-14, xorg-video-abi-15.
  * debian/control.in:
    - Drop dependency on the Linux headers.
    - Add ${misc:Depends}.
    - Add transitional packages for nvidia-173-updates. There is
      no point in keeping the -updates flavour at this point.
    - Recommend nvidia-settings >= 331.20.
  * debian/nvidia-173.dirs.in, debian/nvidia-173.install.in,
    debian/nvidia-173.override.in, debian/nvidia-173.postinst.in,
    debian/nvidia-autostart.desktop.in,
    debian/ubuntu-nvidia-settings.desktop.in:
    - Remove nvidia-settings icon, desktop file, and autostart file.
      This is all provided by nvidia-settings now.
  * debian/nvidia-173.prerm.in,
    debian/nvidia-173.install.in,
    debian/nvidia-173.postinst.in:
    - Disable glamoregl.
    - Do not update gmenucache any more.
 -- Alberto Milone <email address hidden>   Tue, 10 Dec 2013 16:02:04 +0100
Superseded in trusty-release on 2014-01-09
Deleted in trusty-proposed on 2014-01-10 (Reason: moved to release)
nvidia-graphics-drivers-173 (173.14.39-0ubuntu1) trusty; urgency=low

  * New upstream release:
    - Add support for X.org xserver ABI 15 (xorg-server 1.15).
  * debian/dkms.conf.in:
    - Drop patches for Linux 3.10 and 3.11.
  * debian/substvars:
    - Add support for xorg-video-abi-15.
  * debian/rules:
    - Add the download-sources target.
 -- Alberto Milone <email address hidden>   Tue, 10 Dec 2013 11:40:38 +0100
Superseded in trusty-release on 2013-12-10
Deleted in trusty-proposed on 2013-12-11 (Reason: moved to release)
nvidia-graphics-drivers-173 (173.14.37-0ubuntu6) trusty; urgency=low

  * debian/templates/nvidia-graphics-drivers.{install|postinst|prerm}.in,
    debian/glamor.conf:
    - Do not update gmenucache.
    - Disable the glamoregl module.
  * Remove any .desktop file accidentally left in the previous
    revision.
 -- Alberto Milone <email address hidden>   Thu, 28 Nov 2013 15:06:48 +0100
Superseded in trusty-release on 2013-11-28
Deleted in trusty-proposed on 2013-11-29 (Reason: moved to release)
nvidia-graphics-drivers-173 (173.14.37-0ubuntu5) trusty; urgency=low

  * Remove nvidia-settings icon, desktop file, and autostart
    file. This is all provided by nvidia-settings now.
 -- Alberto Milone <email address hidden>   Thu, 21 Nov 2013 19:29:03 +0100
Superseded in trusty-release on 2013-11-22
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
nvidia-graphics-drivers-173 (173.14.37-0ubuntu4) saucy; urgency=low

  * debian/dkms.conf.in,
    debian/dkms/patches/fix-build-with-linux-3.11.patch:
    - Add support for Linux 3.11.
 -- Alberto Milone <email address hidden>   Tue, 06 Aug 2013 14:44:34 +0200
Superseded in saucy-release on 2013-08-06
Deleted in saucy-proposed on 2013-08-07 (Reason: moved to release)
nvidia-graphics-drivers-173 (173.14.37-0ubuntu3) saucy; urgency=low

  * debian/control.in:
    - Recommend nvidia-settings-304.
 -- Alberto Milone <email address hidden>   Fri, 12 Jul 2013 11:16:05 +0200
Superseded in saucy-release on 2013-07-12
Deleted in saucy-proposed on 2013-07-13 (Reason: moved to release)
nvidia-graphics-drivers-173 (173.14.37-0ubuntu2) saucy; urgency=low

  * debian/dkms.conf.in,
    debian/dkms/patches/fix-build-with-linux-3.10.patch:
    - Add support for Linux 3.10.
 -- Alberto Milone <email address hidden>   Tue, 18 Jun 2013 17:12:49 +0200
Superseded in saucy-release on 2013-06-18
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
nvidia-graphics-drivers-173 (173.14.37-0ubuntu1) raring; urgency=low

  * debian/control.in:
    - Conflict/replace/provide xorg-driver-binary.
    - Remove dependencies on the linux headers.
  * debian/dkms.conf.in:
    - Drop the patch for Linux 3.7.
  * debian/substvars:
    - Add support for xorg-video-abi-14.
  * New upstream release:
    - Added support for X.Org xserver ABI 14 (xorg-server 1.14).
    - Fixed font rendering performance and corruption problems
      on X servers with backported support for the new glyph
      cache functionality added to Pixman 0.27.
 -- Alberto Milone <email address hidden>   Fri, 15 Mar 2013 18:25:37 +0100
Superseded in raring-release on 2013-03-19
Deleted in raring-proposed on 2013-03-20 (Reason: moved to release)
nvidia-graphics-drivers-173 (173.14.36-0ubuntu1) raring; urgency=low

  * New upstream release:
    - Added support for xserver ABI 13 (xorg-server 1.13)
      (LP: #1064192).
  * Add support for Linux 3.7.
 -- Alberto Milone <email address hidden>   Tue, 27 Nov 2012 11:55:50 +0100
Obsolete in quantal-updates on 2015-04-24
Deleted in quantal-proposed on 2015-05-01 (Reason: moved to -updates)
nvidia-graphics-drivers-173 (173.14.36-0ubuntu0.1) quantal-proposed; urgency=low

  * New upstream release:
    - Added support for xserver ABI 13 (xorg-server 1.13)
      (LP: #1064192).
  * Add support for Linux 3.7.
 -- Alberto Milone <email address hidden>   Thu, 22 Nov 2012 18:16:29 +0100
Superseded in raring-release on 2012-11-28
Obsolete in quantal-release on 2015-04-24
nvidia-graphics-drivers-173 (173.14.35-0ubuntu3) quantal; urgency=low

  * debian/control.in:
    - Conflict with/replace/provide nvidia and fglrx. This will make
      sure that other binary drivers cannot be installed at the same
      time. This is required by the new restricted drivers UI.
  * debian/rules:
    - Hardcode ABIs 11 and 12.
 -- Alberto Milone <email address hidden>   Fri, 07 Sep 2012 15:31:19 +0200
Obsolete in lucid-updates on 2016-10-26
Obsolete in lucid-security on 2016-10-26
nvidia-graphics-drivers-173 (173.14.22-0ubuntu11.2) lucid-security; urgency=low

  * SECURITY UPDATE: privilege escalation via kernel memory access
    - debian/dkms/patches/blacklist-vga-pmu-registers.patch: blacklist
      more offsets in nv.{c,h}.
    - debian/dkms.conf{.in}: added new patch.
    - CVE number pending
 -- Marc Deslauriers <email address hidden>   Sun, 05 Aug 2012 10:57:34 -0400
Obsolete in natty-updates on 2013-06-04
Obsolete in natty-security on 2013-06-04
nvidia-graphics-drivers-173 (173.14.30-0ubuntu1.2) natty-security; urgency=low

  * SECURITY UPDATE: privilege escalation via kernel memory access
    - debian/dkms/patches/blacklist-vga-pmu-registers.patch: blacklist
      more offsets in nv.{c,h}.
    - debian/dkms.conf{.in}: added new patch.
    - CVE number pending
 -- Marc Deslauriers <email address hidden>   Sun, 05 Aug 2012 10:56:06 -0400
Obsolete in oneiric-updates on 2015-04-24
Obsolete in oneiric-security on 2015-04-24
nvidia-graphics-drivers-173 (173.14.30-0ubuntu8.2) oneiric-security; urgency=low

  * SECURITY UPDATE: privilege escalation via kernel memory access
    - debian/dkms/patches/blacklist-vga-pmu-registers.patch: blacklist
      more offsets in nv.{c,h}.
    - debian/dkms.conf{.in}: added new patch.
    - CVE number pending
 -- Marc Deslauriers <email address hidden>   Sun, 05 Aug 2012 10:54:44 -0400
Superseded in precise-updates on 2014-02-03
Published in precise-security on 2012-08-06
nvidia-graphics-drivers-173 (173.14.35-0ubuntu0.2) precise-security; urgency=low

  * SECURITY UPDATE: privilege escalation via kernel memory access
    - debian/dkms/patches/blacklist-vga-pmu-registers.patch: blacklist
      more offsets in nv.{c,h}.
    - debian/dkms.conf{.in}: added new patch.
    - CVE number pending
 -- Marc Deslauriers <email address hidden>   Sun, 05 Aug 2012 10:53:27 -0400
Superseded in precise-updates on 2012-08-06
Deleted in precise-proposed on 2012-08-07 (Reason: moved to -updates)
nvidia-graphics-drivers-173 (173.14.35-0ubuntu0.1) precise-proposed; urgency=low

  * New upstream release:
    - Added support for xserver 1.11.99.901 (also known
      as 1.12 RC1).
    - Added support for X.Org xserver 1.11 (LP: #948053).
    - Improved compatibility with recent Linux kernels.
    - Fixed a bug that caused libglx.so to fail to load
      on 32-bit X servers.
  * debian/control.in:
    - Bump build dependency on debhelper.
  * debian/dkms.conf.in:
    - Don't apply any patches.
  * debian/rules:
    - Re-enable automatic ABI detection.
 -- Alberto Milone <email address hidden>   Wed, 04 Jul 2012 13:29:51 +0200
Superseded in quantal-release on 2012-09-10
nvidia-graphics-drivers-173 (173.14.35-0ubuntu2) quantal; urgency=low

  * Rebuild against the new xserver abi.
 -- Alberto Milone <email address hidden>   Tue, 03 Jul 2012 16:03:12 +0200
Superseded in quantal-release on 2012-07-03
nvidia-graphics-drivers-173 (173.14.35-0ubuntu1) quantal; urgency=low

  * New upstream release:
    - Added support for xserver 1.11.99.901 (also known
      as 1.12 RC1).
    - Added support for X.Org xserver 1.11 (LP: #948053).
    - Improved compatibility with recent Linux kernels.
    - Fixed a bug that caused libglx.so to fail to load
      on 32-bit X servers.
 -- Alberto Milone <email address hidden>   Wed, 20 Jun 2012 17:26:23 +0200
Superseded in lucid-updates on 2012-08-06
Superseded in lucid-security on 2012-08-06
nvidia-graphics-drivers-173 (173.14.22-0ubuntu11.1) lucid-security; urgency=low

  * SECURITY UPDATE: privilege escalation via kernel memory access
    (LP: #959842)
    - debian/dkms/patches/blacklist-register-mapping.patch: blacklist
      certain offsets in nv.{c,h}.
    - debian/dkms.conf{.in}: added new patch.
    - Thanks to NVIDIA for providing the patch.
    - CVE number pending
 -- Marc Deslauriers <email address hidden>   Sat, 07 Apr 2012 17:53:34 -0400
Superseded in natty-updates on 2012-08-06
Superseded in natty-security on 2012-08-06
nvidia-graphics-drivers-173 (173.14.30-0ubuntu1.1) natty-security; urgency=low

  * SECURITY UPDATE: privilege escalation via kernel memory access
    (LP: #959842)
    - debian/dkms/patches/blacklist-register-mapping.patch: blacklist
      certain offsets in nv.{c,h}.
    - debian/dkms.conf{.in}: added new patch.
    - Thanks to NVIDIA for providing the patch.
    - CVE number pending
 -- Marc Deslauriers <email address hidden>   Sat, 07 Apr 2012 17:51:33 -0400
Superseded in oneiric-updates on 2012-08-06
Superseded in oneiric-security on 2012-08-06
nvidia-graphics-drivers-173 (173.14.30-0ubuntu8.1) oneiric-security; urgency=low

  * SECURITY UPDATE: privilege escalation via kernel memory access
    (LP: #959842)
    - debian/dkms/patches/blacklist-register-mapping.patch: blacklist
      certain offsets in nv.{c,h}.
    - debian/dkms.conf{.in}: added new patch.
    - Thanks to NVIDIA for providing the patch.
    - CVE number pending
 -- Marc Deslauriers <email address hidden>   Sat, 07 Apr 2012 17:49:23 -0400
Superseded in quantal-release on 2012-06-22
Published in precise-release on 2012-01-25
nvidia-graphics-drivers-173 (173.14.30-0ubuntu11) precise; urgency=low

  * Oops!  This driver does not actually support Xserver 1.11.  Rebuild,
    manually specifying video ABI 10.  This will prevent Jockey from
    automatically installing it.
 -- Christopher James Halse Rogers <email address hidden>   Wed, 25 Jan 2012 17:48:57 +1100
Superseded in precise-release on 2012-01-25
nvidia-graphics-drivers-173 (173.14.30-0ubuntu10) precise; urgency=low

  * Rebuild against Xserver 1.11 to pick up new dependencies.
 -- Christopher James Halse Rogers <email address hidden>   Thu, 19 Jan 2012 12:01:30 +1100
Superseded in precise-release on 2012-01-24
nvidia-graphics-drivers-173 (173.14.30-0ubuntu9) precise; urgency=low

  [ Daniel van Vugt ]
  * debian/dkms.conf{.in}:
    - Fix failure to install with kernel 3.2 (LP: #576648).
    - Drop non-functional OBSOLETE_BY variable.

  [ Alberto Milone ]
  * debian/nvidia-$flavour.prerm.in:
    - Use the right path to remove the alternative for the
      other architecture (LP: #915461).
 -- Alberto Milone <email address hidden>   Thu, 12 Jan 2012 18:08:01 +0100
Superseded in precise-release on 2012-01-12
Obsolete in oneiric-release on 2015-04-24
nvidia-graphics-drivers-173 (173.14.30-0ubuntu8) oneiric; urgency=low

  * Re-enable grub fb and drop the initramfs hook in favour of
    "alias nouveau/lbm_nouveau off" (LP: #864149).
 -- Alberto Milone <email address hidden>   Mon, 10 Oct 2011 18:46:31 +0200
Superseded in oneiric-release on 2011-10-10
nvidia-graphics-drivers-173 (173.14.30-0ubuntu7) oneiric; urgency=low

  * debian/rules:
    - Make sure that the module alias is always correct and
      uses underscores instead of hyphens (LP: #855396).
    - Make the grub-gfxpayload file a template and blacklist
      all Nvidia cards so that Grub doesn't set a framebuffer
      which prevents recovery mode from working (LP: #854967).
 -- Alberto Milone <email address hidden>   Fri, 30 Sep 2011 10:06:11 +0200
Superseded in oneiric-release on 2011-09-30
nvidia-graphics-drivers-173 (173.14.30-0ubuntu6) oneiric; urgency=low

  * debian/rules:
    - Remove trailing spaces.
    - Blacklist the updates flavours in modprobe.conf.
    - Add an initramfs hook to make sure that nothings else loads
      open graphics drivers in the initramfs (LP: #839524).
 -- Alberto Milone <email address hidden>   Wed, 07 Sep 2011 16:50:09 +0200
Superseded in oneiric-release on 2011-09-07
nvidia-graphics-drivers-173 (173.14.30-0ubuntu5) oneiric; urgency=low

  * debian/nvidia-173.postinst{.in}:
    - Make sure to create and use X.Org's multiarch extra modules
      path (LP: #807209).
    - Share the same name for grub's blacklist file for all
      drivers.
  * debian/rules:
    - Fix issues with pbuild.
    - Do not provide the X abi any longer. Depending on the ABI is
      enough.
 -- Alberto Milone <email address hidden>   Tue, 30 Aug 2011 17:33:11 +0200
Superseded in oneiric-release on 2011-09-01
nvidia-graphics-drivers-173 (173.14.30-0ubuntu4) oneiric; urgency=low

  * Use an empty ld.so.conf when installing alternative for the
    non-native arch, otherwise it would be impossible to switch
    to mesa without installing mesa for the same architecture.
 -- Alberto Milone <email address hidden>   Mon, 27 Jun 2011 15:37:36 +0100
Superseded in oneiric-release on 2011-06-27
nvidia-graphics-drivers-173 (173.14.30-0ubuntu3) oneiric; urgency=low

  * debian/rules, debian/nvidia-173.prerm{.in},
    debian/nvidia-173.postinst{.in}:
    - Add initial support for multi-arch (LP: #798049).
    - Remove obsolete instructions.
 -- Alberto Milone <email address hidden>   Thu, 23 Jun 2011 16:59:30 +0200
Superseded in oneiric-release on 2011-06-23
nvidia-graphics-drivers-173 (173.14.30-0ubuntu2) oneiric; urgency=low

  * debian/dkms.conf{.in}:
    - Enable builds for 3.0 kernels.
  * debian/control{.in}:
    - Drop transitional packages.
  * Add fix-build-with-linux-3.0.patch:
    - Add support for linux 3.0.
  * Drop obsolete patches:
    - NVIDIA_173.14.12_2.6.27.patch, fall_back_on_mtrr_if_no_pat.patch,
      nvidia-2.6.36-ioctl.patch, nvidia-rt-compat-legacy.patch,
      rt_preempt_31.patchv.
 -- Alberto Milone <email address hidden>   Tue, 14 Jun 2011 17:24:43 +0200
Superseded in oneiric-release on 2011-06-14
Obsolete in natty-release on 2013-06-04
nvidia-graphics-drivers-173 (173.14.30-0ubuntu1) natty; urgency=low

  * New upstream release:
    - Add support for X.Org xserver 1.10 (LP: #741930).
    - Improve compatibility with recent Linux kernels.
 -- Alberto Milone <email address hidden>   Wed, 20 Apr 2011 13:08:15 +0200
Superseded in natty-release on 2011-04-20
nvidia-graphics-drivers-173 (173.14.28-0ubuntu6) natty; urgency=low

  [ Andrea Carpineti ]
  * Fix typo in package description Geforce to GeForce
    (LP: #639955)
 -- Bryce Harrington <email address hidden>   Mon, 07 Mar 2011 17:11:06 -0800
Superseded in natty-release on 2011-03-08
nvidia-graphics-drivers-173 (173.14.28-0ubuntu5) natty; urgency=low

  * debian/control{.in}:
    - Depend on ${xviddriver:Depends}.
  * debian/rules:
    - Manually set video ABI compatibility to 8 so that the driver is not
      installable in applications such as Jockey or manually.
    - Correct comment about what the file is based on.
 -- Alberto Milone <email address hidden>   Mon, 28 Feb 2011 16:11:58 +0100
Superseded in natty-release on 2011-02-28
nvidia-graphics-drivers-173 (173.14.28-0ubuntu4) natty; urgency=low

  * Remove .patch files that were accidentally uploaded.
 -- Alberto Milone <email address hidden>   Fri, 07 Jan 2011 15:14:47 +0100
Superseded in natty-release on 2011-01-07
nvidia-graphics-drivers-173 (173.14.28-0ubuntu3) natty; urgency=low

  * debian/nvidia-173.prerm{.in}:
    - Call dpkg-trigger with --by-package=$PACKAGE_NAME.
  * Add support for blacklisting card ids from GRUB gfxpayload=keep:
    - In Natty gfxpayload=keep is set by default so as to provide a framebuffer
      early in the boot process. Some cards don't play nicely with it, therefore
      we need to blacklist them in a file. The format is a sequence of lines of
      the following form:
        vVENDORdDEVICEsvSUBVENDORsdSUBDEVICEbcBASECLASSscSUBCLASS
      Blacklist lines are regex-matched against a corresponding PCI ID string.
      In practice this means that you can replace any part of the ID string
      with .* to match anything.
 -- Alberto Milone <email address hidden>   Fri, 07 Jan 2011 13:32:17 +0100
Superseded in natty-release on 2011-01-07
nvidia-graphics-drivers-173 (173.14.28-0ubuntu2) natty; urgency=low

  * Move from separate modalias file package to using a package header:
    - debian/control.in, debian/rules: Drop -modaliases package.
    - debian/control.in: Add XB-Modaliases header and dh-modaliases build
      dependency.
    - debian/rules: Build the modalias list to
      debian/nvidia-173.modaliases, where dh_modaliases picks it up, and
      invoke dh_modaliases.
    - debian/control.in: Add Conflicts:/Replaces: to nvidia-173-modaliases, so
      that the obsolete modaliases package gets cleaned up on upgrade.
 -- Martin Pitt <email address hidden>   Sat, 18 Dec 2010 19:25:49 +0100
Superseded in natty-release on 2010-12-18
Obsolete in maverick-release on 2013-03-05
nvidia-graphics-drivers-173 (173.14.28-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - Add support for X.Org xserver 1.9 (LP: #626918).
  * debian/rules:
    - Switch to new xsfbs variables to get the server ABI
      (LP: #616214).
  * debian/nvidia-173.postinst{.in}:
    - Call dpkg-trigger with "--by-package".
  * debian/dkms/patches/nvidia-2.6.36-ioctl.patch:
    - Add compatibility with kernel 2.6.36.
 -- Alberto Milone <email address hidden>   Mon, 04 Oct 2010 14:11:43 +0200
Superseded in maverick-release on 2010-10-04
nvidia-graphics-drivers-173 (173.14.27-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - Fixed a bug in the XvMC driver that prevented it from working on
      systems with AGP graphics cards.
    - Added support for X.Org xserver 1.8.
    - Fixed a bug that could cause X.Org xserver >= 1.7 to hang when
      restarted.
 -- Alberto Milone <email address hidden>   Fri, 16 Jul 2010 12:13:01 +0200
Superseded in maverick-release on 2010-07-16
Obsolete in lucid-release on 2016-10-26
nvidia-graphics-drivers-173 (173.14.22-0ubuntu11) lucid; urgency=low

  * debian/nvidia-$flavour.{dirs|postinst}.in, rules:
    - Install the blacklist file in /lib/nvidia-$flavour instead
      of /usr/lib/nvidia-$flavour so that the file is available
      early in the boot process when /usr is on a different
      partition (LP: #538071).
    - Ignore errors when trying to update the initramfs
      with -k $CURRENT_KERNEL which is known to fail when
      using chroots (LP: #556653).
 -- Alberto Milone <email address hidden>   Fri, 09 Apr 2010 13:10:28 +0200
Superseded in lucid-release on 2010-04-09
nvidia-graphics-drivers-173 (173.14.22-0ubuntu10) lucid; urgency=low

  * debian/nvidia-$flavour.{postinst|prerm}.in:
    - Call gmenucache trigger so that the icon of nvidia-settings
      shows up in the menu (LP: #522969).
 -- Alberto Milone <email address hidden>   Tue, 16 Mar 2010 17:39:22 +0100
Superseded in lucid-release on 2010-03-19
nvidia-graphics-drivers-173 (173.14.22-0ubuntu9) lucid; urgency=low

  * debian/rules:
    - Blacklist lbm-nouveau.
 -- Alberto Milone <email address hidden>   Thu, 04 Feb 2010 16:33:57 -0800
Superseded in lucid-release on 2010-02-05
nvidia-graphics-drivers-173 (173.14.22-0ubuntu8) lucid; urgency=low

  * debian/rules:
    - Use the real name of the kernel module in the modalias
      file instead of the alias.
 -- Alberto Milone <email address hidden>   Wed, 03 Feb 2010 17:35:06 -0800
Superseded in lucid-release on 2010-02-04
nvidia-graphics-drivers-173 (173.14.22-0ubuntu7) lucid; urgency=low

  * debian/nvidia-173.postinst.in:
    - Update the initramfs for the current kernel and for the
      newest one so that the blacklist file is included in
      the initramfs and nouveau can be blacklisted early.
 -- Alberto Milone <email address hidden>   Wed, 03 Feb 2010 10:41:26 -0800
Superseded in lucid-release on 2010-02-03
nvidia-graphics-drivers-173 (173.14.22-0ubuntu6) lucid; urgency=low

  * debian/rules:
    - Blacklist nouveau and the other nvidia proprietary
      drivers in the modprobe.conf file.
 -- Alberto Milone <email address hidden>   Thu, 21 Jan 2010 15:57:43 +0100
Superseded in lucid-release on 2010-01-21
nvidia-graphics-drivers-173 (173.14.22-0ubuntu5) lucid; urgency=low

  * debian/compat:
    - Bump compatibility to 5.
  * debian/nvidia-173.install.in:
    - Remove any reference to vdpau.
  * debian/nvidia-173.postinst.in:
    - Install alternative with --force so that files that
      already exist (from unofficial PPAs or from the Nvidia
      installer, etc.) are overwritten thus avoiding to
      install a broken alternative.
  * debian/rules:
    - Use global replacement when generating files from
      templates.
 -- Alberto Milone <email address hidden>   Tue, 19 Jan 2010 11:56:57 +0100
Superseded in lucid-release on 2010-01-19
nvidia-graphics-drivers-173 (173.14.22-0ubuntu4) lucid; urgency=low

  * debian/nvidia-173.postinst.in:
    - Remove gl_libraries slave link as the file in ld.so.conf.d is
      enough.
 -- Alberto Milone <email address hidden>   Sun, 17 Jan 2010 17:15:41 +0100
Superseded in lucid-release on 2010-01-17
nvidia-graphics-drivers-173 (173.14.22-0ubuntu3) lucid; urgency=low

  * debian/control.in:
    - There's no need for the -dev package to conflict with
      the mesa development packages any more.
  * debian/nvidia-173.postinst.in:
    - Do not set slaves for libglx and libdri. We don't need
      this any more as, thanks to a change in X, xorg_extra_modules
      will suffice.
    - Set link to $PKG_libdir in /usr/lib/GL with alternatives.
 -- Alberto Milone <email address hidden>   Mon, 11 Jan 2010 19:11:03 +0100
Superseded in lucid-release on 2010-01-11
nvidia-graphics-drivers-173 (173.14.22-0ubuntu2) lucid; urgency=low

  * Assign copyright to Canonical Ltd instead of Canonical
    Services Ltd in the packaging scripts and in the copyright
    file.
 -- Alberto Milone <email address hidden>   Sat, 09 Jan 2010 14:34:40 +0100
Superseded in lucid-release on 2010-01-09
nvidia-graphics-drivers-173 (173.14.22-0ubuntu1) lucid; urgency=low

  * Rework packaging taking Mandriva's as a model:
    - Use alternatives instead of diversions.
    - Reduce the number of binary packages to nvidia-173,
      nvidia-173-dev and nvidia-173-modaliases.
  * debian/rules:
    - Switch to CDBS.
    - Remove libGL.la as no static library is provided.
  * debian/nvidia-current.README.Debian.in:
    - Document the update process.
  * nvidia-current.postinst: try to build the module for the most
    recent kernel in addition to building it for the current kernel
    (LP: #474917).
  * New upstream release (LP: #494166):
   - Add support for xserver 1.7.x.
 -- Alberto Milone <email address hidden>   Fri, 08 Jan 2010 23:30:10 +0100
Superseded in lucid-release on 2010-01-09
Obsolete in karmic-release on 2013-03-04
nvidia-graphics-drivers-173 (173.14.20-0ubuntu5) karmic; urgency=low

  * debian.binary/patches, dkms.conf.in:
    - nvidia-rt-compat-legacy.patch: Update patch to allow the driver
      to work with rt kernels again (LP: #413296).
    - rt_preempt_31.patch: Add patch which was already in -185.

 -- Alberto Milone <email address hidden>   Sun, 25 Oct 2009 10:45:15 +0100
Superseded in karmic-release on 2009-10-26
nvidia-graphics-drivers-173 (173.14.20-0ubuntu4) karmic; urgency=low

  * debian/control.in:
    - Add dependency on patch to nvidia-$VER-kernel-source (LP: #453961).

 -- Alberto Milone <email address hidden>   Sun, 18 Oct 2009 16:07:59 +0200
Superseded in karmic-release on 2009-10-19
nvidia-graphics-drivers-173 (173.14.20-0ubuntu3) karmic; urgency=low

  * debian.binary/patches, dkms.conf.in:
    - fall_back_on_mtrr_if_no_pat.patch: Fall back on MTRRs if the
      CPU doesn't support the PAT (LP: #391461).

 -- Alberto Milone <email address hidden>   Fri, 16 Oct 2009 11:30:55 +0200
Superseded in karmic-release on 2009-10-16
nvidia-graphics-drivers-173 (173.14.20-0ubuntu2) karmic; urgency=low

  [ Alberto Milone ]
  * debian/control, debian/control.in:
    - Change the section of the -modaliases package to "admin" as the package
      is not "restricted" (LP: #429153).

  [ Kees Cook ]
  * debian/control.in:
    - Add build dependency on execstack.
  * debian/rules:
    - Drop executable stack markings from precompiled binaries (LP: #409456).

 -- Alberto Milone <email address hidden>   Fri, 25 Sep 2009 18:15:44 +0200
Superseded in karmic-release on 2009-10-08
nvidia-graphics-drivers-173 (173.14.20-0ubuntu1) karmic; urgency=low

  * New upstream release. Supports new kernels (LP: #424624).
    - Updated nvidia-bug-report.sh to automatically compress its log file;
      running `nvidia-bug-report.sh` now produces "nvidia-bug-report.log.gz".
    - Fixed a bug that resulted in AGP FW/SBA settings and overrides being
      applied incorrectly when using the Linux kernel's AGP GART driver.
    - Fixed a bug that could trigger kernel BUG() failures when stress testing
      setup/teardown paths.
    - Re-enabled support for non-SSE CPUs.
    - Fixed a server crash triggered by Kopete's 'new message' popup dialog
      when a composite manager is enabled.
  * debian/control.in:
    - Add -185 to the "Replaces" of packages.

 -- Alberto Milone <email address hidden>   Mon, 07 Sep 2009 11:41:41 +0200
Superseded in karmic-release on 2009-09-07
Obsolete in jaunty-release on 2013-02-28
nvidia-graphics-drivers-173 (173.14.16-0ubuntu1) jaunty; urgency=low

  * New upstream release. Supports the new X.org ABI (LP: #308410)
    * Fixed a problem that caused nvidia-installer to remove Compiz's libglx.so.
    * Added "nvidia-uninstall" as a shortcut for "nvidia-installer --uninstall".
    * Fixed a bug that caused corrupt window decorations in Compiz (LP: #186382).
    * Fixed corruption in KDE 4 when OpenOffice is launched.
    * Fixed a problem that prevented X from starting on 2.6.29-rc1 with an error
      like the following:
      X:6500 map pfn expected mapping type write-combining for d0000000-d0500000,
      got uncached-minus
    * Added the ability to run distribution provided pre- and post- installation
      hooks to 'nvidia-installer'; please see the 'nvidia-installer' manual page for details.
  * Drop debian.binary/patches/NVIDIA_173.14.12_2.6.27.patch
  * debian/nvidia-glx-173.preinst:
    - Correct typo in the removal of diversions of /usr/lib/xorg/modules/extensions/libglx.so
  * debian/nvidia-glx-173.postrm.in
    - Do not remove libGL.so (LP: #309116)
  * debian/nvidia-glx-173-dev.preinst.in:
    - Add diversion on /usr/lib/libGL.so since (the postrm tries to remove it already)
  * debian/nvidia-glx-173-dev.postrm:
    - replace legacy-173xx with 173

 -- Alberto Milone (tseliot) <email address hidden>   Thu, 29 Jan 2009 13:23:57 +0100
Obsolete in intrepid-updates on 2013-02-20
Deleted in intrepid-proposed on 2013-02-27 (Reason: moved to -updates)
nvidia-graphics-drivers-173 (173.14.12-1-0ubuntu5.1) intrepid-proposed; urgency=low

  * Make it conflict with driver 180 (LP: #297543)
  * Make it easier to add the support for new flavours in nvidia-glx-VER.preinst
  * Switch to DKMS patching system (in debian/rules) so as to have different
    patches for different kernel versions

 -- Alberto Milone (tseliot) <email address hidden>   Sun, 30 Nov 2008 18:40:48 +0100
Superseded in jaunty-release on 2009-02-01
nvidia-graphics-drivers-173 (173.14.12-1-0ubuntu6) jaunty; urgency=low

  * Make it conflict with driver 180
  * Make it easier to add the support for new flavours in nvidia-glx-VER.preinst
  * Switch to DKMS patching system (in debian/rules) so as to have different
    patches for different kernel versions

 -- Alberto Milone (tseliot) <email address hidden>   Sun, 30 Nov 2008 18:40:48 +0100
Superseded in jaunty-release on 2008-12-01
Superseded in intrepid-proposed on 2008-12-07
nvidia-graphics-drivers-173 (173.14.12-1-0ubuntu5) intrepid-proposed; urgency=low

  * Add diversions on /usr/lib/libGL.so.1, /usr/lib/libGL.so.1.2,
    /usr/lib/xorg/modules/extensions/libglx.so without checking their existence in
    Ubuntu 32 bit too (LP: #287470)
  * Remove quotation marks from the SOURCES varialble in
    nvidia-VER-kernel-source.postinst

 -- Alberto Milone (tseliot) <email address hidden>   Sun, 02 Nov 2008 13:25:26 +0100
Superseded in jaunty-release on 2008-11-07
Obsolete in intrepid-release on 2013-02-20
nvidia-graphics-drivers-173 (173.14.12-1-0ubuntu4) intrepid; urgency=low

  * Fix (LP: #282284) Replace the nvidia-xconfig binary with a
    script which depends on python-xkit and covers the basic
    functionalities of nvidia-xconfig
  * Add dependency on python-xkit to nvidia-glx-173
  * Test the existence of the dkms folder in
    nvidia-173-kernel-source.postinst

 -- Alberto Milone (tseliot) <email address hidden>   Mon, 13 Oct 2008 17:35:55 +0200
Superseded in intrepid-release on 2008-10-15
nvidia-graphics-drivers-173 (173.14.12-1-0ubuntu3) intrepid; urgency=low

  * Fix (LP: #262027) Make sure to remove (in
    nvidia-173-kernel-source.postinst) any directory which
    was not removed because of bug 261816

 -- Alberto Milone (tseliot) <email address hidden>   Mon, 22 Sep 2008 12:36:29 +0200
Superseded in intrepid-release on 2008-09-22
nvidia-graphics-drivers-173 (173.14.12-1-0ubuntu2) intrepid; urgency=low

  * Rebuild against the new xserver-xorg-dev.

 -- Bryce Harrington <email address hidden>   Thu, 11 Sep 2008 18:12:31 -0700
Superseded in intrepid-release on 2008-09-12
nvidia-graphics-drivers-173 (173.14.12-1-0ubuntu1) intrepid; urgency=low

  * Fix (LP: #261816) Replace "remove" with "remove|upgrade" in the
    case loop in nvidia-177-kernel-source.prerm so that older versions
    of the drivers are removed in case of upgrade
  * Add a patch to support kernel 2.6.27. Call smp_call_function() and on_each_cpu()
    with 3 arguments instead of 4 if kernel == 2.6.27.

 -- Alberto Milone (tseliot) <email address hidden>   Fri, 29 Aug 2008 08:57:20 +0200
Superseded in intrepid-release on 2008-08-29
nvidia-graphics-drivers-173 (173.14.12-0ubuntu5) intrepid; urgency=low

  * Fix (LP: #254969) Make nvidia-glx-173 conflict with xorg-driver-fglrx

 -- Alberto Milone (tseliot) <email address hidden>   Fri, 22 Aug 2008 11:49:08 +0200
Superseded in intrepid-release on 2008-08-22
nvidia-graphics-drivers-173 (173.14.12-0ubuntu4) intrepid; urgency=low

  * Fix (LP: #254444) Remove pound from link in nvidia-glx-173-dev.links.in
  * Fix (LP: #259105) Add missing link to usr/lib/libXvMCNVIDIA.so.#VERSION# in
    usr/lib/libXvMCNVIDIA.so

 -- Alberto Milone (tseliot) <email address hidden>   Wed, 20 Aug 2008 10:57:50 +0200
Superseded in intrepid-release on 2008-08-20
nvidia-graphics-drivers-173 (173.14.12-0ubuntu3) intrepid; urgency=low

  * Don't test the existence of libGL.so, libGL.so.1, libGL.so.1.2 in /usr/lib32 when
    adding a diversion on them in the preinst. This will make sure that NVIDIA's
    libGL.so.xx will win against the one in ia32-libs [amd64]
  * Remove diversions of libGL.so in the preinst added by nvidia-glx-VER and add a new
    diversion of the file to /usr/lib32/nvidia/libGL.so.xlibmesa [amd64]
  * Remove diversion of libGL.so in the postrm.in [amd64]
  * Remove dependency on ia32-libs [amd64]

 -- Alberto Milone (tseliot) <email address hidden>   Sat, 09 Aug 2008 11:08:35 +0200
Superseded in intrepid-release on 2008-08-10
nvidia-graphics-drivers-173 (173.14.12-0ubuntu2) intrepid; urgency=low

  * Make sure that the installers are executable in the debian/rules

 -- Alberto Milone (tseliot) <email address hidden>   Tue, 05 Aug 2008 09:51:36 +0200
Superseded in intrepid-release on 2008-08-05
nvidia-graphics-drivers-173 (173.14.12-0ubuntu1) intrepid; urgency=low

  * Add NVIDIA driver 173.14.12.
    * Added support for GeForce 8600 GS.
    * Fixed a problem with missing rendering in OpenGL Workstation
      Overlays
    * Fixed a problem with running some SDL applications and virtual
      terminal switching.
    * Fixed a potential crash in nvidia-settings when saving to the X
      configuration file.
    * Improved error recovery paths in the case of corruption of the
      commands sent to the GPU.

 -- Alberto Milone (tseliot) <email address hidden>   Mon, 04 Aug 2008 15:05:58 +0200
Superseded in intrepid-release on 2008-08-04
Superseded in intrepid-release on 2008-07-22
nvidia-graphics-drivers-173 (173.14.09-0ubuntu6) intrepid; urgency=low

  * Fix (LP: #247984) Add dependency on ia32-libs for amd64
  * Add the name of the package to the modalias list

 -- Alberto Milone (tseliot) <email address hidden>   Sun, 13 Jul 2008 20:36:09 +0200
Superseded in intrepid-release on 2008-07-14
nvidia-graphics-drivers-173 (173.14.09-0ubuntu5) intrepid; urgency=low

  * Fix (LP: #247527) depend on linux-headers-generic | linux-headers rather
    than on linux-headers

 -- Alberto Milone (tseliot) <email address hidden>   Fri, 11 Jul 2008 15:16:55 +0200
Superseded in intrepid-release on 2008-07-11
Superseded in intrepid-release on 2008-07-10
nvidia-graphics-drivers-173 (173.14.09-0ubuntu4) intrepid; urgency=low

  * Remove reference to the init file from -dev.postinst
  * Don't copy kernel.o.x86_64 to nvidia-kernel-source manually

 -- Alberto Milone (tseliot) <email address hidden>   Thu, 10 Jul 2008 10:41:00 +0200
Superseded in intrepid-release on 2008-07-10
Superseded in intrepid-release on 2008-07-10
nvidia-graphics-drivers-173 (173.14.09-0ubuntu3) intrepid; urgency=low

  * Recommends nvidia-settings instead of Suggests nvidia-settings
  * Put the icon for nvidia-settings in /usr/share/pixmaps

 -- Alberto Milone (tseliot) <email address hidden>   Tue, 08 Jul 2008 18:49:59 +0200
175 of 75 results