nvidia-graphics-drivers-390 390.25-0ubuntu2 source package in Ubuntu

Changelog

nvidia-graphics-drivers-390 (390.25-0ubuntu2) bionic; urgency=medium

  [ Alberto Milone ]
  * debian/rules.defs:
    - Depend on xserver-xorg-core (>= 2:1.19.6-1ubuntu2~).
  * debian/templates/nvidia-dkms-flavour.postinst.in:
    - Remove legacy delayed build code.
  *  debian/templates/control.in:
    - libnvidia-compute should have Conflicts, not Breaks.
  * debian/copyright:
    - Use https in the url.
    - Move stanza about debian rules after debian/*.
  * debian/templates/nvidia-dkms-flavour.install.in
    - Remove debian/copy-nvidia-options and install kernel
      scripts in the DKMS package.
  * debian/templates/control.in:
    - Fix file clash in libnvidia-compute.
    - Use debhelper 9.
    - Add libnvidia-common-$flavour package. This includes
      the GL profiles (which are not arch specific).
  * debian/templates/xserver-xorg-video-nvidia-flavour.install.in:
    - Do not install libnvidia-wfb.so.$version.

  [ Rico Tzschichholz ]
  * debian/rules:
    - Drop superfluous build target references, and unused variables.
    - Avoid empty target, which is fatal.
  * debian/templates/libnvidia-decode-flavour.{install|links}.in:
    - Change vdpau destination.
  * debian/templates/control.in:
    - Relax versioned Conficts.
    - Remove -i386 packages.
    - Add Conflicts/Replaces nvidia-390 to nvidia-kernel-source.
  * debian/templates/libnvidia-gl-flavour.install.in:
    - Fix installation of nvidia_icd.json.
    - Install libnvidia-tls.so on armhf.

 -- Alberto Milone <email address hidden>  Thu, 01 Mar 2018 18:34:26 +0100

Upload details

Uploaded by:
Alberto Milone on 2018-03-01
Uploaded to:
Bionic
Original maintainer:
Ubuntu Developers
Architectures:
i386 amd64 armhf all
Section:
libs
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
nvidia-graphics-drivers-390_390.25.orig-amd64.tar.gz 77.4 MiB 011f2a45bd29cca00b28fc288730e03af45c42f5271054277822bf890d1f736d
nvidia-graphics-drivers-390_390.25.orig-armhf.tar.gz 27.2 MiB c602fb36039d240f4305699930833a98092ca8a8e6acd86e3ee9423afec8b891
nvidia-graphics-drivers-390_390.25.orig-i386.tar.gz 44.6 MiB eb2485fb0b83dd5cae2e84fceb2e334bb2e7a8daed3c8beb6da61b39732665aa
nvidia-graphics-drivers-390_390.25.orig.tar.gz 136 bytes 2017dc9787042b60f6a12feb164a09d767ad4f490df912cdf1ebb20930291f8d
nvidia-graphics-drivers-390_390.25-0ubuntu2.debian.tar.xz 35.5 KiB 953a73cd20b06424293bfabbf8461576145e4543fe088afb8407b20f43b40abe
nvidia-graphics-drivers-390_390.25-0ubuntu2.dsc 5.0 KiB 17a55d09d63ac40534e61d7bde9c2e567b2dc8666cf03908f64ac63e7d973a7a

View changes file

Binary packages built by this source

libcuda1-384: Transitional package for nvidia-headless-390

 This is a transitional package for nvidia-headless-390, and can be
 safely removed after the installation is complete.

libnvidia-cfg1-390: NVIDIA binary OpenGL/GLX configuration library

 The NVIDIA binary driver provides optimized hardware acceleration of
 OpenGL/GLX/EGL/GLES applications via a direct-rendering X Server
 for graphics cards using NVIDIA chip sets.
 .
 This package contains the libnvidia-cfg.so.1 runtime library.

libnvidia-common-390: Shared files used by the NVIDIA libraries

 This package provides a set of files that are required by the NVIDIA
 libraries.

libnvidia-compute-390: NVIDIA libcompute package

 This package provides a set of libraries which enable the NVIDIA driver
 to use GPUs for parallel general purpose computation through CUDA and
 OpenCL.

libnvidia-decode-390: NVIDIA Video Decoding runtime libraries

 This package includes the NVIDIA CUDA Video Decoder (NVCUVID) library which
 provides an interface to hardware video decoding capabilities on NVIDIA GPUs with CUDA.
 .
 The package also provides a VDPAU (Video Decode and Presentation API for Unix-like
 systems) library for the NVIDIA vendor implementation.

libnvidia-encode-390: NVENC Video Encoding runtime library

 The NVENC Video Encoding library provides an interface to video encoder
 hardware on supported NVIDIA GPUs.
 .
 This package contains the nvidia-encode runtime library.

libnvidia-fbc1-390: NVIDIA OpenGL-based Framebuffer Capture runtime library

 The NVIDIA OpenGL-based Framebuffer Capture (NvFBCOpenGL) library provides
 a high performance, low latency interface to capture and optionally encode an
 OpenGL framebuffer. NvFBCOpenGL is a private API that is only available to
 approved partners for use in remote graphics scenarios.
 .
 This package contains the NvFBCOpenGL runtime library.

libnvidia-gl-390: NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD

 This package provides the NVIDIA OpenGL/GLX/EGL/GLES libraries and the
 Vulkan ICD.

libnvidia-ifr1-390: NVIDIA OpenGL-based Inband Frame Readback runtime library

 The NVIDIA OpenGL-based Inband Frame Readback (NvIFROpenGL) library provides
 a high performance, low latency interface to capture and optionally encode an
 OpenGL framebuffer. NvIFROpenGL is a private API that is only available to
 approved partners for use in remote graphics scenarios.
 .
 This package contains the NvIFROpenGL runtime library.

nvidia-384: Transitional package for nvidia-driver-390

 This is a transitional package for nvidia-driver-390, and can be
 safely removed after the installation is complete.

nvidia-384-dev: Transitional package for nvidia-driver-390

 This is a transitional package for nvidia-driver-390, and can be
 safely removed after the installation is complete.

nvidia-compute-390: No summary available for nvidia-compute-390 in ubuntu bionic.

No description available for nvidia-compute-390 in ubuntu bionic.

nvidia-compute-no-dkms-390: No summary available for nvidia-compute-no-dkms-390 in ubuntu bionic.

No description available for nvidia-compute-no-dkms-390 in ubuntu bionic.

nvidia-compute-utils-390: NVIDIA compute utilities

 This package provides utility binaries for paraller general purpose
 computing use cases with the NVIDIA driver.
 .
 CUDA MPS is a feature that allows multiple CUDA processes to share a single
 GPU context. CUDA MPS should be transparent to CUDA programs.
 .
 CUDA MPS requires a device that supports Unified Virtual Address (UVA) and
 has compute capability SM 3.5 or higher.
 Pre-CUDA 4.0 APIs are not supported under CUDA MPS.

nvidia-dkms-390: NVIDIA DKMS package

 This package builds the NVIDIA kernel module needed by the userspace
 driver, using DKMS.
 Provided that you have the kernel header packages installed, the kernel
 module will be built for your running kernel, and automatically rebuilt for
 any new kernel headers that are installed.

nvidia-driver-390: NVIDIA driver metapackage

 This metapackage depends on the NVIDIA binary driver and on all of its libraries,
 to provide hardware acceleration for OpenGL/GLX/EGL/GLES/Vulkan
 applications on either X11 or on Wayland.
 .
 See /usr/share/doc/nvidia-driver-390/README.txt.gz
 for a complete list of supported GPUs and PCI IDs.

nvidia-kernel-source-390: NVIDIA kernel source package

 This package provides the NVIDIA kernel source needed by the userspace
 driver.

nvidia-libopencl1-384: Transitional package for nvidia-headless-390

 This is a transitional package for nvidia-headless-390, and can be
 safely removed after the installation is complete.

nvidia-opencl-icd-384: Transitional package for nvidia-headless-390

 This is a transitional package for nvidia-headless-390, and can be
 safely removed after the installation is complete.

nvidia-utils-390: NVIDIA driver support binaries

 This package contains supporting binaries for the NVIDIA driver.

xserver-xorg-video-nvidia-390: NVIDIA binary Xorg driver

 The NVIDIA binary driver provides optimized hardware acceleration of
 OpenGL/GLX/EGL/GLES applications via a direct-rendering X Server
 for graphics cards using NVIDIA chip sets.
 .
 See /usr/share/doc/nvidia-driver-390/README.txt.gz
 for a complete list of supported GPUs and PCI IDs.