nvidia-graphics-drivers-418 418.56-0ubuntu1 source package in Ubuntu

Changelog

nvidia-graphics-drivers-418 (418.56-0ubuntu1) disco; urgency=medium

    * New upstream release:
      - Added support for the following GPU:
          GeForce MX230
          GeForce MX250
      - Fixed a bug which could sometimes cause Vulkan applications
        to lock up the     GPU when freeing large chunks of memory on
        systems with PRIME enabled.
      - Updated the driver to restrict use of the GPU performance
        counters to system administrators by default. The previous
        more permissive behavior can be restored by setting
        NVreg_RestrictProfilingToAdminUsers=0 when loading nvidia.ko.

 -- Alberto Milone <email address hidden>  Mon, 25 Mar 2019 17:01:55 +0100

Upload details

Uploaded by:
Alberto Milone on 2019-03-26
Uploaded to:
Disco
Original maintainer:
Ubuntu Developers
Architectures:
amd64 i386 all
Section:
libs
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Disco release on 2019-03-26 restricted libs

Builds

Disco: [FULLYBUILT] amd64 [FULLYBUILT] i386

Downloads

File Size SHA-256 Checksum
nvidia-graphics-drivers-418_418.56.orig-amd64.tar.gz 102.2 MiB 6de939bbcea347966856893bd8613779b2bd6b128432fb62a3f7f37b330ec05d
nvidia-graphics-drivers-418_418.56.orig.tar.gz 135 bytes 39108ebd909d5da8309c8a2bab42d74262b40643d7d2b9f63acb175408bfa52e
nvidia-graphics-drivers-418_418.56-0ubuntu1.debian.tar.xz 34.6 KiB cb07d92f045c8e048bf81fc940b79f59c4e96e8b34fcc465742a7ece8a822ba3
nvidia-graphics-drivers-418_418.56-0ubuntu1.dsc 5.3 KiB e6f791f84520fc4a88e44cacf03e4429be2ac70ba119dbb59a7983a9a9ccd33d

Available diffs

View changes file

Binary packages built by this source

libnvidia-cfg1-410: Transitional package for libnvidia-cfg1-418

 This is a transitional package for libnvidia-cfg1-418, and can be
 safely removed after the installation is complete.

libnvidia-cfg1-418: NVIDIA binary OpenGL/GLX configuration library

 The NVIDIA binary driver provides optimized hardware acceleration of
 OpenGL/GLX/EGL/GLES applications via a direct-rendering X Server
 for graphics cards using NVIDIA chip sets.
 .
 This package contains the libnvidia-cfg.so.1 runtime library.

libnvidia-common-410: Transitional package for libnvidia-common-418

 This is a transitional package for libnvidia-common-418, and can be
 safely removed after the installation is complete.

libnvidia-common-418: Shared files used by the NVIDIA libraries

 This package provides a set of files that are required by the NVIDIA
 libraries.

libnvidia-compute-410: Transitional package for libnvidia-compute-418

 This is a transitional package for libnvidia-compute-418, and can be
 safely removed after the installation is complete.

libnvidia-compute-418: Transitional package for libnvidia-compute-430

 This is a transitional package for libnvidia-compute-430, and can be
 safely removed after the installation is complete.

libnvidia-decode-410: Transitional package for libnvidia-decode-418

 This is a transitional package for libnvidia-decode-418, and can be
 safely removed after the installation is complete.

libnvidia-decode-418: NVIDIA Video Decoding runtime libraries

 This package includes the NVIDIA CUDA Video Decoder (NVCUVID) library which
 provides an interface to hardware video decoding capabilities on NVIDIA GPUs with CUDA.
 .
 The package also provides a VDPAU (Video Decode and Presentation API for Unix-like
 systems) library for the NVIDIA vendor implementation.

libnvidia-encode-410: No summary available for libnvidia-encode-410 in ubuntu eoan.

No description available for libnvidia-encode-410 in ubuntu eoan.

libnvidia-encode-418: NVENC Video Encoding runtime library

 The NVENC Video Encoding library provides an interface to video encoder
 hardware on supported NVIDIA GPUs.
 .
 This package contains the nvidia-encode runtime library.

libnvidia-fbc1-410: Transitional package for libnvidia-fbc1-418

 This is a transitional package for libnvidia-fbc1-418, and can be
 safely removed after the installation is complete.

libnvidia-fbc1-418: NVIDIA OpenGL-based Framebuffer Capture runtime library

 The NVIDIA OpenGL-based Framebuffer Capture (NvFBCOpenGL) library provides
 a high performance, low latency interface to capture and optionally encode an
 OpenGL framebuffer. NvFBCOpenGL is a private API that is only available to
 approved partners for use in remote graphics scenarios.
 .
 This package contains the NvFBCOpenGL runtime library.

libnvidia-gl-410: No summary available for libnvidia-gl-410 in ubuntu eoan.

No description available for libnvidia-gl-410 in ubuntu eoan.

libnvidia-gl-418: NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD

 This package provides the NVIDIA OpenGL/GLX/EGL/GLES libraries and the
 Vulkan ICD.

libnvidia-ifr1-410: Transitional package for libnvidia-ifr1-418

 This is a transitional package for libnvidia-ifr1-418, and can be
 safely removed after the installation is complete.

libnvidia-ifr1-418: Transitional package for libnvidia-ifr1-430

 This is a transitional package for libnvidia-ifr1-430, and can be
 safely removed after the installation is complete.

nvidia-compute-utils-410: Transitional package for nvidia-compute-utils-418

 This is a transitional package for nvidia-compute-utils-418, and can be
 safely removed after the installation is complete.

nvidia-compute-utils-418: NVIDIA compute utilities

 This package provides utility binaries for paraller general purpose
 computing use cases with the NVIDIA driver.
 .
 CUDA MPS is a feature that allows multiple CUDA processes to share a single
 GPU context. CUDA MPS should be transparent to CUDA programs.
 .
 CUDA MPS requires a device that supports Unified Virtual Address (UVA) and
 has compute capability SM 3.5 or higher.
 Pre-CUDA 4.0 APIs are not supported under CUDA MPS.

nvidia-dkms-410: Transitional package for nvidia-dkms-418

 This is a transitional package for nvidia-dkms-418, and can be
 safely removed after the installation is complete.

nvidia-dkms-418: NVIDIA DKMS package

 This package builds the NVIDIA kernel module needed by the userspace
 driver, using DKMS.
 Provided that you have the kernel header packages installed, the kernel
 module will be built for your running kernel, and automatically rebuilt for
 any new kernel headers that are installed.

nvidia-driver-410: Transitional package for nvidia-driver-418

 This is a transitional package for nvidia-driver-418, and can be
 safely removed after the installation is complete.

nvidia-driver-418: NVIDIA driver metapackage

 This metapackage depends on the NVIDIA binary driver and on all of its libraries,
 to provide hardware acceleration for OpenGL/GLX/EGL/GLES/Vulkan
 applications on either X11 or on Wayland.
 .
 See /usr/share/doc/nvidia-driver-418/README.txt.gz
 for a complete list of supported GPUs and PCI IDs.

nvidia-headless-410: Transitional package for nvidia-headless-418

 This is a transitional package for nvidia-headless-418, and can be
 safely removed after the installation is complete.

nvidia-headless-418: NVIDIA headless metapackage

 This metapackage installs the NVIDIA driver and the libraries that enable
 parallel general purpose computation through CUDA and
 OpenCL.
 .
 Install this package if you do not need X11 or Wayland support, which is
 provided by the nvidia-driver-418 metapackage.

nvidia-headless-no-dkms-410: Transitional package for nvidia-headless-no-dkms-418

 This is a transitional package for nvidia-headless-no-dkms-418, and can be
 safely removed after the installation is complete.

nvidia-headless-no-dkms-418: NVIDIA headless metapackage - no DKMS

 This metapackage installs the NVIDIA driver and the libraries that enable
 parallel general purpose computation through CUDA and
 OpenCL. DKMS will not be installed, and, therefore, the kernel module
 will not be built.
 .
 Install this package if you do not need X11 or Wayland support, which is
 provided by the nvidia-driver-418 metapackage.

nvidia-kernel-common-410: Transitional package for nvidia-kernel-common-418

 This is a transitional package for nvidia-kernel-common-418, and can be
 safely removed after the installation is complete.

nvidia-kernel-common-418: Shared files used with the kernel module

 This package installs all the optional accessory files for the NVIDIA
 kernel module.
 .
 Install this package if you want to blacklist any conflicting kernel
 modules, and if you want udev to load the the NVIDIA kernel modules,
 and to create the uvm devices automatically.

nvidia-kernel-source-410: Transitional package for nvidia-kernel-source-418

 This is a transitional package for nvidia-kernel-source-418, and can be
 safely removed after the installation is complete.

nvidia-kernel-source-418: NVIDIA kernel source package

 This package provides the NVIDIA kernel source needed by the userspace
 driver.

nvidia-utils-410: Transitional package for nvidia-utils-418

 This is a transitional package for nvidia-utils-418, and can be
 safely removed after the installation is complete.

nvidia-utils-418: NVIDIA driver support binaries

 This package contains supporting binaries for the NVIDIA driver.

xserver-xorg-video-nvidia-410: Transitional package for xserver-xorg-video-nvidia-418

 This is a transitional package for xserver-xorg-video-nvidia-418, and can be
 safely removed after the installation is complete.

xserver-xorg-video-nvidia-418: NVIDIA binary Xorg driver

 The NVIDIA binary driver provides optimized hardware acceleration of
 OpenGL/GLX/EGL/GLES applications via a direct-rendering X Server
 for graphics cards using NVIDIA chip sets.
 .
 See /usr/share/doc/nvidia-driver-418/README.txt.gz
 for a complete list of supported GPUs and PCI IDs.